Question

IT-100 License missing from Centreon Central


Badge +1

Hello,

I am using centreon since last month and everything was working fine. But today, When I connect to Centreon, the licence has been removed and I can’t add a licence anymore. 

 

This morning, I have lost my internet connection for 30 minutes (I think this is relevant)


10 replies

Userlevel 3
Badge +10

Hello @quentinjn-avo 

It seems that the license is here because we can see the end date.

Why do you think it has been removed? You don’t have access to the plugin packs?

Can you share with us the last entries of /var/log/centreon/license-manager.log?

Badge +1

Hello @sduret,

I don’t really know why it’s not working… Here what it say when I try to install / Update my plugin packs, I need an subscription :

 

And here my log :

 

Badge +1

I try to create a new IT-100 Licence and add it to the instance but it says this message and refuse to register me :

 

and in the log it’s showing me this message : 

2022-06-27 09:32|0|0|[RestConflictException] https://api.imp.centreon.com/v2/license-manager/instance : {"code":409,"message":"Instance already registered.","company":

Userlevel 2
Badge +6

I try to create a new IT-100 Licence and add it to the instance but it says this message and refuse to register me :

 

and in the log it’s showing me this message : 

2022-06-27 09:32|0|0|[RestConflictException] https://api.imp.centreon.com/v2/license-manager/instance : {"code":409,"message":"Instance already registered.","company":

I have the same problem what is the solution ?

Userlevel 2
Badge +6

I try to create a new IT-100 Licence and add it to the instance but it says this message and refuse to register me :

 

and in the log it’s showing me this message : 

2022-06-27 09:32|0|0|[RestConflictException] https://api.imp.centreon.com/v2/license-manager/instance : {"code":409,"message":"Instance already registered.","company":

Hi I have the same problem what is the solution ?

Userlevel 3
Badge +10

Hello @Xavier and @quentinjn-avo 

You can’t link a Centreon platform to IT 100 if it’s already linked to another one instance.

In the file license-manager.log we can see that the central server can’t reach the URL https://api.imp.centreon.com/v2/license-manager/instance.

Can you check the proxy information in Administration  >  Parameters  >  Centreon UI ?

Userlevel 2
Badge +6

Hello @Xavier and @quentinjn-avo 

You can’t link a Centreon platform to IT 100 if it’s already linked to another one instance.

In the file license-manager.log we can see that the central server can’t reach the URL https://api.imp.centreon.com/v2/license-manager/instance.

Can you check the proxy information in Administration  >  Parameters  >  Centreon UI ?

Hi thanks for your answer, I have link a multiple time this IT 100 I think because I have move and copy my centreon platform to different ESX so I think the licence is still there but its bugged, It is possible to remove the licence completly whithout the web interface ? like removing the file of licence of something like that ? then add another licence ? because the web interface seem bugged.

But I still think I have the licence because a can use Auto Discovery and we can the licence expires 9999-12-30

Log of license manager:

trying to get acces to api.imp.centreon.com

 License information:

 

Userlevel 3
Badge +10

My bad, I didn’t pay attention to “Authentication failed” message.

So yes you can join it.

 

If you have link your instance many times, it can be the issue because you can’t link more than 3 platform to only one token.

Can you execute this query?

MariaDB [centreon]> SELECT * FROM options WHERE options.key LIKE "imp%";

 

Userlevel 2
Badge +6

My bad, I didn’t pay attention to “Authentication failed” message.

So yes you can join it.

 

If you have link your instance many times, it can be the issue because you can’t link more than 3 platform to only one token.

Can you execute this query?

MariaDB [centreon]> SELECT * FROM options WHERE options.key LIKE "imp%";

 

Hi, but can I unlink my token and add another one with CLI ? or something because the web interface seems really bugging to add another token, Ive tried to add another token but didn’t worked at all

the query:

 

Userlevel 2
Badge +6

Up

Reply