Solved

Upgrade 22.04 to 22.10 - issue

  • 7 November 2022
  • 4 replies
  • 328 views

Badge +3

Hi,

On my Staging environment

Installed: 22.04.7 up-to-date

Upgrad to: 22.10.1

 

https://docs.centreon.com/docs/upgrade/upgrade-from-22-04/

Point:

yum update centreon\* php-pecl-gnupg

 

Error:

--> Finished Dependency Resolution
Error: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch)
           Requires: php-common >= 8.1
           Installed: php-common-8.0.12-1.el7.remi.x86_64 (@anaconda)
               php-common = 8.0.12-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common = 5.4.16-48.el7
Error: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch)
           Requires: php-pecl-protobuf
Error: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch)
           Requires: php-pecl-grpc
Error: Package: centreon-web-22.10.1-4.el7.centos.noarch (centreon-stable-noarch)
           Requires: brotli
Error: Package: php-sourceguardian-loader-8.1-1.el7.centos.x86_64 (centreon-stable)
           Requires: php-common >= 8.1
           Installed: php-common-8.0.12-1.el7.remi.x86_64 (@anaconda)
               php-common = 8.0.12-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common = 5.4.16-48.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

Thanks

icon

Best answer by TA-FFM 8 November 2022, 16:19

View original

4 replies

Badge +3

Hello,

 

Have you successfully performed the Upgrade PHP step?

 

Best Regards

Badge +3

Hi,

yes

https://docs.centreon.com/docs/upgrade/upgrade-from-22-04/

 

Upgrade PHP

Centreon 22.10 uses PHP in version 8.1.

  • CentOS 7

You need to enable the php 8.1 repository

yum-config-manager --enable remi-php81

 

 [root@test~]# yum-config-manager --enable remi-php81
Loaded plugins: fastestmirror

 

Or is the PHP Upgrade a extra Part ?

 

thanks

 

Badge +4

Have you done the yum clean all --enablerepo=* before the update? Doesn’t seem like your yum recognised the 8.1 packages

Badge

Hello,

 

I have followed the guibe but I’m blocked with the following message on Centos 7

 

Error: Package: centreon-web-22.10.4-1.el7.noarch (centreon-stable-noarch)
           Requires: brotli
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

When I try to install brotli package, I have the following message :

 

[root@centreon ~]# yum install brotli
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.pasteur.fr
* centos-sclo-rh: centos.mirror.fr.planethoster.net
* centos-sclo-sclo: centos.mirror.fr.planethoster.net
* extras: ftp.pasteur.fr
* remi-php80: remirepo.reloumirrors.net
* remi-php81: remirepo.reloumirrors.net
* remi-safe: remirepo.reloumirrors.net
* updates: ftp.pasteur.fr
No package brotli available.
Error: Nothing to do

Any Help would be appreciated

Reply