Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Column not found: 1054 Unknown column 'spagn.priority' in 'order clause' in centreon central
Hello everyone,I installed centreon 23.10, and i’m working on retrieving my services, and getting them to work, but there’s a catch : few of my webpages, crucials ones, aren’t accessibles, while they were before. Hosts configuration wasn’t accessible for quite a while, but recently, i had the service configuration, and the whole status details in the monitoring tab. It seems to work, but doesn’t display any services. And it’s not that the services aren’t working either, as you can see on the resources status screenshot.I think it’s a php error, somewhere, but i’ll need the help of someone who know better than me, how the inner side of centreon work. thanks for the help !
The Centreon Plugins team recently introduced a new fashion of scraping monitoring indicators. It’s called Collection. These modes could be seen as 'dumb' boiler-plates, allowing you to monitor 'things' over various protocols or APIs while abstracting some of their complexity. Collection modes rely on a JSON configuration file describing the data you want to get and the processing or mapping you may wish to apply. This kind of mode is handy if you are in one of the following situations:You can't find an existing plugin to monitor what you want or fulfill your particular need. You need to gather data from a in-house, black box, or third-party application and transform it to be easier to analyze. Writing (or asking for) a dedicated plugin appears overkill because you simply want to monitor values and apply thresholds over them. Currently, Collection modes are available for: SNMP (check the tutorial) SQL (check the tutorial)In other words, you can use these on any device supporting SNMP
Hi there, I have the next problem:We have the alerts from centreon sent via telegram. The point is that we don’t want that many alerts, we only want those ones we are interested in. So I tried to filter that information, only achieving to filter the performance data (which is not the message telegram sends, telegram send the status information).To sum up, I want to filter the info from STATUS INFORMATION and I don’t know how. I have tried with How to play with Regex - Part II | Community (centreon.com) and part 1 and it has been impossible for me to succeed. I`ve been working with centreon for just a couple days now so I will gladly thank any help. This is what I want to filter
Hi there, I am working on two version of centreon :Centreon 22.04 on Debian 11 (Bullseye)Centreon 24.04 on Debian 12 (Bookworm)(I am planning to migrate my old system to the new one.) I have a problem on plugins installation.First, it appears on Centreon 24 while configuring it to monitor my hosts, then I noticed it was the same on Centreon 22.. Web : the plugin seems to be installed, but can not be found in “/usr/lib/centreon/plugins”Terminal : the command lead to an error. Actually, it seems that the command is wronge.g. :centreon-pack-network-hp-standard-snmp = KOcentreon-plugin-network-hp-standard-snmp = OK The first command line is provided by Centreon website when you click on “more info” (“i”) of the plugin you wish install. Centreon, is it me or what happenned ? Julius
Hello everyone,Since the upgrade of Centreon, I have lost the history of my graphs. Before the update, I had set the retention values to 365 days in "Performance Data Management". However, today, I only have 6 months of history on all my graphs.The main issue is that I can't modify the retention on my existing graphs and every day, I am losing data older than 6 months.Has anyone encountered this problem before? How can I recover my full history and ensure that my data is retained for 365 days as originally configured?Thank you in advance for your help.
I started by centreon environment after some gap. so when i was logining , it was getting error like 503 error. in the logs of “/var/log/centreon-gorgone/gorgoned.log”024-07-15 03:14:10 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2024-07-15 03:15:10 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2024-07-15 03:16:10 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2024-07-15 03:17:10 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2024-07-15 03:18:10 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '503'] [message: 'Service Unavailable']2024-07-15 03:19:10 - ERROR - [aut
Hello everyone,I'm currently managing a Hyper-V hypervisor environment with the following setup:I recently activated VM replication between two Hyper-V servers (not all VMs are being replicated).Since setting up this replication, Centreon has been reporting the following critical errors: critical: integration service 'Guest Services Interface' status: -/- critical: integration service 'Heartbeat' status: -/- critical: integration service 'KeyValue Pair Exchange' status: -/- critical: integration service 'Shutdown' status: -/- critical: integration service 'Time Synchronization' status: -/- critical: integration service 'VSS' status: -/- These errors appear to be related to the integration services on the replicated VMs. Could someone please help me understand why these errors are occurring and how to resolve them? I've checked the configuration and ensured that VM replication is functioning as expected.Any insights or guidance would be greatly appreciated. Thank you in advance for your
Hello Team, i have create a reports, no errors on cbis.logall reports are create on the folder in my centreon central, but no icones for downloadexemplereports are availlable on ssh, and i download with winscp ;) exemple report on cbis[2024-06-20 12:51:47.975] [INFO ] [com.merethis.cbis.scheduler.TaskList] [pool-4-thread-8] : Created task name_services[2024-06-20 12:51:57.689] [INFO ] [com.merethis.cbis.scheduler.TaskList] [pool-4-thread-9] : Created task name_services[2024-06-20 12:52:01.110] [INFO ] [com.merethis.cbis.scheduler.TaskScheduler] [pool-3-thread-3] : Scheduled TaskPunctual [id=12, name=name_services], generation=20/06/2024 12:51 CEST, start=01/05/2024 02:00 CEST, end=01/06/2024 02:00 CEST[2024-06-20 12:52:01.294] [INFO ] [com.merethis.cbis.scheduler.TaskRunner] [Thread-16] : Started Task [name=name_services, weight=50.0]. Server load : 50.0/500.0[2024-06-20 12:52:01.298] [INFO ] [com.merethis.cbis.job.JobReport] [pool-6-thread-6] : Success of the PREPARE step for job nam
Hi, the Docs links to https://github.com/centreon/centreon-dummy/blob/master/README.md as refference for Module Development, but the Repository is archived/locked. Is there any new way/docs? Or is it still correct and state of the art?
Hello,First, sorry for my English writing please … The problem discribed in this subject happends for example when i try to modify ACLs, or when i try to watch the the properties of users. (I’m logged with an admin account profile)In the case of ACLs : the modifications are finally not saved after they have been saved from the Web interface. Note : The modifications made on ACLs with CLAPI are well stored in databaseIn the case of Users properties : i’ve got a blank page for each user. Your help will be appreciated please.Regards
Hello,How can i configure notification for service group please ? thanks
Hi everyone,I have got this error when i try to see Gorgone configuration file:What can i do?
Bonjour Je voulais faire un upgrade de mon serveur de debian 11 à debian 12. Sauf que ça ne fonctionnait plus. J’ai tenté de supprimer les paquets bullseye de centron pour les forcer à ce resinstaller avec les paquets bookworm mais je n’arrive pas à remettre tous les paquets. Vous auriez une méthode qui va bien ? ou Est-ce qu’il faut que je persévers dans ce sens ?
Hello everyone,Does anyone have an idea how to resolve this error:CHECK_NRPE: Receive header underflow - only 0 bytes received (4 expected). Command:/usr/lib64/nagios/plugins/check_centreon_nrpe3 -H 10.192.30.9 -p 8084 -t 60 -u -2 -P 8192 -c check_centreon_plugins -a 'apps::backup::veeam::local::plugin' 'job-status' ' --filter-name="" --filter-start-time="" --filter-end-time="86400" --filter-counters="" --ok-status="" --warning-status="" --critical-status="%{is_running} == 0 and not %{status} =~ /Success/i" --warning-long="" --critical-long="" --verbose' Other commands are ok. NSClient++ version number/usr/lib64/nagios/plugins/check_centreon_nrpe3 -H 10.192.30.9 -p 8084 -t 60 -u -2 -P 8192I (0.5.2.41 2018-04-26) seem to be doing fine...
I am registering centreon2-centreon-datasource and it is presenting this problem So I can't insert the data to access the datasource I noticed that the grafana directory structure changed in this version
Hi the community,I’m currently experiencing a strange issue (don’t know exactly when it started).In the service tab, I can’t access the “Timeline” tab anymore for any service or host. I get the following error message Symfony\Component\HttpFoundation\Response::__construct(): Argument #2 ($status) must be of type int, string given, called in /usr/share/centreon/src/EventSubscriber/CentreonEventSubscriber.php on line 422In the centreon-error.log log file I saw this error[01-Mar-2023 16:29:02 Europe/Paris] CRITICAL: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'centreon_storage.logs' doesn't exist {"context":"[object] (PDOException(code: 42S02): SQLSTATE[42S02]: Base table or view not found: 1146 Table 'centreon_storage.logs' doesn't exist at /usr/share/centreon/src/Centreon/Infrastructure/Monitoring/Timeline/TimelineRepositoryRDB.php:228)"}[01-Mar-2023 16:29:02 Europe/Paris] CRITICAL: Uncaught Error: Symfony\Component\HttpFoundation\Response::__construct(): Argument #2 ($sta
Hello,We are trying to setup the Windows SNMP plugin with the mode --process-count, but there is something wierd about the logic of this check.I would like Centreon to send a critical alert if the number of processes running matching my filter equals zero, but Centreon always returns OK./usr/lib/centreon/plugins/centreon_windows_snmp.pl --plugin=os::windows::snmp::plugin --mode=processcount --hostname=xyz --snmp-version='2c' --snmp-community='xyz' --process-name='xyz.exe' --critical='0'If the xyz.exe process is running this returns OK, but if the process is not running Centreon also returns OK.Reply when process runningOK: Number of current processes running: 1 | 'nbproc'=0;;0:1;0;Reply when process not runningOK: Number of current processes running: 0 | 'nbproc'=0;;0:1;0;Does it mean we cannot check a single process and return the status critical? Does it need to match at least two processes in order to send a critical status?Best regards,Lorenzo
Hello,I have a problem using REGEXP in the service widget to exclude bad services. When I use more than 256 characters, the screen goes blank, and I can't use more than 256 characters.Will an update resolve this issue? Is there any workaround?Thank you in advance for your help.Best regards,
Hello, I’m trying to install Centreon on my AWS cloud using AMIs `ami-04be5c2c7e9923780` (Oracle Linux 9) or `ami-081241b2722de973f` (Alma Linux 8) but I’m encountering issues during the web installation process.Firstly, we are encountering errors during the Centreon installation, such as "usermod: group centreon-engine does not exist," among others. Additionally, configuration files are not being created:ls -lrt /var/cache/centreon/config/engine/*ls: cannot access '/var/cache/centreon/config/engine/*': No such file or directoryls -lrt /var/cache/centreon/config/broker/*ls: cannot access '/var/cache/centreon/config/broker/*': No such file or directory This seems to be because Centreon does not support operating systems hardened by CIS compliances. The main purpose of my post here is to find out if others have encountered the same issue and if there is a known fix available. Additionally, I would like to inquire if the Centreon team plans to implement support for CIS-compliant OS.With g
Hello,Before we had a service that showed the free disk space on a disk, I deleted it to put a service per disk but I would like to put this service back, does anyone have its name?this is what i have this is what i want anyone can help please? Regards,
Hello, we hit the following error message in our logs, but do not understand the root cause and appropriate fix. ==> ./centreon-broker/central-broker-master.log <==[2024-02-22T12:34:51.765+01:00] [sql] [critical] sql: could not find index for service(1984, 46129) - maybe the poller with that service should be restarted Do you have any hint how to investigate ? Best Regards Olivier
Following a full /var and an enlargement of the FS, the poller does not restart the interface reports a database incident but I don't know in which log to find this error.Thank you for your help
Hi, I deleted hosts but i still have these entries on my services : How can i delete it from my admin page ?
Updated Centreon from 21.10.2 (CentOS 7) to 24.04.04 (Alma Linux 9) /usr/lib/centreon/plugins//centreon_ups_apc.pl \ -plugin=hardware::ups::apc::snmp::plugin \ --mode=battery-status \ --hostname=10.0.0.20 \ --snmp-version='1' \ --snmp-community='MY-SNMP' \ --replace-lasttime-format='' \ --warning-status='%{status} =~ /batteryLow/i' \ --critical-status='%{replace} =~ /yes/i' \ --unknown-status='%{status} =~ /unknown/i' \ --warning-load='' --critical-load='' \ --warning-voltage='' \ --critical-voltage='' \ --warning-current='' \ --critical-current='' \ --warning-temperature='' \ --critical-temperature='' \ --warning-time='' \ --critical-time='' \ --snmp-port=162 Port 161 UDP is used by Windows Server machine and port 162 APC SNMP Powerchute Bussines, I update to last version of agent too PowerChute Serial Shutdown 1.2APC agent detect connection:4/7/24 | 22:06:06 | SNMPV1: Nueva conexión realizada por el usuario MY-SNMP desde 10.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.