Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I didn´t find a way to do that, I can do it in a normal view, but is there a way to show icons for services in Resource status view? Best regards,M
Hi,Imports a mib file in 21.04 centreon. Centreon reports success but I cannot find the oid in Configutation-> SNMP Traps. Anything else that needs to be done? Import output result Moving traps in database...2022-03-29 14:25:47 - INFO - snmptranslate version: NET-SNMP version: 5.7.2 2022-03-29 14:25:47 - INFO - mib name: PAN-GLOBAL-REG 2022-03-29 14:25:47 - INFO - Processing MIB: PAN-GLOBAL-REG 2022-03-29 14:25:47 - INFO - Done 2022-03-29 14:25:47 - INFO - Total translations: 0 2022-03-29 14:25:47 - INFO - Successful translations: 0 2022-03-29 14:25:47 - INFO - Failed translations: 0Generate Traps configuration files from Monitoring Engine configuration form! However, when I import another file, I have a problem Moving traps in database...2022-03-29 14:29:41 - INFO - snmptranslate version: NET-SNMP version: 5.7.2 2022-03-29 14:29:41 - INFO - mib name: PAN-COMMON-MIB 2022-03-29 14:29:41 - INFO - Processing MIB: PAN-COMMON-MIB 2022-03-29 14:29:41 - INFO - # 2022-03-29 14:29:41 - INFO
Hi!I’m new with Centreon and I need to send an email notification when a server is down or disk full (for example)I configure notification with my host & services but I have a problem with the smtp configuration (I have en exchang server onpremise)I found this: https://docs.centreon.com/docs/alerts-notifications/notif-configuration/#:~:text=Go%20to%20Configuration%20%3E%20Users%20%3E%20Contacts,on%20the%20closest%20parent%20template.And this:https://docs.centreon.com/fr/docs/administration/postfix/ I tried to confiure postfix but not receive any mail. There are another way our up to date steps to configure email smtp? Not possible with GUI? Thanks a lot
Hello everyone,I am currently trying to compile centreon-collect 22.10.0 from source, with no success so far.Could you please provide the information related to the environment you use to compile centreon-collect 22.10.0? What are the Pre-requisites? Do you plan to publish a full documentation about how to install a poller from source? Here I share the list of all actions tried and all the errors encountered (so far): The first approach is to look for the official documentation (https://docs.centreon.com/). However, no information is provided about how to install a poller from source. The only process available explains how to install a poller using packages. The second approach taken was then to try compiling centreon-collect 22.10.0 on a CentOs7; following the readme file contained in the source, using the tarball available on https://download.centreon.com/. wget https://s3-eu-west-1.amazonaws.com/centreon-download/public/centreon-collect/centreon-collect-22.10.0.tar.g
bonjour, mon centengine ne demarre pas avril 05 15:24:29 Centreon systemd[1]: Started Centreon Engine.avril 05 15:24:29 Centreon centengine[2617]: [1680701069] [2617] Reading main configuration file '/etc/centreon-engine/centengine.cfg'.avril 05 15:24:29 Centreon centengine[2617]: [2023-04-05T15:24:29.081+02:00] [configuration] [info] Reading main configuration file '/etc/centreon-engine/centengine.cfg'.avril 05 15:24:29 Centreon centengine[2617]: [1680701069] [2617] Processing object config file '/etc/centreon-engine/hostTemplates.cfg'avril 05 15:24:29 Centreon centengine[2617]: [2023-04-05T15:24:29.082+02:00] [configuration] [info] Processing object config file '/etc/centreon-engine/hostTemplates.cfg'avril 05 15:24:29 Centreon centengine[2617]: [1680701069] [2617] Processing object config file '/etc/centreon-engine/hosts.cfg'avril 05 15:24:29 Centreon centengine[2617]: [2023-04-05T15:24:29.082+02:00] [configuration] [info] Processing object config file '/etc/centreon-engine/hosts.cfg
Hello everyone,I had a central centreon with 2 remote pollers. All works fineI must a new poller , and I have some errors, which I don’t fix:
Hi guys, I would know if it is possible o monitor if a windows service is disabled or not. /usr/lib64/nagios/plugins/check_centreon_nrpe -H 10.214.0.16 -p 5666 -t 30 -u -m 8192 -c check_service I don’t find if it’s possible with this command. I just find if a service is up or not (with delay or not). could you help me? Or give me a link to documentation? Laurent
Hello,i follow the topic here How To Configure AzureAD with Centreon | Community for configure OpenID authentification with Azure.i use Centreon v. 22.10.7I encounter the error “No reply address provided” when i click on connect with openID on login page. My configuration is : i’ve create a user like this :
Hi, Everyone,Hi, we have several cisco devices in our environment and those are configured as vrrp for a redundancy.So that we need to minitor its status change by Centreon.But we do not know of how to implement the setting Centreon to minitor VRRP status change, if there are any status change activities has occurred.By the way, We have implemented Basic mibs set of Cisco router and has implemnted an extended mibs as KEEPALIVED-MIB to Centreon. therefore,we thought of implementation necessary MIBS are stored to Centreon to check the VRRP status from OIDs for VRRP status changes.So my question here is if anyone in this forum could got the way to configure the check command for VRRP status change in Centreon, Please share the configuration for check VRRP.Best Regards,
Hi !I am trying to monitor Poly Studio X50 and X30 devices but it doesn’t seems like there are any plugin pack available for these devices. Furthermore, the one available are for Poly RealPresense RPRM, but the RealPresence solution will not be supported anymore as of June 2023 and will be replaced by Poly Lens.As anyone tried to use Poly Lens with the RealPresence plugin ? Is there a plugin available that would be adapted to my problem ? Thank you !Kuroe
hallo!as title, is there a way to monitor microsoft RDS farm or citrix virtual apps and desktops farm via agent nsclient++? there isn’t a ready plugin, it’s a big absence in my opinion. do you have some experience to share?
Hello,I have migrated to the newest version of map and I can no longer display an extended Output on map with the widget Output.When using #statusOutput##extendedOutput#in the widget, the #extendedOutput# will be replaced by NA.Did someone experience the same behavior ?
I have installed respected plugin pack for this in centreon server for this location ( /usr/lib64/nagios/plugin) and I have updated the slack hook url and api key and manuall tried with the command its triggered to slack channel and configured in caommds > notfication option slack_host_notify and slack_service_notiy also verified the parameter monitorng alson in same path location and attached the notification contact user but still i am not getting a notification in slack channel
Hello, I had a remote server, but i can t see graphs when i am loged to the remote server page, but i can see clearly my graphs when i am loged on the central server IHM. On rrd logs on remote server i had this error: error: RRD: could not remove file '/var/lib/centreon/status/0.rrd': No such file or directory i have rebuild my graphs , but i can t see them on remote server IHM. Any idea
Hello,We several iis pool and we need to know how much memory each one is consuming.I found this optionhttps://docs.centreon.com/pp/integrations/plugin-packs/procedures/applications-webservers-iis-restapi/But i haven't tried it yet.Is there any other option ?Thanks,
Hello,is it possible to get DOWN events using clapi or rest api? Every week I use the Event Logs to look for DOWN status and HARD ONLY type during the last 7 days. Looking at the documentation I’m not able to find how/if I can use clapi or rest API for that. Regards,Enrique
Hello, I have an issue with my Centreon database.SQLSTATE[HY000] [1045] Access denied for user centreon (using password: YES) So I created a user centreon and I have now :ERROR 1049 (42000): Unknown database 'centreon' When I write show databases, I have +--------------------+| Database |+--------------------+| information_schema || mysql || performance_schema |+--------------------+3 rows in set (0.000 sec) So I think database is deleted. I don’t know what happened because I don’t change anything. How to solve that without reset my configuration and adding manually hundreds of devices ? I don’t have any access to my web interface due to that Thanks and have a nice day !
when i finished my exportation in centreon , tomorrow i try to launch my server centreon. Suddenly, my centreon server get blocked the message shows “this site can’t be reached”
Hi, we have a Centreon Server with version 19.10.10 (commit 98cbed5e4). Our server, php and Apache configs are set to Atlantic/Canary timezone. My user also has Atlantic/Canary timezone The problem is when I show a gaph, on web interface, for example CPU load, it shows 1 hour minus than real. I mean , now there is 16:20 but graph shows 15:20. If I export the graph in PNG format time is ok and graph shows 16:20 on last data.If I set my centreon user timezone to Europe/Madrid (Atlantic/Canary +1h) the graph ends on 16:20 but should end in 17:20. If I export it times are ok. I’ve tried setting my user timezone to Buenos Aires (12:20 PM) and then the graph is displayed correctly. Again exported grahp on PNG format is ok. I tired also with Lisbon and London timezones with same bad results that on Atlantic/Canary. I think is a bug but don’t know how to debug it. Maybe updating to a more recent version of centreon? Someone has the same problem?
Hi, I’m using a Centreon v22.10 with the BAM module installed.I would like to set an acknowledge on a business activity through the rest api.Is there any REST API endpoint for business activites ? I can’t find any documentation on the subject, only old documention for Centreon 19. Thanks.
Hello,since we last upgrade from 20.10 to 22.04 we have a couple of perl script that fail. It seems as if the URL for the API changed and the authentication token could no be retreive.This is the request in the script, which worked before the upgrade:my $resauth = $ua->request(POST "https://${hostname}/centreon/api/index.php?action=authenticate", [username => "$username", password => "$password"]); And the error is:malformed JSON string, neither tag, array, object, number, string or atom, at character offset 0 (before "<!DOCTYPE HTML PUBLI...") at /opt/clapi/ExportCentreonServices.pl line 75. What can be wrong?Regards,Enrique
Hello,I am trying to install Centreon 22.10 on a fresh installation of Almalinux 8.7, using the quick install script from the Packages option (for Production Environment) following the instructions on https://download.centreon.com/, but I always get the following error and the installation stops and no longer continues:2023-03-28 12:21:23 - INFO - Restarting MariaDB service first2023-03-28 12:21:25 - INFO - Executing SQL requestsERROR 1146 (42S02) at line 1: Table 'mysql.global_priv' doesn’t exist2023-03-28 12:21:25 - ERROR - Could not apply the requests I have tried to install MariaDB before launching the Centreon Script, but I also get the same error...Can anyone help me solve it?Thank you very much.
Hello, I have followed the guide from the Wiki to enable HTTPShttps://docs.centreon.com/docs/administration/secure-platformYet when I try and access Centreon I get an Internal Server Error and in the httpd logs[Fri Feb 25 10:07:53.701198 2022] [core:error] [pid 11079] [client xxxxxxxxxx:60528] AH00125: Request exceeded the limit of 10 subrequest nesting levels due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.This is the configuration (ssl cert domain hidden) /opt/rh/httpd24/root/etc/httpd/conf.d/10-centreon.confAlias /centreon/api /usr/share/centreonAlias /centreon /usr/share/centreon/www/<LocationMatch ^/centreon/(?!api/latest/|api/beta/|api/v[0-9]+/|api/v[0-9]+\.[0-9]+/)(.*\.php(/.*)?)$> ProxyPassMatch fcgi://127.0.0.1:9042/usr/share/centreon/www/$1</LocationMatch><LocationMatch ^/centreon/(authentication|api/(latest|beta|v[0-9]+|v[0-9]+\.[0-9]+))/.*$> ProxyPassMatch f
Hello, I am preparing a MYSQL query that returns all the alerts that are in the acknowledged state. The problem is that I don't see the way to also obtain the comment that each one of them has. Any ideas? Thanks
Bonjour,Description architectureCentral HA 2 nœudRAM 24 Go8 CPU20 PollersRAM 16 Go4 CPUNous avons une augmentation de consommation mémoire sur le process cbd-sql# ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head PID PPID CMD %MEM %CPU103467 1 /usr/sbin/cbd /etc/centreon 57.1 14.4 47763 47542 /usr/sbin/mariadbd --defaul 17.6 64.8Dans les logs /var/log/centreon-broker/central-broker-master.logce genre de message :[sql] [error] SQL: host with host_id = 5751 does not exist - unable to store service of that host. You should restart centengineDans les logs /var/log/mysqld.logce genre de message :Aborted connection to db: 'centreon' user: 'centreon' host: 'xxxxx' (Got timeout reading communication packets)Quelqu’un peut nous aider ?Cordialement
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.