Solved

Instance invalid

  • 17 January 2024
  • 15 replies
  • 101 views

Badge +2

Hello, i’ve a strange issue about centreon licensing:
on Centreon 19.10 with no license at all, when i would like to update monitoring connector or see my IMP page, i have a message: «instance invalid»

 

In the /etc/centreon/license-manager.log, i have this message:

[RestUnauthorizedException] https://api.imp.centreon.com/api/auth/instance : Instance invalid.

 

Does someone knows about it

thks

icon

Best answer by AlexBreizh 16 February 2024, 14:30

View original

15 replies

Userlevel 6
Badge +18

Hi @AlexBreizh, the old IMP system is not available anymore. However, Centreon 19.10 is not supported too.

Can you update to supported version and use Centreon IT-100?

Badge +2

Hi @AlexBreizh, the old IMP system is not available anymore. However, Centreon 19.10 is not supported too.

Can you update to supported version and use Centreon IT-100?

My other centreon’s for other clients are ok without any license.

 

the problem is: if install a centreon 23.10 debian 11 and use the procedure to migrate the old 19.10 one, the licensing issue is “herited”  even if the 23.10 was ok before the procedure

 

the global process i want to do:

i have a 19.10 centreon functionning but too old on centos 7

i would like to migrate it in a centreon 23.10 debian 11

 

the new centreon was installed from scratch, after it i follow the procedure to migrate the old in the new.
all is ok but the licensing issue.

 

i did this procedure twice for other clients before and all was good.

https://docs.centreon.com/docs/22.10/migrate/migrate-from-el-to-debian/

 

no licenses too.

 

i think i have to delete some old config after the migration ?

 

 

Badge +2

ps i have 340 servers

Badge +2

nobody knows ?

Badge +2

up

Userlevel 4
Badge +13

Could it be possible to upgrade from 19.10 to 22.10? as CentOS 7 still supported, make sure all is ok and then to the migration to another OS?

 

https://docs.centreon.com/docs/22.10/upgrade/upgrade-from-19-10/

Badge +2

@ponchoh 

i finished to upgrade just now.

but the issue is the same about the licence:

2024-02-15 11:17|0|0|[RestUnauthorizedException] https://api.imp.centreon.com/api/auth/instance : Instance invalid
 

i cannot upgrade plugin pack

Userlevel 4
Badge +13

@AlexBreizh without a License or https://docs.centreon.com/docs/getting-started/IT100/ you will not be able to use the connectors ( https://docs.centreon.com/docs/monitoring/pluginpacks/#license ) you can use the plugins for sure ( https://github.com/centreon/centreon-plugins ) are we on the same page?

Badge +2

@AlexBreizh without a License or https://docs.centreon.com/docs/getting-started/IT100/ you will not be able to use the connectors ( https://docs.centreon.com/docs/monitoring/pluginpacks/#license ) you can use the plugins for sure ( https://github.com/centreon/centreon-plugins ) are we on the same page?

A license is required to access the full Monitoring Connectors catalog

 

But some connectors (those i’m needed) does not needs any license.

the fact is, for another  client, i was able to upgrade from 19 to 23 and another from 2.x to 23 without any license issue...

Userlevel 4
Badge +13

Do you have the autodiscovery installed “Administration > Extensions > Manager” is ok if it says license needed.

Badge +2

Do you have the autodiscovery installed “Administration > Extensions > Manager” is ok if it says license needed.

 

i don’t need this widget
and the other widgets are ok on last version

 

the issue is on plugin packs

 

when i go to the extensions > subscription i have the message “Instance invalid.
See our documentation “ on the 19.10 version.

and after the update to 22, the page is gone (but i i’m able to upload a license file if i want (and i do not want :) )

 

 

Userlevel 4
Badge +13

Do you mind installing the module for auto discovery and test again your list of connectors.

 

 

Badge +2

Do you mind installing the module for auto discovery and test again your list of connectors.

 

 

i didn’t mind it cause i want no license.

on my 23.10 fresh install i don’t have the issue, cause i think it’s linked to the old install and the problem is pasted through its data when i upgrade or try to migrate to the fresh 23.10 server

Userlevel 4
Badge +13

You do not need a license to install it, it will indeed show that you need a license (no need to install a lic.) but I want to test as I believe there might be some libraries that might be affecting your display. Let me know.

Badge +2

You do not need a license to install it, it will indeed show that you need a license (no need to install a lic.) but I want to test as I believe there might be some libraries that might be affecting your display. Let me know.

ok, so

i uninstalled the autodiscovery module and the licence manager module

disconnected and connected again

and installing again licence manager module and autodiscovery module

 

and my issue is gone

 

thank you so much for your help

Reply