Solved

Install Centreon NSClient++ on WS2019 and 2016

  • 14 February 2023
  • 6 replies
  • 622 views

Badge +1

Hello trying to install NSClient++ on my WS 2019 and 2016 but nothing, a just have a commande prompt for couple of minute and some error “UNKNOW : Need to specify ‘--plugin’ option.”

I try it with silent install but same thing

 

If anyone has an idea, thank you 

icon

Best answer by MichaelW 15 February 2023, 11:41

View original

6 replies

Userlevel 4
Badge +13

👋

 

@lamuzu 

 

did you get the nsclient from here? ( https://github.com/centreon/centreon-nsclient-build/releases )

did you follow the tutorial? ( https://docs.centreon.com/pp/integrations/plugin-packs/getting-started/how-to-guides/centreon-nsclient-tutorial/ )

what is that you are trying to achieve?

Badge +1

@ponchoh I can't install the exe I get from the first link that's my problem 🙂 I get this error UNKNOW : Need to specify ‘--plugin’ option.”

Userlevel 4
Badge +13

Can you share which link you are using and a screenshot of the error? thank you 😁😎

and then the latest plugins

Badge +1

Hi @ponchoh, i use this link for the download “https://github.com/centreon/centreon-nsclient-build/releases”

 

 

i got the same error when i double click the .exe

Userlevel 3
Badge +8

Hi, you have donwloaded centreon_plugins, not NSclient++ package from centreon

 

Nsclient++ : https://github.com/centreon/centreon-nsclient-build/releases/download/20211102152445/Centreon-NSClient-0.5.2.41-20211102-x64.exe

Latest centreon_plugins: https://github.com/centreon/centreon-nsclient-build/releases/download/20221115/centreon_plugins_20221710_x64.exe

Once NSC++ is installed, go to C:\Program Files (x86)\Centreon NSClient++\scripts\centreon and replace the centreon_plugins.exe by the last version you have downloaded ( remove the date in filename )

Badge +1

Thank you @MichaelW, i though  that nsclient++ was build inside centreon plugin.

 

Thank you for your support

Reply