Solved

Database Issues 22.04.2 to 22.04.4

  • 20 September 2022
  • 15 replies
  • 196 views

Badge +3

Hi there,

 

i have a Plattform consisiting of several Remote Servers, some with Pollers attached to them. On one of my remote-servers there was an automated update-job running in error upgrading centreon form 22.04.2 (Plattform Version) to 22.04.4 (remote Server Version) and since then the Machine and its poller are no longer updating the central Centreon. I get the remote marked down with Database Issues and the last update according to the Pollers-Page yesterday. Commands get pushed via gorgone, as i can see them in the logs but results don’t appear to come back to the Central Instance. In the Web of the remote it is all up2date. 

The broker-log on the Remote shows the following error:

 BBDO: invalid protocol header, aborting connection: waiting for message of type 'version_response' but nothing received

 

The whole plattform is set to BBDO-Version 2 in the Configs

 

Please help. What will happen if i update the whole plattform to 22.04.4? Will that break the whole communications or will it restore it?

 

Regards

 

icon

Best answer by TA-FFM 28 September 2022, 16:00

View original

15 replies

Badge +3

Well, this was a very disapointing experience, posting here and getting 0 replies for Support…...

Userlevel 4
Badge +9

Sorry @TA-FFM, I'll do what I can to make sure your concern is being answered. 

Userlevel 6
Badge +16

Hi, 


Sorry about that.

 

What you can try is:

  • stopping cbd on your remote: service cbd stop
  • clean the cache directory on your remote, maybe some corrupted / bbdo v3 data are still present here: rm /var/lib/centreon-broker/* -f
  • start broker on the remote

 

Do you still get the invalid version message? 

 

Cheers

 

Badge +3

Hi sims, thanks for your reply - unfortunately this doesn’t change the behaviour, no.

 

I woul dupdate the central to the same version, if i knew this would fix it, but i’m a bit afraif if this breaks the comms to the other 8 remote servers i have running, as this will basically break the whole plattform…..

 

Regaqrds

Timo

Userlevel 6
Badge +16

I would recommend you to downgrade this specific remote server to the version used by other remote servers. Don’t update your central server. 


I can’t understand how such a minor release would break things so sorry about that.

 

Downgrading web, engine, broker and their dependency will probably work. Do not hesitate to clean the broker directory after the downgrade.

Userlevel 6
Badge +16

Also, could be interesting to have the result of this grep command on both central and remote server: 

 

grep type /etc/centreon-broker/central-broker.json

 

 

Badge +3

This isn’t working properly. It is reverting the packages on the Systems disk, but still says it is a 22.04.4-System upon the Login-Window. So the changes in the DB were not reverted…….

and the comms to the centreal is also not coming back.

 

Badge +3

the grep:

on centrals web:

# grep type /etc/centreon-broker/central-broker.json
                "type": "ipv4"
                "type": "ipv4"
                "type": "ipv4"
                "type": "ipv4"
                "type": "ipv4"
                "type": "ipv4"
                "type": "ipv4"
                "db_type": "mysql",
                "type": "unified_sql"
                "type": "stats",

 

on the remote:

# grep type /etc/centreon-broker/central-broker.json
                "type": "ipv4"
                "type": "ipv4"
                "type": "stats",

Userlevel 6
Badge +16

Hi, 

Would you be available for a remote session? It would help finding a solution. 

 

This afternoon, between 4 and 5?

Badge +3

Hi sims, yes i would be available. I am currently in the Berlin timezone. 

Userlevel 6
Badge +16

Ok, I’m a bit late, I hope I’ll be able to send you a link in 15 minutes or so.

 

Badge +3

Sims, i think i fixed it.

And i feel a bit stupid, telling you how……..

I had broker-config-files lying in the /etc/entreon-broker/ - directory with the config that matched them, when i work on them in the centreon Web-UI and i had relatively new ones with .rpmnew - Endings.

I moved those out of the way on all the systems now (the .rpmnew ones) and restarted all the centreon and until now it appears to be stable without giving me any more database-errors

 

Badge +3

Those systems came from the 21.04-CentOS7-ISOs which were provided back then and upgraded by the documentation. I’m really not sure if i missed to delete them at one point or what exactly changed……

 

I found thos .rpmnew-Files by grep -rnw '/etc/centreon-broker/' -e '3.0.0.'

Badge +3

I will monitor it, but by now it appears stable. I will give you another update here by friday.

 

I very much appreciate you taking your time and making yourself available - Thank you,sims

Userlevel 6
Badge +16

Great news! Keep us posted. 

 

Cheers,

Reply