Solved

Erreur 404 dépot

  • 8 March 2024
  • 8 replies
  • 102 views

Badge +6

Bonjour à tous.

Je suis en train d’installer centreon 23.10 sur une nouvelle machine Débian 12.

Je suis bloqué car lors de l’update juste après avoir enregistré les deux dépot centreon, j’ai un message d’erreur.

MErci d’avance pour votre aide.

 

Laurent.

 

icon

Best answer by laurentl 8 March 2024, 14:40

View original

8 replies

Badge +6

J’ai remplacé le dépôt en mettant 24.04 et plus d’erreur.

En revanche, la commande : 

apt install -y --no-install-recommends centreon
Impossible de trouver le paquet centreon

 Une idée?

 

Badge +6

J’ai enfin trouvé le problème.
JE ne sais pas pourquoi, mais cette commande du tuto de centreon : 

echo "deb https://packages.centreon.com/apt-standard-23.10-stable/ $(lsb_release -sc) main" | tee /etc/apt/sources.list.d/centreon.list
echo "deb https://packages.centreon.com/apt-plugins-stable/ $(lsb_release -sc) main" | tee /etc/apt/sources.list.d/centreon-plugins.list

crée les depots avec en fin : bookworm

alors qu’il faut : bullseye
Donc c’est à modifier dans les deux fichiers :)

Userlevel 5
Badge +11

Bonjour,

Juste pour compléter, les dépots avait en fin bookworm car vous êtes sous Debian 12, et les commandes de la doc Centreon qui ajoute les dépôts utilisent une commande/variable pour mettre le nom de la release à la fin

echo "deb https://packages.centreon.com/apt-standard-23.10-stable/ $(lsb_release -sc)

 

Sous Debian 12, $(lsb_release -sc) retourne bookworm

Sous Debian 11, cela retourne bullseye

 

Ca ne fonctionnait pas car il n’y a pas de dépôt Centreon pour bookworm (la doc que vous avez utilisé devait être celle de Debian 11)

Badge +6

Bonjour Vcoum

Tu as raison, la doc dispo sur centreon et pour Debian 11, donc ce que tu dis et tout à fait juste.

J’ai quand même mis plus d’une heure pour trouver le soucis!!!!

Ça ne pose pas de problèmes d’importer des paquets bullseye pour une bookworm?

J’ai fait pareil, j’ai installé une debian 12 pour contourner le problème de php (je suis coincé avec un proxy entreprise pour connexion limitée à internet).

Du coup j’ai modifié la version dans mon sources.list comme indiqué plus haut.

 

Merci d’avance.

En tout cas je comprends mieux pourquoi la version préconisée sur centreon est la debian 11. pas de paquets debian 12 existants...

Userlevel 5
Badge +11

Personnellement j’ai pu faire une installation 23.10 sous Debian 12 en lab, en faisant les modifs cités plus haut

Ca reste un Centreon de test, je n’ai pas pu voir si toutes les fonctionnalités fonctionnent correctement

Mais la partie open-source semble fonctionnelle 

Ok Donc pas de blocages a priori. Je dois bosser sur mon proxy pour choper les dépôts centreon nécessaires alors...en tout cas Merci pour ces retours.

Reply