Question

Issue with Host template configuration in Central web page


Badge +3

Hello everyone,
we have a fresh installation of Centreon 22.04 with IT-100 and when I try to change the timezone of the host template OS-Linux-SNMP-custom (for example) and then save the configuration, this error comes out:

The connection was reset
The connection to the server was reset while the page was loading.

and the changes are lost.

The component versions are:
centreon-web-22.04.0-2.el7.centos.noarch
centreon-pp-manager-22.04.0-2.el7.centos.noarch
Any ideas on what can be the reason?

Thank to all

 


21 replies

Badge +3

  I add that there are these errors:

Aug 02 14:21:30.175983 2022] [proxy_fcgi:error] [pid 27257] (70008)Partial results are valid but processing is incomplete: [client 10.8.202.10:51406] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.193867 2022] [proxy_fcgi:error] [pid 27258] (70008)Partial results are valid but processing is incomplete: [client 10.8.202.10:51412] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.211727 2022] [proxy_fcgi:error] [pid 27259] (70008)Partial results are valid but processing is incomplete: [client 10.8.202.10:51418] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.227718 2022] [proxy_fcgi:error] [pid 25943] (104)Connection reset by peer: [client 10.8.202.10:51436] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.244213 2022] [proxy_fcgi:error] [pid 27266] (104)Connection reset by peer: [client 10.8.202.10:51420] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.266144 2022] [proxy_fcgi:error] [pid 25940] (70008)Partial results are valid but processing is incomplete: [client 10.8.202.10:51434] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

[Tue Aug 02 14:21:30.295695 2022] [proxy_fcgi:error] [pid 25941] (104)Connection reset by peer: [client 10.8.202.10:51440] AH01075: Error dispatching request to : (reading input brigade), referer: http://10.8.100.219/centreon/main.get.php?p=60103&o=c&host_id=4

 

Badge +3

All the errors above can be found on: /var/log/httpd24/error_log

Userlevel 5
Badge +12

Hi @Luca D'Eredità do you use a proxy or a firewall to connect to Centreon UI?

Badge +3

Hi @Laurent, neither (proxy or firewall).
I connect in vpn on the Centreon UI.

Userlevel 5
Badge +12

@Luca D'Eredità which browser and version do you use?

Badge +3

I use either:

FIREFOX 104.0

CHROME 104.0.5112.102

Userlevel 5
Badge +12

I tried with both and I can’t reproduce your issue.

 

You have this error is you change other fields on this form?

 

Can you put your Centreon Apache configuration from /opt/rh/httpd24/root/etc/httpd/conf.d/10-centreon.conf file?

Badge +3

Hi Laurent, yes it’s a tricky situation. Yes we have the same error on every other fields in this form (and even on other form).

Badge +3

How can i put the Centreon Apache configuration ?

Every time I paste the code this form tell me that:

“Something gone wrong”

 

Userlevel 5
Badge +12

Can you put your Centreon Apache configuration from /opt/rh/httpd24/root/etc/httpd/conf.d/10-centreon.conf file?

Badge +3

Hi Laurent,

 as I said before, every time I paste the code this form tell me that:

Something's gone wrong

How can I put the configuration to avoid this issue ?

Userlevel 5
Badge +12

@Luca D'Eredità when you answer to this topic, you can click on “...” then select “code” and past your configuration

Badge +3

I try that already.

 

Badge +3

Even with the Language set as Apache I have this issue.

 

Userlevel 5
Badge +12

Ok you use standard HTTP configuration from Centreon.

This is the first time we see this error.

How many users are connected to Centreon?

You Centreon platform is only available in private network without WAF?

 

Badge +3

Hi @Laurent,

There is only one user (admin).

Weird thing but by ssh tunneling of Centreon UI port 80 everything works.

Userlevel 5
Badge +12

And do you try using private mode with our browser?

Badge +3

Yes

Userlevel 5
Badge +12

Can you try to download the OVA with Alma8 and check if you have the same issue?

Badge +3

I cannot do this because this is customer infrastructure and we cannot create new servers.

Userlevel 5
Badge +12

@Luca D'Eredità

Some of our users had similar problems because there was an F5 firewall between the user workstation and the Centreon server.

 

Can you check with your IT, control F5 logs and add a rule for Centreon?

 

Regards

Reply