Question

Rocky Linux 9.3 latest updated unable to install centreon 23.10

  • 25 March 2024
  • 1 reply
  • 51 views

Badge +1

I’ve followed this URL

https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-packages/

 

But when I run  the command

dnf install -y centreon
Last metadata expiration check: 2:18:39 ago on Mon 25 Mar 2024 09:58:48 AM CET.
Error:
 Problem: package centreon-23.10.10-1.el9.noarch from centreon-23.10-stable-noarch requires centreon-central = 23.10.10-1.el9, but none of the providers can be installed
  - package centreon-central-23.10.10-1.el9.noarch from centreon-23.10-stable-noarch requires centreon-poller = 23.10.10-1.el9, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.8-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.8-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.2-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.2-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.9-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.9-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.4-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.4-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.7-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.7-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.10-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.10-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.5-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.5-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.3-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.3-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.1-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.1-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.6-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.6-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.0-1.el9.noarch from centreon-23.10-stable-noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.0-1.el9.noarch from centreon-23.10-stable-noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
 


1 reply

Badge +1

Hello,

I have the same problem.

This command resolved the problem :

dnf install dnf-plugins-core
dnf install epel-release
dnf config-manager --set-enabled crb

Execute script : 
 

bash /tmp/unattended.sh install -t central -v 23.10 -r stable -s -l DEBUG  2>&1 |tee -a /tmp/unattended-$(date +"%m-%d-%Y-%H%M%S").log

 

Reply