Solved

Update 21.04 to 21.04.15 : INTL Not LOADED

  • 13 September 2022
  • 3 replies
  • 41 views

Userlevel 1
Badge +8

After a ym update and a reboot , i v got this message on or DEV IT-100 plateforme .

also an error message during starting php73:

 systemctl status rh-php73-php-fpm.service -l
● rh-php73-php-fpm.service - The PHP FastCGI Process Manager
   Loaded: loaded (/usr/lib/systemd/system/rh-php73-php-fpm.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/rh-php73-php-fpm.service.d
           └─centreon.conf
   Active: active (running) since Tue 2022-09-13 17:05:34 CEST; 3s ago
 Main PID: 11715 (php-fpm)
   Status: "Ready to handle connections"
   CGroup: /system.slice/rh-php73-php-fpm.service
           ├─11715 php-fpm: master process (/etc/opt/rh/rh-php73/php-fpm.conf
           ├─11716 php-fpm: pool www
           ├─11717 php-fpm: pool www
           ├─11718 php-fpm: pool www
           ├─11719 php-fpm: pool www
           └─11720 php-fpm: pool www

Sep 13 17:05:34 supvm-centreon01 systemd[1]: Stopped The PHP FastCGI Process Manager.
Sep 13 17:05:34 supvm-centreon01 systemd[1]: Starting The PHP FastCGI Process Manager...
Sep 13 17:05:34 supvm-centreon01 php-fpm[11715]: [13-Sep-2022 17:05:34] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: /opt/rh/rh-php73/root/usr/lib64/php/modules/intl (/opt/rh/rh-php73/root/usr/lib64/php/modules/intl: cannot open shared object file: No such file or directory), /opt/rh/rh-php73/root/usr/lib64/php/modules/intl.so (/lib64/libicuio.so.50: undefined symbol: _ZN6icu_5013UnicodeString9doReplaceEiiPKtii)) in Unknown on line 0
Sep 13 17:05:34 supvm-centreon01 systemd[1]: Started The PHP FastCGI Process Manager.

Any Idea ?

icon

Best answer by sdouce 14 September 2022, 09:29

View original

3 replies

Badge +2

Is the intl extension enabled ?

Userlevel 1
Badge +8

Is the intl extension enabled ?

In fact this is my problem , Extension try to be enabled but wont ..

/opt/rh/rh-php73/root/usr/lib64/php/modules/intl.so (/lib64/libicuio.so.50: undefined symbol: _ZN6icu_5013UnicodeString9doReplaceEiiPKtii)) in Unknown on line 0

 

Our Server is CENTOS 7, and i try to upgrade rpm from 21.04 to 21.04 last minor update .

 

Userlevel 1
Badge +8

Ok Found it !

 

ldd /opt/rh/rh-php73/root/usr/lib64/php/modules/intl.so
        linux-vdso.so.1 =>  (0x00007ffdb55c5000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f416ed86000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f416ea84000)
        libicui18n.so.50 => /usr/local/sap/nwrfcsdk/lib/libicui18n.so.50 (0x00007f416e636000)
        libicuuc.so.50 => /usr/local/sap/nwrfcsdk/lib/libicuuc.so.50 (0x00007f416e24b000)
        libicudata.so.50 => /usr/local/sap/nwrfcsdk/lib/libicudata.so.50 (0x00007f416cc78000)

        libicuio.so.50 => /lib64/libicuio.so.50 (0x00007f416ca6a000)
        libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f416c762000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f416c54c000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f416c17e000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f416f1fc000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f416bf76000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f416bd5a000)

This red lib are used for SAP plugin and depend with libicu .

i moved them to another directory and restarted my rh-php73-php-fpm.service

And it work !

 

Problem is i certainly ll need to recompile my SAP library to use my plugins .

 

 

Reply