Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi, Is it possible to set macro extraoption in autodiscovery rules?This is what I do:$_SERVICEEXTRAOPTIONS$="--oid-filter='ifDesc' --oid-display='ifDesc' --snmp-autoreduce --verbose";I want just set that if my variable $name_index$ is empty Cordialy,Francis
Hi everyone,I have a perl script that runs fine from the commandline, gives back the error level and the text. Runs under the Centreon user as well, but it keeps giving me the message ‘ No output returned from plugin’.The return code used is this: if( $currentlyBuilding eq 'false' ) { if( int($lsbThresholdCrit) <= int($tsec) && int($lsbThresholdCrit) != "0" ) { $retStr = "Build has been broken for " . $tsec ." seconds; first failed build number: " . $firstFailedBuildId . " (" . $firstFailedBuildURL . ")"; $exitCode = 2; } elsif( int($lsbThresholdWarn) <= int($tsec) && int($lsbThresholdWarn) != "0" ) { $retStr = "Build has been broken for " . $tsec ." seconds; first failed build number: " . $firstFailedBuildId . " (" . $firstFailedBuildURL . ")"; $exitCode = 1; } else { $retStr .= ", build has been broken for " . $tsec ." seconds; first failed build number: " . $firstFailedBuildId . " (" . $fir
Hi everybody !I have created a service in order to check Oracle autoextended tablespaces.A SQL custom query runs in order to retrieve the TB space utilization. Unfortunately, the result in UNKNOWN because some special caracters appears in the command output.The query (in the command check):--sql-statement="SELECT ddf.tablespace_name $ARG5$,round((ddf.bytes - sum(dfs.bytes)) / (ddf.maxbytes) * 100, 2) taux_occupation_tablespace FROM dba_free_space dfs,(select tablespace_name, sum(bytes) bytes, sum(decode(maxbytes, 0, bytes, maxbytes)) maxbytes FROM dba_data_files group by tablespace_name) ddf,dba_tablespaces dt WHERE dfs.tablespace_name (+) = ddf.tablespace_name AND dt.tablespace_name = dfs.tablespace_name AND dt.contents <> 'UNDO' GROUP BY ddf.tablespace_name, ddf.bytes, ddf.maxbytes ORDER BY $ARG5$" --warning=$ARG6$ --critical=$ARG7$But in centreon, <*> appears in the output, just before ‘UNDO’:UNKNOWN: Cannot execute query: ORA-00904: "UNDO" : identificateur non valide (D
Hello,Unless I’m mistaken, it is not possible to share a playlist with a public link in Centreon 24.04.8.Are there any plans to add this feature in a future version 24.04.x ?Thanks for your help
Hello,Do you think it would be possible to provide an APT repository for the plugins (https://packages.centreon.com/apt-plugins-stable/) for Ubuntu or other distributions? Or, could you please tell me where I can download the script "/usr/lib/centreon/plugins/centreon_linux_local.pl" along with the plugins? Also, an installation procedure with dependencies would be very helpful.Have a good day.Best Regards
Hi,When I use the "hardware::pdu::eaton::snmp::plugin" plugin with the "environment" mode I get errors on the return : It turns out that the temperature probes which are added to the PDU no longer have the same OIDs. OIDs requested by the plugin : OIDs from the new MIB EATON : (.1.3.6.1.4.1.534.6.8) I can also see that this request has already been made several times on the centreon-plugins github :https://github.com/centreon/centreon-plugins/issues/3222https://github.com/centreon/centreon-plugins/issues/2888 If it was only necessary to change the OID I could have made the modification but in this case it is also necessary to review the mapping because the return of these new OIDs is different and requires adaptation. Could you please modify this plugin to be able to check new PDU ? Do you need me to provide any other information ? Thanks for your help.Kind Regards.
Bonjour,Nous voudrions changer notre configuration concernant notre de base de donnée .Nous voulons mettre les données sur un serveur externe , toute la configuration du ‘Mariadb’ est faite lace ( Création du User avec les privilèges).Maintenant je me pose la question pour effectuer le changement sur le serveur Centreon.Faut il juste modifier le configuration du Broker Output , en changeant la nouvelle adresse du serveur de base de donnée ? Ou faut il modifier autre chose ?Merci pour votre aide Hello,We would like to change our database configuration.We want to put the data on an external server, all the configuration of the 'Mariadb' is done lace (User creation with privileges).Now I'm wondering how to make the change on the Centreon server.Should I just modify the Broker Output configuration, changing the new database server address? Or do I need to change something else?Thanks for your help
Hi,I’ve imported the configuration from my Centreon 20.10 to my new Centreon 24 but it doesn’t work : [ - ] CentralConfiguration mechanism used: legacyReading main configuration file '/var/cache/centreon/config/engine/1/centengine.DEBUG'.Reading resource file '/var/cache/centreon/config/engine/1/resource.cfg'Error Contact 'User' has no service notification commands defined!Error Contact 'User' has no host notification commands defined!Cannot resolve contact 'User'Checking global event handlers...Checking obsessive compulsive processor commands… Thank you for your help !
Bonjour,Is someone succeeded to retrieve macro parameters from Host, HTPL, Service and STPL ?Centreon version 24.04
Hello,I created a notification command to send an email when a specific alert occurs, but it doesn't work. The Host or service is not recognized.Could you help me please?Notification Command:/usr/local/bin/send_ticket_email.sh SMTPAPPR_IVA-IVANTI@groupe-casino.fr "$NOTIFICATIONTYPE$" "$HOSTNAME$" "$SERVICEDESC$" "$NOTIFICATIONOUTPUT$" "$SERVICESTATE$"CASE 1:echo "[`date +%s`] SEND_CUSTOM_SVC_NOTIFICATION;ENG_XM001W9J_SRV_WIN_APP_PRD;HTTP-Soap-Content-eng-e-com;1;auteur;Ceci est un test de notification de hôte" >> /var/lib/centreon-engine/rw/centengine.cmd[2024-11-29T09:49:57.408+01:00] [external_command] [debug] [1386] push execute [1732870197] SEND_CUSTOM_SVC_NOTIFICATION;ENG_XM001W9J_SRV_WIN_APP_PRD;HTTP-Soap-Content-eng-e-com;1;auteur;Ceci est un test de notification de hôte[2024-11-29T09:49:57.770+01:00] [external_command] [info] [1386] EXTERNAL COMMAND: SEND_CUSTOM_SVC_NOTIFICATION;ENG_XM001W9J_SRV_WIN_APP_PRD;HTTP-Soap-Content-eng-e-com;1;auteur;Ceci est un test de
Hi everybody, I’m new in Centreon’s world (and to the world of monitoring).In my Centreon, I’ve many hosts where I monitor processes or services (Windows). What is the best practice for checking processes?Currently, I have 1 check per service, like this:/usr/lib/xxx/xxx//centreon_windows_snmp.pl --plugin=os::windows::snmp::plugin --mode=service --hostname=1.2.3.4 --snmp-version='2c' --snmp-community='public' --service='service_name1' --warning= --critical= --state='' --regexp Result : OK: Service 'service1' state is 'active' [installed state: 'installed']/usr/lib/xxx/xxx//centreon_windows_snmp.pl --plugin=os::windows::snmp::plugin --mode=service --hostname=1.2.3.4 --snmp-version='2c' --snmp-community='public' --service='service2' --warning= --critical= --state='' --regexp Result : OK: Service 'service2' state is 'active' [installed state: 'installed']etc…I’ve tried to use just one command, with this syntaxe : /usr/lib/xxx/xxx//centreon_windows_snmp.pl
I have 3 DB2 servers, all have the same processes (only the DB name are different), they all have the same process check (based on a service template).The checks worked well for several months, from a few days the check is CRITICAL on 1 server whereas the process is still present. I can’t find why. Here is the check command from the poller :/usr/lib64/nagios/plugins/check_centreon_nrpe3 -H XXX0002.domain -p xxxx -t30 -u -c check_centreon_plugins -a ‘os::linux::local::plugin’ ‘process’ ‘--warning-total= --critical-total=1:1 --warning-time= --critical-time= --filter-command="^db2sysc$" --filter-arg="0" --filter-state="" ‘For XXX0002 it returns :CRITICAL: Number of current processes: 0 | 'processes.total.count'=0;;1:1;0;For XXX0001 and XXX0003 it returns :OK: Process: [command => db2sysc] [arg => db2sysc 0] [state => S] duration: 1y 7M 12h 30m 31s - Number of current processes: 1 | 'processes.total.count'=1;;1:1;0; When I execute the bash command used by the check, i.e.ps -e -o s
Hello,please, how to set a static IP address in Centreon 24.10 (Debian)?The file “/etc/network/interfaces” does not exist.Thank You.
Hi,When I try to install centreon-awie to migrate, I can’t find it on the web interface.I have repo errors when I try with CLI.Thanks
Bonjour, J’ai un problème de cache depuis la mise à jour que j’ai faite, 23.10 > 24.10.Je me connecte bien sur mon interface web, si je me déconnecte puis reconnecte j’ai ce message d’erreur “ An error occurred during authentication “J’ai appliqué chown -R centreon:centreon /var/cache/centreonToujours le meme problème.La seule facon pour que ca fonctionne c’est de vider le cache manuellement:rm -rf /var/cache/centreon/* Avez-vous une idée svp? Merci--------------------------------------------------------------------------Hello,I have a cache problem since the update I did, 23.10 > 24.10.I connect well to my web interface, if I disconnect then reconnect I have this error message “An error occurred during authentication “ I applied chown -R centreon:centreon /var/cache/centreonStill the same problem.The only way for it to work is to empty the cache manually:rm -rf /var/cache/centreon/*Do you have any idea please?Thank you
Hi there,I’m trying to monitor VMWare Vshepre on premise infrastructure.I just followed this topic : https://docs.centreon.com/fr/pp/integrations/plugin-packs/procedures/virtualization-vmware2-esx/This just worked for a couple of days and suddenly with no explainable reason didnt !I get an error when configuring the connector :UNKNOWN: Container connection problem I had a look into /var/log/centreon/centreon_vmware.log and just got this error :default' Login to VirtualCenter server failed: Server version '' at 'https://myvcenterserver:443/sdk/vimService.wsdl' unsupported.My current Centreon Version is 22.04 (tried with 22.10 too and didnt worked)My VSphere infrastructure runs 7.0.3 version (vcenter servers ans ESXiDoes anyone can help me ?Thanks
It appears that I am locked out of the admin account for the WebUI for Cent 24.04. I am not sure if it expired and never got changed, or if one of my coworkers changed it and now can’t remember the new password, but I need to get it reset via the CLI. I have done some searching and have tried a couple of the different options that I have found. UPDATE contact_password SET PASSWORD('MyNewPassword') where contact_alias='admin';andUPDATE contact_password SET password = PASSWORD('MyNewPassword') WHERE contact_id = (SELECT contact_id FROM contact WHERE login = 'admin'); Neither of which seems to have worked. I have tried other variations on this as well with no luck. The closest I seem to have gotten was with the first one, but it returns an error:ERROR 1054 (42S22): Unknown column 'contact_passwd' in 'field list' Any help would be appreciated to get this reset so I can access the WebUI and silence some annoying alarms.
Bonjour,Depuis quelques jours, j’essaie de monter une surveillance sur une base de données mySQL8 avec le plugin Centreon, j’ai tout configuré comme il le fallait, mais j’ai un message d’erreur au retour par exemple sur le check ‘database size’ :UNKNOWN: Cannot connect: Authentication plugin 'sha256_password' cannot be loaded: /usr/lib64/mysql/plugin/sha256_password.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce typeJe serai heureux d’avoir vos avis si vous avez rencontré ce genre d’erreur, merci d’avance.
Bonjour, Lorsque j’utilise le menu (centreon 22.10 bientôt migré) administration - Logs je subis une vague d’erreur ‘ooops something went wrong’. Parfois, j’arrive jusqu’à la page mais impossible de faire une recherche pour les mêmes raisons.Alors, est-ce que quelqu’un a une idée sur ces erreurs ? Sinon, savez-vous ou sont ces informations ? (base de donnée ? Fichiers ? Logs ? ) pour faire une consultation manuel.Merci de votre aide,Pierre
Hi.I‘m using centreon_windows_snmp.pl to monitor CPU, Memory usage, process and disk space on my servers. When I execute any command on my pollers it works, but on web shows (No output returned from plugin). Central server and pollers are on version 24.04.7. Any ideas?
HelloI’m trying to make dashboard filtered on a host group (or a host category)I want the “condensed” view of the status grid widgetthe host group has only 2 members. ‘Standard’ (non condensed) I have my 2 hosts if I use Condensed , the total in the tile is wrong and is counting ALL the host without filtering. it should display 2 in green, it says 6...(this is a test platform with IT-100 edition, 24.04, latest patch from last week) tested that on 2 different platform, I have the same behaviour. is anyone else getting the same result?
I want to add monitoring of Ciphermail gateways to my Centreon instance. Reading the documentation, Ciphermail provides HTTP endpoints that returns a {OK|Warning|Critical|Unknown}report. I thought I could use the HTTP Server connector but this seems to force you to test the content of the response in one way or another. Is there a way to just use the content as-is?
Hello,I'm a little confused about this situation and I don't know how to correct it.The documentation for the connector indicates that it returns the results of network traffic counters in b/s, but in reality, it returns in Bytes/s, that devirtualizes the service graphs. Do you know how I can correct this situation? Is there a way to transform the metric value?Thank you so much.CentreonUnifiDreamMachineRef.: https://docs.centreon.com/pp/integrations/plugin-packs/procedures/operatingsystems-linux-ssh/Centreon 24.04.8
HI,I have Centreon Central version 21.10.8 installed on centos 7 with onboard DB and some pollers. I set up a dedicated server for CentreonMBI with db onboard. After following the official documentation, when I try to create my first JOB, the WEB page goes into error with "The connection has been interrupted", in the Centreon Central apache log I find this ""GET /centreon/modules/centreon- bi-server/configuration/generation/javascript/jobNameExists.php?sid=70ndm5ub7l1bbia5tsp5r95n1b&name=gino&gid= HTTP/1.1" 200 1 "http://xxx.xxxx.xxx.xx/centreon/main.get.php?p=30210&o=a" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:132.0) Gecko/20100101 Firefox/132.0".In the cbis log I find this error only at startup: “[2024-11-26 17:41:52.219] [WARN ] [com.merethis.cbis.etl.ResourceLoaderRunnable] [Thread-17] : Cannot associate acl rule with host of id 52[2024-11-26 17:42:17.177] [WARN ] [com.merethis.cbis.etl.ResourceLoaderRunnable] [Thread-18] : Cannot associate acl rule with host of i
Hello I have a Centreon instance with a lot of usefull commands and templates, which I want to move to my new installation . Sadly , every file the awie export creates is corrupted. Cannot be opened / unzipped. Can I do this export from the VM ? ( Im on Linux onPrem installation 24.04v)
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.