Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Bonjour,Nous utilisons Centreon 23.10.11 (Bientôt 24.04.XX), dans un environnement Redhat 8.Nous envisageons d’installer un nouveau serveur MBI (Centreon Bi Reporting Server) avec sa base de donnée Mariadb (Donc 1 seul nouveau server)J’aimerais avoir un retour d’expérience sur ceux qui ont déjà fait ça … et surtout:Avez vous rencontré des soucis lors de l’Ajout du serveur MBI dans votre infra de Prod existante ?Genre: Problème de crash de la base ou d’indispo du Central Web ..… ?A la base on m’avait conseillé de créer une nouvelle infra de POC identique à la Prod puis de relier le nouveau serveur MBI dessus … puis une fois validé: brancher le serveur MBI sur l’infra existante…. mais tout ça me semble compliqué et trop long….Surtout que la Doc me semble bien faite : https://docs.centreon.com/fr/docs/reporting/installation/ Merci pour vos retours,Cdt
Hi,When a poller has just been restarted, both querying the API or looking at the UI, one can see there is no downtime for some particular objects. The fact is, there is a downtime actually, but it doesn’t appear before a few time (around a couple of minutes).When some external tools relay on the presence of a downtime to take some decision, restarting a poller may lead to some issue (and sometime a simple reload isn’t sufficient).I wonder if some other people have also experienced this behaviour, and if it could be possible for Centreon not to indicate the absence of a downtime before it is not fully updated (hence with a 100% reliability)?Sorry if I’m unclear, please ask for some clarification if this isn’t the case.
When i try to open centreon-map4 on my mac, the application close itself a few second after i try to open it.I try to Open directly with unix’s executable but i have this message error : Centreon-Map4[41685:2124814] CheckForInstalledJavaRuntimes: Please visit http://www.java.com for information on installing java. Another issue : Java is already install on my compturer. please help, Kind Regards,
Hi at all,I monitor some network interfaces on Linux servers. I use centreon_linux_snmp.pl plugin in interfaces mode.Below the command:/usr/lib/centreon/plugins//centreon_linux_snmp.pl--plugin=os::linux::snmp::plugin--mode=interfaces--hostname=*********--snmp-version='2c'--snmp-community='*******'--interface='.*'--name--add-status--add-traffic--critical-status=''--warning-in-traffic='80'--critical-in-traffic='90'--warning-out-traffic='80'--critical-out-traffic='90'--verbose--change-perfdata='traffic_in,,scale(Mbps),mbps'--change-perfdata='traffic_out,,scale(Mbps),mbps'--change-perfdata='traffic,,scale(auto)'--snmp-autoreduceIn status information I have the following output: How you can see, the value in Mb/s correspond at the value in %. How I can fix this issue. Can I set thresholds in percentage?--warning-in-traffic='80'--critical-in-traffic='90'--warning-out-traffic='80'--critical-out-traffic='90'This is my Performance data output:Performance data'traffic_in_lo'=15.59mbps;0:8;0:9;0;
Hello,i have issue with update info from remote server to central server.i would like to know if it’s due to version of centengine (24.04.6) that is different of central 24.04.5. I can export the check from central to the remote sever and information are update correctrly on eachremote server interface but it’s failed like screenshot above on web interface on central? ps: i’ve installed the vm with the method of Unattended installation of a remote server and just notice for 2vm the version of centengine are differen than the central. If i need that all central and poller use same version, how update it fo the last version in my case to 24.04.6 ? Thank in advance
Hello everyone,I’m encountering an issue with a custom notification script in Centreon, and I’m hoping someone here has seen this before or might have some ideas on how to resolve it.The Setup:I’m running a custom notification script that integrates Centreon with an OTRS system. The script sends a cURL request to the OTRS API to check if there is an existing open ticket before creating a new one. The script works perfectly when executed manually from the command line. It sends the request, gets a response from the API, and creates or acknowledges the ticket correctly. The script also logs debug information to /tmp/debug-notif-otrs.log. [2024-10-09 11:22:09] DEBUG: Début script de notif[2024-10-09 11:22:09] DEBUG: Construction du payload à envoyer à l'API[2024-10-09 11:22:09] DEBUG: Sending request to OTRS API with payload: {"UserLogin":"WS_OTRS","Password":"XXXXXXX","QueueIDs":194,"StateType":"open","Title":"SLD-NAF\/Memory*"}[2024-10-09 11:22:10] DEBUG: Received response from OTRS API
Hello,I’ve got an issue and don’t know why the status of equipement on remote server is not update on the DB central.From Central:we can see status running yes on my remote server but the PID and last update is not updated… From the remote server:We can see status of the poller and see PID (30856)different than on the central (10342)All monitoring appears only on the web interface of the remote server and not also on the central... When i export the config poller from central, the status is restarted on the remote server as well but not updated on central…I suppected than there is a broker issue where all the communication seems failed from remote server to the central…but the connection is working :log of central-broker-master.log in remote server is not update… but log of remote server is updated with error: any ideas?thank you.
Bonjour,Je suis sur une infra en 24.04 (fresh install) et je rencontre un problème avec MAP et les services.Dans une MAP, je rajoute des hôtes, des services, des hostgroups et des servicegroups, jusque là, pas de soucis.Tout s’affiche comme il faut mais à un moment donnée, qui semble coïncider avec un export de configuration, les services disparaissent de la MAP (tout le reste fonctionne).Si je vais voir en base de données, je vois bien que les services sont toujours attribués à ma MAP mais ils ne s’affichent pas.Si je redémarre le service centreon-map-engine du serveur MAP, ils réapparaissent temporairement jusqu’au prochain export de configuration.J’ai beau reproduire l’erreur et regarder les différents logs que ce soit sur le Central ou le MAP, je ne vois pas d’erreurs particulières.Si vous avez des idées ….
Good morning,We noticed that under the Preformance Graphs, the "Display Only The Legend" function in the Curve Definition is not working.All other functions like color or output of values works fine. However, it is not possible to hide a line when the "Display Only The Legend" function is selected.Is there a solution or a workaround for this?Many greetingsMartin
I am unable to monitor a fortigate, the plugin is not available in the debian 12 repositories # apt install centreon-plugin-network-fortinet-fortigate-snmpReading package lists... DoneBuilding dependency tree... DoneReading state information... DoneE: Unable to locate package centreon-plugin-network-fortinet-fortigate-snmp centreon-engine/centengine.log:[2024-10-03T16:22:25.174+02:00] [runtime] [warning] [113147] Error: Service check command execution failed: could not create process '/usr/lib/centreon/plugins//centreon_fortinet_fortigate.pl': No such file or directoravailables fortinet plugins
Hello, I'm planning to leverage Linux TC queues to be able to implement trafic from/to a specific IP address in Centreon.My primary idea is to be able to graph each iSCSI multipath connection independently.I plan to rely on this project extending SNMPd with custom OID providing metrics per TC queue:https://github.com/mum4k/tc_reader/ It provides two modes, one showing metrics for a single queue and another one aggregating two queues together to emulate input/output. Format is described like this:myOID data will be in this hierarchy:myOID.1 - tcIndexLeaf - Stores integers, the SNMP indexes assigned to Qdiscs and Classes.myOID.2 - tcNumIndexLeaf - Stores an integer, the count of indexes assigned to Qdiscs and Classes.myOID.3 - tcNameLeaf - Stores strings, the names of Qdiscs and Classes. Names are in the form "eth0:2:3", which means interface eth0, Qdisc 2, Class 3.myOID.4 - sentBytesLeaf - Stores counter32, the sent byt
hello,i will want a monitor who is critical when the write-iops is zero with the centreon_purestorage_snmp.pl centreon_purestorage_snmp.pl --plugin=storage::purestorage::snmp::plugin --mode stats --hostname **** --snmp-version='2c' --snmp-community='****' --critical-write-iops=0OK: Read Bandwith : 131.06 Kb/s - Write Bandwith : 1.05 Mb/s - Read IOPs : 3 - Write IOPs : 28 - Read Latency : 446 us/op - Write Latency : 146 us/op | 'read_bandwidth'=131056.00b/s;;;0; 'write_bandwidth'=1048448.00b/s;;;0; 'read_iops'=3iops;;;0; 'write_iops'=28iops;;0:100;0; 'read_latency'=446us/op;;;0; 'write_latency'=146us/op;;;0; I can't tell him different or less thanthanks
Hello,When I select a host on the reports page, an empty page appears. I am running centreon version 22.04 on CentOS 7 I think this happened after an update but I didn't notice it right away, or maybe I missed a step in the update process. This is the error message that appears in /var/log/php-fpm/centreon-error.log when I try to access this page: [19-Sep-2024 17:17:50 Europe/Paris] PHP Fatal error: Uncaught PDOException: SQLSTATE[HY000]: General error: 1030 Got error 194 "Tablespace is missing for a table" from storage engine InnoDB in /usr/share/centreon/www/class/centreonDB.class.php:309Stack trace:#0 /usr/share/centreon/www/class/centreonDB.class.php(309): PDO->query()#1 /usr/share/centreon/www/include/reporting/dashboard/DB-Func.php(84): CentreonDB->query()#2 /usr/share/centreon/www/include/reporting/dashboard/viewHostLog.php(126): getLogInDbForHost()#3 /usr/share/centreon/www/main.get.php(272): include_once('...')#4 {main} thrown in /usr/share/centreon/www/class/centreo
Good morning,I would like to make modbus requests with centreon.But when I want to run my request, I get an error UNKOWN: Unable to open a connection at TCP.pm line 56.I think I'm missing a few things.
Hello everyone, I hope you're all doing well.I'm following the How to write a module documentation to create a module in Centreon. Everything works fine except when trying to upgrade the module.The documentation mentions that we should have an upgrade path like this: UPGRADE > dummy-x.x > sql > upgrade.sql.I created an UPGRADE folder in /usr/share/centreon/www/modules/traps (module is named traps ) and inside it, I created traps-1.1 > sql > upgrade.sql. The upgrade.sql file contains an SQL query to create a table named test_v11 in the centreon_storage database.In conf.php, I updated 'mod_release' from '1.0' to '1.1'. When I go to Extension > Manager, I see the update button.However, when I click it, I receive an error.I then renamed UPGRADE to upgrade, and when I clicked the update button again, the upgrade showed as successful, but the test_v11 table was not created.I also tried updating conf.php to 'mod_release' => '1.2', and again, the update process showe
Hi,I unlinked my IT100 license because i have to register more than 3 servers and 100 hosts.I thought its was possible with the free version ( unlicensed).Now i have one central server and 5+ remote servers. But i cant see more than 99 hosts.That s if i had the number hosts limitation, without the number of remote server limitation.Can someone to confirm its normal, or not ? Thank you
Bonjour à tous,Je suis actuellement en alternance, et dans le cadre de ma mission, je dois effectuer une migration complète de notre infrastructure qui est actuellement monitorée sous Eyes Of Network (EoN) vers Centreon sous redhat 9J'ai un grand nombre d'hôtes et de services à migrer, ce qui rend la tâche impossible à réaliser manuellement. J'aimerais automatiser le processus en utilisant l'API de Centreon pour importer directement les hôtes et les services depuis des fichiers XML générés par Eyes Of Network.Cependant, j'ai besoin d'aide pour :Comprendre comment structurer les appels API de Centreon pour automatiser l'import des hôtes et des services. Obtenir des conseils ou des exemples de scripts qui permettent d'effectuer ce type de migration. Savoir comment convertir correctement les informations des fichiers XML de Eyes Of Network pour qu'ils soient compatibles avec Centreon.Toute aide ou orientation serait grandement appréciée. Si quelqu'un a déjà réalisé une migration similaire
Hello,Im checking the apppool state with this command: /usr/lib/nagios/plugins/check_centreon_nrpe3 -H hostip -p 5666 -u -2 -P 8192 -c check_app_pool -a poolnameThis is the content of check_app_pool.ps1:[CmdletBinding()]Param( [Parameter(Mandatory=$True,Position=1)] [string]$ApplicationPool)Set-Variable OK 0 -option ConstantSet-Variable WARNING 1 -option ConstantSet-Variable CRITICAL 2 -option ConstantSet-Variable UNKNOWN 3 -option ConstantImport-Module WebAdministration$appPool = Get-Item "IIS:\AppPools\$ApplicationPool"if ($appPool -eq $null) { Write-Host "IISPOOL UNKNOWN: Application pool '$ApplicationPool' not found." exit $UNKNOWN}$state = $appPool.stateif ($state -eq 'Started') { Write-Host "IISPOOL OK: Application pool '$ApplicationPool' is 'Started'." exit $OK} elseif ($state -eq 'Stopped') { Write-Host "IISPOOL CRITICAL: Application pool '$ApplicationPool' is 'Stopped'." exit $CRITICAL} else { Write-Host "IISPOOL UNKNOWN: Application pool '$Applicati
Hello,I migrated my Centreon 22.10 from CentOS7 to Debian 11 successfully.Now il would like to migrate Centreon 22.10 to 24.04.Iam following Centreon Doc but after apt install --only-upgrade centreon i have :Can you help me please.Les paquets suivants contiennent des dépendances non satisfaites : centreon-gorgone-centreon-config : Dépend: centreon-gorgone (= 24.04.2-1~bullseye) mais ne sera pas installé centreon-license-manager : Dépend: centreon-gorgone (>= 24.04~) mais ne sera pas installé Dépend: centreon-gorgone (< 24.10~) mais ne sera pas installéE: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Hi team, I can't find the template that gave me the status of my storage on my server, like: === START OF SMART DATA SECTION === SMART overall-health self-assessment test result: FAILED!NVM subsystem reliability has been degradedto return as critical in Centreon
Hi all,Last week I upgraded my Centreon 23.04 open source on Debian 11 to 24.04 (still on Debian 11) and then Mariadb from 10.5 to 10.11 by following the official documentationSince this upgrade, some information seem frozen in the web ui.When I click on the poller menu I have two new lines : “incident on database 1” and “offline poller 1” I have only one poller and it is onlineOn the pollers configuration screen, my poller is still seen on 23.04 version and outdated On the resources status page, the last control column seems to be stuck at the upgrade date : By the way, the platform is still working as of notifications but I’d like to know what is the problème with those displays errors. Thank you
Hi,Do you know if it is possible to configure a Timeperiod to get the service running only the 06th of each months.Looks like we can only specify the week day and the time range … ?Thanks
Hi,On the legacy status page (Monitoring > Status Details > Services) it is possible to filter on hostgroup and then disable some services. I can’t manage to do it in the Resources Status page, nor in the configuration part of the UI. It’s Centreon Web 23.10.16. Did I miss something or is it a missing feature? I notice a few other actions also are missing, like enable/disable notification.As the legacy pages are supposed (I haven’t check that) to be no more present from 24.04 version, do you confirm those actions have been added to the new interface, or planned to be added in 24.10? I’ve been told the legacy pages wouldn’t be removed until all the functionalities have been ported to the new page but I’d like to have a confirmation before upgrading any plateform.NB: In the example above it would be obviously possible to filter on a service template (assuming a clean templating…) but I had a case recently for which it wasn’t an option. Above is only a dummy example for illustra
Hello,Is there a way to monitor systemd service from linux servers with snmp ?Thank you for your help
Bonjour,Pourriez vous me donner une solution pour le problème auquel je suis confronté qui apparait toujours lors de navigation sur la page ressources status en choississant la nouvelle vue par hôtes (essentiellement sur les navigateurs edge et chrome, l'anomalie n'a pas été détectée sur Firefox) (version centreon 23.10.12 et 24.04). L’erreur est réplicable lors de l’ouverture d’un onglet supplémentaire centreon puis en allant sur la page ressources status et en choississant la nouvelle vue par hôtes. Error visible on second webpage when the 3rd stay okCi-après la fenêtre de debug et un extrait des logs php-fpm : debug infos tail -f /var/log/php-fpm/centreon-error.log----------[02-Jul-2024 14:25:03 Europe/Paris] WARNING: Warning: Undefined array key "metrics" {"exception":"[object] (ErrorException(code: 0): Warning: Undefined array key \"metrics\" at /usr/share/centreon/src/Core/Resources/Infrastructure/API/FindResourcesByParent/FindResourcesByParentPresenter.php:170)"}[02-Jul-20
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.