Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi, on https://docs.centreon.com/docs/alerts-notifications/resources-status/#cql-criteria I can read: You can use regular expressions. Wildcards are not supported: a search pattern starting with a * is not valid.So `.*` isn’t supported anymore? But it seems than things like `[0-9]` aren’t either. So my question is, what regex I may use there?Use of regex was one of the rare amelioration this new page has, so I’m a bit disappointed. Second question, does a stabilization in how the search works is planned or will be there some other modifications in the future?
In the centreontrapd.log log file I have the following error which returns every minute:2024-05-07 08:09:49 - ERROR - 528 - MySQL error : cannot connect to database : Access denied for user 'centreon'@'localhost' (using password: NO) (caller: centreon::common::db:/usr/share/perl5/centreon/common/db.pm:268)2024-05-07 08:09:49 - ERROR - 528 - Cant load cache trap oids.2024-05-07 08:09:49 - ERROR - 528 - Dont skip trap. Need to solve the error.Is there a setting to modify to no longer have this error? Centreon still works.
I have install centreon with remoteDB and one poller based on centos8 ,it works well. but now I want to change the IP addresses of these three servers, and I would like to know which configuration files I need to modify to ensure that the monitoring system functions properly after the change.
Hello, I configured a fresh install of Centreon version 23.10.6 few months ago and I'm experiencing a strange problem with the service graphs.Some of them stop filling up after a random time but information collected are still correct, only the graph is impacted. SNMP v2c and v3 with a snmp user have been configured and tested on Windows and Linux to contact monitored servers. This happens randomly on Windows or Linux, sometimes in the same subnet (so not a firewall issue), sometimes not, and randomly on SNMP v2 or v3. On the same monitored host, not all services are impacted.When I restart the poller, graphics works for about 1 or 2 hours, then stop filling up.Does anyone have any ideas?Thank you in advance,Regards.
Hi, i have a new ALMA 9 Platform + Centreon 23.10.x I want to install - Azure CLI setup - https://docs.centreon.com/pp/integrations/plugin-packs/getting-started/how-to-guides/azure-credential-configuration/#azure-cli-setup Problem: conflicting requests - nothing provides libpython3.6m.so.1.0()(64bit) needed by azure-cli-2.29.2-1.el7.x86_64 from azure-cli(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) i check in the internet and i want to install ( manual ) dnf install /tmp/python3-libs-3.6.8-56.el8_9.2.alma.1.x86_64.rpmLast metadata expiration check: 1:00:33 ago on Mon Apr 15 13:22:00 2024.Error: Problem: conflicting requests - nothing provides python(abi) = 3.6 needed by python3-libs-3.6.8-56.el8_9.2.alma.1.x86_64 from @commandline - nothing provides libnsl.so.2()(64bit) needed by python3-libs-3.6.8-56.el8_9.2.alma.1.x86_64 from @commandline - nothing provides libnsl.so.2(LIBNSL_1.0)(64bit) needed by python3-libs-
Hello,We upgraded Centreon 21.10 to 23.10 on February 18, 2024.Since then we have performance issues on database server.Also we have replication issues bteween master and slave (backup) databases.Our DATA team is asking me about structural changes to the database.Who can help me find this information?
Hello,I’m trying to monitor RUT from Teltonika.When I check NTP :/usr/lib/centreon/plugins//centreon-plugins/centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode=time --hostname=10.151.40.254 --snmp-version='2c' --snmp-community='public' --ntp-hostname='10.240.10.254' --ntp-port='' --warning-offset='-5:5' --critical-offset='-30:30' --timezone=':Europe/Paris'CRITICAL: Time offset -7200 second(s): Local Time : 2024-04-09T07:01:16 (:Europe/Paris) | 'offset'=-7200s;-5:5;-30:30;; /usr/lib/centreon/plugins//centreon-plugins/centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode=time --hostname=10.151.40.254 --snmp-version='2c' --snmp-community='public' --ntp-hostname='10.240.10.254' --ntp-port='' --warning-offset='-5:5' --critical-offset='-30:30'OK: Time offset 0 second(s): Local Time : 2024-04-09T07:01:31 (+0000) | 'offset'=0s;-5:5;-30:30;;In Centreon interface, RUT are in Paris et on the web interface of RUT there are in PAris too.I don’t understand where is the problem. Is it
Is there a way to make alert notifications per user? That is, only one slack channel is notified (for example, in my case I use slack) of all alerts from hosts/services to which a given user has access.
hi all,i delete by error the central poller .but after i add it is not running.i have connection time refused to 127.0.0.1:5569with netstat i have only this line tcp6 0 0 127.0.0.1:50976 :::* LISTEN 4297/centengine all services are running.have you an idea how activate the port 5569 for localhost. Best Regards
Hi !I meet a problem when i import my exported files.Context : i exported all the services in one file.zip with the import/export centreon tools.I need to re-deploy my centreon virtual machine and re-install it.Before it, i exported 3 files : the hosts the services the commandsI redeployed/reinstalled the VM and Centreon and with my new instance, i imported the 3 files. The first problem is that when i import anything, i got the message ‘please wait… this process can take several minutes’.But after a long moment i refresh the page, export the poller configuration and reload it, and i see that i got new hosts for example.But for the services and commands, i imported it and there are a lot of missing from my exported configuration.I try to compare my previous configuration and new, and there are a lot of differences, somes commands was not imported, same for the services etc…Is someone met this problem already ?Is someone has a solution for me please ?Regards.Olivier
Hi,Am I the only one to get this: I got it first a coouple of days ago and I have been told by @Fabrix that it was a bug now resolved.It doesn’t seem resolved to me.Regards
Hello I want to supervise a Veeam backup with centre on 23.10 I searched into documentation, but it shows only configuration in centreon My question is if there is a configuration into veaam backup???
Hello The Watch,I try to copy/paste icons from Draw.io to Centreon Map Editor.First, everything seems to be OK ! I can edit the stencil with the height, width, style,… But, when click the ‘’save’’ button : It disappears !!!! 😭Does somedy know the issue ?Thank you.
Hi Community!I am facing on testing wsman cpu plugin, I followed the documentation provided, except the part of adding a new dedicated user, because I am testing with Administrator. Any idea on how to fix UNKNOWN: Could not enumerate instances: SSL connect errorCentos 8 StreamCentreon 22.04 Thanks in advance.
So, two days ago, i was there, i just ended migrating the databases, and this mornig, i just come to my office, load the page, and i get an error 404, the requested url was not found on this server. on the same page.My apache server is workinggorgoned,mariadb, cbd, all work well. however there’s no httpd neither httpd24-httpd services.I rolld back to the previous snapshot, same error.I uninstalled then reinstalled centreon-web, don’t work either.
Hi !First topic here, feel free to help me format / edit things or give feedback ! I’m new to centreon, but i’ve seen that there are quite a few topics related / with similar issues, but yet I can’t get my head around this issue !I’m trying to install a new server with local database, following the “using package” doc https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-packages/ The final aim would be to migrate from a 20.10 on our old infra to this new serverI’ve seen another post do it, I run an Oracle Linux Server 8.9, with ARM proc# cat /etc/*release |grep NAMENAME="Oracle Linux Server"PRETTY_NAME="Oracle Linux Server 8.9"CPE_NAME="cpe:/o:oracle:linux:8:9:server"# uname -maarch64# uname -r5.15.0-203.146.5.1.el8uek.aarch64I feel like I’ve followed every step of the doc, here is what I’ve “adapted” :End of step 1 : I tried with 23.10 and 24.04 (either one would be good for me) dnf module php : I tried with remi-8.1 and remi-8.0 Once I’ve downloaded the
i want to migrate from Centreon 2.8 on centoOS7 to Centreon 23.10 on Debian 11.While the whole installation, and webinstall went well, following that documentation , as soon as i try to transfer my databases, as indicated i get the following error on the login page of my server :Error while searching for the widgets version of the Centreon platformSQLSTATE[42S02]: Base table or view not found: 1146 Table 'centreon.provider_configuration' doesn't existError while searching authentication tokensNot only that, but i can’t log back with the credentials used on the old server, neither the one i was using before dumping my databases.I checked both /etc/centreon/conf/pm and /etc/centreon/centreon.conf.php, on both servers and they were using the same credentials on both.During the webinstall i entered the corresponding credentials for the admin profile.If you also need it, i’m running both on VMWare.I actually rolled back the new server on a snapshot who’s at the correctly ( or seemingly) con
Mise à jour de : centreon-license-manager-23.10.1-1.el8.noarch 31/96 Exécution du scriptlet: centreon-license-manager-23.10.1-1.el8.noarch 31/96PHP Fatal error: Class Core\Infrastructure\Common\Presenter\CsvPresenter contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Core\Infrastructure\Common\Presenter\PresenterFormatterInterface::format) in /usr/share/centreon/src/Core/Infrastructure/Common/Presenter/CsvPresenter.php on line 29Symfony\Component\ErrorHandler\Error\FatalError {#2755 #message: "Error: Class Core\Infrastructure\Common\Presenter\CsvPresenter contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Core\Infrastructure\Common\Presenter\PresenterFormatterInterface::format)" #code: 0 #fi
Installation avec documentation de MAP hebergé sur le central, je fini avec erreur 404Diagnostic:########## Centreon Map server version ########## [INFO] ii centreon-map-engine 23.04.0-bullseye amd64 Centreon Map service under Spring Boot framework########## System ########## [INFO] SELinux is not availableUnit firewalld.service could not be found. [OK] Firewall is disabled [INFO] Physical memory available on the server: 8135672 kb. [INFO] Number of CPU available on the server: 4 core(s)########## Java ########## [OK] Java 17 installed [OK] Optimization found for JVM: JAVA_OPTS="-Xms512m -Xmx4G -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/log/centreon-map -Dcentreon-map.signing-key=XveFFpHwCQ2MELePt7yeqCWsFFEHmQpM4deRRdQutwi8FfAzPDrgtG7FGYY4JZbLq -Dcentreon-map.access-token-validity-seconds=15552000 -Dmanagement.endpoints.enabled-by-default=false -Dmanagement.endpoint.health.enabled=true -Dmanagement.endpoint.metrics.enabled=true"########## Database connection ###
Hello The Watch,Will we have the possibility to create this kind of graphs that we can have on custom view on the new dashboards ?It is interesting for the inbound and outbound traffic for example. Thank you for your answerBest Regards,
Bonjour, j’ai un soucis avec le plugin centreon_genric_snmp.plEn effet je supervise une centaine de service sans problème mais sur quelques uns, les valeurs retournées ne sont pas les bonnes. /usr/lib/centreon/plugins//centreon_generic_snmp.pl --plugin=apps::protocols::snmp::plugin --mode=string-value --hostname=11.22.33.44 --snmp-community='MonSNMP' --snmp-version=2c --oid='.1.3.6.1.4.1.20542.9.1.1.4.3176.0' --format-ok='"Connected"' --format-warning='%{details_warning}' --format-critical='%{details_critical}' --format-unknown='%{details_unknown}' --warning-regexp="Not Enabled" --critical-regexp="Not Connected"OK: "Connected"J’ai comme résultat “Connected”Alors que si je fait la commande snmpwalk dans la foulée : snmpwalk -v 2c -c MonSNMP 11.22.33.44 .1.3.6.1.4.1.20542.9.1.1.4.3176.0iso.3.6.1.4.1.20542.9.1.1.4.3176.0 = STRING: "Error Connecting"j’ai bien ma bonne valeur. Cela ne le fait que sur certains Hôtes. Une idée ? Merci
hello I’m supervising vcenter version 8 with centeon 23.10! is it possible because I check in documentation the only versions to supervise are 6 and 7 !! any idea please
Bonjour,J’ai eu ce message d’erreur lors de l’upgrade du central : Mise à jour de : centreon-license-manager-23.10.1-1.el8.noarch 28/89 Exécution du scriptlet: centreon-license-manager-23.10.1-1.el8.noarch 28/89 // Clearing the cache for the prod environment with debug // falsePHP Fatal error: Class Core\Infrastructure\Common\Presenter\CsvPresenter contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Core\Infrastructure\Common\Presenter\PresenterFormatterInterface::format) in /usr/share/centreon/src/Core/Infrastructure/Common/Presenter/CsvPresenter.php on line 29CRITICAL: Fatal Error: Class Core\Infrastructure\Common\Presenter\CsvPresenter contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Core\Infrastructure\Common\Presenter\PresenterFormatter
Hello,My monitoring server is warning me about CPU Ready consumption over 5% but when I calculate this value with extracted data directly picked from my vcenter, I’m not able to find the same result.I also installed a new system which is able to graph CPU Ready and this value for a particular virtual machine doesn’t exceed 1%.What am I doing wrong with Centreon ?It seems that this value is multiplied by 10 in the plugin.Thank you for your help.
Hi,When I change a custom made command or a service on Centreon 23.10.11 WebUI, they are ignored until I restart all Centreon services :# systemctl restart cbd centengine gorgoned centreonIf I just try to export configuration as I did on Centreon 22.10 WebUI, all modifications made are ignored. Even if : Changes made on the command are present into /etc/centreon-engine/commands.cfg and /etc/centreon-engine/services.cfg but not on the service view from the top of the web page and are not monitored as expected.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.