Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I have installed a new AlmaLinux 8 poller to continue OS migration from Centos7 to Alma8.I have 1 central+1 poller on CentOS7 and 2 pollers on Alma8, all 22.04.12 versionThe new poller is installed but not integrated. It’s a fresh install, so it’s in 22.04.14 version.Before add the new poller to the platform, I want to update other servers from 22.04.12 to 22.04.14. First on my TEST platform ( centos7 ):Update of centreon-web, broker….:=> OKUpdate of all centreon-plugins => FAILED, all with the same error. Ex with this plugin:First I thought it was caused by new repos packages.centreon.com ( TEST server have new repos, PROD servers have old ones, yum.centreon.com ).So I tried on the TEST platform with old repos. Same error. Test with a Centos7 prod poller:I have tried the update of an unused plugin on a Centos7 prod poller ( with old repos )Same error !! Test with a Alma8 prod poller, with the same plugin ( old repos ):Update OK, with the same plugin So I’m stuck with this pro
Bonjour à toute la communauté,J’ai déja réussi à établir la communication entre GLPI 9.5 et Centreon 21.10.3 à travers le token.cependant la difficulté réside dans les autres éléments de paramétrage s’il en existe pour la création automatiques des tickets en cas d’alerte et une possibilité de réaliser les tests pour s’assurer que le module est fonctionnel. je reste en attente d’une procédure minitieusement détaillée et fonctionnel qui pourra m’aider à atteindre cet objectif. Merci
hello,I have a Centreon MSP platform on which we have deployed 3000 devices with 33000 services so far. However, I have noticed that the "/var/lib/centreon" partition is saturated despite having data available for only a one-month period.I have a Centreon MSP platform on which we have deployed 3000 devices with 33000 services so far. However, I have noticed that the "/var/lib/centreon" partition is saturated despite having data available for only a one-month period. /dev/mapper/vg_data-centreon_lv 677G 658G 19G 98% /var/lib/centreon du -sh /var/lib/centreon/*0 /var/lib/centreon/centcore312K /var/lib/centreon/centplugins260K /var/lib/centreon/centreon-bi-server1.8M /var/lib/centreon/installs0 /var/lib/centreon/log636G /var/lib/centreon/metrics338M /var/lib/centreon/nagios-perf0 /var/lib/centreon/perfdata18G /var/lib/centreon/status
Hello,I work on a dev environment. Is it possible to create maps in the "map engine" directly in the Centreon GUI, and export them to a production environment?Or to export the maps, I have to create MAP on the workstation client map, then right click and export map ?Other question: Centreon will continue support MAP legacy and map engine in the future ? Where eventually will we all have to switch to map engine?Thank you
Hello,Could you plan the package of NRPE 4.0.3 ?Actually the 4.0.2 who is built and packaged by Centreon have a bug with the nasty_metachars parameter https://github.com/NagiosEnterprises/nrpeSee the ChangeLoghttps://github.com/NagiosEnterprises/nrpe/blob/master/CHANGELOG.mdExtract :NRPE Changelog4.0.3 - 2020-04-28FIXESFixed nasty_metachars not being read from config file (#235) (Sebastian Wolf)4.0.2 - 2020-03-11FIXESFixed buffer length calculations/writing past memory boundaries on some systems (#227, #228) (Andreas Baumann, hariwe, Sebastian Wolf) Fixed use of uninitialized variable when validating requests (#229) (hariwe, Sebastian Wolf) About the deprecation of NRPE by Nagios and maybe the NSClient++ because the last release is April 2018, what is the roadmap ? using the NCPA agent ?Regards,
Bonjour,Utilisateur de clapi j’ai remarqué que lorsque j’utilisais getparam sur les services j’ai l’erreur:PHP Warning: Undefined variable $paramString in /usr/share/centreon/www/class/centreon-clapi/centreonService.class.php on line 579 Je suis allé voir dans le fameux fichier php et la variable paramstring n’est pas défini selon mes maigres connaissances.C’est non bloquant mais pour éviter à l’erreur de s’afficher à chaque ligne de commande j’ai défini la variable.L’erreur vient de moi ou c’est un oubli ?Bonne journée :)
Hi,In the resource details right panel, group names are truncated: This is in 22.10.7.Has it been fixed in 22.10.9 or in 23.04?
Hello,I have a bizarre problem with import/export of objects with CLAPIso I exported from Centreon 20.10 (centos 7) and I imported to Centreon 22.10 (debian 11)but when I export to the newest version, I got the name of certain objects truncatedin consequence, other objects could not be created since they're related to the correct name of those truncated objects nameseven after export, I could not change the name of those truncated names, only if I changed it directly in the databasedoes this might be considered as bug, or I am just missing a step? any insight could be appreciatedThank you(in the picture, normally the command object is named "App-Centreon-Mysql-Partitioning", but all P and A got truncated)
Hello !Firstly I’d like to thank all readers for your time and consideration. Now here’s my issue. When setting up centreon and mariadb along with it, I used a password containing ‘&’ and this would not have been a problem if I was not using NagVis as a plugin for centreon. The thing is that they use the same database and the same database user as well but NagVis config file raises errors when using characters such as ‘&’ or ‘²’ in the dbpassword variable.(I already tried to escape using ‘&’ by encoding it in UTF8 or ‘&’ but it doesn’t work) To fix this issue, I looked for a way to reconfigure database configuration in centreon but didn’t find anything, so I manually changed the hardcoded password in the multiple conf files which worked for a bit. But now, when I restart centreon-broker from the web interface, it replaces the password I replaced by the one with ‘&’. Thing is I can’t find out where it finds it from since I can’t grep it from anywhere else. Is the
Hello,in the new version centreon 23.04 I installed the plugin nsclient (nrpe) for that it is necessary to install the plugin: "yum install centreon-nrpe3-plugin". or dnf install but it doesn't find nrpe3 with version 23.04
Can I have more than one Certificate Authority on centreon 21.04?
HelloI have a Centreon 20.10.18 server and for a while I've been having a little problem viewing network graphs.Outbound graphs are well-drawn, but although data from outgoing connections exist, the inbound graphs are not visibles 😥Exemple:I have this behavior on absolutely all network card graphicsIf you can help me and solve this problem I would greatly appreciate it.Thanks in advance
Hi, After reading the various documentations and this forum I managed to get the plugin to work however I have an error in the response.I have the error :UNKNOWN: Cannot decode response (add --debug option to display returned content)If i add --debug to the commande the result seems good… Thanks for help. ======> request sendPOST http://localhost:8091/Accept: application/jsonUser-Agent: centreon::plugins::backend::http::useragentContent-Type: application/json{"password":"password","command":"getSystem","login":"login","host":"192.168.0.100"}======> response doneHTTP/1.1 200 OKConnection: keep-aliveDate: Wed, 29 Jun 2022 15:28:31 GMTContent-Length: 485Content-Type: application/jsonClient-Date: Wed, 29 Jun 2022 15:28:31 GMTClient-Peer: 127.0.0.1:8091Client-Response-Num: 1{"requestDuration":115,"code":0,"result":[{"batchJobWaitingForMessage":0,"batchJobHeldWhileRunning":0,"activeJobInSystem":290,"percentProcessingUnitUsed":10.9,"maxJobInSystem":163520,"batchJobOnUnassignedJobQueue":
Hello,I have a problem with graph generation. They are no longer being generated. I have checked the directory /var/lib/centreon/metrics and the .rrd files are present with the owner set as centreon-broker and the permissions set to -rw-r--r--. Additionally, I have regenerated the RRD databases from Administration => Settings => Data, but it still doesn't work. Moreover, all services are running fine and I don't see anything suspicious in the logs.Thanks for your assistance.
Hello Everyone,I´m currently receiving this error in some of my monitored MSSQL Databases.Unknown option: warning-database at /usr/lib/centreon/plugins/centreon_mssql.pl line 2118.This is the plugin.Also, I checked and the database “tempdb” is okay.If anyone can assist on this.Thanks in advance,
Hi Guys Did anybody has Centreon 23.04 HA cluster in production ?Did you noticed any bug ?Can I upgrade from 22.04 directly to 23.04 ?
Hello,I have a problem to monitor the interfaces, I have the following errors:“Unknown option: warning-input-power at /usr/lib/centreon/plugins/centreon_huawei_snmp.pl line 141.”following the plugin update.Has anyone encountered the problem before?THANKS
Hello !I use Debian 11 with Centreon 22.10.2When i try to add a host, the plug-in not showing up in templates list. Plug-in installation is ok.Can you help me please ? Thanks for your help.Romain
Hi,For some reason after upgrading Centreon from 22.10 to 23.04 I’m not able to access the About page. I see a message saying “You are not allowed to reach this page” It’s like the ACL is blocking my user but I do have access to everything. Of course it’s not important to loose access to the About page, it’s just strange 😅 For reference this was not a normal upgrade, I did migrate to Debian 11.I followed the Centreon documentation, so I installed Centreon on Debian 11, did the Web install and then migrated the data base to the new Debian server. Everything went fine, and everything else seems to be working as expected.I did try the About page on the fresh install of 23.04 before importing the production database to the new server and it was working fine, the problem with the About page only happened after importing the DB. Any ideas of what could be the problem and/or how to fix it ?
Hello everyone,Being new to Centreon, i just discovered clapi and tried to type a command line to do an action on a particular host but i get everytime such an error “Object ‘MyHost” not found in Centreon API”. So, i went to centreon documentation (https://docs.centreon.com/docs/api/rest-api-v1/) and saw that it was an error perhaps from an authentification matter. My errors are the 401 and 404.I can’t find a solution for the moment. I need help. Thank you :)
HelloThis question is probably for someone who know how the whole centreon plugin works, probably someone from centreon I’m working on a plugin for a SAN appliance with Rest, I did all the groundwork, followed the guidelines etc.. and I’m now tying up all the command line parameters and trying to have “correct” plugin in practice I managed to get my data selection working, and for example I use this in the loop for “manage_selection” $self->{filesystem}->{ $filesystem->{'NAME'} } = { name => $filesystem->{'NAME'}, storage_pool => $filesystem->{'PARENTNAME'}, space => { total_space => $total, used_space => $used, free_space => $free, prot_space => $prot, prct_used_space => $prct }I have a custom “space usage output” and some standard long output/prefix outputsub custom_space_usage_output { my ($sel
Hi everyone, we have two hosts that are on two different pollers in a parent/child relationship.Is there a way to show the relationship through an arrow (for example) on a map?Thanks
Bonjour,Suite à installation de centreon 22.10.7 au lancement de interface webErreur : Oops, something went wrongCela ne gène pas le fonctionnementComment corriger cette erreur ?Merci
Hi,I’m trying to use the Centreon Linux SNMP script “centreon_linux_snmp.pl” to monitor disk usage.I was able to configure all the parameters I needed but I’m seeing a strange behavior after I configure a “warning-usage-prct” or “critical-usage-prct”.For some reason, the output message changes depending if the disk utilization has triggered the warning/critical.Normal output:/usr/lib/centreon/plugins/centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=disk-usage --hostname=192.168.100.42 --snmp-version='3' --snmp-username='snmpuser' --authprotocol='MD5' --authpassphrase='cent1610!' --filter-disk-path='/$' --warning-usage-prct=80OK: Partition '/' usage total: 23.63 GB used: 17.95 GB (75.94%) free: 5.69 GB (24.06%), Inodes used: 4 % | 'count'=2;;;0; 'used'=19271544832B;;;0;25377501184 'free'=6105956352B;;;0;25377501184 'used_prct'=75.94%;0:80;;0;100 'inodes'=4%;;;0;100 Output when warning/critical is triggered:/usr/lib/centreon/plugins/centreon_linux_snmp.pl --plugin=os::linux
Bonjourje suis actuellement en train d’installer centreon sur un os centos 7, et je suis le tutoriel officiel de centreon À partir des paquets | Centreon Documentationaprès avoir suivi celui ci pour l’installation de l’os.*A partir de Centreon ISO el7 — Centreon 2.8 documentation mais je suis bloqué, lorsque je tape cette commande: yum install -y https://rpms.remirepo.net/enterprise/remi-release-7.rpm j’ai un message d’erreur et je ne sais pas pourquoi .j’aurai donc besoins d’aide car j’ai beau regarder sur internet, je ne trouve pas de solution. cordialement.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.