Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi all !I am installing a new Centreon 22.04 platform in order to use Centreon Debian repo.Everything is working well but I’m looking for a method to get my custom views (about ~ 20 views) in the new platform. Does everyone know a better method than re-create all views by hand ?Regards
I have an issu CentOS 7.9.2009systemctl status httpd24-httpd● httpd24-httpd.service - The Apache HTTP Server Loaded: loaded (/usr/lib/systemd/system/httpd24-httpd.service; enabled; vendor preset: disabled) Active: failed (Result: exit-code) since Wed 2022-10-19 15:27:55 CEST; 5min ago Process: 15682 ExecStart=/opt/rh/httpd24/root/usr/sbin/httpd-scl-wrapper $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE) Main PID: 15682 (code=exited, status=1/FAILURE) Status: "Reading configuration..."Oct 19 15:27:54 srv-log systemd[1]: Starting The Apache HTTP Server...Oct 19 15:27:55 srv-log httpd-scl-wrapper[15682]: (20014)Internal error: AH00058: Error retrieving pid file run/httpd.pidOct 19 15:27:55 srv-log httpd-scl-wrapper[15682]: AH00059: Remove it before continuing if it is corrupted.Oct 19 15:27:55 srv-log systemd[1]: httpd24-httpd.service: main process exited, code=exited, status=1/FAILUREOct 19 15:27:55 srv-log systemd[1]: Failed to start The Apache HTTP Server.Oct 19 15:27:55
Hello,I need to add multiple hosts, but when i try to send this request, it responds with a 400 (Bad parameters):Works only with 1 host (200 code):What is the correct way to add them?Thanks for your help.
Hello,In the reports many hosts have an undetermined status because they were added in Centreon during the year.As a result the available status of these hosts and globally is wrong.Is there a way to generate this report whitout taking the indeterminate status ?Or am I doing it wrong… Thank you
Hi Everybody,I am a old user of centreon, after the 22.04 i use sso configuration with http_header and i now want to use with openid. I configured my lemonldap and after test, when i click on “connect with Openip” i go to my lemonldap and return on the login prompt.Centreon-web.log is not very verbose [2022-10-06T17:12:40+0200] [INFO] [EventSubscriber\WebSSOEventSubscriber:188]: finding web-sso configuration[2022-10-06T17:12:40+0200] [INFO] [Core\Application\Platform\UseCase\FindInstallationStatus\FindInstallationStatus:47]: check installation status of centreon web[2022-10-06T17:12:40+0200] [DEBUG] [EventSubscriber\UpdateEventSubscriber:69]: Checking if route matches updates endpoint[2022-10-06T17:12:40+0200] [INFO] [EventSubscriber\WebSSOEventSubscriber:188]: finding web-sso configuration[2022-10-06T17:12:40+0200] [DEBUG] [EventSubscriber\UpdateEventSubscriber:69]: Checking if route matches updates endpoint[2022-10-06T17:12:40+0200] [DEBUG] [EventSubscriber\UpdateEventSubscriber:69]:
Hi After upgrade to 22.04, i have a soucy. when i call my url centreon.domain.net i am redirect to https://centreon.domain.net/centreon and it’s work. but i want refresh my page my browser remove my /centreon/ folder and loop redirect. my centreon server is behind apache proxy and i have rewrite rule.
How do i filter out results retuned by the Watchguard plugin mode hardware to only show interface eth0 and eth1 and not eth2, eth3 or eth4 which are unplugged.command:/usr/lib/centreon/plugins//centreon_watchguard_snmp.pl --plugin=network::watchguard::snmp::plugin --mode=hardware --hostname=x.x.x.x --snmp-version='2c' --snmp-community='XXXX' --component='.*' --verbosereturns:CRITICAL: Device 'network interface eth2' status is 'down' - Device 'network interface eth3' status is 'down' - Device 'network interface eth4' status is 'down' | 'count_device'=10;;;;Checking devicesdevice '' status is 'running' [instance = processor.196608]device '' status is 'running' [instance = processor.196609]device '' status is 'running' [instance = processor.196610]device '' status is 'running' [instance = processor.196611]device 'network interface eth0' status is 'running' [instance = network.266240]device 'network interface eth1' status is 'running' [instance = network.266241]device 'network interface et
Hello everyone, I have configured the sending of mails for centreon however I can't find where to put the "from", I have an address in noreply@xxxxxxx, but I don't know where to put it, my mails are sent with :configuration of the file /etc/postfix/main.cfthank you in advance Kélian
Hello,While i was trying to configure the Postfix to send mails, I always end up with the same problem : myadress@outlook.com not allowed to send as root@hostname.localdomain STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message [BeginDiagnosticData]Cannot submit message. The relayhost = [smtp.office365.com]:587 like it is write in outlook.Does anyone know how to solve this problem?Thanks for your help.Kind regards,
Hello Team, I would like to change the sender of the notification because my SMTP server allow only a specific mail address. Thanks for your help.
Hello I want to install centreon on Virtual machine test with package method because we don’t have a Centos ISO for 22.0.4 :(I have follow this documentation after Debian11 fresh install: https://docs.centreon.com/fr/docs/installation/installation-of-a-central-server/using-packages/When I want to install centreon with :apt install centreon we have these two many error: L'information suivante devrait vous aider à résoudre la situation : Les paquets suivants contiennent des dépendances non satisfaites : centreon-gorgone : Dépend: libnet-curl-perl mais il n'est pas installable Dépend: libssh-session-perl mais il n'est pas installable centreon-plugin-applications-databases-mysql : Dépend: libcrypt-argon2-perl mais il n'est pas installable Dépend: libhttp-proxypac-perl mais il n'est pas installable Dépend: libkeepass-reader-perl mais il n'est pas installable
Bonjour,J’essai d’effectué une requête SQL avec le plugin sql-statement PostgreSQL mais à chaque execution j’ai une erreur que je n’ai pas via l’editeur PostgreSQL. Voila la requete:centreon_postgresql.pl --plugin=database::postgres::plugin --host=192.168.100.179 --username='username' --password='password' --port='4432' --mode='sql' --sql-statement='select case when "Status" = 7 then 1 else 0 end as Execution FROM public."ExecutionResults" where "TaskID" = '75c49284-8b61-442c-bec5-7567027602f2' order by "StartTime" DESC limit' --warning='' --critical=''Voici l’erreur que me remonte la requete:UNKNOWN: Cannot execute query: ERREUR: erreur de syntaxe sur ou pr▒s de ▒ c49284 ▒LIGNE 1 : ...FROM public."ExecutionResults" where "TaskID" = 75c49284-8b6… POuvez vous m’aider sur cette erreur car je ne trouve pas.MerciSebastien
Hello,I just installed the Centreon version from the VMware template provided by Centreon.I strictly followed the setup and the different actions to be carried out. I started to fill in my database but after changing my password, I can no longer log in. I followed the procedure I found on this page (https://thewatch.centreon.com/platform-7/user-is-blocked-742#:~:text=Login%20to%20the%20community&text= Forgot%20password%3F,instructions%20to%20reset%20your%20password.), but it doesn't work.Is there a particularity related to version 22.04.7?Thank you for your help.
Hello everyone,I have some troubles with graphs in version 22.04. I installed centreon 2 weeks ago but i can’t see graphs it says ‘there’s no data’I searched how to fix this but i didn’t see any problems on internet can someone help me please ?
Hello everybody ,I have a question for you .How are calculated metrics in /var/lib/centreon/metrics In my CENTRAL folder each files are 76K or 224K for some of them .But for my remote serveur , each file are 2.1M and my folder is full . I want to purge them , but they come over and over .How to purge really ?
I am looking for a way to monitor system and application logs on remote servers but without installing an NRPE agent. My servers are configured in snmpv3 and the standard monitoring works well. On other servers we use the check_logfiles plugin to monitor error messages in logs. I am looking for a way to use either check_logfiles or equivalent but without having to install an nrpe agent. Is there a way for exemple link ELK with Centreon or this kind of methodes?
Hi,Has someone already tried to use the Open-Tickets Plugin (Used to create tickets to a provider like ITSM, or JIRA).I installed it and created a first rule.But when I try to add the Widget (In Custom View) : I always get the error “Please create a rule first”.The documentation I followed is this one : Configuration | Centreon Documentation Thanks a lot
Hello everyone! I want to use the plugin packs and check what each argument is supposed to do and which options are available for a given plugin. Is there a documentation on how to do that?
Hello,In Centreon there is a Netscaler plugin that monitors the Hardware but it does not provide us with information about memory and CPU consumption. So we are creating a script to monitor these parameters via SNMP (through the OIDS and snmpwalk). Once assigned, the OIDS indicated by the manufacturer do not appear. We believe that when this happens it is necessary to add the MIBs file.It is right? And if it is, how should it be done? Thanks Best Regards,
Hello, since the upgrade from 21.04 to 22.04 I no longer have an RRD graph displayed Thanks for your help
Hello, Can you tell me if the new centreon map edition environment is available and operational ?I mean Centreon Map client on IHM directly ?We’ve seen that it’s one of the subject of the centreon summit 2022 ! A great news buy the way. Thanks
Hi, general question I can visualizee.g.which host has the service = xywhich host has assigned the service xyAll host = 400Service = eg MSQL servicee.g. result = 47 host Widget / Graphical and so on e.g. widget - service monitoringbut do not show all hosts , only the number of hosts have the service anyone has a idee Thanks
I have multiple host who have detailed status (Host assumed to be UP), but I don't know why. Host and services are green.This may cause problems ?
Hello, If two users have created a recurring downtime, is it possible to add an acl that only sees the downtime they created? CordialyFrancis
Hello,I just finilized installation of Centreon on GCP, my topoligy is 1 central in EMEA and 2 poller 1 in US and another one in Singapore.I monitor 1000 hosts and 5000 services.I have an error ‘Latency detected, check configuration for better optimization’, and I see that my graph is not complete…Help please :)
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.