Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I am using the Hirschmann plugin pack to monitor a switch.The memory service returns a strange critical error:CRITICAL: Memory total: 79.77 MB used: -87.12 MB (-109.22%) free: 166.88 MB (209.22%)Here is the command :/usr/lib/centreon/plugins//centreon_hirschmann.pl --plugin=network::hirschmann::standard::snmp::plugin --mode=memory --hostname=10.0.X.X --snmp-version='3' --privpassphrase='XX' --authprotocol='MD5' --snmp-username='admin' --privprotocol='DES' --authpassphrase='XX' --warning-memory-usage-prct='80' --critical-memory-usage-prct='90' The other checks are not a problem: CPU, Process, Hardware…The poller is installed on a debian server and the version of the net-snmp package is 5.9+dfsg-3Is there a solution to this problem?Best regards
Hello,we have an issue with pollers aren’t updatedbefore this happened, we had an incident with database partition which was full, so we resolved that and we got this problem afterI did restarted all services : cbd, centengine, gorgoned, mysqland they are all active and runningand in the logs side, on the central-module-master.log, we have this block of errors which is repeated every time I restart the cbd service:[2022-07-27T10:27:56.421+02:00] [tcp] [error] Error while reading on socket: End of file[2022-07-27T10:27:56.516+02:00] [core] [error] failover: global error: Attempt to read data from peer localhost:5669 on a closing socket[2022-07-27T10:27:56.516+02:00] [core] [info] BBDO: unable to send stop message to peer, it is already stopped: Attempt to read data from peer localhost:5669 on a closing socket[2022-07-27T10:27:56.516+02:00] [core] [info] bbdo stream stopped with 0 events acknowledged[2022-07-27T10:27:56.518+02:00] [tcp] [error] TCP: Connection refused to localhost:5669[
HelloI have a strange behavior when I import certain ldap usersI get a blank Contacts/Users pageI enabled ldap debug, and on centreon-error.log, there is this error every time I try to import an userPHP Fatal error: Uncaught PDOException: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`centreon`.`contactgroup_contact_relation`, CONSTRAINT `contactgroup_contact_relation_ibfk_1` FOREIGN KEY (`contact_contact_id`) REFERENCES `contact` (`contact_id`) ON DELETE CASCADE) in /usr/share/centreon/www/class/centreonDB.class.php:274Stack trace:#0 /usr/share/centreon/www/include/configuration/configObject/contact/DB-Func.php(1277): CentreonDB->query('INSERT INTO con...')#1 /usr/share/centreon/www/include/configuration/configObject/contact/ldapImportContact.php(134): insertLdapContactInDB(Array)#2 /usr/share/centreon/www/include/configuration/configObject/contact/contact.php(168): require_once('/usr/share/cent...')#3 /usr/
Hello everyone,I'm trying to update Centreon 21.04.13 by following this procedure: Montée de version depuis Centreon 21.04 | Centreon DocumentationEverything is working fine during the installation and I am now able to login !However, I have got the following errors on the GUI :Pollers not running Database issueI’ve checked the Centreon logs but I could not find anything related to this error.I’ve followed the troubleshooting article from Centreon, everything seems to be OK (https://www.centreon.com/blog/centreon-troubleshoot-series-episode-1-help-mon-poller-ne-fonctionne-pas/)Thank you in advance for your help !Kind regards UPDATE : I have find something strange, the version of the poller is “Centreon Engine 21.04.4”
Hello, I have a status issue when I use the "centreon_stormshiel_snmp.pl" plugin to check storage.I want to check a specific storage:→ ./centreon_stormshiel_snmp.pl --plugin network::stormshield::snmp::plugin --hostname @IP --snmp-version 3 --snmp-autoreduce --snmp-username user --authpassphrase pwd --authprotocol SHA --privpassphrase pwd --privprotocol AES --mode storage --storage=’(/|/data|/var|/log|/tmp)$’ --name --regexp --warning-usage 80 --critical-usage 90 If i run this command directly on my central server, i have a great status, but on centreon GUI, i have “Warning - (no output returned from plugin).If i modify the --storage for /data for exemple, it’s ok on GUI.I have enable the checkbox “Enable shell” on the “Configuration → Commands → checks → name:xxx) Can you help me please ?Thank you
Hi I have a problem with my /var/lib/mysql space disk it is almost full and when its full everything will be down, which file can I remove or what can I do to solve this problem ?
Hello,In Centreon I have duplicate check with Ping for my hosts.One on the host and a second as a service.When I remove the check with the Ping service, I have this warning when exporting the poller configuration :Warning "name host" has no services associated with it!Is it possible to remove this warning or am I doing it wrong ? Thank you
Hello,I don't know if the problem is me, but when I install the poller using version 21.04 I get a return to yum errorhttps://yum.centreon.com/standard/21.04/el7/stable/x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to yum.centreon.com:443; operation in Classes "Try another mirror.https://yum.centreon.com/standard/21.04/el7/stable/x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to yum.centreon.com:443; operation in Classes "Try another mirror.https://yum.centreon.com/standard/21.04/el7/stable/x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to yum.centreon.com:443; operation in Classes "Try another mirror.https://yum.centreon.com/standard/21.04/el7/stable/x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed to connect to yum.centreon.com:443; operation in Classes "Try another mirror.Can anyone tell me how can I repeat this?Cordiallyfrancis
Hi there I have a problem with Centreon MAP desktop client, when I synchronise resources, I have this error : Resource synchronization has crashedIn the log on the server, I have :[2022-04-21 16:44:24.995] [ERROR] [c.c.s.m.s.b.s.impl.CentreonSynchronizer] [StudioScheduledTask-7] : Error while running CentreonSynchronizerorg.springframework.orm.jpa.JpaSystemException: More than one row with the given identifier was found: 4278, for class: com.centreon.studio.map.server.dao.centreon.entity.ExtendedServiceInformation; nested exception is org.hibernate.HibernateException: More than one row with the given identifier was found: 4278, for class: com.centreon.studio.map.server.dao.centreon.entity.ExtendedServiceInformationAny idea?Thanks!
Hi, We have a Centreon 20.04.3 working like a charm for several months and years.But, since about 10 days, we can no more update and apply changes in monitoring.More precisely, when :creating a new service for an existing host, and exporting to all servers, conf is OK but monitoring is not refreshed/applied, modifying an existing service, with just a change (IP, ...), and exporting : same thing. Conf OK but monitoring is not updated.Of course, central, sat, etc… have been rebooted… No changes.We are not able to know what action we have done, which could create our problem. We have deleted 10 or 15 days from now, one host, but not attached services. So we have now services we cannot update/view because of lack of their host. But not sure that is connected to our problem.We do not know where to investigate… Any idea ? PS : Our Centreon is clustered : one Mysql server, one central, and 6 sat.
Hi,I am currently monitoring a QNAP NAS with SNMP, and i wasn’t really satisfied with the way the QNAP plugin handled the data and i had compatibility issues with some of the functions so i decided to make my own checks for the memory utilisation.Here’s my issue :Basically, when i ask for the amount of free memory on my NAS with a get-snmp request, i get this value :This is exactly what i want on Centreon since i can display this on a graph.However, when i use the generic-snmp plugin with the same parameters, i get this…It seems that the plugin interprets the result as “ok” without giving me the actual value. Using the --verbose flag doesn’t change the result either.How do i formulate the snmp command to get a proper value? Here’s the syntax i use right now :perl centreon_generic_snmp.pl --plugin apps::protocols::snmp::plugin --mode string-value --hostname “IP” --snmp-version 3 --snmp-username ‘username’ --authpassphrase 'passphrase' --authprotocol MD5 --oid .1.3.6.1.4.1.24681.1.2.3.0T
Hello,I have a little machine with a little of ram and CPU.I have a poroblem with only this machine when she have a big load.I see two kind of error in centreon : Snmp time out Process timeout1 - Snmp timeoutI think i resolv Snmp timeout by using --snmp-timeout in the command (centreon plugin via github). 2 - Process timeoutFor the process timout i read official doc and increase timeout in poller configuration. (increase x2).It is better but for some service i see again Process timeout error.Can yu have idea or something to troubleshoot ?thx a lot
Hello,I followed this doc (https://docs.centreon.com/fr/docs/upgrade/upgrade-from-21-10/) for upgrade Centreon 21.10 to 22.04.I am stuck in the upgrade step 21.10.1 to 21.10.2 : It loads for hours with no result, anyone have any idea what's going on ?Thank you for your help.
Hello friends,My old platform is running under Centos 7 with Centreon 22.04.I prefer using now Debian 11. I see yu just launch Debian 11 package.My step : I have made a fresh install of centreon 22.04 on Debian 11 using package and offical doc Now i want to migrate from my old Centos 7 Centreon 22.04 to my new server Do yu have a official doc or something like that because i found nothing ? Thx a lot
HelloI would like to obtain metrics and a graph on the Traffic of an Alcatel 6560 port via snmp.Do you have a solution and could guide me please?CordiallyRichard
Hi there,We need to configure the LDAP on Centreon 22.04.0, but impossible to complete the configuration because in the contact template section nothing is displayed.We tried on all web browsers nothing is displayed anyone has an idea.We are on the last VM download on the official site of Centreon.Thanks for your help.
Hello,I suggest a new idea.Is it possible to see the alarms directly on the first container of the map.I explain.We have multiple view in the Map, but when there is an issue, we can’t see it directly on the Map.We have to clic on one of the map to see if there is a pb.
Hi, I used to use SNMP to monitor the disk space of my servers and I used --filter-perfdata='storage.space|used|free' to have a nice display in my web interface and in my notifications. Today I use NRPE but unfortunately the display is like this: What option would allow me to have the used space in % or the free space in %?what i have now :( Thanks in advance :)
Hello there !I have a little problem when i want to use the icmp_check on my firewall.For the details :My Firewall allow ping from my LAN (it’s a sophos firewall) When i’m connected on Centreon an i use the check in CLI it work When it’s the centreon-engine who use the check the error message is : check_icmp: Failed to resolve : Nom ou service inconnuThanks for your help !
Hello,With the template OS-Windows-Traffic-Global-SNMP i’m able to have the traffic in and out of the host but i don’t why that take many interface (even if i have only one) and it to me. I discover that the different traffic in are equal with each other and the out are equal too with each other. It doesn’t have an impact because in the graph they print in the same path, however when they are too many i can’t have information. In this picture it show the problem and i have only one interface.If you have any idea will be great.
Hello, I used centreon-plugin-Cloud-Prometheus-Kubernetes.Suddenly my service return Cannot decode json response with the extra large output like:UNKNOWN: Cannot decode json response: {"kind":"DeploymentList","apiVersion":"apps/v1","metadata":{"resourceVersion":"285898050"},"items":[{"metadata":{"name":"frt-user-compet","namespace":"cmp","uid":"1584f994-863e-4753-8178-f1d4be407dc9","resourceVersion":"282014202","generation":18,"creationTimestamp":"2022-06-22T10:35:46Z","labels":{"k8s-app":"frt-user-compet"},"annotations":{"deployment.kubernetes.io/revision":"11","kubectl.kubernetes.io/last-applied-configuration":"{\"apiVersion\":\"apps/v1\",\"kind\":\"Deployment\",\"metadata\":{\"annotations\":{},\"labels\":{\"k8s-app\":\"frt-user-compet\"},\"name\":\"frt-user-compet\",\"namespace\":\"cmp\"},\"spec\":{\"revisionHistoryLimit\":1,\"selector\":{\"matchLabels\":{\"k8s-app\":\"frt-user-compet\"}},\"strategy\":{\"rollingUpdate\":{\"maxSurge\":\"25%\",\"maxUnavailable\":\"25%\"},\"type\":\"
Hi,I tried today to setup a new centreon central server using the latest Rocky Linux 8.6 as the host, since i was under the assumption that RL was the standard followup to centos, and i found reference to it in the unattended script.I found it perfectly working (only had a simple issue regarding permissions in /etc/centreon-engine and /etc/centreon-broker), but i still have one issue that i cannot find a solution for, i cannot reload configuration of restart centengine from the webui. If i generate and move configuration files, then restart manually centengine, all is good and monitoring works fine. But trying to reload or restart from webui result in this log in gorgoned.log2022-07-08 18:17:49 - INFO - [legacycmd] Handling command 'ENGINERELOAD', Target: '1'2022-07-08 18:17:49 - ERROR - [action] validate plugins - unsupported operating system2022-07-08 18:20:00 - INFO - [cron] Launching job 'broker_stats'2022-07-08 18:20:00 - INFO - [cron] Launching job 'engine_stats'2022-07-08 18:20:
After the Upgrade to 21.10 I have one service that stops to work.I’m receiving this error: UNKNOWN: Can't locate object method "is_zero" via package "Math::BigInt" at /usr/share/perl5/Math/BigInt.pm line 1198.
Bonjourje cherche a superviser des données de téléphonie dans teams , comme la latence/gigue/perte paquet ou encore le nombre d’appel en VOIPfaut-il attendre que Microsoft développe un api ? afin que centreon puisse le faire ? Merci
Hi,This is my first topic, please keep nice with me ;-)i have create a service wich use a script python. i build an url to return on the field “Extended status information”for example : https://myhost.com/detail?param1=4&param2=12 But when i receive the notification by mail, the character “&” (Ampersand or esperluette in french) is missingThis is my command of notification by email :/usr/bin/printf "%b" "$SERVICEOUTPUT$\n\$LONGSERVICEOUTPUT$\nNotes : $SERVICENOTES$\nLien d'aide de resolution : $SERVICENOTESURL$\n\n\nDate/Time: $DATE$/$TIME$\nService: $SERVICEDESC$\nHote : $HOSTALIAS$\nStatut : $SERVICESTATE$\n\n" | @MAILER@ -r noreply.supervision@isocel.info -s "Supervision ALICE - $SERVICEDESC$" $CONTACTEMAIL$ Have you got an idea to keep the “&” on my url please ? Thanks a lot.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.