Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,We have some vm hosted by our provider but we can't get the services up.i tried with snmp (tcp 5666) or nrpe (udp 161) but both not working.The ISP opened those ports in their firewall.The one in red is nrpeThe one in green is snmpfor both type of services on the same VM it seems like something blocking but i dont know where.snmpwalk works but i get this message when typing it on the centreon centralAny advice or any ideas?Best regards,Stephane ADEKALOM
Hi,Since few days, I have following errors in /var/log/centreon-gorgone/gorgoned.log Last week, errors were gorgoned.log-20250629:2025-06-28 03:40:47 - ERROR - [proxy] Send message problem for '10': gorgoned.log-20250629:2025-06-28 03:41:47 - ERROR - [proxy] Send message problem for '10': And since 2 days, I have this :2025-06-30 09:23:57 - ERROR - [proxy] container 1: Receiving DIE: Usage: EV::Loop::io(loop, fh, events, cb) at /usr/share/perl5/vendor_perl/gorgone/class/clientzmq.pm line 399.2025-06-30 09:29:17 - ERROR - [proxy] container 1: Receiving DIE: Usage: EV::Loop::io(loop, fh, events, cb) at /usr/share/perl5/vendor_perl/gorgone/class/clientzmq.pm line 399.2025-06-30 09:34:37 - ERROR - [proxy] container 1: Receiving DIE: couldn't do /usr/local/lib64/perl5/auto/share/dist/FFI-Platypus/config.pl Too many open files at /usr/local/lib64/perl5/FFI/Platypus/ShareConfig.pm line 45.2025-06-30 09:34:37 - ERROR - [proxy] container 1: Receiving DIE: couldn't do /usr/local/lib64/perl5/aut
Hello,If I’ve understood correctly, with the plugin centreon_nsclient_restapi, we can access to Application, Security and System Windows logs.Do you know if there is a possibility to access to Setup ?
Bonjour j’ai installer centreon 24.10 sur debian 12 et tout focntionne correctement mais le central est toujours n’est pas encours d’éxécution que dois je faire !!merci d’avance
/centreon_cisco_standard_snmp.pl --plugin=network::cisco::standard::snmp::plugin --mode=stackis doing fine for physical stack switches.We have some stackwise virtual switches in fine condition, but this check is showing up as ‘notredundant’.old classical stack:OK: Stack status is 'redundant' - Number of members waiting: 0, progressing: 0, added: 0, ready: 2, SDM mismatch: 0, version mismatch: 0, feature mismatch: 0, new master init: 0, provisioned: 0, invalid: 0, removed: 0 - All stack members status are ok | 'waiting'=0;;;0; 'progressing'=0;;;0; 'added'=0;;;0; 'ready'=2;;;0; 'sdm_mismatch'=0;;;0; 'version_mismatch'=0;;;0; 'feature_mismatch'=0;;;0; 'new_master_init'=0;;;0; 'provisioned'=0;;;0; 'invalid'=0;;;0; 'removed'=0;;;0;.1.3.6.1.4.1.9.9.500.1.1.3.0 = 1.1.3.6.1.4.1.9.9.500.1.2.1.1.3.1000 = 1.1.3.6.1.4.1.9.9.500.1.2.1.1.3.2000 = 4.1.3.6.1.4.1.9.9.500.1.2.1.1.4.1000 = 15.1.3.6.1.4.1.9.9.500.1.2.1.1.4.2000 = 14.1.3.6.1.4.1.9.9.500.1.2.1.1.5.1000 = 0.1.3.6.1.4.1.9.9.500.1.2.1.1.5.2000
Certain poller not sending email notification.Check configuration of working poller to problematic poller and cant see the issue.Tried troubleshooting email test to poller not sending any email notification:echo "test" | mail -s "test" test@test.comtesting goes thru and received my test emailany idea where to check or we missed out for this poller?Centreon version 21.10.7
Hello Centreon addicts, We were using Centreon 2.8.32 community edition for about 3 years and were very happy with it to manage our infra, so we decided to buy a License for upgrade to the latest version and use the commercial plugins.BUT, migration is really not an easy way, I’ve first tried to follow the migration path on Centreon Web Site (https://docs.centreon.com/fr/docs/migrate/migrate-from-3-4/) but we follow a lot of issues with the database that cannot pass the UPGRADE - 22.04.1 step…Then I tried to use the Export feature on the old one but it stays running for days without evolution, then I decided tu use centreon-clapi -e from command-line, and ther a very enormous file is generated (more than 50GB !!!) but it does not reach the end of the export and fails with that error message: A critical diagnostic event occurred in the memory device. Retry operation. <br/>--Novell NMS trap annotation<br/>Variables:<br/> 1: alertSystem<br/> 2: alertTableIndexOID
Hi, I have a problem using the APIs.I created my API with the admin accountcurl -s -d "username=admin&password=MyPassword" -H "Content-Type: application/x-www-form-urlencoded" -X POST https://Website/centreon/api/index.php?action=authenticate{"authToken": "MyAPI"} curl -s -H ‘X-AUTH-TOKEN:'MyAPI’' -H “Content-Type: application/json” -X GET 'https://Website/centreon/api/latest/configuration/monitoring-servers/7/generate-and-reload' It returns the error {"code":500, "message": "There was an inconsistency error in the exported files - please use the legacy export menu to troubleshoot"}I'm using Centreon version 24.10.7. There's an IP to access the web interface in front of a reverse proxy for the central unit. Another IP is assigned to the central unit for communication with pollers.I don't understand where my problem comes from.
Bonjour a tous, Je viens tout juste de mettre à jour mon Centreon de la version 22.04 à 24.10, et l’opération s’est bien déroulée. Les versions du central et des pollers sont à jour, tout comme le serveur de base de données, qui utilise désormais MariaDB 10.11.Cependant, je rencontre un souci d’affichage global de l’interface web. Il semble que Centreon n’arrive pas à charger correctement le thème, même après avoir vidé le cache de mon navigateur.Test fait en ingconito, meme resulta.Auriez-vous une piste ou une solution à me proposer, s’il vous plaît ?A savoir que je suis sur AlmaLinux 8.Merci d’avance pour votre aide.;)
Hello,I’m currently experiencing an issue in the Service Discovery module of Centreon.When trying to scan services for a specific host, the search field should suggest the host as I start typing its name (after entering the first 3 letters, for instance). However, in my case, no suggestions appear, even though the host is properly configured in the system and enabled.🔍 Expected behavior:When typing the first letters of a host name (e.g., "Cen"), the host "Centreon-Server" should appear in the suggestion list.🐞 Observed behavior:No suggestion is shown, even though the host exists and is fully configured (status: enabled, correct poller, and template applied).📎 Attached screenshots: Host Configuration (Host “aaaaaa” exists and is enabled) Service Discovery search box (typing “Centreon” returns nothing) Could you please advise if this is a known issue or if there are specific requirements for the host to appear in the Service Discovery module?Thanks in advance for your help.
Hello,I’m using the Debian Bookworm Centreon image you provide. The loading of the “Loading monitoring connectors” is very very slow, but more generally browsing in any page is quite slow I tuned few Mariadb SQL Backend settings and also tuned some PHP settings but it’s still very slow What is strange is that the CPU usage and memory usage is not full (around 50%) Any idea would be very appreciated Many thanks
Bonjour,Je souhaite installer Centreon 24.10 sur AlmaLinux 8.10. Selon la documentation officielle de Centreon les paquets de la version 24.10 sont compatibles avec AlmaLinux 8, AlmaLinux 9, RHEL 8/9, Oracle Linux 8/9 et Debian 12.Voici les informations de mon système :NAME="AlmaLinux"VERSION="8.10 (Cerulean Leopard)"PLATFORM_ID="platform:el8"Donc je suis bien sur une base EL8, ce qui est officiellement pris en charge.Cependant, lors de la configuration du dépôt j’ai eu cettre erreur :https://packages.centreon.com/rpm-standard/24.10/el8/x86_64/repodata/repomd.xmlMerci de me confirmer si les dépôts EL8 pour Centreon 24.10 sont bien disponibles et fonctionnels. Sinon, dois-je utiliser Centreon 24.04 en attendant ?
Bonjour,Sur une derniere version 23.10 j’ai continuellement l’erreur suivante sur mon collecteur:ERROR - [core] Package 'gorgone::modules::core::action::hooks' already loadedJ’ai tenté de supprimer ces 5 dernieres lignes dans le 40-gorgone.yaml du collecteur mais rien y fait Merci pour vos retours
Hello,My cisco C3850 switches are attached to the Net-Cisco-Standard-Environment-SNMP-custom model.Centreon display these WARNING for some switches:Temp Inlet Sensor 0/1012' is 29 C Temp Inlet Sensor 0/1012' is 30 CTemp Inlet Sensor 0/3012' is 31 CTemp Inlet Sensor 0/1012' is 20 C Temp Inlet Sensor 0/3012' is 31 CRegarding the temperatur, the color should be green and not orange. How to solve it please?Maybe I have to exclude the Temp Inlet Sensor filtering it in EXTRAOPTIONS of the Net-Cisco-Standard-Environment-SNMP-custom model but I don’t know the syntax.Hare are the current content of the EXTRAOPTIONS:--verbose --filter-perfdata='^(sensor\.(celsius_|rpm_)|temp_)' Thank fo your help. Regards
Hi,We are using Centreon Open Tickets (Version centreon-open-tickets-21.10.1-1).It has been configured with rules to create ticket on our Jira infra.Afiter follwowing this documentation : Integration Open-Tickets - Accueil DIS - Centreon - Wiki (vaudoise.ch)… we can now open a ticket manually from the’Custom View’ page… this iw working Well. But now we would like that tickets are created automatically when a Centreon Services reaches it critical hard State.To do this, I need to configure a Notification Command : but its means that we must to know the syntax on how to create a ticket in command line.On our poller we installed this package:centreon-plugin-Notification-Centreon-Opentickets-Api-20221017-094659.el7.centos.noarchIt provides this plugin : ‘/usr/lib/centreon/plugins/centreon_notification_centreon_opentickets_api.pl’ The modes availables are . close-host close-service open-host open-service … So we should be able to create a ticket in command line with this plugin, but
Hello,i follow the procedure to register remote server to central server and it exits with success: But on the central GUI, i’m not found the remote server preregistred, do you know why???Thank for your help
Hello everyone I”m monitoring hosts from a certain poller x that’s connected to the centreon central, however when i run command checks on the poller server I do get a result returned but on centreon web UI I see “uknown” state? and that no result was returned from plugin? anyone has any idea why? on the server itself:it’s same exact command so I’m unsure why I’m not seeing result on web UI?
Hi,I have installed centreon_fortinet_fortigate.pl fro the Monitoring connector manager.In the available mode I have uptime listed./centreon_fortinet_fortigate.pl --plugin=network::fortinet::fortigate::snmp::plugin --list-modePlugin Description: Check Fortinet Fortigate in SNMP....Modes Available: ap-usage cluster-status cpu disk hardware interfaces ips-stats link-monitor list-interfaces list-link-monitors list-switches list-virtualdomains memory sdwan sessions signatures switch-usage uptime vdom-usage virus vpnHowever when I try it:> /usr/lib/centreon/plugins//centreon_fortinet_fortigate.pl --plugin=network::fortinet::fortigate::snmp::plugin --mode=uptime --hostname=X.Y.Z.A --snmp-version='2c' --snmp-community='dummy'UNKNOWN: Cannot load module --mode. Can't locate snmp_standard/mode/uptime.pm in @INC (you may need to install the snmp_standard::mode::uptime module) (@INC contains: /usr/lib/centreon/plugins FatPacked::94775752674704=HAS
HelloMy company has a VM with Centreon setup (I think he himself is connected to other instances and getting their informations)I’m exporting this data into my VM with graphite (to visualize with Grafana) but not every host is showing in the DB. (there is like 20 host out of 100 so lots of missing data)There is already an equivalent to my VM, an old setup by someone else and it is getting every host and dataSomeone has any idea what i could do / check ? additionnal info :graphite is running the whisper/carbon pair to receive and store datacarbon is listening to port 2003 in TCP (plaintext protocol)
Hello I’ve upgrade my old CentOS7 with Centreon 22.04 to OL8 with Centreon 24.I had to remove all mariadb, and centreon package to proceed the OS upgrade.The database is now correctly configured, I have my old data, and want to make the Centreon Upgrade.When I goes to page /install/upgrade, and start upgrade, I’m currently stuck at step 4: 22.10.30 to 23.04.0When I check logs I see some errors:sql-error.log>[2025-06-06T15:14:01+02:00] ERROR : [CentreonDb] Error while executing the simple query: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'sat.token_type' in 'where clause' | {"context":{"default":{"back_trace":{"file":"/usr/share/centreon/www/class/centreonDB.class.php","line":947,"class":null,"function":null},"request_infos":{"url":null,"http_method":null,"server":null,"referrer":null}},"exception":{"exception_type":"PDOException","file":"/usr/share/centreon/www/class/centreonDB.class.php","line":342,"code":"42S22","message":"SQLSTATE[42S22]: Column not found: 1054 Unknow
Good morning,we are trying to set up SAML authentication with our EntraID applicationWe´ve published application, we´ve remote login url, entity id and user id attributeBut when we try to login appears the following error: Authentication method 'X509, MultiFactor, X509Device' by which the user authenticated with the service doesn't match requested authentication method 'Password, ProtectedTransport'How can we fix it?
Hello,I am using centreon 24.10.6.I have created recurring downtimes on certain services (as seen below), however they do not work and do not show up in Monitoring>Downtimes. On the server itself, manipulating recurring downtimes do not generate any logs anywhere, however it does affect the database and I can see the different entries. When creating regular downtimes however, it does work normally, showing up in the Monitoring section and in the logs on the server. It might be a problem with rights on certain files as I’ve been having problems with that recently or that the process which is supposed to retrieve information from the database is not functional, but I haven’t been able to figure it out. Thank you !
BAM update from 23.10 to 24.10 does not seem to apply required SQL schema updates, as a result upgrade renders BAM unusable with error like this[2025-04-07T14:32:23+03:00] ERROR : [CentreonDb] Error while using CentreonDb::query | {"context":{"default":{"back_trace":{"file":"/usr/share/centreon/www/class/centreonDB.class.php","line":947,"class":null,"function":null},"request_infos":{"url":"/centreon/api/internal.php?object=centreon_bam_top_counter&action=getBamTopCounterData","http_method":"GET","server":"10.204.72.72","referrer":"https://10.204.72.72/centreon/main.php?p=20201"}},"exception":{"exception_type":"PDOException","file":"/usr/share/centreon/www/class/centreonDB.class.php","line":1011,"code":"42S22","message":"SQLSTATE[42S22]: Column not found: 1054 Unknown column 'all_business_views' in 'field list'","previous":null},"custom":{"db_name":"centreon","query":" SELECT ba_group_id, all_business_views FROM mod_bam_acl ","pdo_error_infos":["42S22",1054,"Unknown column 'all_b
🇬🇧Hello,I have a VMWare probe "Datacenter Alarm Custom" configured on a VCSA. When I encounter an issue reported by the vCenter, I get all the details in the resource status:Statut détailléCRITICAL: Datacenter 'DCXXXXXX' 1 problem(s) detectedchecking datacenter 'DCXXXXXX'critical: alarm [red] [VirtualMachine] [XXXXXXXXX] [2025-04-08T13:33:26.854728Z] Virtual machine CPU usage/Default alarm to monitor virtual machine CPU usage This is perfect, but I would like to receive this content via email as well, especially in case of anomalies at night or any other time when I am not in front of the monitoring system. However, the history does not mention the details nor the email notifications:mardi 8 avril 2025 15:07CritiqueTentatives: 3CRITICAL: Datacenter \'XXXXXXXX\' 1 problem(s) detected ***** centreon Notification *****Notification Type: PROBLEMService: Datacenter-AlarmsHost: XXXXXXXXAddress: 123.45.67.89State: CRITICALDate/Time: 08-04-2025 Additional Info : CRITICAL: Datacenter XXXXXXXX
Hello,I am using centreon 24.10.6.I’ve had all servers up and running for a while now and I’ve noticed that there are some gaps in the Availability page in the Reporting tab. Most recently I noticed a gap of more than a week where the status is written as “Undetermined” even though the servers were in fact up and the checks were still running without issue and without change (seen in logs).Although I could take the Mean Time percentages, I’d rather have the graph display the correct values. I’ve tried rebuilding for these dates and it executes without error but doesn’t change anything. /usr/share/centreon/cron/eventReportBuilder --config=/etc/centreon/conf.pm --start-time="2025-05-25" --end-time="2025-06-05" --rebuild The conf.pm file is correctly configured.This is the output of the rebuild command: I wasn’t able to find the issue, if you have any idea please let me know, thank you !
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.