Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I was asked to rebuild 2 days of my BI data, days 20260713 and 20260714 but it failed with PK error: [root@rdy-cnt-bi]# /usr/share/centreon-bi/etl/perfdataStatisticsBuilder.pl -r -s $date_start -e $date_end --no-purge [395/1873]2026-07-24 12:30:27 - INFO - [SCHEDULER] >>>>>>> start2026-07-24 12:30:27 - INFO - [SCHEDULER][PERFDATA] >>>>>>> start2026-07-24 12:30:29 - INFO - [PURGE] Truncate partition 20260713 on table [mod_bi_metricdailyvalue]2026-07-24 12:30:29 - INFO - [PURGE] Truncate partition 20260714 on table [mod_bi_metricdailyvalue]2026-07-24 12:30:29 - INFO - [PURGE] Truncate partition 20260713 on table [mod_bi_metriccentileweeklyvalue]2026-07-24 12:30:29 - INFO - [PURGE] Truncate partition 20260714 on table [mod_bi_metriccentileweeklyvalue]2026-07-24 12:30:29 - INFO - [PURGE] Truncate partition 20260713 on table [mod_bi_metrichourlyvalue]2026-07-24 12:
Bonjour,Pour un CMA en version 24.10.17, on ne peut pas effectuer une découverte des services via l’interface Configuration/Services/Scan. Lorsque nous renseignons le nom de la VM le champ de recherche du type de service disparait...Savez-vous pourquoi et surtout, je cherche à monitorer les services (comme c’est actuellement fait avec SNMP).Merci d’avance !
Bonjour Je me pose des questions quand à l’utilisation des récurent down time.Jusque là je n’utilisait que des périodes temporelles.Mais d’après mes constatation si la période est appliquée à un hôte (par exemple jours ouvrés seulement), et que les services de l’hôte sont sur du 24x7 alors si un service est KO le week end, j’aurais quand même une notification. Je souhaite donc remplacé ça par un downtime (au niveau de l’hôte ou du groupe d’hôte). Mais que ce passe-t-il si mon service tombe KO pendant le downtime et reste KO même lors des premier contrôle en dehors du downtime ? vais-je recevoir mes notifications (en dehors du downtime biensûr) ? Merci d’avance pour vos éclairages Contexte : Centreon 24.10
Hello,Centreon version : 24.10.29I only have a single, standalone central server, nothing else. Actions on the web interface are not being applied like acknowledging an altert, planning downtime or forcing a check control. I noticed that exporting the configuration does not trigger write in gorgoned.log nor centengine.logI also noticed that gorgone service is running fine, but is not listening on port 8085 for API calls from the web interface. IS this normal behavior ?Also, centreon-web.log last write timestamp is 22 July (2 weeks ago) which means the actions I am launching from the web UI are not being detected somehow. I checked write permissions in centreon directories. They seem fine :/etc/centreon # ls -l /etc/centreon-engine/total 304-rw-rw-r-- 1 www-data centreon-engine 4005 24 juil. 18:18 centengine.cfg-rw-rw-r-- 1 www-data centreon-engine 17509 24 juil. 18:18 commands.cfgdrwxrwxr-x 2 www-data centreon-engine 4096 6 nov. 2024 conf.d-rw-rw-r-- 1 www-data centreon-engine
Bonjour a tous, je cherche a afficher seulement mon Hote KO dans OpenTicket mais je ne trouve pas comment procéder:Dans OpenTicket, j'ai sélectionné l'option « Hide services with DOWN host » pour éviter que la liste des services « unknown » remonte dans OpenTicket lorsque mon hôte est KO.Cependant, si je sélectionne cette option, je n'ai plus aucune alerte qui remonte dans OpenTicket, même pas l'hôte tout seul comme sur l'image. C'est pourtant ce que je souhaite obtenir, mais je ne trouve pas comment faire.Pour faire simple, je souhaiterais que si mon hôte est KO, il remonte tout seul dans OpenTicket, sans la liste des services « unknown ».Quelqu'un aurait-il une idée ? Merci de vos retours.
Hello,J’ai un soucis avec mon serveur distant que j’ai rattaché au Central. La supervision marche à la fois en local et la vue depuis le Central mais sur le serveur distant je rencontre sur tous mes services supervisés (plugins tiers stormshield/cisco, etc...) des soucis d’affichage concernant les commandes. Ils m’indiquent en capture: Les plugins j’ai comparé, c’est à la fois pour du service nrpe3 qui necessite pas de mdp et snmpv3. En allant plus loin dans la recherche j’ai trouvé dans ma base de données locale que les groupes d’hôtes et de services sont inexistants. Et c’est un vrai problème car j’ai plus de 30 hôtes supervisés, des groupes d’hôtes pour le filtrage et près de 300 services. J’ai fait des montées de mon Central et serveur distant en 24.04.26 mais le problème persiste. J’ai déjà redémarré les machines, réactualisé les services mais rien à faire.Auriez-vous une idée de comment rectifier cela s’il vous plaît ? 🙏 PS: j’ai déjà réinstallé Centreon sur le serveur distant m
There is a typo error on the last perl for Merakisub get_network_wireless_usage_history { my ($self, %options) = @_; return $self->request_api( endpoint => '/networks/' . $options{network_id} . '/wireless/usageHistory', get_param => [ 'deviceSerial ='. $options{serial}, 'timespan=' . $self->{timespan} ], hostname => $self->get_shard_hostname(serial => $options{serial}) ) } sed -i "s/'deviceSerial ='/'deviceSerial='/" /usr/lib/centreon/plugins/centreon_cisco_meraki_restapi.pl If it can help somone ...
Hi,I have for a couple months now had issues mainly with the hosts and ICMP. Hosts are pinged every minute to get the UP/DOWN status. I’ve noticed that every other ping is basically failing in a “CRITICAL”. I have tried manually to ping some of these hosts from the same server and there are no network related issues.The issues seem to mainly be related to performance. For services UP/DOWN these checks work better but they are scanned every 5 minutes.Occassionally there can be a PROCESS TIMEOUT. I’m running centreon 24.10.25 on Debian 12 with 4 vCPU and 16 GB memory.We have 478 hosts in our centreon environment and 2052 services. This is running on one cenral poller.I’m thinking about setting up one more poller to see if it might solve things.The “tuning” tab on the engine configuration looks like this. Engine statistics:
Hello,We have on prem centreon 23.04 and I need to install the Monitoring Connectors1) F5 BigIP SNMP which brings this host template in Centreon so I can monitor F5 network devices: Net-F5-Bigip-SNMP-custom and 2) X509 Certificate which brings this host template in Centreon so I can monitor certificates in format .pem and .der :App-Protocol-X509-custom .tried multiple links but not working https://plugins.centreon.com/ https://marketplace.centreon.com/ and I need them to be .rpm files on redhat to manage the installation on prem.Can you please help me with an available location to download them ?
Hello, Just a note that recently the unattended script on page https://docs.centreon.com/docs/24.10/installation/installation-of-a-poller/unattended-install-poller/ as step 2 for installing 24.10 pollers:curl -L https://download.centreon.com/24.10/unattended.sh --output /tmp/unattended.sh is throwing HTTP 404 and downloading the HTML error page instead.URL: https://download.centreon.com/24.10/unattended.sh In my opinion, it would be better for these pages to either:if this situation is unavoidable, return HTTP 404 status without returning a human readable document, instead of whole HTML to be pulled and executed blindly on other people’s servers, return a script that echoes “sorry we pulled the script for maintenance, try again later”, or joining lines 2 and 3 using && operator to avoid executing the error page. Thank you.
Pour une supervision sur des serveurs windows avec CMA, pourquoi centreon remonte des chiffres en PetraBytes ou ExaBytes lorsque l'occupation du swap augmente alors que la taille qui lui est alloué n'est que de quelques Giga ?Merci d’avance !
Is it possible to add dashboards in the module awie ?
since middle on weekend all service usinf esx8 api popup same error:UNKNOWN: no data for resource host-709473 counter mem.capacity.usable.HOST at the moment. - no data for resource host-709473 counter mem.consumed.vms.HOST at the moment. - get_esx_stats function failed to retrieve statsThe counter mem.capacity.usable.HOST was not recorded for resource host-709473 before. It will now (creating acq_spec).The counter mem.consumed.vms.HOST was not recorded for resource host-709473 before. It will now (creating acq_spec). in debug on poller:== Info: We are completely uploaded and fine=> Recv header: HTTP/2 500=> Recv header: date: Mon, 09 Mar 2026 14:24:12 GMT=> Recv header: content-type: application/json=> Recv header: x-envoy-upstream-service-time: 13=> Recv header: vary: Accept-Encoding=> Recv header:=> Recv data: {"messages":[{"args":[],"default_message":"Unable to create Acquisition Spec due to conflict at row: `375`","localized":"Unable to create Acquisition Spec
Hello,I try to monitor our docker swarm with Centreon and I’m facing an issue with “service status” check of the docker plugin pack (API not SSH)Got a task in desired state=running but state=pending because this container cannot start (wrong placement rule) [root@swarm1:~]# docker service ps mzcuervresdb ID NAME IMAGE NODE DESIRED STATE CURRENT STATE ERRORwbd3dz5c051t stack-traefik_traefik.1 traefik:v3.7 Running Pending about an hour ago "no suitable node (scheduling …"(...)If I look more deeply this task[root@swarm1:~]# docker inspect wbd3dz5c051tq8wf8hjf9jy0f(...) "Status": { "Timestamp": "2026-07-22T09:59:36.52320026Z", "State": "pending", "Message": "pending task scheduling", "Err": "no suitable node (scheduling constraints not satisfied on 2 nodes; 1 node not available for n
Hi, is there an manual , how can i reset the password for my local “admin” account ? LDAP Admin - no problem Thanks
The centreon-engine-daemon = 24.10.23-1.el8 RPM is missing Problem 1: cannot install the best update candidate for package centreon-engine-24.10.22-1.el8.x86_64 - nothing provides centreon-engine-daemon = 24.10.23-1.el8 needed by centreon-engine-24.10.23-1.el8.x86_64 from centreon-24.10-stablethe “debug” rpm is on the repo but not the normal repo
Hellogot a sql error in centreon-web.log when trying to add CMA agents :in logs : [2026-06-18T11:40:32+0200] [ERROR] Rollback of 'AddAgentConfiguration' transaction. {"custom":null,"exception":null,"default":{"request_infos":{"uri":"/centreon/api/latest/configuration/agent-configurations","http_method":"POST","server":"supervision.admdom.tld"}}}[2026-06-18T11:40:32+0200] [ERROR] Error while adding broker directive in agent configuration {"custom":{"user_id":21,"ac_type":"centreon-agent","ac_name":"CMA"},"exception":{"type":"Core\\Common\\Domain\\Exception\\RepositoryException","message":"Error while adding broker directive in agent configuration","previous_type":"Adaptation\\Database\\Connection\\Exception\\ConnectionException","previous_message":"Error while executing the insert query : Error while executing the statement : An exception occurred while executing a query: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fai
HelloI’ve set-up CMA on my central + poller + an agent.In centreon, I’m unable to select host template “ OS-Linux-Centreon-Monitoring-Agent[-custom] “ template. I can see them in host templates and edit the -custom one.They just don’t appear in the host template selection list
Hello, just here to share to the community an issue that i encountered, the underlying issue, and how it can be resovled.This happened on a quite heavily loaded central server (poller included), and my end users reported receiving load of emails alerts regularly, but during bursts of a few minutes.After investigating the commands failing, there was nothing to correleate them, any service could fail, and all failed with the same output: “Execute command failed”. Something strange was at work here.After going more in the logs, especially centreon-engine logs, i find it. “Too many open files”. Here is the issue.At first i supposed there was permissions issues or something, but this is irrelevent as all can happend to any commands usually working fine. So i dig deeper on the internet, and here i find it, the Linux File Descriptor Limit. cyberciti.biz - linux increase the maximum number of open files . This limit by default is around 1024. I then do a quickls /proc/[centengine_pid]/fs/*and
Hi,I don’t know if it changed recently or if it has always be like that, but I noticed the following: if --expected-content has a value, then --critical-content is ignored. It means, if one want to check both a return code and the presence of a string in the page content, one should not use --critical-content=’ %{code} != 200 and %{code} != 401’ --expected-string=foo (because then only the presence of “foo” would be checked!), but what must be used is --critical-content=’ %{code} != 200 and %{code} != 401 or %{content} !~ /foo/mi’.Is it something that changed recently? Is this something reliable (ie: it won’t change in the futur) ?
Hello I’am checking the sensor component but I have criticals when ethernet is down and as no amperes which is normal. Sensor 'Ethernet1/26 Lane 1 Transceiver Bias Current Sensor/300044004' is 0 A How can I filter this I tried several ways with no result. --filter='(?!.*is.*0.*A.*)'--filter='(?!.*is.*0.*)'-filter='^(?!.*is.*0.*)'--filter-perfdata-adv='not (%(value) == 0)'--filter-perfdata-adv='not (%(label) !~ "sensors.amperes.*")'--filter-perfdata-adv='not (%(label) =~ "sensors.amperes.*")'--filter-perfdata-adv='not (%(label) == "sensors.amperes.*")'
Hi,I’m using Monitoring Connector "Oracle Database”.All services are OK, except both :- Rman-Backup-Age :Status is “ CRITICAL: Rman 'DB FULL' backups never executed - Rman 'DB INCR' backups never executed - Rman 'ARCHIVELOG' backups never executed - Rman 'CONTROLFILE' backups never executed - Rman backups never executed.”- Rman-Backup-Problems :OK: During the last 3 days, number of backups completed: 0, failed: 0, completed with warnings: 0, completed with errors: 0However rman backups works perfectly (daily): incr, full, archivelog 100% guaranteed.Our rman catalog is on an external rman catalog database and channel type is SBT.Why the connector didn’t seen our backups ?Thank youNicolas
Hello.Is there a plugin that can be used to get the DNS zone expiration from SOA?I have tried with the DNS Service connector, using --mode=request --search-type='SOA' but it doesn’t show the complete SOA. With --verbose or --debug the result is the same, only the response time.Regards
Hi guys,I need Help to change data collection from poolers.I mean in my configuration all poolers should communicate with the main Centreon Engine 23.04.4 via VIP address. But for some poolers after a reboot of main Centreon server they are sending data directly to Centreon servers without passing through the VIP and until now I didn’t find how or where to force the pooler to communicate only with the VIP.Can you please help me in this case ?
captureThe url provided https://raw.githubusercontent.com/centreon/centreon-collect/refs/tags/25.10.15-latest/agent/installer/scripts_linux/install_cma.shdoes not exist
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.