Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,Checking TCP is ok, but how do i check an openvpn UDP port? /usr/lib/centreon/plugins//centreon_protocol_udp.pl --plugin=apps::protocols::udp::plugin --mode=connection --hostname=192.168.0.1 --port=1111CRITICAL: Connection failed on port 1111 thanks,Mathias🤔
Hello,I have an API whose authentication is only done by user/password: basic authentication.How can I translate this into the json file?Knowing that I only want to provide the user and password, and not the base64 encoding of user/password in the header.
Hi,(Sorry in advance for my English) I’m trying to link a Remote Server on a Central both behind a firewall. Everything is Working (i can supervise some equipement on the remote network) but the Poller on the Remote is still displayed as “Central” and not running. On the Central side, everything is working and the Remote is displayed as working and updating. Is this an issue on the Remote ? Thank you in advance for your help.
The issue is specifically with PHP v8.2 install. It appears that for Alma v8 it would use the remi repository, but when the OS is v9 it does not use the remi repository.My operating system is AlmaLinux v9.2 ESU (with Tuxcare). It appears that the unattended.sh script tries to install php 8.2 (required for 24.10) using the command “dnf module install php:8.2”.I have installed PHP 8.2 from the remi repository outside the unattended.sh script, is there an option to the script to skip the php install during the installation process?I have also posted this on the CloudLinux support site to get their take on it and still waiting on their response. ThanksSteve H.
Hi,I have a centreon 24.10.4 environment at work and we currently ran into one issue after migrating an old environment.Everything works fine except we noticed the postfix sends a mail every minute which seems to be a result of centreon-tokens not being able to remove outdated tokens.This is what /var/log/centreon/centreon-tokens.log is saying.#1 {main} thrown in /usr/share/centreon/www/class/centreonDB.class.php on line 165PHP Fatal error: Uncaught Exception: SQLSTATE[HY000] [1045] Access denied for user 'centreon'@'localhost' (using password: YES) in /usr/share/centreon/www/class/centreonDB.class.php:165Stack trace:#0 /usr/share/centreon/cron/outdated-token-removal.php(35): CentreonDB->__construct()#1 {main} thrown in /usr/share/centreon/www/class/centreonDB.class.php on line 165 This is from the postfix logMar 12 09:21:01 centreon postfix/smtp[2613111]: 369C81C0AA0: to=<www-data@centreon.xxx.se>, orig_to=<www-data>, relay=smtp.xxx.se[192.168.x.xxx]:25, delay=0.15,
Hello,I have my centreon server who’s on another site, to access it I use proxy cause i currently have PRTG and I want to change it to centreon. So temporarly I access my centreon all with url’s :PRTG : myurl.com Centreon : myurl.com/centreon/loginAnd the thing is whenever I want to connect my poller , who’s on another site, to that remote server he can’t find it.
Bonjour Je viens de migré une partie de mon infra de centreon 23.04 vers 24.10.5.J’ai des remote server.lorsque j’essai de les reload ou restart depuis l’interface web du central, les broker ne sont pas relancer.gorgoned.log : 2025-03-18 10:48:11 - DEBUG - [pull] read message from external: [ACTIONENGINE] [4c0377c5d7047c4200ddb350137041d73f2090489eb8903c6bea8ccbc5764f3f9f8c793823e93f8253476e60dd186645afdb3ab9c6e49b7cee7d9f79b50c16aa] [25] {"logging":0,"content":{"metadata":{"centcore_cmd":"ENGINERESTART","centcore_proxy":1},"command":"sudo systemctl restart centreon_vmware.service"}}2025-03-18 10:48:11 - DEBUG - [pull] internal message: [ACTIONENGINE] [4c0377c5d7047c4200ddb350137041d73f2090489eb8903c6bea8ccbc5764f3f9f8c793823e93f8253476e60dd186645afdb3ab9c6e49b7cee7d9f79b50c16aa] [25] {"logging":0,"content":{"metadata":{"centcore_cmd":"ENGINERESTART","centcore_proxy":1},"command":"sudo systemctl restart centreon_vmware.service"}}2025-03-18 10:48:11 - DEBUG - [pull] read message from ex
Bonjour,Depuis quelques jours, je m’intéresse à Centreon pour superviser mon parc informatique.J’ai installé Centreon 24.10.7 sur une VM, puis quelques hôtes et services.Le service « ping_lan » affiche bien que mes éléments supervisés sont bien actifs maisje bute sur comment visualiser l’état des disques constituant un NAS Qnap.Mon service est bien basé sur le modèle « HW-Storage-Qnap-Disk-Global-SNMP-custom », les valeurs de la macrosont celles de base.Le status des ressources est réactif mais je n’ai pas saisi où indiquer à Centreoncomment checker les disques du NAS.merci pour votre aideEric
I have followed the guide https://docs.centreon.com/docs/migrate/migrate-from-3-4/migration from-3-4 to 24.Just a few error when"Everything is ready !Your Centreon Platform is about to be upgraded from version 2.8.26 to 24.04.6"I had to manually run the SQL statements in the files:/usr/share/centreon/www/install/php/Update-20.04.19.php/usr/share/centreon/www/install/php/Update-20.10.11.php/usr/share/centreon/www/install/php/Update-20.10.12.phpBut when the migration is done, and I try to login, I get:"An error occurred during authentication" If I check the browser DevTools console (F12), i see “500 Internal Server Error”. BRFredrik
I have multiple Centreon instances and wanted to provide a standard configuration to my instances.Currently i am making use of the CLAPI v1 and was considering using the API REST as it seem to be the target now, but as what i want to deploy is provided as a rolling release, i’m wondering if there is a better way to provide commands and templates in a standard way in “readonly” mode and to update them as i roll updates.I wish to deploy that as i deploy configuration files through rpm packages, my hope is that there is some kind of config.d folder that i could make use of to deploy my files so they are added to the available commands and services. Anyone making this kind of updates ?
Hi there!I am currently downloading Centreon's open-source version 24.10.I'm struggling and I don't know why.I followed the Centreon documentation: https://docs.centreon.com/fr/pp/integrations/plugin-packs/procedures/operatingsystems-linux-ssh/The problem is that I can’t find the service "OS-Linux-Cpu-SSH-custom" in my Centreon interface.My plugins are updated, so do I need to create this service manually?I created a check command that I use in the host setup, which is:--plugin=os::linux::local::plugin --mode=cpu --hostname=$HOSTADDRESS$ --ssh-option='-l <user>' --warning=70 --critical=90When i restart my poller, no error is return.Can someone help me or redirect me to a blog or tutorial that I can follow?Sorry if I'm not very clear — I'm trying to understand how SSH-Remote monitoring works in Centreon.
Hi,when I export a configuration, on all the pollers file /var/log/centreon-gorgone/gorgoned.log reports:2025-01-07 11:00:13 - ERROR - [action] Copy processing - Can't copy file to /etc/centreon/centreon_vmware.json, Permission denied2025-01-07 11:00:13 - ERROR - [action] Copy processing - MD5 does not match2025-01-07 11:00:13 - ERROR - [action] Copy processing - MD5 does not match2025-01-07 11:02:13 - ERROR - [action] Copy processing - Can't copy file to /etc/centreon/centreon_vmware.json, Permission denied2025-01-07 11:02:13 - ERROR - [action] Copy processing - MD5 does not match2025-01-07 11:02:13 - ERROR - [action] Copy processing - MD5 does not match2025-01-07 14:40:40 - ERROR - [action] Copy processing - Can't copy file to /etc/centreon/centreon_vmware.json, Permission denied2025-01-07 14:40:40 - ERROR - [action] Copy processing - MD5 does not match2025-01-07 14:40:40 - ERROR - [action] Copy processing - MD5 does not matchThese messages started after a restore of the central serv
Today, we have probes for CPU, Swap and Memory and I'd like to be able to add a duration before considering the alert, whether it's warning or critical.A CPU consumption of over 90% for 3 minutes doesn't require the same analysis as a consumption of over 90% for 1 hour.That's why I'd like to add this waiting time before triggering the alert
Bonjour la communauté,Nous avons effectué une migration de CentOS 7 Centreon version 22.10 vers une distribution Alma 9 Centreon version 24.10.5.Nous avons suivi la procédure Migrer depuis un OS de type EL vers un autre OS de type EL (depuis un Centreon 18.10 ou plus récent) | Centreon Documentation (jusqu’à l’étape 5.8).La migration semble s’être bien déroulée.Cependant, en s’authentifiant sur la page aucun résultat s’affiche. Or, dans la partie Configuration\Hôtes\Hôtes ou Configuration\Services\Services par hôte des éléments y figurent.Dans la partie Collecteurs, le collecteur Central.Nous n’avons pas désinstallé les agents précédemment installés pour la version 22.10 (environnement Windows).Serait-il possible d’avoir une aide ?Merci à toute la communauté.
Hello,I got an Database issue but I don’t know where the error can be, when I check mysql/error.log nothing there.I already followed steps with https://thewatch.centreon.com/troubleshooting%2D41/my%2Dpoller%2Dis%2Ddown%2D112?tid=112&fid=41My connections are up Central :tcp 0 0 10.x.x.x:38000 10.x.x.x:5777 ESTABLISHED 56402/gorgone-proxytcp 0 0 10.x.x.x:5669 10.x.x.x:57086 ESTABLISHED 734/cbdPoller :tcp 0 0 10.x.x.x:5777 x.x.x:38000 ESTABLISHED 1757/perltcp 0 0 10.x.x.x:57086 x.x.x:5669 ESTABLISHED 1816/centengine I have this error :2024-12-19 09:18:45 - ERROR - [core] Package 'gorgone::modules::core::action::hooks' already loaded2024-12-19 09:19:00 - ERROR - [legacycmd] Cannot process message type 'SENDCBCFGthrowing it away. the 3 pollers have the same image I just changed the ip and the hostname, on my hypervisor in 1 the poller does not work while on hypervisor 2 it works
Hello,Despite following this KB : Deleted resources are still appearing in the Resource Status pageTroubleshooting I still encountering the issue.Centreon version : v24.10.5 Yesterday I removed, from the GUI three hosts :ESX1.TLD.COMESX2.TLD.COMVCENTER.TLD.COM I then, as usual, exported the configuration.And from there, the three hosts are still there when looking at the resources status page, but they do not appear on the “Configuration → Hosts → Hosts” page. I tried to disabled them via mariadb : But after restarting the central, they juste re-enabled themselves alone : What must I do to permanently removed the three hosts from Centreon, once and for all. Regards,
Hello,After upgrading my central and my poller to the 24.10.5, I tried to add the new VMware ESX connector through the Configuration > Monitoring Connectors Manager menu. Everything went fine, I then export the configuration to the poller, without any issues. But on the poller, the /etc/centreon/centreon_vmware.json is not present at all. And when I try to install the daemon, I have this kind of message : How do I resolve that ? Regards,
Hello, I want to set up a service to monitor a specific port 5643 on Centreon 21.04.2 on one of my hosts. I just need to be alerted if it is up, or down. I’ve done some search's but haven’t come up with a way to do it. Anyone got any tips or suggestions for me? Thanks,Steve Arnold
BonjourJ’ai migré de la 23.04 à la 24.10 début mars.Je n’avais pas trop de problèmes : restart des poller distant, mais qui était lié à l’application de la BP28 de l’ANSSI : voirchangement de format des fichiers broker sur mes ancien poller qui était resté en 23.04 (résolu par une copie de sauvegarde des ancien fichier et remise en place après les exports de configuration.) par contre depuis une mise à jour courant avril (passage en 24.10.6) je ne semble plus être en mesure de pousser mes fichiers via gorgone vers un serveur proxy (cf ) depuis j’ai des erreurs dans mes log gorgone sur mon central : 2025-04-25 10:36:32 - ERROR - [proxy] Send message problem for '8': voici mon /etc/centreon-gorgone/nodes-register-override.ymlnodes: - id: 1024 type: push_zmq address: XXX.XXX.XXX.XXX port: 5556 prevail: 1 nodes: - id: 2 pathscore: 1 - id: 3 pathscore: 1 - id: 4 pathscore: 1 - id: 5 pathscore: 1 - id: 6 pathscore: 1
Bonjour Je cherche une manière “élégante” de mettre en place des notification vers une personne d’astreinte (de garde) en plus des notifications autres : nous envoyons un mail sur une boite mail qui est transformé en appel téléphonique. contexte : astreinte en heure non ouvrée (mais ce n’est pas grave si il y a aussi des appels en heures ouvrées)Centreon 23.04 Nous utilisons déjà les notifications en journée. Nous avons des sites qui nécessitent une astreinte et d’autre non (groupes d’hôtes différents) Nous avons des services qui nécessitent une astreinte et d’autre non (groupes de services différents et criticités différentes)J’ai essayé 2 méthodes :Mettre le destinataire d’astreinte sur un modèle de service laborieux au niveau paramétrage et donc source d’erreur Mettre une escalade laborieux au niveau paramétrage et donc source d’erreur dans ce cas si on fait l’escalade à la première notification alors la notification normale ne part pas et est remplacée par la notification d’esca
We are encountering an issue regarding the retrieval of metrics from Google Cloud Monitoring into Centreon. Specifically, some metrics do not appear to be correctly interpreted—particularly those returned in a distribution format.When querying the Cloud Monitoring API, we receive values in the following format:json"value": { "distributionValue": { "count": "2", "mean": 0.4811553955078125, "sumOfSquaredDeviation": 0.0042963802115991712, "bucketOptions": { "linearBuckets": { "numFiniteBuckets": 100, "width": 0.01 } } } } Centreon appears to expect a single value, such as those of type int64, rather than an aggregated distribution. Could you confirm whether this type of format (distribution) is supported? If not, is there a configuration or method that would allow us to extract a more usable value from this data?
Bonjour, J’ai besoin de monitorer des ESX 8.0 et 7.0.L’activation du SNMP est plus simple que sur les versions précédentes.JE voulais savoir si il y avait un connecteur pour juste les ESXI et la doc associées?J’ai vu un connecteur vCenter également, quels sont les droits mini dans vcenter? Existe t il une doc détaillée? Merci
Bonjour, Je suis à la recherche d’informations concernant le plugin Vmware qui permet de checker le thinprovisionng.Est-ce qu’il serait possible d’avoir une explication sur le rôle de ce dernier et de savoir ce qu’il va chercher comme information.J’ai un nombre important de serveurs qui me remontent un statut warning , avec l’information thinprovisionnig actived, et d’autres qui sont en statut OK. Merci d’avance pour votre retour
Hello, I am using the following command to monitor the Microsoft Team service:/usr/lib/centreon/plugins/centreon_office365_management_api.pl \ --plugin=cloud::microsoft::office365::management::plugin \ --mode=service-status \ --tenant='**' \ --client-id='***' \ --client-secret='***' \ --http-backend=curl \ --use-new-perfdata \ --verbose \ --filter-service-name='Microsoft Teams' \ --warning-status='%{classification} =~ /Incident/i && %{status} =~ /serviceDegradation/i' \ --critical-status='%{status} =~ /ServiceInterruption/i' and I receive the following message:"WARNING: Service 'Microsoft Teams' status is 'serviceDegradation' [issue: 2024-10-10T15:00:00Z Some users may intermittently see an incorrect presence state using any Microsoft Teams client incident]" This message, given the date, is old and does not match the status page of Microsoft as shown in the images.Running in debug mode, I verify that the tenant is correct, the incidents are listed, but at the end of
Hello, since migrating the platform from CentOS 7 to Debian 12 following the procedure, I'm experiencing a license issue. The IT-100 license appears to be properly validated, but it still shows 'license required'.The number of hosts has not been exceeded (verified via query). I’ve tried linking and unlinking the license, deleted the epp.license file, uninstalled and reinstalled the Auto Discovery, IT Edition Extensions, and License Manager modules. Nothing has worked so far.The license is used only on this platform, but I suspect the system fingerprint may have changed, even though the IP address remains the same. What else can I do, please?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.