Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello guys, has anyone here using vCenter vSphere 8 with Centreon? Our current vCenter will be upgraded to vSphere 8 soon. We want to make sure that Centreon would be able to monitor vCenter (vSphere 8), the ESXs inside it and the VM hosts residing in it. Unfortunately, we will not have test vCenter vSphere 8 to test and check the compatibility of Centreon with it. Appreciate, your feedback on this. Sincerely,Crisanto
Bonjour à tous, Je passe l’upgrade de Centreon 23.10 vers 24.04, tout se passait bien, jusqu’à la MAJ de MariaDB 10.5 vers 10.11, je suis bien le tuto étape par étape, je mets bien mon repo à jour:dnf config-manager --add-repo https://packages.centreon.com/rpm-standard/24.04/el9/centreon-24.04.repoet quand je passe la commande:dnf install MariaDB-server-10.11\* MariaDB-client-10.11\* MariaDB-shared-10.11\* MariaDB-compat-10.11\* MariaDB-common-10.11\*Il me met:Errors during downloading metadata for repository 'packages.centreon.com_rpm-standard_24.04_el8_centreon-24.04.rep':il manque le o de .repo ! je pense que l’erreur de vient de là, comment y remédier ? Merci
Hello i create a template that use a command that i created on web interface, but the shortcut to see detail of the command is not working and i don’t know why…i’ve got centreon last version 24.10. detail of command check_ssh:
Hello, I was trying to setup an autologin dashboard on my Centreon and i am not able to make the autologin feature to work specifically on the dashboard URL. Context I am running Centreon 23.10.22 on Rocky 9 I followed the autologin documentation Configuring Autologin | Centreon Documentation and created a contact with only readonly permissions on the dashboard. After that i created an autologin token and the whole process allows me to create the following URL https://centreon.local/centreon/home/dashboards/library/2?autologin=1&useralias=autologin_readonly_viewer&token=XXXXXX When using this URL, i am sent back to the login page of the Centreon. That being said, if i use that same token to the home page of the Centreon, i can then login and manually go to the dashboard page (i have the permissions on the dashboard as it is shared to the readonly user). CauseThe reason seem to be a 403 HTTP error on the path /centreon/api/latest/configuration/users/current/parameters I am wonde
Hello, using the Log Retention with a value 365 or even 31 the Cronjob /usr/share/centreon/cron/centstorage_purge.php doesn’t clean (all) old comments.I’ve got comments from 2017. Responsible SQL Query to cleanup:DELETE FROM comments WHERE (deletion_time is not null and deletion_time ' . '< __RETENTION__) OR (expire_time < __RETENTION__ AND expire_time <> 0)Value for __RETENTION__ is the value from the config, in my case 365. The table field expire_time is always 0, so the second part of the query is never matching.The field deletion_time is on many entrys NULL (currently 100174 entrys) and on 3287090 entrys not null. I’m not sure about the fields deletion_time and expire_time what are they for. But comments from 2017 shouldn’t be there in Year 2025 with retention period of 365 days. Manually checking the filter:SELECT * FROM centreon_storage.comments WHERE (deletion_time is not null and deletion_time < 1708297200 ) OR (expire_time < 1708297200 AND expi
Hi,Why sorting on the information column isn’t available anymore? This is very handy to get a list of services suffering from a same issue type?What’s the point of suppressing a trivial functionality like this?! Is that (not so) new (but still in a beta state!) so bloated or badly written that even with a 100 (!) display limit such a simple task like this isn’t possible in an acceptable time?Is it a user desire to get over simplified UI? Or a guideline from a UI specialist of any kind?Why didn’t I provide feedback on this point sooner? Because the issues with this UI are myriads…Please explain such design choice or let me know what I’m doing wrong.Regards,
Hi, This is from Centreon Web 23.10.18. Has it been fixed in 23.10.21 or in a more recent branch? I wouldn’t say it’s a bug, but a quite worrying design choice still imho.Am I the only one for whom it matters quite a bit?
Hi, why is that so? :chmod: cannot access '/var/cache/centreon/config/engine/*': No such file or directorychmod: cannot access '/var/cache/centreon/config/broker/*': No such file or directorywarning: %post(centreon-common-23.10.22-1.el8.noarch) scriptlet failed, exit status 1Error in POSTIN scriptlet in rpm package centreon-common(upgrade from 23.10.21 to 23.10.22)I did this upgrade after a reboot and stopped units centreon,httpd, php-fpm so I guess it is normal I hove no file there, but why does a post-install script is doing that, whatever files would be there or not?Is it an attemp at fixing a possible permission issue? I find this strange but maybe it’s not.Related to ?Have a nice weekend
Hi,I just migrated the configuration and data of my test centreon server (centos 6.7 + centreon 22.10 IT-100) to a new server Alma9+centreon 24.04. Everything went well, including the migration of the IT-100 license. Now, I will do the same with my production server, except that it has a 2500 host EPP license (which was an offline license, but recently became an online license with a token, at the request of centreon). How do I migrate this type of license? (request a temporary license?)
Bonjour, depuis la mise à jour vers la 24.10.3 j’ai ce message d’erreur.j’ai déjà installerapt-get install libwww-curl-perl
Bonjour @ tous,Deux jours que je me bat avec la version 24.10. Nous sommes censé upgradé nos versions de production en 24.10, sauf que quand je déclare un remote correctement (déjà fait sur les ancienne version et sa fonctionné). Le central semble ne plus vouloir que j’ajoute d’hôte…Message d’erreur : Vous n'êtes pas autorisé à accéder à cette ressource (avec le compte admin de base je précise)Bug ? Quelqu’un a déjà eu le tour ?
hello,when i want create a job in auto-discovery api i have this error message: '[proxy] Array value found, but an object is required\ I have test with with null {}
Hello , need youre help i have error with synchronisation of my poller : after a lot of check i see that i have error when executing this commande : journalctl -u gorgoned -n 50thanks for HelpCordially
Hello Centreon Community,I’m currently setting up Centreon to supervise my office network and would appreciate some guidance.I have installed Centreon on a virtual machine (VM) running under VMware Workstation on my PC.My network IP range is 10.206.38.10 to 10.206.38.254. i want to supervise real machines and their actual network usage using this Centreon setup.What is the best method to scan and add all the machines in my network to Centreon?Are there specific plugins or configurations I should use for effective monitoring?Since Centreon is running in a VM, what are the best networking settings to ensure it can reach all machines in my network? (NAT, Bridged, etc.)
Hi,I have a problem since the last Centreon update 23.10.22, I can no longer modify a service or even create new ones, because the notification period disappears as soon as I save.So when I reboot the collector, it says I have not assigned a notification period on the service. I am using AlmaLinux 9.5 and Centreon 23.10.22. Thanks
Bonjour,Je ne peux plus effectuer de dnf update sur ma VM, j’ai les réponses suivantes::J’ai aussi effectué un yum clean all mais rien n’y fait.Merci dnf updateDernière vérification de l’expiration des métadonnées effectuée il y a 0:02:58 le ven. 07 mars 2025 15:55:45.Erreur : Problème: package centreon-gorgone-23.10.11-1.el9.noarch from @System requires perl(Net::Curl::Easy), but none of the providers can be installed - cannot install both perl-Net-Curl-0.57-1.el9.x86_64 from centreon-plugins-23.10-stable and perl-Net-Curl-0.55-1.el9.x86_64 from @System - cannot install both perl-Net-Curl-0.57-1.el9.x86_64 from centreon-plugins-23.10-stable and perl-Net-Curl-0.54-2.el9.x86_64 from centreon-23.10-stable - cannot install both perl-Net-Curl-0.57-1.el9.x86_64 from centreon-plugins-23.10-stable and perl-Net-Curl-0.52-1.el9.x86_64 from centreon-23.10-stable - cannot install both perl-Net-Curl-0.57-1.el9.x86_64 from centreon-plugins-23.10-stable and perl-Net-Curl-0.55-1.el9.x86_64 from c
after deleting perl 5.38 and changed to perl 5.36 when i’m trying to dowload centreon package to use nrpe4 on ubuntu 24.04with apt -y install centreon-nrpe4-daemon centreon-plugin-operatingsystems-linux-locali have an error: libcrypt-openssl-aes-perl : Dépend: perlapi-5.36.0 mais il n'est pas installable i dowloaded perl 5.36.0 from internet bc there is no version available with apt install perl -v return This is perl 5, version 36, subversion 0 (v5.36.0) built for x86_64-linux when i run apt -y install centreon-nrpe4-daemon centreon-plugin-operatingsystems-linux-locali have thisLecture des listes de paquets... FaitConstruction de l'arbre des dépendances... FaitLecture des informations d'état... FaitVous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.Les paquets suivants contiennent des dépendances non satisfaites : centreon-plugin-operatingsystems-linux-local : Dépend: libcrypt-openssl-aes-perl mais ne sera pas installé
In the services and service templates, when I select the notification period and confirm, the notification period field is empty again when I return to it. I am on Centreon 24.10
Welcome to the Contribution and Development forum. I am Laurent Pinsivy, the product manager dedicated to everything about integration of a Centreon platform and eager to get many of you to join the conversation. This is the "place to be" if you are contributing or developing new extensions for Centreon. Ask questions if you need help, reply to questions from others and raise your rank in The Watch, post feedback or share your experience. Stay tuned for articles, news, events, and more upcoming content! As a reminder a dedicated chapter in our documentation will help you.You can also find examples in our Github repository:Centreon Stream Connectors Centreon widget dummy Centreon module dummy Centreon Plugins development guide You can post Questions and Conversations in any category. Conversations are the most common type of post in this category.Questions are in Q/A format. They can have best answers, which give points to the user that posted the solution and highlights the answer for
Hello everyone,I'm experiencing an issue with Centreon where the following error repeatedly appears in the logs:Error: Attempt to run active check on host 'FARJ-AP-ENS-38' with no check command What I’ve checked so far:The host has a Check Command assigned (base_centreon_ping).Active checks are enabled.Applied the configuration changes and restarted the centengine service.Despite these checks, the error persists, causing high resource usage and forcing me to restart the server periodically.Has anyone encountered this issue before or has any suggestions on how to fix it?Thanks in advance! Note: This log appears every minute, which is significantly impacting system performance.
Hello, In CentOS when i try to execute the command : systemctl enable rh-php72-php-fpm httpd24-httpd mariadb centreon cbd centengine gorgoned snmptrapd centreontrapd snmpd » Error msg: “ No such file or directory”I tried : systemctl enable httpd24-httpd » No error msg so it’s goodI tried systemctl enable rh-php72-php-fpm » Error msg: “ No such file or directory”your help please,
Bonjour à tous,J’utilise en ce moment un mikrotik RB 1100AH sauf que lorsque je procède à l’installation du template mikrotik proposé par centreon, celui ci ne génère parmi ces plugins “centreon_mikrotik_snmp.pl”, afin de mener la supervision de cette équipement quelqu’un peut-il m’apporter son aide à ce propos.
Hello,In DSMD, existing extensions are working well.But when i try to add some slots or when i try to add a new pool, extension is disabled and i get an error when i try to enable.I can’t find anything on logs.Can you help me to make it working?Thanks.
Hi,I would like to monitor WebCloud for my mysql database, with API to check database size. Thanks,
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.