Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,We are used to checking the Event Log for services in Centreon (to see state changes, alerts, etc.).We have noticed that these events appear empty in the ‘EVENT LOG’ interface, regardless of the service consulted.This is happening since the last Upgrade (from 23.10.17 to 24.04.7).I tried to select only one host, or different services : or nothing : but the page remains EMPTY : If I select a time Range (Instead of LOG PERIOD) : same result.I found on thewatch multiple discussions on that subject … I tried to find some solutions … but could not find any solution.Any idea ?
hi, I use centreon-plugins for azure.When I run the plugin with centreon :UNKNOWN: Command error: sh: az: command not found I tried in command line with the user centreon-engine and it works. It works beacause the PATH is correctly setup but when centreon run the command it doesn’t load the profile… How to run the profile of centreon-engine for this type of plugin ?
Bonjour,J’ai un souci actuellement avec centreontrapd : il prend trop de temps à s’exécuter.J’ai environ 3000 traps avec le même OID (et de même sur 3 autres OID), à cause de ça chaque trap met plus d’une minute à être traitée.Après analyse du code de centreontrapd, celui-ci recherche d’abord toutes les traps ayant l’OID parent de la trap envoyée (3000 dans mon cas), puis pour chacun des OID parent trouvé cherche l’hôte (3 à 5 ms avec une pointe à 50 ms) et le service associé et pour le service s’il n’est pas en downtime (12 à 20 ms avec une pointe à 90 ms).Si on compte la totalité : 3000 x (3 + 12) = 45 000 ms soit 45 s au minimum et 3000 x (5 + 20) = 75 000 ms soit 75 s mais peut durer encore plus longtemps.Mon problème est que je reçois entre 40 et 100 traps par minute et il est donc impossible pour centreontrapd de traiter tout ça ce qui fait que j’accumule les traps dans /var/spool/centreontrapd sans jamais pouvoir les résorber.Auriez-vous une solution pour résoudre ce problème s’
Hi all ! Since somes days i got a problem in my gorgoned logs:- ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '404'] [message: 'Not Found'] Why did that return me this message in my Gorgoned logfile ?When i use the discovery mode that work fine so i’m curious to know why that appear..
Hello, I have this error on my DWH: [servicestateevents: 2022-07-20 02:50:39] [mod_bi_servicestateevents: 2022-07-20 02:50:38] I have imported data from 2022-07-20 to 2022-07-21 using /usr/share/centreon-bi/etl/importData.pl -r -s 2022-07-20 -e 2022-07-21 --ignore-databin after I used /usr/share/centreon-bi/etl/eventStatisticsBuilder.pl -r -s 2022-07-20 -e 2022-07-21 --events-only. My jobs finished but the same error persiste. What is the problem? CordialyFrancis DOUNGA
Bonjour,Visiblement je me suis trompé dans ma commande; lorsque j’ai voulu attacher mon remote mon central a perdu toute la partie configuration d’hôte. Je ne sais pas comment faire un rollback. Merci de votre aide
Hello, When I am trying to use Blocked-Packets-Per-Interface feature on pfSense, I get the following error : UNKNOWN: Need to specify OIDs. Same when I try to launch the following command (from centreon documentation) :/usr/lib/centreon/plugins/centreon_pfsense.pl \ --plugin=apps::pfsense::snmp::plugin \ --mode=pfinterfaces \ --hostname='10.0.0.1' \ --snmp-version='2c' \ --snmp-community='my-snmp-community' \ --filter-name='em.*' \ --warning-traffic-in-block='80' \ --warning-traffic-out-block='90' \ --critical-traffic-in-block='80' \ --critical-traffic-out-block='90' \ --use-new-perfdata I activated my IT-100 license and installed pfSense plugin. Any idea of what could be the issue ? Thank you.
Hi,I try to use the mongodb plugin DocumentationI manage to connect to the mongodb and get data if I use a user with admin privilege.I tried to define a user with just the required rights as given in the documentation: listDatabases listCollections collStats serverStatus dbStatsI have defined the following role:admin> db.getRole( "centreonMonitoring", { showPrivileges: true } ){ _id: 'admin.centreonMonitoring', role: 'centreonMonitoring', db: 'admin', privileges: [ { resource: { db: 'admin', collection: '' }, actions: [ 'collStats', 'dbStats', 'listCollections', 'listDatabases', 'serverStatus' ] }, { resource: { db: '', collection: '' }, actions: [ 'collStats', 'dbStats', 'listCollections', 'listDatabases', 'serverStatus' ] } ], roles: [], inheritedRoles: [], inheritedPrivileges: [ { resource: { db: 'admin', collection: '' }, actions: [
Hi,After update 24.10.2 to 24.10.3OS DEBIAN 12I have this message when export config:I chown www-data:www-data /etc/centreon/centreon_vmware.jsonexport config is ok.But now /etc/centreon/centreon_vmware.json is empty !!! and "UNKNOWN: Unknown container name"Any idea ?thx for help
bonjour monsieur j'ai espère que vous avez bien je pense que vous avez des idée concerne interfaçage de GLPI avec centreon , Je cherche à configurer Interfacer Centreon/GLPI: je souhait continue sur deux approches:==> Revoir la configuration de l'API Open Tickets pour générer automatiquement les tickets au niveau de GLPI.==> En parallèle, une deuxième solution, envoyer les alertes vers l'adresse mail itsm@gmail.ma au niveau de GLPI, pour générer les tickets avec les informations de l'incident. le problème c’est sauf que a all époque si nous test une alert il ne pas générer un ticket est ce qui il ya quelque ici il est des idée concerne ce sujet merci d’avance ?
Hi everyone,I have a problem in my configuration of centreon 23.10.In fact, every sunday, i have this error in gorgoned.log……………………………………………………………………...Log :2024-12-01 03:30:06 - ERROR - MySQL server has gone away2024-12-01 03:30:07 - ERROR - MySQL error : cannot connect to database 'mysql:host=localhost:3306;dbname=centreon': Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (caller: gorgone::class::db:/usr/share/perl5/vendor_perl/gorgone/class/db.pm:339) (try: 0)2024-12-01 03:30:08 - ERROR - MySQL error : cannot connect to database 'mysql:host=localhost:3306;dbname=centreon': Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (caller: gorgone::class::db:/usr/share/perl5/vendor_perl/gorgone/class/db.pm:339) (try: 1)2024-12-01 03:30:11 - ERROR - [engine] Cannot get Pollers configuration2024-12-01 03:30:11 - ERROR - [statistics] Receiving DIE: Can't use string ("-1") as a HASH ref while "strict refs" in use at /usr/share/p
Hi all,I'd like to check the speed of a switch port and put thresholds (warning at 100Mbps and critical at 10Mbps)Here's the command line :Port 1 :perl centreon_plugins.pl --plugin=network::cisco::standard::snmp::plugin --mode=interfaces --add-speed --interface=10104 --hostname=10.100.0.11 --warning-speed=100000 --critical-speed=10000the ouput :CRITICAL: Interface 'Gi1/0/4' Speed : 1.00Gb/s | 'speed'=1000000000b/s;0:100000;0:10000;0;Port 2 :perl centreon_plugins.pl --plugin=network::cisco::standard::snmp::plugin --mode=interfaces --add-speed --interface=10119 --hostname=10.100.0.11 --warning-speed=100000 --critical-speed=10000the ouput :CRITICAL: Interface 'Gi1/0/19' Speed : 100.00Mb/s | 'speed'=100000000b/s;0:100000;0:10000;0;Not sure I understood the way it should workDo you have an example that works ?Many thanks for your answer
When i use auto discovery VM (vmware v8), i have this error in my gorgoned.log! do you have any idea please, 24.10.3 ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '401'][message: 'Unauthorized']
Hello,I would like to send a sql query to a database and get the value (using a select count etc...) I can do it from the 'command line' but from the web interface I am completely lostThanks for your help
Hi, I have problem, a package is not installedEjecutando operación Preparando : 1/1 Ejecutando scriptlet: centreon-common-24.04.9-1.el9.noarch 1/2Removing previous centreon engine and broker configuration files in cache ...Creating centreon user and group ... Actualizando : centreon-common-24.04.9-1.el9.noarch 1/2Error unpacking rpm package centreon-common-24.04.9-1.el9.noarch Verificando : centreon-common-24.04.9-1.el9.noarch 1/2 Verificando : centreon-common-24.04.5-1.el9.noarch
Hi, Im trying to add a poller and I’m getting the following error.ERROR - http://my_central_ip:80 {“message”:”No parent platform was found for: ‘poller-1@’my_poller_ip’”} I think the problem is that this server doesnt see the Central one, but I dont understand why… Central works fine (with a remote ddbb)Any idea? I have fllowed the official documentation...
Dear all, I would like to skip notifications by mail about traps of short duration. What would be perfect is the “First notification delay (FND)” option for passive services, this FND works for non-volatile services, but I don’t know how to use it with traps (if I configure a passive service as a non-volatile, it doesn't work). The ideal way to work for me would be like this:To set a threshold for trap notification in 1 minute. Skip notifications for services switching from OK → CRITICAL → OK, with CRITICAL lasting less than 1 minute.Receive notifications for services switching from OK → CRITICAL → OK, with CRITICAL lasting more than 1 minute.Is that possible?Thanks in advance and Merry Christmasjosep garcia
My root partition is full and I have tried with archive log files and I dropped some of the old database partitions using below commands to clear some space with help of chatgpt.Now Pollar is down and showing the database issue“ALTER TABLE log_archive_service DROP PARTITION p20231220, p20231221, p20231222, p20231223, p20231224, p20231225, p20231226, p20231227, p20231228, p20231229, p20231230, p20231231;”I checked the logs “cat /var/log/centreon-broker/central-broker-master.log | grep 'error'”[2024-12-23T13:18:03.411-05:00] [sql] [error] mysql_connection: Table 'centreon_storage.data_bin' doesn't exist[2024-12-23T13:18:03.411-05:00] [sql] [error] connection 0x7fdcd0020fb0 fail to connect: Table 'centreon_storage.data_bin' doesn't exist[2024-12-23T13:18:13.412-05:00] [sql] [error] mysql_connection: Table 'centreon_storage.data_bin' doesn't exist[2024-12-23T13:18:13.412-05:00] [sql] [error] connection 0x7fdcd0020fb0 fail to connect: Table 'centreon_storage.data_bin' doesn't exist
Hi,I’m opening this thread wondering if a lot of people use this feature. And how it makes them they be more efficient in their monitoring.In our case, one of the point that prevents us to do so is the fact that this functionality forbids using the state retention. At least this is what the help popup tells : Is this the case still? Is is still considered experimental nowadays?Docs (https://docs.centreon.com/docs/23.10/alerts-notifications/notif-flapping/ (24.10 is the same)) does not say so so I don’t know what to believe. Is it an obsolete indication in the UI or an omission in the docs? I found this post too, two years old, which seems to have been abandoned on a it-will-change-soon-be-patient status. What’s the deal on flapping detection?A last remark, I guess the maths are done whatever the functionality is used or not, because I can see a “Status change percentage” showing in services and hosts detail infos in the UI. Couldn’t be avoided for performance matters? Even if obviousl
Hi,I see Centreon Engine version 23.10.13 being available in the repository for RHEL 8 but I find no release notes for it. Also, I find nothing in the Github from the commit indicated in the description from de RPM package.I see a release note for Centreon Collect dated december the 19th, from the description I understand that Broker and Engine, and the connectors (?!) have been grouped under this new name. Is that correct?Why such a oddly choice? Why Gorgone had not been included also then?What can you tell about that, or can you lead me to some documentation on the implications of this reorganisation of the software suite?
Hello all,I created a custom command with multiple arguments, as URL, port, USERNAME and PASSWORD In service template definition, I would like hide values of USERNAME and PASSWORDIs it possible to hide these fields, as we can do it in “centreon service templates” Regards, Laurent
Hello,can i find out why internal Centreon-central services are in "critical" state? They have been in this state since Centreon (VMWare OVA) was first launched. Other manually set services works.Thank You for help.
Hello,i need to install “postfix” but the official guide (for the same version as mine) doesn't work:Configuring your Centreon to send emails | Centreon DocumentationFirst step:apt install mailx cyrus-sasl-plainE: Package 'mailx' has no installation candidateE: Unable to locate package cyrus-sasl-plainHmm, so I try to install only mailx:apt install mailx Package mailx is a virtual package provided by: mailutils 1:3.15-4 bsd-mailx 8.1.2-0.20220412cvs-1You should explicitly select one to install.So, I install “mailutils”:apt install mailutilsInstalled, but postfix service doesnot exists.sudo postfix statussudo: postfix: command not foundIf I try install cyrus-sasl-postfix again:apt install cyrus-sasl-plainE: Unable to locate package cyrus-sasl-plainWhy the official guide do not working? Am I doing something wrong?
Hi,since upgrade to 24.10 from 23.04 we can’t GETMACRO from clapi command.ie: sudo centreon -u XXX -p "XXX" -o STPL -a SHOW -v "Virt-VMWare2-Vm-Tools-Generic-custom"id;description;alias;check command;check command arg;normal check interval;retry check interval;max check attempts;active checks enabled;passive checks enabled130;Virt-VMWare2-Vm-Tools-Generic-custom;Vm-Tools;Virt-VMWare2-VM-Tools-Global-Custom;;;;;2;2but :sudo centreon -u XXX -p "XXX" -o STPL -a GETMACRO -v "Virt-VMWare2-Vm-Tools-Generic-custom"macro name;macro value;description;is_passwordPHP Warning: Uninitialized string offset 0 in /usr/share/centreon/www/class/centreon-clapi/centreonObject.class.php on line 668EXTRAOPTIONS;--verbose;;0PHP Warning: Uninitialized string offset 0 in /usr/share/centreon/www/class/centreon-clapi/centreonObject.class.php on line 668SERVICEID;VMware-064;;0
Hello, Does someone monitor version 9 of Rubrik with Centreon ?(my platform : Centreon version 23.10.18)I have some trouble to connect to tools and to obtain apiusername/password in Rubrik.So my questions is :Does someone use successfully Rubrik rest api plugins with version < version 9 of Rubrik ?Does someone use successfully Rubrik rest api plugins with version >= version 8 of Rubrik ?Difference between the two ?Thanks a lot.Regards.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.