Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
i have installed centreon 23.10 on my new machine, and i’m trying now to install nagvis with it.What my newly installed machine nagvis look like so far.I’ve seen this around, and it seems it’s due to nagvis not being installed.I’m currently following this procedure : https://www.it-connect.fr/centreon-enterprise-server-cartographie-avec-nagvis/ and i’m stucked at the moment where it’s asked to clon the centreon-nagvis-backend.git.knowing how trickey it could be, i first checked if the file was still available, and it appears that it’s not.Another user on this forum have the same issue with this file here, at the end : I took a look around the centreon repos page , and among the 16 packages, none seems to have any link with nagvis.however, i found that : https://github.com/centreon/centreon-nagvis. It seems legit, since it’s from the centreon page. i may test it, to see if it works.I you happen to have an archive of the centreon-nagvis-backend.git file, please let me know.
I don’t know how to fix this problem with Windows Server and SNMPv3
Hi,I’m in the process of reinstalling of Centreon on one of our platform which presents too many unresolved and spurious issues (it’s a RHEL 8, Centreon 23.10).I wonder about those two files I get after the uninstall of Centreon packages on the central:/usr/share/centreon/.env.local.php.rpmsave/usr/share/centreon/.env.rpmsaveI’m not asking what a .rpmsave file is, but the purpose of the two relative files.Content of the first is (I just deleted the “secret” which is a long hexadecimal string): <?php// This file was generated by running "composer dump-env prod"return array ( 'APP_ENV' => 'prod', 'APP_SECRET' => '', 'APP_DEBUG' => true, 'DEBUG_LEVEL' => 100 );(I’m surprise there isn’t a PHP closing tag but maybe it’s normal)Second one is that (secret string removed also) :APP_ENV=prod APP_SECRET=I remember an episode where the Centreon support asked me to install a PHP module to help them to troubleshoot the problem I had. I know I’ve done the necessary for the mo
Hi,Sur mes Pollers, j'avais déjà remarqué des fichiers dont le nom commence par "sed" dans le dossier /etc/centreon-engine.Mais aujourd'hui, j'ai un de mes Pollers qui contient 759 de ces fichiers.Que sont ces fichiers ?Pour information, mes Pollers sont doublés. Il y a un actif et un passif. Sans rentrer dans le détail de la configuration, le Poller où je rencontre cette saturation est inactif (centengine est arrêté).
Hi,I observe this on Centreon 23.10 but this has been the case at least from 20.04.On RHEL 8 a user modified config file usually generate a *.rpmnew file when a new version of the config file has to be installed, so the it’s possible to keep user modifications in place and eventually merging both files when it makes sens. Actually in this case there isn’t even a new version of this file. The update just overwrites it for nothing, this is annoying.
Hello,I want to get the CPU from recent Aruba switch 1930 or 2530 and i have the error “UNKNOWN: SNMP Table Request: Cant get a single value.” with the plugin pack aruba./usr/lib/nagios/plugins/centreon-plugins/centreon_plugins.pl --plugin=network::aruba::standard::snmp::plugin --mode=cpu --hostname=192.168.10.231 --snmp-community='centreon' --snmp-version='2c'UNKNOWN: SNMP Table Request: Cant get a single value. Thanks for help.
Hi team,For sending events from Centreon to ServiceNow instance, i configured servicenow event manager, using the following document. https://docs.centreon.com/docs/integrations/event-management/sc-service-now-em-events/.But, i was unable to get the events in servicenow instance and in the central-broker-master.log log file, i am getting the error like: [2024-05-27T23:55:21.285-05:00] [lua] [error] lua: unknown error running function `write'Do you have any suggestions to help me solve the problem and to get the events in servicenow instance?
Hi,My server is:AlmaLinux 8.10 (Cerulean Leopard)Centreon 24.04.2I'm faced with this problem:the ‘centreon_storage’.’logs’ table is literally full of these entries:While they should be like this (it's a second server where we have few hosts); Can anyone help me?Thanks in advanceEmanuele.
Hi I try to configure Centreon with Opsgenie without success, Can some one tell me why i have the log below ? [core] [info] multiplexing: 'OPSGENIE' starts with 8894 in queue and the queue file is disable Regards
Hello,After upgrading, cbd refuse to start with this error: Error during cbd exit: TLS: GNU TLS run-time version is incompatible with the compile-time version (3.8.3): please update your GNU TLS library Have you a solution ?Regards
Hi all,we have received critical alert for partitioning at database.Please find the status info in the below.CRITICAL: Partitions for table 'centreon_storage.logs' are not up to date (current retention forward in days: 0) - Partitions for table 'centreon_storage.log_archive_service' are not up to date (current retention forward in days: 0) - Partitions for table 'centreon_storage.log_archive_host' are not up to date (current retention forward in days: 0) UNKNOWN: Couldn't get partition infos for table 'centreon_storage.data_bin'FYI we are using the version of - Centreon 22.04.19Can anyone help me out of this issue. Thanks in advance.
Hi,Don’t know if it caused by our data or if a bug in Centreon but I have a passive service that the legacy page (also the top counter) shows as pending, it does not appear when filtering on pending. And when I filter on the service description it then appears, but with an OK status.Can’t be 100% sure but I think this behavior appeared in the two or three last revision of 23.10.Anybody also observed this?
Hello, We actually use scripts to check if elements are KO on our applicationsWe use Snmp and OID.We can actually display the script result, and here the result : CRITICAL: value(s):Name Agent Statusserver 1 Can't connectserver2 Can't connectserver3 Can't connectserver4 Can't connect We want to display each alert line by line. Is centreon able to do this ? Thanks all ! Regards
Hello, I'm working on centreon-docker.some people will say it's difficult.but, centreon in a docker allows me to quickly test the service easly. have carried out three types of deployment:all in one container container ( centreon + database) container (centreon + php + database)Here's my dockerfile. I'm looking for distributors.I'll send you more later.FROM debian:bullseye-slimARG MAJOR_VERSION=24.0.1ARG CENTREON_SOURCES="https://download.centreon.com/"ARG IMG_VERSION=0.1LABEL org.opencontainers.image.authors="Lionel BAKALA <lionel.bakala@orange.fr>" \ org.opencontainers.image.description="centreon web-interface based on Apache2 web server with MariaDB database support" \ org.opencontainers.image.documentation="https://docs.centreon.com/docs/getting-started/welcome/" \ org.opencontainers.image.licenses="GPL v2.0" \ org.opencontainers.image.source="${CENTREON_SOURCES}" \ org.opencontainers.image.title="Centreon web-interface" \ org.opencontainers.ima
Hello guys,Is there a way to update all hosts or at least a hostgroup from snmpv2 to snmpv3?Is difficult to take one by one especially having multiple hosts.thanks,Marius
Hi probably a bit of a noob question here as historically I’ve been using Centreon for the last 7 years but only ever needed a single server.I have a requirement to monitor a clients infrastructure but they don’t have direct access to the central server so, as far as I can tell, I can just deploy a remote poller and have it report back to the central server (I only want one place to login and view all the graphs and systems status etc). The central server would not be able to talk directly to the client equipment but the remote poller would be installed on the client site and communicate back over the internet. Is this the correct approach? Thanks in advance
Bonjour,je n’arrive pas à installer centreon 23.10 sur RHEL 8 j’ai besoin d’aide S’il vous plaît !!!
Bonjour depuis un temps je n’arrive plus a ouvrir mon outil CENTREON.Nous constatons un message d’erreur “ Unable to connect to database “ qui s’affiche uniquement.Besoins de votre support Please!!
Hi.I installed centreon 24.04 - Template - with the IT-100 license but Auto Discovery does not work.In the licensing, on the Centreon website, it says that it includes the Auto Discovery part, but I tested LKEY on another Centreon, version 19.04 and it said that the license did not support Auto Discovery.Did I miss something?What should I do? Gorgoned last log:2024-05-13 13:25:07 - DEBUG - [statistics] Writing in file '/var/lib/centreon/nagios-perf//perfmon-1/nagios_hosts_states.rrd'2024-05-13 13:25:07 - DEBUG - [statistics] Event: [STATISTICSLISTENER] [0c869192314aaa0a432ea7e481c20f6156f5e4edebe45d0e10c93bfc7796df209fc0cd59d595a76c83f03c29eaca3da6f60a434a9f2d186a79ef91a5fe99ecbe-1] [] { "code": 2, "data": {"message":"commands processing has finished successfully"} }2024-05-13 13:25:12 - DEBUG - [action] Received SIGCLD signal (pid: 747162)2024-05-13 13:25:12 - DEBUG - [autodiscovery] -class- host discovery - check centreon module installed2024-05-13 13:25:12 - ERROR - [autodiscovery]
Hi teamI need your help to solve this NTP service.on several of my servers in DMZ I have this error "The command (check_centreon_plugins) returned an invalid return code: -1073741502 "Do you have any suggestions to help me solve the problem?Thank youSILUE .
Hi,I encounter a dependency error when installing version 24.04: Paramétrage de centreon-pp-manager (24.04.0-1~bullseye) ...Paramétrage de centreon-auto-discovery-server (24.04.0-1~bullseye) ...su: l'utilisateur apache n'existe pas ou l'entrée de l'utilisateur ne contient pas tous les champs requisdpkg: erreur de traitement du paquet centreon-auto-discovery-server (--configure) : installed centreon-auto-discovery-server package post-installation script subprocess returned error exit stat us 1Paramétrage de centreon-it-edition-extensions (24.04.0-1~bullseye) ...su: l'utilisateur apache n'existe pas ou l'entrée de l'utilisateur ne contient pas tous les champs requisdpkg: erreur de traitement du paquet centreon-it-edition-extensions (--configure) : installed centreon-it-edition-extensions package post-installation script subprocess returned error exit stat us 1dpkg: des problèmes de dépendances empêchent la configuration de centreon-central : centreon-central d
Hello, I’d like to use the Dashboard feature to see the remaining percentage of ink of multiple printers. If I try to use the “Single metric” Widget it works as you can see bellow : However when I put the same Datast selection in the “Top/bottom” Widget I have a “metrics not found” error : As said above, I would like to monitor multiple printers that way that’s why using the “Single metrics” widget on all printers plus all color (black, cyan, magenta, yellow) is not comfortable at all and would like to use 4 “Top/bottom” Widgets instead (one for each color). If you know a way to fix this issue, I request your assistance. If you need further information feel free to ask.
Hello, i have successfully installed the manager : However, it does not show when trying to add a host : Licensed activated for 100 hosts and i didnt install anything yet other than that manager. I have followed the tutorial at https://docs.centreon.com/pp/integrations/plugin-packs/procedures/hardware-devices-nvidia-gpu-smi-ssh/#prerequisites all the way to the “Add a new Host and apply the HW-Device-Nvidia-Gpu-Smi-SSH-custom Host Template step” Thanks
Hi,I’m meeting an issue, I configured the SAML authentification with my IdP Cyberark. The redirection on my IdP is fine but when I’m trying to authenticate i got the error Contact does not exist.But I can see the new user/contact created in the the centreon list (I use the Auto import users fonctionnality). I don’t see any error with SAML tracer.Any idea ?Regards,
Hello,I’m new user of Centreon, and i just install the last version 24.04 of centreon from official documentation.I just add a host with some services that are provided with template After exporting the configuration file, Services monitoring are working but no graph are display….Could someone help me to solve the issue? perhaps i’m missing to select an option for graph?? Regards
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.