Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I’m new user of Centreon, and i just install the last version 24.04 of centreon from official documentation.I just add a host with some services that are provided with template After exporting the configuration file, Services monitoring are working but no graph are display….Could someone help me to solve the issue? perhaps i’m missing to select an option for graph?? Regards
Hi all. I am using Centreon 23.10 version.I followed the installation procedure and host add procedure from online documents.All are good, but sometimes it shows some hosts are down but when I check it is found okay and not down for many days.What is the solution?
Hello The Watch,Do you know if there is a list with more precise descriptions of the metrics returned by the WSUS plugin?The documentation page remains rather poor on this subject and I wouldn't want to make any mistakes on the interpretation of said metrics.Thank you,Best regards,
Bonjour The Watch,Depuis quelques semaines je suis confronté à un problème épineux et je ne trouve pas de réponse satisfaisante, ou alors je m’y prends mal 😅.Je cherche à superviser un Serveur WSUS pour obtenir ce que le plugin permet (https://docs.centreon.com/fr/pp/integrations/plugin-packs/procedures/applications-wsus-nsclient/)Or, a priori l’installation du plugin côté Poller est OK. Le NS Client côté WSUS semble OK. Et pourtant :ou si vous préférez :Je suis un peu dans l’impasse, merci de votre aide. Bien cordialement,Vincent
Is it possible to mention @people or tags in Teams notifications?https://www.centreon.com/seamless-collaboration-send-centreon-notifications-in-microsoft-teams-rooms/
Good morning,I am setting up an external poller.I have my central server on a site A and my poller on a site B.What are the necessary settings made at the level of firewalls.Thank you for your help.Sincerely,Anthony
Hello Community :I would like to request some information and I thank you in advance for following up on my request,I am supervising a service by OID and I have encountered several cases in this task,1- in Output the value obtained is in MB whereas I would like to display it in TB.2 - using numeric-value I manage to obtain the graphs but you have to put several options to obtain the desired value.3 - using String-value I obtain the desired value but there is no graph for this service and for me it is essential to have a graph for analysis.Conclusion: I would like to be able to convert the Output from MB to To / Obtain a Graph for the service using String-Value
hello, I have implemented the open source version of Centreon 22.04. I'm trying to set up notifications via Microsoft Teams but unfortunately it doesn't work. I applied the procedure https://www.centreon.com/blog/envoyez-vos-notifications-centreon-dans-vos-salons-microsoft-teams-en-toute-simplicite/ .Email notifications work fine. If on the user I replace the TEAMS notification by EMAIL it works. On the other hand for a TEAMS notification nothing happens; I don't see any log relating to the attempt to send, and on the internal firewall I don't see any packets going out so I assume that Centreon is not sending this notification. I tried this command with ssh /usr/lib/centreon/plugins/centreon_notification_teams.pl --plugin=notification::microsoft::office365::teams::plugin --mode=alert --custommode=webhookapi --teams-webhook=https:[MON_WEBOOK] --notification-type='RECOVERY' host-name='posteAF' --service-state='UP' --date='14-06-2022' --action-links --centreon-url=[URL_CENTREON][MON_WEB
Hello all Trying to create a simple check command based on SSH cmd-return mode (following )I have created this simple check command : /usr/lib/centreon/plugins/centreon_linux_ssh.pl --plugin=os::linux::local::plugin --hostname=$HOSTADDRESS$ --ssh-backend='libssh' --ssh-username='centreon-monitoring' --ssh-priv-key='/var/lib/centreon-engine/.ssh/id_rsa' --mode=cmd-return --exec-command=/usr/bin/true --manage-returns='0,OK,OK#1,CRITICAL,KO#,UNKNOWN,Problem' But command fails, log (connector-ssh.log) shows : “[core] [error] fail to parse cmd line /usr/lib/centreon/plugins/centreon_linux_ssh.pl <...> option '?' requires an argument Any idea on the missing argument ? Thank you
Hi everyone, I have a CENTOS7 server which hosts a centreon and an integrated nagvis and I would like to migrate my server to another one with a more recent OS like Alma9. Concerning centreon I easily found a way to migrate it but none for nagvis. Which brings us to the following question: do you know a way to migrate a nagvis that uses centreon?(CentOS 7.9, Centreon 22.10, Nagvis 1.9..35
Is there a reason why ctime column on data_bin table is not indexed?Without indexes partitioning and purging requires a full table scan, and with performance metrics collection this table can get _extremely_ large which makes aforementioned tasks very slow, I am now watching a purge processwhich has been running several days now ..
Hi,recently, we implemented SAML-Login with Microsoft Azure following the YouTube tutorial from Centreon (https://www.youtube.com/watch?v=vilNJPxz25U). This configuration works well for most users, however, we encounter an error when users are already authenticated elsewhere with another method (X509 for instance).We noticed that Centreon sends the following in the SAML-Request: <saml:AuthnContextClassRef> urn:oasis:names:tc:SAML:2.0:ac:classes:PasswordProtectedTransport</saml:AuthnContextClassRef>We would like to change the Authentication Context from “PasswordProtectedTransport” to “unspecified”, as this resolved the same issue on another application. I was unable to find any information on configuring this in the documentation (https://docs.centreon.com/docs/connect/saml/). Any help would be much appreciated.
These are the errors that Gorgone’s log gives me root@centreon:/etc/centreon-gorgone# tail -f /var/log/centreon-gorgone/gorgoned.log2024-06-04 16:27:26 - ERROR - [proxy] Tar failed: Could not create filehandle for 'tmp-19.tar.gz': Permission denied2024-06-04 16:27:26 - ERROR - [proxy] Tar failed: Could not create filehandle for 'tmp-19.tar.gz': Permission denied2024-06-04 16:27:46 - ERROR - curl perform error : SSL peer certificate or SSH remote key was not OK2024-06-04 16:27:46 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - http request error2024-06-04 16:28:46 - ERROR - curl perform error : SSL peer certificate or SSH remote key was not OK Cloud you help me with this, please?
Hi guys I activated SSL on my MAP server (Dedicated), but, after executing script (diagnostic.sh) I have a warring (see bottom in yellow). Can someone tell me what the problem is please? Config file : centreon-map.conf RUN_ARGS="--spring.profiles.active=prod,tls" Config file : map-config.properties # Key-store when Map server provide web services by HTTPScentreon-map.keystore=/etc/centreon-map/map.jkscentreon-map.keystore-pass=xxxxxxxxxxxxxxxxxxxx ########## Protocol verification ########## [WARNING] Centreon Map server configured to use HTTP protocol [INFO] Centreon Central configured in Map to use https protocol. [OK] Centreon Central successfully answered to HTTPS request Regards
Hello everyone,I would need to have the CPU and memory used of a specific process and be able to issue alerts if it exceeds a certain threshold.I use Centreon NRPE agent for Windows. I really apreciate if you have any solution or suggestion.Regards.
Quel est la longueur max de key_field svp ?J’envoi de la donnée mais trop a priori et le Centreon dit “no row return” ce qui est faux en plus. Décidément la documentation Centreon est bien pauvre versus le prix du produit….Nous ne sommes pas non plus débordé par les réponses sur ce forum ou même par les réponses aux tickets du support officiel…. Quel Galère !!!
HelloToday, it seems that a file is missing on apt repositoriesE: Failed to fetch https://packages.centreon.com/apt-standard-23.04-stable/pool/gorgone/centreon-auto-discovery-server_23.04.6-1_amd64.deb 404 [IP: 54.195.120.211 443] full traceroot@centreon-central:~# apt updateHit:1 http://deb.debian.org/debian bullseye InReleaseHit:2 http://deb.debian.org/debian bullseye-updates InRelease Hit:3 http://security.debian.org/debian-security bullseye-security InRelease Hit:5 https://apt.grafana.com stable InRelease Hit:7 https://packages.centreon.com/apt-plugins-stable bullseye InRelease Hit:4 https://downloads.mariadb.com/Tools/debian bullseye InRelease Hit:8 https://packages.centreon.com/apt-standard-23.0
Bonjour, En cliquant sur historique j’ai ce message d’erreur : Symfony\Component\HttpFoundation\Response::__construct(): Argument #2 ($status) must be of type int, string given, called in /usr/share/centreon/src/EventSubscriber/CentreonEventSubscriber.php on line 386Et le statut de la base de donnée ne renvoie aucune information. Pourriez-vous me dire où dois-je regarder pour corriger cela., en vous remerciant par avance.
Bonjour,Savez-vous s’il sera possible lors de futures versions de modifier les intitulés de légende dans les graphes, svp ?Merci beaucoup,Bien cordialement,Vincent LIARD, Nantes Metropole
I had the ambition to develop a small widget for Centreon but with the arrival of version 22.04 I am lost because we have two types of widgets, those for the dashboard (new) and those for personalized views (old). There is a link for the “old” widgets https://docs.centreon.com/fr/docs/22.04/developer/developer-widget/is there a link for "new widgets"?I do not necessarily want to invest and develop on a method potentially abandoned by centreon
Hello, i just wanted to be sure that centreon is installed but when i do centreon -v,i see this logs:PHP Warning: Undefined global variable $conf_centreon in /usr/share/centreon/config/bootstrap.php on line 57PHP Fatal error: Uncaught TypeError: Symfony\Component\Dotenv\Dotenv::populate(): Argument #1 ($values) must be of type array, null given, called in /usr/share/centreon/config/bootstrap.php on line 57 and defined in /usr/share/centreon/vendor/symfony/dotenv/Dotenv.php:187Stack trace:#0 /usr/share/centreon/config/bootstrap.php(57): Symfony\Component\Dotenv\Dotenv->populate(NULL)#1 /usr/share/centreon/bin/centreon(42): require_once('/usr/share/cent...')#2 {main} thrown in /usr/share/centreon/vendor/symfony/dotenv/Dotenv.php on line 187Does anyone already see this error ?
Hi,When trying to Monitoring with SNMP Traps. i have to select a template named “generic-passive-service-custom” as described in the documentationhttps://docs.centreon.com/docs/monitoring/passive-monitoring/monitoring-with-snmp-traps/but there is no template with such a name.FYI i’m using no license.
Hi all,I am trying to send metrics from Centreon to our Splunk instance, but have not had any success. I followed the steps here: https://docs.centreon.com/docs/integrations/data-analytics/sc-splunk-metrics/.When I run the curl command at the bottom of that page to test the connection with Splunk, it works and the event shows up in Splunk as expected. However, none of the actual metrics from Centreon show up. If I enable curl command logging in the stream connector, I can copy one of the curl commands and run it manually. The Splunk HTTP Event Collector responds with a 200/OK status, but the event never appears in Splunk.To simplify things, I tried sending a service_status or host_status event pulled directly from the documentation page above. That also gives a 200/OK response code, and never arrives in Splunk. Changing sourcetype, source, index, host, time, etc. does not seem to fix the issue.Does anyone else have this working, and if so how did you do it? I would be happy to pr
Hi, Can someone explain to me what the role of these 2 parameters is in /etc/centreon-map/centreon-map.conf -Dcentreon-map.signing-key=xxxxxxxxxxxxxxxxxxxxxx-Dcentreon-map.access-token-validity-seconds=xxxxxxxxxxxx centreon map installed in didecated server. Thanks
Hello guys,I have a weird problem and I don’t know if it’s me not understanding the metrics correctly or if I have a real problem.I have an Ubuntu server with a CPU check attached to it. This server in the centreon interface shows 65%+ average CPU usage, but when I’m actually connected on the server and I run a HTOP command, the max value I see for the CPU usage is 20%.Here is the HTOP screenshot:Here is the centreon value screenshot:Is there a reason for that?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.