Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello, i trying to install a new central Centreon on RHEL9, i’m new on redhat but in this documentation (https://docs.centreon.com/fr/docs/installation/installation-of-a-central-server/using-packages/#pr%C3%A9requis) there is a command which doesn’t work :dnf config-manager --set-enabled codeready-builder-for-rhel-9-rhui-rpmsit’s failed because there no repo with this name, i thnink it’s du to https://access.redhat.com/solutions/6970108 If it’s the case , it seem like is not resolve yet, do Centreon still work in redhat 9 ? Regard
hello I would like to know if Nagvis is still compatible with centreon 22.10?
/etc/centreon-bi/config.properties has a parameter display_sql_requests, when it is set to true where are SQL queries supposed to be logged?I have checked all logs in /var/log/centreon-bi/ and I can't find any queries being logged in any of these filescbis.outcentreon-bi-backup-reporting-server-db.logcentreon-bi-backup-reporting-server-files.logcentreonBIETL.logdataRetentionManager.logdiagnostic.logrebuildAllEvents.logrebuildAllPerf.logI need to log sql queries for troubleshooting.
Hi,I’ve been asked (and asked here) what was the status of the implementation of the Nagios standard macros in Centreon. I got no answer yet and manage to make an ad-hoc command to help me to have an idea of the subject. Doing that I noticed an unrelated problem, which is the subject of this post.In the legacy pages one could access the whole detailed output, whatever is the length of its lines (even if it is needed to scroll horizontally for long lines) : But I noticed that it was not anymore possible with the new interface, even if enlarging the side panel at its maximum width, the end of the longest lines is not visible at all : It’s Centreon Web 22.10.15, I can’t test newer version at the moment.Is it something we can expect to be fixed. Actually I didn’t have the case apart of this one, but user may ask me to have some information in the detailed output, and maybe no one complained, but it’d because they all still use the legacy pages… :/
Hi,While in the legacy pages the detailed output of the check was properly displayed, this is definitively not the case in the new interface.Empty lines are simply squeezed. I suppose the idea is to gain some place but I doubt this si a good idea: if a plugin has empty lines in its detailed output it is obviously for reason. They should be displayed as is.
Hi everyone! 😊I have a Custom View, and I would like to display this website : https://www.cert.ssi.gouv.fr/alerte/, which is a french site reporting all security alerts, but it tells me the site doesn’t allow the connection.Does someone know a way to display an HTTPS Page becaus I don’t think an HTTP Loader will do it ? ThanksAntonin 😉
Hi all !While upgrading from 23.10 to 24.04, I ended up with a failure, as shown below.Does anyone has experienced a same issue and would have a clue to finalize the upgrade ?In upgrade.log :2024-05-06 10:00|0|0|UPGRADE - 24.04.0: Unable to install core widgets - Code : 0 - Error : Widget is already installed. - Trace : #0 /usr/share/centreon/src/CentreonModule/Infrastructure/Source/SourceAbstract.php(73): CentreonLegacy\Core\Widget\Installer->install()#1 /usr/share/centreon/src/CentreonModule/Infrastructure/Service/CentreonModuleService.php(109): CentreonModule\Infrastructure\Source\SourceAbstract->install()#2 /usr/share/centreon/www/install/php/Update-24.04.0.php(58): CentreonModule\Infrastructure\Service\CentreonModuleService->install()#3 /usr/share/centreon/www/install/php/Update-24.04.0.php(267): Core\Platform\Infrastructure\Repository\DbWriteUpdateRepository->{closure}()#4 /usr/share/centreon/src/Core/Platform/Infrastructure/Repository/DbWriteUpdateRepository.php(144)
Hi,After the upgrade I can no longer push the configuration to distant pollers. Pushing the configuration to the central is OK, but when I try to do it for a distant poller I get this error:Preparing environment... OKGenerating files... NOK (Exception received : Warning: Undefined array key 4 [file: /usr/share/centreon/www/class/config-generate/broker.class.php] [line: 211] )Aborted.Any idea ?I also have this error in /var/log/php-fpm/centreon-error.log :[30-Apr-2024 16:01:12 Europe/Paris] ERROR: No route found for "GET https://xxxxxxx.xxx/centreon/api/latest/auto-discovery/scheduling/jobs" {"context":"[object] (Symfony\\Component\\HttpKernel\\Exception\\NotFoundHttpException(code: 0): No route found for \"GET https://xxxxxxx.xxx/centreon/api/latest/auto-discovery/scheduling/jobs\" at /usr/share/centreon/vendor/symfony/http-kernel/EventListener/RouterListener.php:135)\n[previous exception] [object] (Symfony\\Component\\Routing\\Exception\\ResourceNotFoundException(code: 0): No routes f
I am trying to make sense of how Centreon broker works, and especially performance data storing to SQL database as this is where we have most performance issues.On Centreon 23.10 with unified SQL output there is an option Store in performance data in data_bin, documentation states following about this parameterunified-sql-type outputs have the following parameters:Store performance data in data_bin Should this output save the metric data in the database? Default is yes. If no, this output will generate RRD data without saving them into the database, making a rebuild impossible. However, RRD file generator output in central-rrd-master also have same Store in performance data in data_bin parameter, and documentation states about this parameter exactly same as for unified-sql-type output.I am a bit confused, if both of these are set to yes are we then storing performance data twice into SQL?If we would like to have ability to rebuild RRD data is it okay to set performance data storing in
In broker advanced settings documentation there is a very brief mention of garbage collectorhttps://docs.centreon.com/docs/23.10/monitoring/monitoring-servers/advanced-configuration/#unified-sql-outputsMoreover, this output has a garbage collector that will clean old data from the database occasionally. This is an optional process, as old data is marked disabled, and can actually be useful to keep for debugging purposes. I can’t find any explanation for what is considered “old data” and why or how it is marked “disabled”? Can anyone explain what data garbage collector will clean up, how is data considered to be old and/or disabled?I really find documentation to be lacking in several aspects.
Hi,The multiple bug fixes and enhancements in 23.10 compared to 22.10 are very appreciated. Thanks to the developers.But I only see one “Duration” column although they were two in the legacy page (“duration” and “hard state duration”). Why’s that?If this is for a clarity reason, what I can understand (but strongly disagree though), I think the “Hard state duration” is the most relevant of both.What do you think?
Our 23.10 deployment complains about BAM Reporting filters being too restrictive, [2024-05-14T11:56:10.947+03:00] [config] [error] endpoint applier: The configured write filters for the endpoint 'centreon-bam-reporting' are too restrictive and will be ignored. bam categories are mandatory.[2024-05-14T12:22:35.887+03:00] [config] [error] endpoint applier: The configured write filters for the endpoint 'centreon-bam-reporting' are too restrictive and will be ignored. bam categories are mandatory. but BAM filter is selected and enabled, so to me this error makes no sense.central-broker.json content for centreon-bam-reporting { "type": "bam_bi", "filters": { "category": [ "bam" ] }, "check_replication": "no", "queries_per_transaction": "0", "db_port": "3306", "db_type": "mysql", "db_name": "centreon_st
Bonjour, Depuis la version 23.10 et c’est toujours le cas en 24.04, je ne peux pas masquer le menu Centreon même en ajoutant à la fin de mon URL&min=1 pour mon écran de supervision :------------------------------------------------------------------Hello, Since 23.10 and always on 24.04, i can’t hide centreon menu with URL&min=1 for monitor screen : Thanks
Hi Centreon Support Team,Currently we have an issue with exporting graph logs it gives me blank page and nothing exportsOnly solution way is to split its charts and it exports successfully but it creates additional work for us because it is splitting charts. Centreon Version:Centreon 21.10.13
Hello ,Is this model possible for client infraOur company manage central, and imagine a remote managing other.
Hi,I would like to monitor the number of dialup VPN on a Fortigate with a hardcoded value in the Centreon configuration that will be modified over the time.Ideally, I would like to have a warning when we have more than this number, and a critical when we have less.The current plugin Fortigate does not return dialup vpn information as those one seem stored in differents OID than standard site 2 site VPN. Here are the some additionnal information: https://docs.fortinet.com/document/fortigate/6.4.0/new-features/32869/snmp-polling-extensions-to-support-new-oids-6-4-2 So, I ran an snmpwalk on this OID: 1.3.6.1.4.1.12356.101.12.4.1.1.16 I can find some interesting values:[...].1.3.6.1.4.1.12356.101.12.4.1.1.16.1 = STRING: "DialUpX_0".1.3.6.1.4.1.12356.101.12.4.1.1.16.2 = STRING: "DialUpX_1".1.3.6.1.4.1.12356.101.12.4.1.1.16.3 = STRING: "DialUpY_1".1.3.6.1.4.1.12356.101.12.4.1.1.16.4 = STRING: "DialUpY_4".1.3.6.1.4.1.12356.101.12.4.1.1.16.5 = STRING: "DialUpZ_3"[...]So my idea is to first cat
Good morning, Following the migration of centreon 22.11 on centos7 to debain.I have a problem accessing Control (configuration-->command) I see the controls already created but when I click on them I have no display and it is impossible for me to create new control.If someone has a solution or a track to explore I am interestedThanks in advance.
Hi everyone, Since I migrated a centreon server from version 18.10 to version 22.10, I get the following error in the gorgoned.log : When I access the Centreon login page, I also get the following error as well as the following error in the browser's code inspector: I've done a lot of research but I think the solution must be quite simple, the server is running under Centos 7. Thanks for your help :)
Hello, I've set up a Centreon 23.10 HA cluster and installed the BAM extension modules. However, I'm encountering an issue where all menu items are non-functional except for the BAM and Business pages, which return a 404 error.Is this a common issue? Specifically, the following paths are returning 404 errors:/centreon/configuration/bam/ba/centreon/configuration/bam/bvs Could you advise on how to resolve this? Thank you!
Bonjour, J’ai installé sur une machine debian 12 (fresh install) centreon. Tous est ok sauf….. Les plugins.Après plusieurs recherches, il est spécifié dans l’installation, une partie “Proxy”, sauf que nous n’en avons pas, la machine fait bien ces mises à jour debian, télécharge les paquets sur les repository, etc.Même si je télécharge les plugins avec debian, centreon ne veut rien savoir. J’ai testé de faire l’installation chez moi en perso, tout fonctionne.Du coup, je me pose des questions. Est-il obligatoire d’avoir un proxy ?Par quel port passe le Monitoring Connector Mannager afin d’afficher les plugins sur la page ? Voici à quoi ressemble ma page : Merci de votre aide,Cdt,
Hello,I configured my central server in HTTPS and also the MAPPING server in https. the API of the latter is in UP state, I have no error during the configuration (see image below) and yet my maps do not go up in the web interface of my Centreon, have you already encountered this problem ? good day
Hi All, Will there will be any issues if we update the centreon database to MariaDB ver. 10.11? Has anyone test before? Thanks in advance for advise/inputs.
Hi,Nowadays some pretend that companies and developers relay on AI to understand what their users need: https://www.algolia.com/I can understand how IA, particularly deep-learning, can improve software on many levels, for example in Centreon, how it can help to determine and tune alert thresholds or reveal problem patterns which could else stay invisible to operators, I hardly see how it can be relevant for such type of high-level, human-oriented problems.Does anybody has some experience in the matter?To keep this discussion a bit Centreon centric: what do you think of the cloud-based aspect (ie: SaaS) of the IA features developed in Centreon? While it is sure that that kind of application is very often ressource intensive, it is also an obvious source of valuable data many organisms would like not to freely share but monetize themselves. The fact is a lot of companies today have the infrastructures (datalakes, distributed systems, etc…) to do so. I guess they’d like to be able to run
Hi everybodyI want to install vmware connector on my Debian 11 poller (raspberry pi) to monitor my vmware infraestructure but i´m facing some issues. root@raspberrypi:/home/pi# apt install centreon-plugin-virtualization-vmware-daemonReading package lists... DoneBuilding dependency tree... DoneReading state information... DoneSome packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstabledistribution that some required packages have not yet been createdor been moved out of Incoming.The following information may help to resolve the situation:The following packages have unmet dependencies: centreon-plugin-virtualization-vmware-daemon : Depends: libzmq-libzmq4-perl but it is not installableE: Unable to correct problems, you have held broken packages. Is anyone facing the same issue?
Hi Guys I am having the below problems with my 22.04 cluster .I cannot restart database resource and when I switch the frontend the database are stopping on both nodes Cluster name: centreon_clusterCluster Summary: * Stack: corosync (Pacemaker is running) * Current DC: FRSDPRECENTHAFE02 (version 2.1.6-9.1.el8_9-6fdc9deea29) - partition with quorum * Last updated: Wed May 8 05:38:41 2024 on FRSDPRECENTHAFE01 * Last change: Wed May 8 05:21:17 2024 by hacluster via crmd on FRSDPRECENTHADB03 * 4 nodes configured * 21 resource instances configuredNode List: * Online: [ FRSDPRECENTHADB03 FRSDPRECENTHADB04 FRSDPRECENTHAFE01 FRSDPRECENTHAFE02 ]Full List of Resources: * Clone Set: ms_mysql-clone [ms_mysql] (promotable): * Stopped: [ FRSDPRECENTHADB03 FRSDPRECENTHADB04 FRSDPRECENTHAFE01 FRSDPRECENTHAFE02 ] * vip_mysql (ocf::heartbeat:IPaddr2): Started FRSDPRECENTHADB03 * Clone Set: php-clone [php]: * Started: [ FRSDPRECENTHAFE01 FRSDPRECENTHAFE02 ] * Stopped: [ F
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.