Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi everyone,I am asked to monitor some of our divices within Centreon.Some templates are already used, so I was asked to edit a script for gatheing some Data.We are in an SCCM Iinfrastructure, we have some Distribution Points and some PCs configured as Peer Cache.So, for those PCs, I want to monitor some of theire characteristics. I can’t use SNMP on the PCs because it is deprecated and is no more available within Windows 10 OS.Microsoft advise is to use the CIM model.I have the request for the data I want to gather:$namespace = "ROOT\ccm\Policy\Machine\ActualConfig"$classname = "CCM_SuperPeerClientConfig" $SPCParameters = Get-WmiObject -Class $classname -ComputerName $computer -Namespace $namespace | Select-Object CanBeSuperPeer, HttpsEnabled$SPCParameters.CanBeSuperPeer$SPCParameters.HttpsEnabled if(($SPCParameters.CanBeSuperPeer -eq $true) -and ($SPCParameters.HttpsEnabled -eq $true)){ # Rien à faire, tout est ok}else{ Write-Host "Vérifier la présence du " $computer "dans la c
Hi,Is there a way to use the logical operators “negation” and “or”. For example : All the services for a hostgroup but without the services from another hostgroup?Like, I want the services from groupA but not from groupB.
Hi,We use LDAP account and this warning makes no sens whatsoever : Both 22.10.11 and 22.10.15 (at least) are concerned.
Hello Community, I hope you all are doing well.I followed the instructions to install a remote server from the link : installation-of-a-remote-server.In the 5 step when executing the command :/usr/share/centreon/bin/registerServerTopology.sh -u <API_ACCOUNT> \-t remote -h <IP_TARGET_NODE> -n <REMOTE_NAME>I get the following error that i did not find in the Main error messages from the installation link :- ERROR - 192.168.56.13: {"code":500,"message":"Error from Central's register API : The platform: 'remote1'@'192.168.56.13' cannot be added to the Central linked to this Remote \/ Central's response => Code : No parent platform was found for : 'remote1'@'192.168.56.13'"}Both my central server and the remote are on the same network. I’m using Centreon v22.04 on both servers. I’m working on CentOS 7.I tried to find a solution in the forum but nothing worked for me. Do you know what I could do to solve this issue ?Thank you.
Hi Guys,I would like to have your opinion about Centreon. I plan to install the 23.10 version (Community edition) but I am undecided between Alma 8 or 9.In the long term, which of these is the best to use (more popular, stable, fewer bugs, available packages, recommended by Centreon)?Your answer will be appreciated!Thanks in advance.
Hi,I’ve been asked by a user what this new icon, if it has a particular meaning: The service has no Note URL defined, but its parent template has. could it be the reason for the presence of this icon?(Centreon Web 22.10.15)
Dear Centreon Support Team,I hope this email finds you well. I am currently working on integrating Centreon into our system, specifically focusing on notification settings. However, upon enabling notifications either at the host level or within user settings, I have observed a significant influx of continuous requests from the Centreon servers.I would appreciate your guidance on how to effectively control and manage the frequency of these requests to ensure a smoother integration process. Your prompt assistance in resolving this matter is highly valued.Thank you in advance for your support.
Hi Guys I have installed new Almalinux 8 poller and I am facing this issue on gorgone log .I believe due to this, the poller is not communicating well with central server and I see centengine is not running in the Centreon GUI. 20.2024-02-05 04:29:09 - ERROR - [pull] decrypt issue: FATAL: padding_depad failed: Invalid argument provided. at /usr/lib64/perl5/vendor_perl/Crypt/Mode/CBC.pm line 20.2024-02-05 04:29:29 - ERROR - [pull] decrypt issue: FATAL: padding_depad failed: Invalid argument provided. at /usr/lib64/perl5/vendor_perl/Crypt/Mode/CBC.pm line 20.2024-02-05 04:30:11 - ERROR - [pull] decrypt issue: FATAL: padding_depad failed: Invalid argument provided. at /usr/lib64/perl5/vendor_perl/Crypt/Mode/CBC.pm line 20.2024-02-05 04:30:11 - ERROR - [pull] decrypt issue: FATAL: padding_depad failed: Invalid argument provided. at /usr/lib64/perl5/vendor_perl/Crypt/Mode/CBC.pm line 20.2024-02-05 04:30:21 - ERROR - [pull] decrypt issue: FATAL: padding_depad failed: Invalid argument provid
Hi, You probably already know about it, but since a few days we have a issue with some packages without signature Removing libzmq5-4.3.5-1.el9.x86_64.rpm: Package libzmq5-4.3.5-1.el9.x86_64.rpm is not signedRemoving libzmq-tools-4.3.5-1.el9.x86_64.rpm: Package libzmq-tools-4.3.5-1.el9.x86_64.rpm is not signedRemoving zeromq-devel-4.3.5-1.el9.x86_64.rpm: Package zeromq-devel-4.3.5-1.el9.x86_64.rpm is not signed For this repository (Opensource) :[centreon-23.04-stable]baseurl=https://packages.centreon.com/rpm-standard/23.04/el9/stable/$basearch/
Hello, i’m trying to set up the new vtom plugin with centreon.I have some trouble connecting the plugin since it ask for apiusername and password.Vtom only have api key access. I don’t know what is this username and password that it ask for…Can somebody help on this please ? Thanks !
Hello,I'm looking to upgrade from version 3.4 to version 23.10.To do this, I've created a new 23.10 server, and now I'm doing the migration (following the documentation).However, as soon as the data is transferred, I can no longer access the 23.10 server Do you have any idea how I can solve this problem?Thank you for your answer, have a nice day,
Hello I have multiple oracle databases (9.2 to 21).I have 2 instanat client on my poller (21 and 11.2)I try using “--connect-options oracle_home=/usr/lib/oracle/11.2” or “ --oracle-home /usr/lib/oracle/11.2/client64/”but it doesn’t workWithout option I have : UNKNOWN: Cannot connect: ORA-03113: end-of-file on communication channel (DBD ERROR: OCISessionBegin)Is someone have an idea ? Best regards
Good morning, I would need that if any of three services associated with the host is in warning or critical state, the host changes its state. Now if any or all of the associated services are in critical or warning the host continues to appearing in green. Many thanks
Hello everyone,I run the Centreon update as usual, and now I have the problem below:I restored my virtual machine, no time yet to investigate, if anyone has had a similar problem?Thanks “23.10.7 to 23.10.8 UPGRADE - 23.10.8: Unable to insert centreon-widget-resourcestable in dashboard_widgetsYou seem to be having trouble with your upgrade.Please check the "upgrade.log" and the "sql-error.log" located in "/var/log/centreon" for more detailsYou may refer to the line in the specified file in order to correct the issue.The SQL files are located in "/usr/share/centreon/www/install/sql/"But do not edit the SQL files unless you know what you are doing.Refresh this page when the problem is fixed.”
Hi,I need your help. I’ve installed centreon map, everything seems OK but I got a timeout error when I’d like to access to supervision → MAP on central server :on centreon-map serveur, diagnostic is ok (I’m using http access) :########## Centreon Map server version ########## [INFO] centreon-map-engine-22.10.15-1.el8.noarch########## System ########## [OK] SELinux disabled [OK] Firewall is disabled [INFO] Physical memory available on the server: 7836804 kb. [INFO] Number of CPU available on the server: 4 core(s)########## Java ########## [OK] Java 17 installed [OK] Optimization found for JVM: JAVA_OPTS="-Xms512m -Xmx4G -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/log/centreon-map -Dmanagement.endpoints.enabled-by-default=false -Dmanagement.endpoint.health.enabled=true -Dmanagement.endpoint.metrics.enabled=true"########## Database connection ########## [OK] Connection to centreon [OK] Connection to centreon_storage [OK] Connection to centreon_map########
Good morning,We use version 22.10.4 of centreon on centos7, the collector is integrated into the server.The problem I have is this.When adding new hosts to centreon these appear well in hosts but I do not see them in the resource status.When exporting the configuration on the collector it tells me that I have 21 host while in the resource status only 19 hosts appear.I think I have to forget something but I don’t see what.If anyone has an idea I’m interested.Thanks in advance.
Hello,I need to migrate a large amount of data from an old centreon server to a new centreon server.So I can use the migration document, but can I export only a part of the database? Or can I just transfer all the data at once?Because I have a large amount of data to transfer (on average 200GB in centreon_storage).Thank you for your answer.
Hello the Centreon community…I use a Centreon (IT-100) on witch I have A Windows host monitored. Temporarilly we added 32 CPU cores then return to 12 CPU. But all perfdata (for the 32 CPU) are still displayed on the graph with N/A value.Is it possible to purge the no more used perfdata of a service and show only the 12 CPU core ? Best regards
Hello,I have an installation with a server with all services. I have the server in Azure. We have deployed an Azure MySQL instance to become the Centreon server database.Is there a document that explains how to migrate the local Centreon database to one from Azure? I have not been able to find anything on the subject in the documentation.Thank you
Hello. I am running snmpwalk extend ('NET-SNMP-EXTEND-MIB::nsExtendOutLine. "ExtendName"). CENTREON reports OK status because snmpwalk is working correctly. However, I need the exitcode of the exend in CENTREON. Alternatively, I need to determine the status of the extension and display the correct status in CENTREON. Thank you for your help.
Hi,Centreon provides automatic hosts discovery with the centreon-plugin-Operatingsystems-Linux-Snmp.noarch package (For On-Prem servers).On the Central you need to install centreon-pack-operatingsystems-linux-snmp-23.09.2-1.el8.noarchBut in our compagny: SNMP is disabled everywhere. My question is : is there any other way than SNMP to automatically discover linux hosts ?I couldn’t find such connector (with discovery feature) in the centreon documentations … Thanks a lot
Please provide the steps that need to be followed to migrate from centreon to nagios as we are in the plan of migration.
Hi,Although it has been reported many versions ago it is still not possible (in 22.10.19) to re-order custom filters in the Resource Status page. May we expect this to be fixed someday?To be precise, it is indeed possible to re-order the custom filters with a simple drag-n-drop but when the page is reloaded the filters get back to their original order (ie: the order in which they have been created).Can’t tell for everyone but that’s the kind of little thing that is of real annoyance in everyday use.
Hello,I'm interested in the Centreon ( the open source version) I understand that the solution provides hardware monitoring.I wanted to know if the Nagios Core solution also offers monitoring for the following elements:Web Applications (internal IS and SaaS IS) (Access time to the service, definition of business actions, transactional errors, response time, incidents on plugins, etc.)Software installed on workstations (examples: Loading time, errors, CPU and memory usage. For the Office suite, a more detailed view (email opening time, waiting time for sending, opening time for encrypted emails, opening time for the calendar, opening time for Teams, display time for Teams, etc.)Operating System (examples: crashes, blue screens, driver issues)Antivirus, EDR (examples: Impact of the process on equipment load)Filers (examples: Network drives, OneDrive)Equipment startup (Example: including details up to the end of session loading as well as user-initiated shutdowns "button")I wanted to kno
I don't know if this is normal, but the services to which SNMP traps are connected remain pending until the traps are sent from the device. I have triggered the traps manually. After that everything works perfectly, the services go into the critical state and then into the OK state and stay there until a trap is sent again.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.