Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I have a need to check the file system usage at OS level for my infrastructure. For physical servers, I used the snmp templates and i can check the FS usage but for VMs I am not able to find the right service template. is it possible? if yes, could you please tell me the right service template.
Hello TeamI have just added few ESXi to the centreon. All monitored services are ok except ‘Esx-Memory’, which has status UNKNOWN with error: Cannot get counter 'mem.state.latest' for the sampling period '300' (counter level: 2, sampling level: 1) . I found some advise that it can be fixed in vcenter web client but i cannot find where to change value from 1 to 2 for ‘ mem.state.latest ‘ settings, which is responsible for this counter.
Greetings everyone,i have a strange problem in which i cannot solve, perhaps someone can point in right direction.I'm using the plugin pack for printer standard rfc3805, however, its reporting opposite and doesn't seem to follow the warning/critical thresholds.for example, i have known color printer with black toner at 16%, critical threshold is any number above 16% - it reports back as “OK”,when i change the critical threshold to any number below 16% - it reports as “critical”also i have magenta toner at 82%, same scenario, i play with the thresholds, any number above 82% reports as “critical” any number below 82% reports as “OK”i was able to reproduce this with any snmp printer on my network, its reporting opposite.What gives? any known bugs with this python plugin ?my centos7 box is all up to date, centreon is at latest version and plugins are up to date etc.Attached is a screenshot.
I'm trying to export Centreon monitoring data to Graphite as per "https://www.centreon.com/export-data-graphite/" document. and I'm getting below error in Centreon Broker Master log.[1707810605] error: endpoint applier: no matching type found for endpoint 'Graphite'please help me to pinpoint this issue.
i have this issue : Reason: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'pluginpack_dep_id' cannot be null For information all the extention are updated to the last version
I am unsure about the rates of traffic I get for my interfaces on my switch. In the picture you can see that the incoming traffic remains under 1 Megabit/s. But I got an internet speed of much more than 1 Megabit/s.
hello i have this problem any idea ?
hi I try to install a centreon on almalunix 8 in virtul machine I follow this tutorial https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-packages/#step-4-web-installation I continue to web installation but when I come to the page “DataBase Information” I have this error: SQLSTATE[HY000] [2002] Permission denied The root password is set. Can you help me for that?Thanks in advance.Regards,Ahmed
Hi,Just so you know, the link to the change log present in the upgrade dialog is broken:
Hello,Openfiles monitoring failing due to authentication issue. Error - Status informationUNKNOWN: command execution error [exit code: 127]When trying the command i get below error: # /usr/lib/centreon/plugins/centreon_linux_ssh.pl --plugin=os::linux::local::plugin --mode=open-files --hostname='x.x.x.x' --ssh-backend='libssh' --ssh-username='admin'--ssh-password='******' --ssh-port='22'UNKNOWN: auth issue: pubkey issue Manual ssh to the server works fine from poller. Please assist.
Hi, I monitor the expiration of keys and secrets for my applications in Azure. I have encoutered an issue with the return of warning/critical thresholds for keys and passwords.For instance : /usr/lib/centreon/plugins//centreon_plugins.pl --plugin=cloud::microsoft::office365::management::plugin --mode=app-credentials --tenant=$MY_TENANT_ID --client-id=$CENTREON_API_CLIENT_ID --client-secret=$CENTREON_API_CLIENT_SECRET --filter-app-name='3CX Serveur' --unit='d' --warning-key-expires='''OK: application '3CX Serveur' key credential 'XXX' status: valid, expires in 2y 7M 3w 1d 18h 53m 10s | '3CX Serveur~XXX#application.key.expires.days'=966d;;;0;=> the key expires in 966 days. Now I want to receive an alert when key expires in 900 days : /usr/lib/centreon/plugins//centreon_plugins.pl --plugin=cloud::microsoft::office365::management::plugin --mode=app-credentials --tenant=$MY_TENANT_ID --client-id=$CENTREON_API_CLIENT_ID --client-secret=$CENTREON_API_CLIENT_SECRET --filter-app-name='3CX S
Bonjour,J'ai un problème avec proc-ntpd. En effet, le service ne fonctionne pas lorsque j'essaie de surveiller mon central. L'erreur est la suivante : "Status information CRITICAL: Number of current processes running: 0".NB : J'utilise Debian.
hello Guys,Could you check this issue. Maybe its nothing new…After I run /usr/lib/centreon/plugins//centreon_protocol_http.pl --plugin=apps::protocols::http::plugin --mode=json-content --hostname=10.140.140.105 --proto='http' --port='80' --urlpath='/xx/xx/monitors.json' --header='Content-Type: text/xml' --data='' --lookup='' --threshold-value='count' --format-ok='%{count} element(s) found' --format-warning='%{count} element(s) found' --format-critical='%{count} element(s) found' --warning-numeric='' --critical-numeric='' --warning-string='' --critical-string='' I get this error Status informationUNKNOWN: Cannot load module --mode.Could not find sub '$TOKEN_ROOT' exported by JSON::Path::Constants at /usr/local/share/perl5/JSON/Path/Evaluator.pm line 11.BEGIN failed--compilation aborted at /usr/local/share/perl5/JSON/Path/Evaluator.pm line 11.Compilation failed in require at /usr/local/share/perl5/JSON/Path.pm line 14.BEGIN failed--compilation aborted at /usr/local/share/perl5/JSON/Pa
I have working setup of Central and Poller both using 22.04.5-1 version on CentOS7.I'm trying to add new poller with 22.04 version but on RHEL 8.Followed this documentation - https://docs.centreon.com/docs/22.04/installation/installation-of-a-poller/using-packages/ But on new Poller will RHEL 8 - I see centreon version as centreon-poller-22.04.20-1.el8.noarch. All services are running on poller but on Central poller configuration it showing "Is running ? as NO". So, question is central with version "22.04.5-1" will not work with poller version "22.04.20-1"?do they need to be "exactly" the same?
i need help to fix this proplem
Hi,I need to deal with this kind of return from my MSSQL query: “IDF - OK”i tried to use a regex expression, of course i have read this:How to play with Regex - Part I | Community (centreon.com)How to play with Regex - Part II | Community (centreon.com) so i tried : --critical-string='%{value_field} ne "^(.*OK.*)" 'it’s seem to be ok there: regex101: build, test, and debug regex so for now i got a wrong return:CRITICAL: IDF - OK I also try to return multiple rows with a single query but I did not achieve to print a key_field and a value_field in a same return. any idea are welcome.
Greetings everyone,i have a strange problem in which i cannot solve, perhaps someone can point in right direction.I’m polling my printer thru snmp with “consum test” command to see whats available to poll:screenshot below shows I’m able to poll listed items such as black toner:my next item i want to poll are the drum status, so:printer or centreon doesn't like the string “Drum Cartridge (R1)”but its listed as that just like Black Toner.However, this string with backslashes works via command line:My problem really is the above command with the backslashes only works with command line, when doing this command via the GUI, it doesn't work, I’m finding the GUI is stripping the backslashes… has anyone come across this or know of a solution/workaround ??
Dear community,I’m asking your help. I try to create a new customized notification connector. At this moment I’m pretty sure the command is properly formated.However, Never I’ve received a notification sent using this connector.From “Notification side”, here is what I’ve configured.host notifyservice notifyHere is what is logged within centreon-engine.loglog centreon-engine(No output return from plugin is just because of the connection unavailable, as everytime I want the system to use this connector, I cut the network connection within the virtual machine. Therefore Centreon is unable to communicate with the agent).The more strange that I’m unable to understand and go further is “Error: can't execute service notification 'astreinte_tel' : missing separator '''”The user ‘astreinte_tel’ is the one who should use the connectors… Note: I’ve tried to enable debug logs, but don’t know why the current system is unable to keep my settings, therefore nothing is filled in centengine.debug. I ho
Hello everybody,I am trying to set alarm threshold on my AWS RDS alerting. (“Cloud-Aws-Rds-Storage-Api” service template)When I try to set a threshold i get the UNKNOWN message: “Wrong warning-memory-free threshold”I have tried almost every combination (10 GB, 10G, 10*1024B and even with space before the unit)The “--unit” option is unavailable…Anyone succeeded in setting threshold in this plugin ? (centreon_aws_rds_api.pl)Thank you :)
Hi, Im currently trying to do a Centreon cluster, with the centreon documentation two nodes.I’m able to do the master and slave replication, so if I ve a host in the master and the master goes down and my slave become the master I can see the host on the centreon interface.But when I do the reserve, so adding a host in my slave when my master is down, then I set my master to up, and I come to see the host on the master the replication is not done i can’t see the host on the master.To conclude replication master to slave OK but replication slave to master NOT OKIf you have any ideas what is going on tell me 🙂 thanks . Salut, j’essaye actuellement de faire un cluster Centreon, avec la documentation Centreon deux nœuds.Je suis capable de faire la réplication maître et esclave, donc si j'ai un hôte dans le maître et que le maître tombe en panne et que mon esclave devient le maître, je peux voir l'hôte sur l'interface centreon.Mais quand je fais la l’inverse, donc ajouter un host dans mon
I get as ouput for an interface this:“Interface '1' Status : up (admin: up), Traffic In : 28.37Kb/s (0.00%), Traffic Out : 215.18Kb/s (0.02%)Interface '1' Status : down (admin: up)” My regex is this ‘^1$’. But I want to match it for the first occurence only so that I get the right output. Thank you for your help
Je suis intéressé par Centreon pour le monitoring et la supervision. je voudrais savoir si les informations existantes dans la documentation concernent la version communautaire ou bien la version propriétaire.Merci bien pour votre collaboration.
je voudrais savoir comment je peu resoudre ce probleme
Hello,I’m getting downtimes using API v2 without problems. I need to filter those downtimes that are really actives, specifically those you can see at ‘Downtimes’ page in the Centreon interface. However, from the API I get many more than the ones I see at ‘Downtimes’ page. How can I get the same result? Which filter do I have to use?I thought the active ones were those with ‘deletion_time’ to NULL or ‘actual_end_time‘ to NULL, but the are a lot with these values that don’yt appear on the interface. So I don’t know how to get the ‘real’ ones.Can you help me?Thanks in advance.Albert
Hi,I’m trying to configure SNMP Traps on my Centreon servers, I have one Central and one Poller which are correctly working as active monitoring servers.When I take a look at the config files:Central (/etc/centreon/centreontrapd.pm)our %centreontrapd_config = ( # databases credentials centreon_db => "dbname=/etc/snmp/centreon_traps/centreontrapd.sdb", centstorage_db => "dbname=/etc/snmp/centreon_traps/centreontrapd.sdb", db_type => 'SQLite', # server type (0: central, 1: poller) mode => 0 # spool directory spool_directory => '/var/spool/centreontrapd/',);1;Central (/etc/centreon/conf.pm)$centreon_config = { VarLib => "/var/lib/centreon", CentreonDir => "/usr/share/centreon/", CacheDir => "/var/cache/centreon/", "centreon_db" => "centreon", "centstorage_db" => "centreon_storage", "db_host" => "localhost:3306", "db_user" => "centreon", "db_passwd" =&
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.