Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi, i want to test this new Plugin “ Nmap CLI” - Discovery Pack “i doesnt find it ?Centreon 22.10 is installed.when i search under “plugin Packs Manager” - “nmap” - No plugin packs foundwe have a Centreon licenseCentreon package is installed “centreon-plugin-Applications-Nmap-Cli” rpm -qa | grep centreon-plugin-Applications-Nmap-Clicentreon-plugin-Applications-Nmap-Cli-20230608-122119.el7.noarch Thanks
Hello,I'm looking to monitor Office 365 via the "cloud::microsoft::office365::management::plugin" plugin.However, I have an error that appears when I run it: "UNKNOWN: Can't locate object method "get_code" via package "centreon::plugins::http" at /usr/lib64/nagios/plugins/centreon-plugins/cloud/microsoft/office365/cus tom/graphapi.pm line 195."I've already updated the files,Do you know where this is coming from?Thanks in advance
Hello,I have the four checks related to OS-Linux-SNMP which are bugged.Indeed, these are configured as follows:$CENTREONPLUGINS$/centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=cpu --hostname=$HOSTADDRESS$ --snmp-version='So, I wanted to modify them.To do this, I go to /etc/centreon-engine/commands.cfg and I make the necessary changes to the commands having the problem.However, when I reload my pollers, the commands return to their initial state, before modification.How to make so that the modifications are integrated and remain so?Thanks in advance
Hello,I want to configure traps on my Centreon server to receive alarms from a router, and now I am trying to find the best configuration to do it, for that I want to know if it’s possible to add a variable (macro) to an advanced matching rule, I tried to add $1 and $p1 but it didnt work it’s print the variable but not it’s content. (see image below)my idea is rather than adding a matching rule for every possible interface, I want to do it with one rule for similar interface names for example for GigabitEthernet0/1 and GigabitEthernet0/2 I want to add one matching rule like “GigabitEthernet0/$1” and the macro $1 here contain the interface index (1 or 2).. is there a way to print a variable in the matching rule ? Thank you for helpRegards
Hello,does someone have ever try to deploy it ?Download Centreon | Open Source IT Infrastructure Monitoring Tool here you can find a password for the web interface:Discover the Centreon web interface | Centreon Documentation here an other one:Using a virtual machine (VM) | Centreon Documentation but these password do not work.is there a way to reset the admin password ?does some one has the good one ? On Download Centreon | Open Source IT Infrastructure Monitoring Tool for the vm on 23.04, the link for doc and releases notes are broken.
Hello,i deployed a Centreon HA cluster, now i’m trying to monitor the HA Cluster following this guide:https://docs.centreon.com/pp/integrations/plugin-packs/procedures/applications-monitoring-centreon-ha/ when i reach the key exchange chapter, it seems that the guide is not useful or the procedure is incorrect!i even tried this way:tried another way for key exchange added a new host (IP=virtual IP) added community string and version left everything else blank, not sure if i should fill in the (SSHPASSWORD + SSHUSERNAME ...)i’m so confused here; tried key exchange multiple times but most of the cluster services are getting errors like : UNKNOWN: Command error: centreon-engine@172.X.X.X: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
I have the problem that almost all pages like “Custom Views”, “Monitoring Connectors Manager”, “Host configuration”, “Service configuration” are displayed as a blank white / black page.The only menu working - luckily - ist the “Resources Status”.Example “Custom Views”What can I do. I really need to manage my hosts in the next days and add some more…DNF Update is up to date on my server.I only have this one central server.Running on ALMA 8 Linux.
I have created a new server with Centreon on it and I would like to import my old MAPs from the old server but except that I have imported all the MAPs and images and the images in the MAPs are not displayed. And I did import all the database and everything is well installed it is verified. Would anyone have a solution for me please?
Hello everybody,I'm having problems with Microsoft teams notifications on Centreon, it was working before, but now there is no notification, what could be the problem? Thanks
Hello,I'd like to know if I'm the only one who can't do the new 23.04.2-1 and 23.04.3-1 updates.I'm not sure if it's just me who can't do the new updates.Is it possible to get some information please?
Hello,I have a Centreon with remote server. I would like to install a separate license for each Central and remote.It’s possible to have a different license for the Central and the Remote server? How i can install the license ?Thank’s
Hi,I rebuild my MBI DB, and the "process" - now is freeze / hang ... , since 10 Houre'sServer reboot / all Service running , found no issuedisk space is ok # /usr/share/centreon-bi/bin/centreonBIETL -r 2023-06-08 09:40:00 - INFO - [SCHEDULER][DIMENSIONS] >>>>>>> startwait And Wait .… thanksandreas
Hi,I’ve upgraded from 21.10.5 to 22.04 and I need to revert to 21.10 because I’ve a lot of problems.1st one I’ve configured a no working openID connection. Once I’ve updated all PluginPack I loose the conncection to the website with the problem “whitelist IP”.As i can’t connect to the web interface I can’t remove the openID configuration. 1st revert back for me!In 21.10 version I desactivate openID connection and upgrade again to 22.04. I can now update all pluginPack an d continue to work on this version.When I try to send configuration I’ve an new problem:No picture on the left on each items and problems appear in errors/warnings in move files:Warning chmod(); Operation not permitted (I’ve not this problem on 21.10)You can see these 2 problems here:https://ibb.co/q1kGFLXHere the last line of the error loghttps://ibb.co/bF24zvXAnd I’ve some problem with PP proxmox (crédential problems) and TCP check seems to not working well.So I’ve reverted again to version 21.10.Hope these informati
Hello !I recently installed Centreon 22.10 using the OVA image given.I then updated it to 23.04 using the documentation. (Upgrade from Centreon 22.10 | Centreon Documentation)Then, using the web API import/export, populated it with centreon 2.6 hosts, services etc..In the broker configuration I changed the conf file from “central-module.xml” to “poller-module.json” and the central was up. I then changed the conf files of central-broker-master to “central-broker.json” and central-rrd-master to “central-rrd.json”. Following these changes the central went down as such.I followed → My poller is down | Community (centreon.com)But did not find an answer.I have found errors in /var/log/centreon-broker/central-module-master.log : [2023-05-30T16:28:58.259+02:00] [core] [info] multiplexing: engine started[2023-05-30T16:28:58.261+02:00] [core] [info] Poller '' with id 0 connected[2023-05-30T16:29:11.051+02:00] [core] [info] bbdo stream stopped with 0 events acknowledged[2023-05-30T16:29:11.051+02
Hello, I am implementing centreon openid connect with Azure AD, and I have an error “could not resolve host login.microsoftonline.com”.the central server does not have direct access to the internet, the flows are proxied. how do I configure open id connect so that it uses my proxy? Thanks all
Hello, I have trouble configuring the OpenID Connect authentication configuration.We use a reverse proxy to connect to the Identity Provider and to connect to Centreon (v. 22.10.4). We are using a VPN, the domain cannot be resolved publicly.External URL (after reverse proxy):IDP : https://idp.external.XXXX.intra Centreon : https://supervision.external.XXXX.intraInternal URL (before reverse proxy):IDP : https://idp.internal.XXXX.intra Centreon : https://supervision.internal.XXXX.intra The problem is, when I click on “Login with openid” button after configuring OpenID Connect authentication, I get redirected to an URL like this :https://idp.external.XXXX.intra/application/o/authorize/?client_id=XXXX&response_type=code&redirect_uri=http://supervision.internal.XXXX.intra/centreon/authentication/providers/configurations/openid&state=648057e829375&scope=openidThe redirect URI is false here because Centreon is taking its own internal URL and we want that the redirect URI would
in the Free TI version, can I install the plugins I want?
Hello team, I wanted to check how I can monitor VPN certificates that are installed on Checkpoint Firewalls. Currently, I am using the template X509 and it works fine but for VPN certificates installed on Checkpoint Firewall, I don't know how to make it work. Please advise. Thank you. Crisanto
Hello,Although I have installed several monitoring connectors, my discovery command list remains empty. Is this normal?Because every time I use auto discovery for services I always get the same message "No results found in Gorgone response" so I think the problem is that I don't have any discovery commands.Thanks you in advance
Bonjour,Je n’arrive pas à configurer correctement le plugin Speedtest pour me permettre de remonter correctement les infos de ma liaison internet.Quelqu’un l’a t’il déjà déployer ? peut il me donner les infos utilisés pour que cela fonctionne (hôte associé (centreon-central ou autre, ...)Merci pour votre aide et retourJohann
Hello, I've encountered a new problem, I've received this error "Provider configuration with name local not found" I've looked at the sql base provider_configuration file but it's empty. How can I fix this error?
Hi there,We’re having an issue with our Central when we want to export the configuration.I did check the permissions on the file “plugins.json” and it seems to be correctcentreon-engineadmin0664Is there anything else I can check?Thanks for your help
Good morning.My connection to Centreon isn’t working. The error message is incorrect password while I use the doc password provided with the virtual machine. I’m not changing the password.Password use: Centreon123!login use: admin
Bonjours.Ma connexion a Centreon ne fonctionne pas. Le message d’erreur est mot de passe incorrecte alors que j’utilise le mot de passe de la doc fournis avec la machine virtuelle. Je n’est pourtant pas modifier le mot de passe.Mot de passe utiliser : Centreon123!identifient utiliser : admin
Hello, I have a powershell script for monitoring the windows firewall : if (((Get-NetFirewallProfile | select name,enabled) | where { $_.Enabled -eq $True } | measure ).Count -eq 3) {exit 0} else {exit 2}In nsclient.ini I have :check_fw_state=cmd /c echo scripts\\custom\\check_fw_state.ps1; exit($lastexitcode) | powershell.exe -command -When I launch it I have this : PS C:\Program Files\Centreon NSClient++\scripts\custom> .\check_fw_state.ps1PS C:\Program Files\Centreon NSClient++\scripts\custom> $LASTEXITCODE2But when I try with nscp test I have this : check_fw_stateD ext-script Command line: cmd /c echo scripts\\custom\\check_fw_state.ps1; exit($lastexitcode) | powershell.exe -commad -L cli CRITICAL: No output available from command (check_fw_state).L cli Performance data: What do I miss ? NB: If I put a Write-Host “2”instead of “exit 2” I get the return but it’s not a critical : check_fw_stateD ext-script Command line: cmd /c echo scripts\\custom\\check_fw_st
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.