Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,I ‘ve a Centreon server 21.10.10 (Centos) wich work fine with Google Oauth2.I am moving to Centreon 22.10.1 (Debian) but OpenID connection is broken.The authorization code is sent by Google but Centreon give me a “Request for connection token to external provider has failed” Any help are welcome ! here is an example of the OauthFlows :{ Explanation: "GET from ORIGINATOR(previous page) => REDIRECTURL(Current page)", date: "2022-11-17T06:50:41.376Z", page: "page_1", originator: "https://accounts.google.com//o/oauth2/v2/auth?client_id=123123123123-xxxxxxxxxxxxxxxxxxxxxxxxxxx.apps.googleusercontent.com&response_type=code&redirect_uri=https://supervision._____.org/centreon/authentication/providers/configurations/openid&state=6375d9b97beaf&scope=email", redirectURL: { baseURL: "https://supervision._____.org/centreon/authentication/providers/configurations/openid...", state: "6375d9b97beaf", code: "4/xXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxXxX_xXx
I notice that the check process of my Centreon-engine (22.04.0) of my central server is broken from time to time, without disturbing my supervision.[2022-11-08T12:59:52.390+00:00] [events] [info] [25017] SERVICE ALERT: Central;Centreon-engine;OK;HARD;1;OK: Number of current processes running: 1 - Total memory usage: 153.07 MB - Average memory usage: 153.07 MB - Total CPU usage: 3.13 %[2022-11-08T13:09:52.985+00:00] [events] [info] [25017] SERVICE ALERT: Central;Centreon-engine;CRITICAL;SOFT;1;CRITICAL: Number of current processes running: 0[2022-11-08T13:10:52.390+00:00] [events] [info] [25017] SERVICE ALERT: Central;Centreon-engine;CRITICAL;SOFT;2;CRITICAL: Number of current processes running: 0[2022-11-08T13:11:52.856+00:00] [events] [info] [25017] SERVICE ALERT: Central;Centreon-engine;OK;HARD;1;OK: Number of current processes running: 1 - Total memory usage: 153.07 MB - Average memory usage: 153.07 MB - Total CPU usage: 3.02 %[2022-11-08T13:31:52.028+00:00] [events] [info] [25017]
Bonjour à tous,De puis mon passage en Veeam Backup & Replication 11 aucun check de job de backup ne passe.En effet, voici le message d’erreur : UNKNOWN: Command error: Snap-In Veeam no present or not registered En lisant la doc Veeam, il apparait que Veeam a changé son mode de check, savez-vous comment changer les checks Centreon pour qu’il prenne en compte la modification de veeam ? “Starting with Veeam Backup & Replication 11, the Veeam PowerShell Toolkit is a PowerShell module instead of a snap-in.Scripts containing the command "Add-PSSnapin VeeamPSSnapin" will fail and display the error:No snap-ins have been registered for Windows PowerShell.From the Veeam Backup & Replication 11 What's New PDF:PowerShell module — By popular demand, we switched from the PowerShell snap-in to the PowerShell module, which can be used on any machine with the backup console installed. We also no longer require PowerShell 2.0 installed on the backup server, which is something many customers
Hello,I am creating a script for a service control and I have a problem. The script takes a few seconds to run and get the information as it performs a fairly extensive query. When it takes time to return the information in the control, a timeout appears.Is there a way to make the control wait for a certain time, for example like what the snmp-timeout command does? Thanks Best regards,
Bonjour à tous. Je vous explique brièvement la situation.Je travail avec l’équipe informatique dans un lycée dans lequel le sous traitant officiel “econocom” va nous changer nos serveurs “physique” en serveur virtualisé.Jusqu'à présent il n’y avait aucune solution de supervision.A présent, le sous traitant va superviser les VM avec “son” centreon.Depuis quelques temps, en interne, nous réfléchissions à installer centreon pour superviser notre infrastructure. Ma question est : Est ce que les VM peuvent être superviser par deux collecteurs centreon; celui du sous traitant et le notre?Merci d’avance pour vos réponses.Cordialement.
Hi,After Upgrade from 22.04 to 22.10 on AlmaLinux 8 (Centreon IT100), "Ressource Status" show duplicate services whereas “deprecated pages” are OK.By hovering the mouse over a duplicate service both are selected !Already tried :Purge browser cache / use Private mode / change browser Export config whilte Restarting Monitoring Engine Restarting manually entengine.service and cbd22.10 ressource status22.10 deprecated page Anyone had the same behavior ?
hi, when i click on services → scan tab it’s show like this...anyone has any idea how to solve this
Hello,We have the following error when trying to create a new user via l-ihmwe have upgraded from 21.04 to 22.04.7with php8no modification at the level of the LDAp conf has been madetail -f /var/log/php-fpm/centreon-error.log[08-Nov-2022 10:34:01 Europe/Paris] CRITICAL: Warning: Undefined array key "contact_ldap_dn" {"context":"[object] (ErrorException(code: 0): Warning: Undefined array key \"contact_ldap_dn\" at /usr/share/centreon/www/class/centreonAuth.LDAP.class.php:109)"} thank you in advance
Hi, I hope someone can help, so i installed 2 version of centreon 22.10 and 22.04 i get the same problem which is i cant install plugins even after installing them from ssh using the cmd,i trien other plugins to check however it’s the same always disabled for both versions the plugins are ngins apache and asteriskthanks for any help or suggestions. Kind regards
Hello I get an error when I want to retrieve the rsa public key [root@poller-1 tmp]# perl gorgone_key_thumbprint.plBareword found where operator expected at gorgone_key_thumbprint.pl line 9, near ""en" data" (Missing operator before data?)Bareword found where operator expected at gorgone_key_thumbprint.pl line 9, near ""auto" data" (Missing operator before data?)Bareword found where operator expected at gorgone_key_thumbprint.pl line 9, near ""light" data" (Missing operator before data?)Bareword found where operator expected at gorgone_key_thumbprint.pl line 9, near ""dark" data" (Missing operator before data?)Can't modify numeric lt (<) in scalar assignment at gorgone_key_thumbprint.pl line 9, near ""en" data"syntax error at gorgone_key_thumbprint.pl line 9, near ""en" data"Excessively long <> operator at gorgone_key_thumbprint.pl line 28. OS centos 7perl v5.16.3centreon 22.04 Thanks for your help
Hello, dear colleagues,When we run the mentioned check(check_mssql) we get the below error.UNKNOWN: PDO MSSQL/DBLIB support is not installed on this server. Try adding packages php-pdo and php-mssql.We have used the following commands.sudo dnf install php-pdosudo dnf install php-mssqlHowever, in the 2nd command we get the following error.No match for argument: php-mssqlError: Unable to find a match: php-mssqlNote that Centreon is version 21.10 and the server OS is RedHat 8.3.Please show your support.
Bonjour, depuis 2 jours le poller est bien lancé mais ne se met plus à jour.Je suis en Centreon 21.10.13J’ai effectué toutes les vérifications indiquées ici :https://www.centreon.com/blog/centreon-troubleshoot-series-episode-1-help-mon-poller-ne-fonctionne-pas/Merci de votre aide
Hello Community,Recently i’ve posted an issue on the project chatops Issues · centreon/centreon-chatops · GitHub, i reviewed the Centreon documentation. I think i have my answer.Actually chatops module seems to be able to communicate with Centreon (Acknowledgement, Downtimes, list status) and it can’t push/stream events inside a chatroom.The only possibility to remediate to that would be an output broker for Mattermost or a stream connector for Mattermost ? (Broker module seems to be the only flow to stream events, business activity and metrics)A centreon-plugins could be a more simple solution in order to just be a notification command (a fork of Notification Slack for Mattermost) ?Regards,Greg
Hello,Maybe you could rename Citrix Netscaler to Citrix Netscaler ADCI encounter a problem with the type of VServer sslvpn.The mode vserver-status give a false return when you use a sslvpn.You don’t have Health, Traffic and Client like a Loadbalancer VServer.Is it possible to implement this distinction ?Documentation about the OID of a Citrix ADC here https://developer-docs.citrix.com/projects/citrix-adc-snmp-oid-reference/en/latest/ not mention health, traffic and client about this type of vserver. -bash-4.2$ /usr/lib/centreon/plugins/centreon_netscaler.pl --plugin=network::citrix::netscaler::snmp::plugin --mode=vserver-status --hostname='@IP_of_Ctrix_ADC' --snmp-version='3' --snmp-community='private' --snmp-username centreon --authprotocol SHA --authpassphrase "my_auth_passphrase" --privprotocol AES --privpassphrase "my_priv_passphrase" --filter-name='VS_sslvpn' --filter-type='' --warning-health='@50:75' --critical-health='@0:50' --filter-type='sslvpn'CRITICAL: Virtual Server 'VS_ssl
Hi there,We have this stacked view from Cacti we want to migrate to Centreon and I am wondering how to do so.Any tips?ps: There are different interfaces from different hosts involved
Eric here,I did a fresh install of Centreon 21.10.8, with a Central and Database server.Upon adding servers to be monitored, I notice that the status of hosts and services go to UNKNOWN for a few seconds (about 5s to 10s) every few minutes. In the monitoring views as well, the status of hosts and services go to UNKNOWN for a few seconds (about 5s to 10s) every few minutes.However the real status of the servers is unchanged, and checks on the command line from Central poller are OK. What I have tried:Test Network Performance: I tried to see what is going on in the browser; I can see a lot of ajax/xhr requests from the browser to the server. The execution time of these requests in the browser does not seem to be long (100ms to 200ms for the top counter statuses and 1s to 2s for the monitoring views). I tried the same requests via curl in the cli on the Central server and I get the same execution times. Modifiy Refresh Settings: I tried changing the settings Administration > Settin
Hello,I am in version 21.10.7 and for more than a month, I have no more graphics.I try to Rebuild RRD Database ofr all metrics.It’s a new install.Configuration servers: Centreon 21.10.7RedHat 8.6PHP 8.0.21Apache/2.4.3710.5.13-MariaDB MariaDB Server
Hello Do you have any release date about 22.10 version for Centreon Web ?Thanks
Hello,So far I have made the different version upgrades and modifications of the different confs manually,I'm looking for a solution or advice on how to automate the whole thing (Centreon conf, plugin, etc.) via a git CI/CD or other solution. I would be grateful if anyone has any ideas .Thanks
Hi the Watch Community.I would like to know how activate full debug on the openid actions.I have alreday changed the configuration through the web interface : “ You can enable Authentication debug through the Administration > Parameters > Debug menu to understand authentication failures and improve your setup. “But i have problem with “authorization key” in order to give authorizations for my openid user.For examphe in the php file : /usr/share/centreon/src/Core/Security/Application/UseCase/LoginOpenIdSession/LoginOpenIdSession.phpIn the function : “getUserClaimsFromIdTokenOrUserInformation”By default no log about the claims interpretation.How activate it ?Thanks for your help
Hello Team,I have an issue on my centreon plateform, sometime on of my pollers are not able to check service.status change to "UNKNOWN" with this following error : (Execute command failed).My version of Centreon is : v. 22.04.4Thanks in advance for your help.Regards,
Hi, I’ve a old Centreon Version (19.10) and since a day, widgets are blanks in custum view without modification of this plateforme.Have you got an idea ? Example on simple Widget : HTTP Loader. Sincerely,Manu
Hi ,When i try to login to Support.centreon.com i get a single sign-on error.
Hello, indeed I have just updated centreon web from 22.04.5 to 22.04.7, so I notice an instability of the centreon services (cbd, ).and I have the following errors : best,
Hello, please we are unable to acknowledge the alarms on Centreon 20.04.20. (it does not work, without any error)here are the real time logs after acknowledgment :tailf /var/log/centreon-gorgone/gorgoned.log | grep -i Acknowledged2022-10-18 10:29:14 - INFO - [legacycmd] Handling command 'EXTERNALCMD', Target: '32', Parameters: '[1666081753] ACKNOWLEDGE_SVC_PROBLEM;SGB1E100-A.DPD;RUBRIK-STORAGE;2;0;1;878473;Acknowledged by 878473'Can you help please ?thanks
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.