Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I am using the same centreon plugin vmware command on two different pollers.One of them works.In the poller that works when I run the command: curl https://ipvcenter/sdk/vimService.wsdl -vvv -k I have a return that proves it works On poller not working when I run command: curl https://ipvcenter/sdk/vimService.wsdl -vvv -k I got error like: Initializing NSS with certpath: sql:/etc/pki/nssdb* CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none* NSS error -5961 (PR_CONNECT_RESET_ERROR)* TCP connection reset by peer* Closing connection 0curl: (35) TCP connection reset by peer What does that mean? while it was still working 2 weeks ago CordialyFrancis DOUNGA
Bonjour, je suis totalement débutant et…. perdu ;)j’ai suivi le tuto ci dessous:https://docs.centreon.com/fr/docs/upgrade/upgrade-from-21-04/et dans l’avant dernier pas … j’ai ce message d’erreur sans savoir que faire ?si quelqu’un pouvait m’orienter ? Merci à vous
Hello everyone i have an issue, i can ping the VIP, but i cant get a single value with the plugin keepalived even if the service is working. Thanks for your answers !Keepalived config:Config centreon:
Hi,After migration (all OK) : I got a problem on service template page : see picture attached.template names misinterpretationAnd, about the log files, only warnings in /var/log/php-fpm/centreon-error.log :[30-Aug-2022 11:08:26 Europe/Paris] PHP Warning: Attempt to read property "value" on null in /usr/share/centreon/GPL_LIB/SmartyCache/compile/ac81e1f21d5b4453f8a41890089d1cc1725bf0e6_0.file.content.tpl.php on line 68[30-Aug-2022 11:08:27 Europe/Paris] PHP Warning: Undefined array key "finish" in /usr/share/centreon/GPL_LIB/SmartyCache/compile/ac81e1f21d5b4453f8a41890089d1cc1725bf0e6_0.file.content.tpl.php on line 49[30-Aug-2022 11:08:27 Europe/Paris] PHP Warning: Attempt to read property "value" on null in /usr/share/centreon/GPL_LIB/SmartyCache/compile/ac81e1f21d5b4453f8a41890089d1cc1725bf0e6_0.file.content.tpl.php on line 49[30-Aug-2022 11:08:27 Europe/Paris] PHP Warning: Undefined array key "finish" in /usr/share/centreon/GPL_LIB/SmartyCache/compile/ac81e1f21d5b4453f8a41890089d
Hello,I have a fresh installation of the centreon version 22.04 open source un Alma linux 8 (split : 1 central, 1 DB and several pollers).I can see in the documentation that it is possible to update centreon using the “yum update centreon\*” command.https://docs.centreon.com/fr/docs/update/update-centreon-platform/If I want to update my version of centreon (and just centreon) I just have to do some commands “yum update centreon\*” on the central and on the pollers (nothing on the database server) please correct me if I'm wrong.This will update all centreon packages (I guess if there are some dependencies to satisfy, the packages will also be updated or installed).On the other hand, I wonder about the update of the OS part and other packages outside centreon.If I want to keep my linux distributions up to date, is there a way to do this in a simple way and is recommended (perhaps excluding packages during the “yum update”?Or is it that when we update the OS we also update centreon becaus
Hello,How can I know who has disable notification on service from centreon interface > more action > service disable notification? CordialyFrancis
Hello to all.After a reboot of my CentOS, i’m unable to access to my centreon web interface. I’ve researched on internet some solutions but i can’t find something that solve my problem.Facing these errors when I type :@IP @IP/centreon Also, i can not start the httpd24-httpd service. Below, there are the errors from systemctl status httpd24-httpd and journalctl -xe.journalctl -xesystemctl status httpd24-httpdHope someone can help me please
Hello,I want to add services to database PostgreSQL monitoring.Service name: backup-ageService name: Full backupIs there a suitable plugin or tool for monitoring backup services?Sincerely
Hi everyone, I have a issue with my plugins. I don’t have them anymore ?Thanks for your answers !
Bonjour,
Hello everyone, I set up centreon few weeks ago, but there is a thing i want to do and i can’t find any informations on the web. I will give access to centreon for some collaborators, and i want to simplify the interface for adding new services. To do this, i want to hide some fields. This is the result i want to have : Do you have any ideas ? Best regards, Florian
Hello,I am installing the last version (22.04) open source of centreon but I encounter problems.I am at the stage of securing centreon, especially the HTTP2 part :https://docs.centreon.com/docs/administration/secure-platform/#enabling-http2I was asked to do this :Here is my current config file : I don't really understand what I should do, the "-" and "+" signs intrigue me. I had the idea of committing or uncommenting lines but with these "+" and "-" I don't see what I should do. Could you help me please ? ThanksCordially
Hi, I have written a skeleton for python script for centreon. The problem is that the script works fine until I import the pyrfc library, which is the key for this script.Without this library centreon returns me a green OK message which is fine.Once the library is there, it returns No output returned from plugin. If I run the script through the OS under the user centreon-engine it works fine even with the library. I have the latest version of pyrfc and it works fine because I use it in other scripts, it just doesn't work in the centreon UI. My command is : /usr/bin/env python3 /usr/lib/nagios/plugins/SCRIPTS/test.py (working fine from OS)With library, without library it’s green and returning desired output.What I've tried so far:set chmod 777 on the scriptchange the owner to centreon-enginerun the script on the OS under the user centreon-engine - worksreinstall pyrfc librarychecked Python versions My Code:#!python__author__ = 'xxxx'__version__ = 0.1import osimport timeimport pyrfc # I
Hello,By any chance is there a way to change the Centreon logo at the login screen to put a customized one ?Thanks for your help
Hi, I have automated the installation of Centreon with Ansible, but i am facing some issue synchronizing the images.After some discussions on slack, I managed to reuse the php script: /usr/share/centreon/www/include/options/media/images/syncDir.phpI have just removed the session_id function since i hav to run the script from a shell.Here is the script:<?php/* * Copyright 2005-2015 Centreon * Centreon is developped by : Julien Mathis and Romain Le Merlus under * GPL Licence 2.0. * * This program is free software; you can redistribute it and/or modify it under * the terms of the GNU General Public License as published by the Free Software * Foundation ; either version 2 of the License. * * This program is distributed in the hope that it will be useful, but WITHOUT ANY * WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A * PARTICULAR PURPOSE. See the GNU General Public License for more details. * * You should have received a copy of the GNU General Public L
Hello Community !Here is the configuration I'm tryuing to apply, in order to acknowledge an alert.In this example, the topic is to create the acknowledge when the traffic on interface Tu30 is greater than 0.1%.1-The CLAPI command to execute is the following.centreon -u admin -p xxx -o RTACKNOWLEDGEMENT -a add -v "SVC;RouterName,Traffic-Tu30;ACK test;2;0;1"When I'm trying directly this command on the central, it works fine.2-So, I've created the following script, called handle-acknowledge-test, in /usr/lib/centreon/plugins/eventhandler/ directory#!/bin/bash#script to acknowledge WARNING status on RouterName host, Traffic-Tu30 servicecase "$1" in CRITICAL) ;; WARNING) centreon -u admin -p xxx -o RTACKNOWLEDGEMENT -a add -v "SVC;RouterName,Traffic-Tu30;ACK test;2;0;1";; UNKNOWN) ;; OK) ;;esacexit 0Rights are described here
Hello,I want to monitor my D: partition on a Windows server. I use the 'OS-Windows-Disk-Generic-ID-SNMP' plugin and I set the DISKID value to 1. It is the C: drive that comes up.With the 'OS-Windows-Disk-Generic-Name-SNMP' plugin, I set the value D: for the DISKNAME option and it's still the C: drive that comes up.Could you help me ?Thanks in advanceSteve
Hi !I have a question, Im doing a Centreon HA. But there is not HA with the pollers or the remote servers right ? So even if we have Centreon central HA with a master and slave but our pollers or remote servers goes down we have no more monitoring because they collect all of the data. So Centreon HA is not really HA then, how we can do poller or remote server HA ? To be sure that everything is HA ? Thanks for your answers !
Hello everyone,we have a fresh installation of Centreon 22.04 with IT-100 and when I try to change the timezone of the host template OS-Linux-SNMP-custom (for example) and then save the configuration, this error comes out:The connection was resetThe connection to the server was reset while the page was loading.and the changes are lost.The component versions are:centreon-web-22.04.0-2.el7.centos.noarchcentreon-pp-manager-22.04.0-2.el7.centos.noarchAny ideas on what can be the reason?Thank to all
Hi,does anyone know a good script - Check / powershellfind duplicate MAC addresses on a Hyper-v - Cluster Thanks
Hello I often had a failed job. When I look in my logs, I think my problem comes from the sftp connection. Here is today's log:[21/07/2022 10:00:35 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:36 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:36 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [INFO ] [Publication][SFTP] Try to connect...[21/07/2022 10:00:37 ] [ERROR ] Error while opening SFTP sessioncom.jcraft.jsch.JSchException: connection is close
Hello Community,I need your help for the intergation of pagerduty in centreon.I followed the documentation below:https://docs.centreon.com/fr/docs/21.04/integrations/event-management/sc-pagerduty-events/but in the central-broker logs, I have this errorerror: lua: error running function `write'/usr/share/lua/5.1/centreon-stream-connectors-lib/sc_broker.lua:42: attempt to call method 'get_host' (a nil value)file contente: -- get host information from broker cache local host_info = broker_cache:get_host(host_id)anyone have an idea about this problem ?Thanks for your help <3
Bonjour à tous,Y a t il une solution pour superviser un disque supérieur à 128To via snmp ou NRPE ?J’ai besoin de monitorer 4 x 277 To et je ne sais pas comment faire avec CentreonMerci pour votre aide
I have freshly installed 22.04 under RHEL8 and find that I cannot set my language to en_UK so that I get date and time in their correct formats of 24hr and DD/MM/YYYYHow do we add en_UK?
Hello,Regarding this link :Le support de CentOS par Centreonthere was an hope to see centreon packaging developped for ubuntu.Is there a state about centreon packaging for ubuntu ?Thank you for your feedbackOlivier
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.