Question

Automate Linux NRPE3 plugin installation by Ansible

  • 3 March 2023
  • 0 replies
  • 201 views

Badge +5

Hello community !

 

I’ve recently encountered a problem while trying to install the centreon-plugin-Operatingsystems-Linux-Local.noarch component for Linux NRPE3 plugin supervision on an Oracle Linux end-server, using Ansible automation.

 

Here is a fragment of my Ansible playbook code (I use yum_repository as dnf_repository is not yet available in Ansible):

- name: Add Yum repository

  yum_repository:

    name: Centreon

    baseurl: https://yum.centreon.com/standard/22.10/el8/stable/x86_64

 

- name: Install requirements

  dnf:

    name: “{{ item }}”

    state: latest

    with_items:

      - centreon-nrpe3-daemon.x86_64

      - centreon-plugin-Operatingsystems-Linux-Local.noarch

 

While launching the above playbook i got the following error related to the installation of the second component:

Depsolve Error occurred:

Problem: cannot install the best candidate for the job 

- nothing provides perl(JSON::XS) needed by centreon-plugin-Operatingsystems-Linux-Local-20230215-164619.el8.noarch

 

I did some research online and found a solution by lauching the following code prior to the task install requirements:

dnf -y module reset perl

dnf -y module enable perl:5.30

 

But i still got some errors as follows:

Modular dependency problems:

 

Problem 1: module perl:5.26:820181219174508:9edba152.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8030020200609055348:8af31532.x86_64

- module perl:5.30:8030020200609055348:8af31532.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:820181219174508:9edba152.x86_64

- module freeradius:3.0:20190512205742:fbe42456.x86_64 requires module(perl:5.26), but none of the providers can be installed

- conflicting requests

 

Problem 2: module perl:5.26:820181219174508:9edba152.x86_64 conflicts with module(perl:5.30) provided by perl:5.30:8040020200923213406:466ea64f.x86_64

- module perl:5.30:8040020200923213406:466ea64f.x86_64 conflicts with module(perl:5.26) provided by perl:5.26:820181219174508:9edba152.x86_64

- module freeradius:3.0:8000020190425181943:75ec4169.x86_64 requires module(perl:5.26), but none of the providers can be installed

- conflicting requests

 

Does anyone has a clue? Thanks you !


0 replies

Be the first to reply!

Reply