Solved

New OVA deployment failing partitioning step

  • 15 September 2022
  • 3 replies
  • 33 views

Badge +1

I followed this guide (even started fresh just to be sure) https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-virtual-machines/ and when I get to the step to run the centreon-partioning.php I receive this error message:

 

This is a brand new OVA deployment with zero customization done. I manually tried running the centstorage-purge.php script from the cron.d folder and it cleared several partitions but this error persists. Next I logged into MySQL via mysql -u root and tried dropping the partition manually, see here:

You’ll see now the partition in question has incremented down by 1 digit, I incremented downward until the error changed here

But unfortunately I’m back to square one here same error as previous

Is this a known issue with the latest OVA on the download page?

icon

Best answer by dfite 15 September 2022, 23:11

View original

3 replies

Badge +1

Actually I think I just stumbled onto a solution, at least one that appears to work in the short term. I went into Centreon’s Administration > Parameters > Options and screenshotted all of the retention settings listed then set them all to 1 day and saved.

 

Next I manually ran the cronjob for purge and it scrubbed a bunch of partitions it previously didn’t get rid of. Then I reset the settings back to their defaults (from my screenshot) and ran a purge again, then ran the partitioning script and it completed successfully!

Badge +10

🥳

Userlevel 5
Badge +12

@dfite which version of OVA did you use? “CentOS7 VMWare (OVA)” or “Alma8 VMWare (OVA)”?

Regards

Reply