Question

Problem during installation of centreon 23.10 on Rhel 8

  • 1 March 2024
  • 2 replies
  • 57 views

Badge +2

After Created my Centreon 23.10 repository on my Redhat Satellite

I have launched on my Rhel 8 Server the command : dnf install centreon on the Central Server

But i’m block with some unavailable paquets.

Do you know where coudl be my issue ?

Problem: package centreon-23.10.9-1.el8.noarch requires centreon-central = 23.10.9-1.el8, but none of the providers can be installed
  - package centreon-central-23.10.9-1.el8.noarch requires centreon-poller = 23.10.9-1.el8, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.0-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.0-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.1-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.1-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.2-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.2-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.3-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.3-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.4-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.4-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.5-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.5-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.6-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.6-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.7-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.7-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.8-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.8-1.el8.noarch
  - nothing provides nagios-plugins-icmp >= 2.0.0 needed by centreon-poller-23.10.9-1.el8.noarch
  - nothing provides nagios-plugins-dhcp >= 2.0.0 needed by centreon-poller-23.10.9-1.el8.noarch


2 replies

Badge +2

The context was to download all needed package in a Redhat Satellite repository

and the Issue was with Redhat Satellite repository misconfiguration

One more thing : Take care with this ligne in the .repo : module_hotfixes=1

This line was missing after the creation of my repository

Badge +1

Same problem with Rocky Linux 9 and Centreon 23.10…

 

 

Do you know the solution?

Reply