Solved

speedtest plugins broken ?

  • 6 December 2022
  • 13 replies
  • 5509 views

Userlevel 1
Badge +4

Hello, I am creating this request because I have a problem with the speedtest plugin, I always get the same error: "UNKNOWN: Command error: ERROR: Unable to connect to servers to test latency."

Is the plugin still maintained ?

 

if the plugin uses speedtest-cli, I think it's because of that because speedtest-cli doesn't work anymore either

 

 

Kélian

icon

Best answer by Laurent 7 December 2022, 14:48

View original

13 replies

Userlevel 6
Badge +19

Hi @Kélian,

maybe it was outage issue because I tested this morning and it’s work:

[root@ip-10-25-9-17 ~]# /usr/lib/centreon/plugins/centreon_monitoring_speedtest.pl --plugin=apps::monitoring::speedtest::plugin --mode=internet-bandwidth
OK: speedtest ping time: 11 ms, download: 724.29 Mb/s, upload: 837.38 Mb/s | 'ping.time.milliseconds'=11.883ms;;;0; 'internet.bandwidth.download.bitspersecond'=724293667b/s;;;0; 'internet.bandwidth.upload.bitspersecond'=837380308b/s;;;0;
[root@ip-10-25-9-17 ~]# date
Tue Dec 6 08:42:53 UTC 2022

 

Userlevel 1
Badge +4

can you try the command speedtest-cli pls ? 

Userlevel 6
Badge +19

And now I have an error:

# speedtest-cli --list
Retrieving speedtest.net configuration...
Cannot retrieve speedtest configuration
ERROR: HTTP Error 403: Forbidden

# /usr/lib/centreon/plugins/centreon_monitoring_speedtest.pl --plugin=apps::monitoring::speedtest::plugin --mode=internet-bandwidth
UNKNOWN: Command error: Cannot retrieve speedtest configuration - ERROR: HTTP Error 403: Forbidden

It looks like a speedtest.net issue

Userlevel 1
Badge +4

i don’t have the same error 

 

Userlevel 6
Badge +19

Do you have a proxy on your server to access to Internet?

Userlevel 1
Badge +4

no, i have a reverse proxy but simple proxy no

 

i’ve tried on a aws vps, and i have the same error

Userlevel 1
Badge +4

I think the plugin is simply not up to date, I tried to modify the .pl by removing speedtest-cli (old speedtest.net cli) by "speedtest" and I have now a new error which makes sense because the plugin is not adapted for this new command

 

Kélian

Userlevel 6
Badge +19

You right speedtest-cli must be replaced by speedtest

Userlevel 1
Badge +4

Yes, and the centreon plugin is not up to date.

Userlevel 1
Badge +7

same issue, anyone solved it?

Badge +3

It’s more a speedtest issue: https://github.com/sivel/speedtest-cli/pull/788

It’s not a centreon-plugins problem (with speedtest we have the same error).

Userlevel 1
Badge +4

Hello,

@qgarnier 

i have no error with the speedtest command : 

 

Kélian

Badge +3

The URL to get server list have changed: https://github.com/sivel/speedtest-cli/pull/796

But not it’s not commited. The plugin will use the official version: https://github.com/centreon/centreon-plugins/pull/4563

Reply