Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello, I have installed a new version of Centreon 21.10.5 on an Oracle linux 8.5 server. I can't install the MongoDB plugin, I have a perl dependency error. dnf install centreon-plugin-Applications-Databases-MongodbDernière vérification de l’expiration des métadonnées effectuée il y a 2:06:10 le mer. 23 mars 2022 14:53:29 CET.Erreur : Problème: installation impossible du meilleur candidat pour la tâche - rien de fournit perl(Hash::Ordered) rendu nécessaire par centreon-plugin-Applications-Databases-Mongodb-20220113-084434.el8.noarch(essayez d’ajouter « --skip-broken » pour ignorer les paquets non installables ou « --nobest » pour ne pas utiliser seulement les meilleurs paquets candidats)I followed the installation procedure, did I forget something or is it from the oracle linux distribution ?If someone has an idea, thanks
Hello,we prepare monitoring our VMWARE infrastructure .This one is very large . almost 40 Vcenters with 1500 ESX .I would like to know if our connector will survive and if you have some stress test data in return.. By the way, is there a possibility to load-balance on connectors ? Sébastien
I don’t undeerstand in the documentation how to add a remote server in a dmz.The remote server can connect to internet but is not accessible from.When I use registerServerTopology.sh on the remote server, I have a 500 error.In the log on the central, the error is “no route to host”.Am I clear ?
Bonjour,J’ai créé plusieurs hotes win srv 2019 avec le plugin check-host-snmp-custom, ca check bien en CLI.J’ai donc deployé les services puis exporter la conf dans le collecteur avec aucune erreurs ( juste de warning sur les intervalles de notifications). Hors je ne retrouve pas mes hôtes ni services dans le status des ressources ni dans les rapports. J’ai vérifié le status des services suivant :systemctl status gorgonedsystemctl status cbdMême procédé a un restart sans que cela résolve le problème !A noté que c’est une nouvelle installation et a jours Si vous avez une petite idée je vous en remercie.
Bonjour, J’essai de mettre un place un check via prometheus en mode expression est lors de la requête j’ai une erreur “UNKNOWN: No expressions found.”Pouvez vous m’aider car si je passe la query directement sur Prometheus elle fonctionne pas avec le plugin Centreon.Ci joint ma requete. /usr/lib/centreon/plugins//centreon_prometheus_api.pl --plugin=cloud::prometheus::restapi::plugin --mode=expression --proto='http' --hostname=IP_serv --url-path='/api/v1' --port='9091' --query='utilization,rate(container_cpu_usage_seconds_total{container!~"POD"}[5m])*100' --query='throttled,rate(container_cpu_cfs_throttled_seconds_total{container!~"POD"}[5m])*100' --instance='x.x.x.x:8080' --output='Node %{instance} Average (Last 5min): %{utilization}%, Throttled(Last 5min): %{throttled}%' --multiple-output='All CPU metrics are OK' --verbose --use-new-perfdata
Hello everyone,I have a problem with two supervised servers which often have a fairly high load.It seems that when the server works a lot I lose SNMP returns which puts all of my services in UNKNOWN state (which is quite painful because the ghost notifications follow one another without much relevance).Do you have any idea what could be done to prevent this?
Hello,I would like to know if there is a configuration available that can enable the admin of a Centreon Server, or a module developer to add new items to the “More actions...” drop down list, the interface : Monitoring > Status Details > Services | Hosts.
Hello,I would like to open a new ticket concerning problems I am having with Centreon NSClient on Windows Server 2016.Old topic : I think that the resolution of the problem last time was a stroke of luck … Always the same mistake: “CHECK_NRPE STATE CRITICAL: Socket timeout after 10 seconds.”Has anyone had this problem recently? Here are the logs: 2022-03-14 10:19:21: error:c:\source\0.5.2\include\socket/connection.hpp:168: Failed to read data: short read2022-03-14 10:21:34: error:c:\source\0.5.2\include\socket/connection.hpp:168: Failed to read data: L’opération d’entrée/sortie a été abandonnée en raison de l’arrêt d’un thread ou à la demande d’une application2022-03-14 10:22:58: error:c:\source\0.5.2\include\socket/connection.hpp:168: Failed to read data: End of file2022-03-14 10:24:58: error:c:\source\0.5.2\include\socket/connection.hpp:168: Failed to read data: End of file2022-03-14 10:26:34: error:c:\source\0.5.2\include\socket/connection.hpp:168: Failed to read d
We have configured the centreon for monitoring and it is not sending notification multiple times. How to fix this .
Hello the community !I’ve learned how to use CLAPI commands to make a massive import of hosts, withe following line :centreon -u [username] -p [password] -i ImportHost.csvImportHost.csv is created with the following format :HOST;ADD;Device;Alias;IP;Template(s);Poller;HostGroup Now, I’d like to remove massively devices from a hostGroup. The CLAPI is given below :centreon -u [username] -p [password] -o HG -a delmember -v "HostGroup;Device" Do you know the way to create a file with the list of devices to remove from the hostGroup, in order to execute the action with a unique command ?(something like centreon -u [username] -p [password] -i DeviceToRemoveFromTheHostGroup.csv)Thanks,Pierre
Hello,I would like to monitor several Windows hosts with Centreon. I would like to do this monitoring via an NRPE agent. I followed the "https://docs.centreon.com/21.10/fr/integrations/plugin-packs/procedures/operatingsystems-windows-nsclient-05-nrpe.html" doc.Unfortunately, I'm stuck. Indeed, I can't install the "check_centreon_nrpe" on my Centreon server. I can't install the "centreon-pack-operatingsystems-windows-nsclient-05-nrpe". I have a message that the packages could not be foundMy Centreon was installed via the official ISO and no source modifications were made.Could you help me?Thanks in advance for your answers !
Hello,I need some help after the crash of my centreon monitoring that stop working after a disk full on the central poller.After this crash, I found that the poller server was working with the date set to 2043 instead of 2022.I have correct the date and sync the 2 servers with a ntp server.But now, during the restart of the poller (systemctl restart centreon.service), I have this error in the log (/var/log/centreon-broker/central-broker-master.log) : [1646820491] error: failover: 'connection-to-CENTREON.POLLER' cannot connect endpoint.Centreon Broker 20.04.17 log file closedCentreon Broker 20.04.17 log file opened[1646820551] error: conflict_manager: error in the main loop: could not prepare update query for event 'host_check' on table 'hosts': could not update poller: Out of range value for column 'last_alive' at row 1[1646820552] error: failover: 'connection-to-CENTREON.POLLER' cannot connect endpoint.[1646820555] error: failover: 'connection-to-CENTREON.POLLER' cannot conne
Is it possible to change the default graph period view globally, per host or service? I have some services that produce pretty steady graphs and a weekly view would be more helpful than a daily view.
Hi everyone. I have a very strange behavior here…I installed Centreon with database using the ISO (latest). Everythning is up to date and monitoring works.After, I need to change the IP of the poller and move the server from a network to another (which has no internet access).Since that, every time a want to change the page (switch from Host configuration page to Services configuration page for instance), the web sever takes at least up to 7 seconds to print the page.I thought about a Mariadb problem, turn on the slow_query debug, nothing found. Does anyone have an idea about that ?? Thanks a lot !
Hi,I Try to understand how work the reaload of a poller when i add an host from the API.Because my poller does not reload when i do it. There is a command ? Thanks.
Ever since I migrated to 21.10.4 when press enter in search column at “monitoring > Status Details > Service grid”, I am getting page duplicated inside the page itself.Also I don't get to show the “Services” or “Host” in “monitoring > Status Details >” and My account page under Administration > Parameters > My Account is showing blank for me. Is this issue with my installation or issue with this particular version.?Anybody know how to fix this issues ? any way to repair entire Centreon web ?
upgraded from 2.8.32 to 21.10 and notification not working.Host timeline showing as alerted user, but mail is not receiving for alerts.Relayhost is already set and test echo email is working fine. No traces of notification mail in /var/log/maillog apart from test email. Any ideas how to trace the issue ?
Hi guys, I used Centreon for a long time to monitor firewalls and servers, but it's been five years since I last used it and now I'm setting up an instance at home to monitor my media server. I still remember most of the things, but I used to create my own commands and generating graphs for anything I needed, but I can't remember the output pattern that allows Centreon to understand the exit code as well as the values to be used in the graphs.I learned a lot from the old forum which we cant access anymore (access denied 401). I don't know why they did that, but anyway.The things I remember are:I have to use exit codes 1,2,3 and to plot graphs I need something like tag=$value;min,max, but I cant remember or find the correct syntax. Can someone help me with that?Today I just want to `ls -1 | wc -l`, and generate a graph from the output of this command. As simple as that.Thanks
I need help i just installed Centreon on the Centos7 and everything is fine I am able to access to the login interface but as soon as I installed phpMyAdmin on the same server Centreon no longer opens "http://192.168.150.134/centreon"The requested URL /centreon/index.php was not found on this server.but " http://192.168.150.134/phpmyadmin" works ,I want both to work at the same time to see my database at the same time.
Hello Community, I need to do a report on Uptime from all of my servers (windows or Linux).I have the service that give me the uptime of all of my servers configured.they are all in state OK because I didn’t create warning or critical limits. I only have a “time”.But I don’t find the adequate report to have all these data reported.I just need a report with host and uptime. I think the issue is all events are in OK state. Could you help me? Laurent
Hi all, We recently got an Azure MSSQL instance, and need to monitor it, but unfortunately it isn’t as smooth right now as “on-premise” MSSQL instances:Wether I’m using the user@server that usually Azure instances require or not:/usr/lib/centreon/plugins//centreon_mssql.pl --plugin database::mssql::plugin --hostname 'XXXXXXX.database.windows.net' --username 'Centreon@XXXXXXX.database.windows.net' --password 'XXXXXXX' --mode='connection-time' --warning=1000 --critical=5000CRITICAL: Cannot connect: OpenClient message: LAYER = (0) ORIGIN = (0) SEVERITY = (78) NUMBER = (44)Server , databaseMessage String: Server name not found in configuration files.OpenClient message: LAYER = (0) ORIGIN = (0) SEVERITY = (78) NUMBER = (45)Server , databaseMessage String: Unknown host machine name.OpenClient message: LAYER = (0) ORIGIN = (0) SEVERITY = (78) NUMBER = (41)Server , databaseMessage String: Unable to connect: Adaptive Server is unavailable or does not exist | The host exists and can be resolved
Bonjour, Dans broker , j’ai le message suivant qui apparait: [error] mysql_connection: could not store logs correctly: Incorrect string value: '\xCE\xBCs' for column `centreon_storage`.`logs`.`output` at row 3517 Cela coupe la lecture de broker et donc rend l’application indisponible. Quelqu’un a déjà vu ce cas/trouvé une solution? Cordialement,Francis DOUNGA
Hello, As I said in my previous questions, i had to upgrade my Centreon 2.8.32 to the latest version.I’m following the official documention, https://docs.centreon.com/current/fr/upgrade/upgrade-from-3-4.html, but I’m stuck at the :yum update centreon\* part.I did the previous step with no errors.(log is in french sorry)Here it what display at the end of the command : --> Résolution des dépendances terminéeErreur : Paquet : centreon-lang-fr_FR-2.8.32-1.el7.centos.noarch (@centreon-stable-noarch) Requiert : centreon-web = 2.8.32-1.el7.centos Suppression : centreon-web-2.8.32-1.el7.centos.noarch (@centreon-stable-noarch) centreon-web = 2.8.32-1.el7.centos Mis à jour par : centreon-web-21.10.2-4.el7.centos.noarch (centreon-stable-noarch) centreon-web = 21.10.2-4.el7.centos Disponible : centreon-web-21.10.0-2.el7.centos.noarch (centreon-stable-noarch) centreon-web = 21.10.0-2.el7.centos
J’ai installé la version 21.10.15 de centreon et par la suite j’ai procédé à une mise à jour des plugins vu qu’il y avait pas dans la plate forme comme l’indique le tutoriel en ligne. Seulement après l’éxécution de la commande se trouvant dans le tutoriel, j’ai constaté que j’étais passé à la version 21.10.3 et en plus en introduisant mes paramètres de connexion de départ sur le formulaire d’authentification, le système me génère le message “Internal server error”.Que faire SVP?
Hi,Can i set or write an OID with centreon?For example, every 15 minutes set an oid to 1 from 0. (Push button via web). Thanks for your reply.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.