Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,The service ‘Partitioning’ on my server goes critical.Result of /usr/share/centreon-bi/etl/centreonbiMonitoring.pl --db-content[mod_bi_metriccentilemonthlyvalue: 2023-07-01 00:00:00] [mod_bi_metriccentileweeklyvalue: 2023-07-17 00:00:00]database view from centreon-web:command i try :nohup /usr/share/centreon-bi/etl/dimensionsBuilder.pl -d > /var/log/centreon-bi/rebuild_dimensions.log &2023-10-10 14:42:17 - INFO - Getting servicecategories properties from Centreon database2023-10-10 14:42:17 - INFO - Updating servicecategories dimension in Centstorage2023-10-10 14:42:17 - INFO - Getting service properties from Centreon database2023-10-10 14:42:17 - INFO - Updating service dimension in Centstorage2023-10-10 14:42:17 - INFO - Updating metric dimension in Centstorage2023-10-10 14:42:17 - INFO - Updating liveservice dimension in Centstorage2023-10-10 14:42:17 - INFO - Updating centile properties2023-10-10 14:42:17 - INFO - Send ACL synchronization signal to CBIS2023-10-10 14:42:17
Hello [root@ip-10-0-12-126 ~]# centreon -u dummy -p 'vuYAQ#9gr!5u5xx' -o HOST -a applytpl -v "REVERSE-PROXY-2"Return code end :But if I click the “ Create Service linked to the template too” on the GUI , its works. I didnt had any issues with any other clapi command, seems strange this one fails. Also, the hostname is 100% correct, because rest of clapi commands are working fine. Any workaround ? I wouldnt want to downgrade centreon version just for this. Centreon v.24.10.3
Hi, we are trying to monitor a vsan-cluster-usage through the centreon_vmware_connector_client.pl plugin. To do this, we have copied the files VIM25VsanmgmtStub.pm and VIM25VsanmgmtRuntime.pm into the same folder where the VIM25Runtime.pm file is located. This has worked for us so far in Centos 7 but when migrating to Debian 11 we get the errorUNKNOWN: Vsan is not enabled in vmware connector.We don't see any difference but it doesn't work correctly.Any ideas? Thanks
Bonjour, In the host panel, there is a radio switch “ Create Service linked to the template too”.Is it possible to activate it with the rest API? With the REST API, i am creating new hosts from template.But the new hosts don t have services linked to the template.Is it possible to add these services linked to the template with the rest API? Thanks for the future answer,Mathias
Bonjour/Hi,Est-ce que des gens ont expérimenté ou utilisent un poller distant chez AWS (ou plus largement dans le cloud) et auraient des retours d’expérience à partager ? (Poller distant chez AWS, serveur central en local)Does any people tested or use a distant poller hosted at AWS (or another cloud provider) and would have some user experience to share? (Distant poller in the cloud, central server on-premise)Bonne journée/Have a nice day.
Hello guys,Since few weeks, i need to restart my vm centreon 22.04 (centos 7) every 2 or 3 days.all check stop and the next check is in the past.I don’t know what to check or verify in such case. Here is an exemple of what i mean:
Hello everyone,Since upgrading to 24.04.7, I have a problem with ACL management.My non-admin users no longer see the service groups in the detailed services or in the custom views.If I set my user as administrator, I can see the service groups. I've looked at the acl management and resource access is set to all.For testing purposes, I gave my user full rights (he has access to all) but the list of group services remains empty. I've checked that my user is in the right rights group. When I want to reload the ACLs, I get an error message. Thanks for your help
Hello,I have an issue regarding ACL. I wanted to restrict the ressource view to some users.For information I run a fresh 24.04.07 centreon installation made on a debian 12.Here what I’ve done (following the documentation) :Creation of a “Ressource Access” ACL On tab “Hosts resources” I’ve checked only the host I wanted to display and leave everything by default On tab “Services Resources” I’ve checked “Include all servicegroups” I leave the others tab as default Creation of a “Menu access” ACL I only checked “Home”, “Monitoring” and “Reporting” Creation of a “Action Access” ACL I duplicated the existing “Simple User” ACL and removed some actions like Enable/Disable Notification … I just wanted the users to have a display access. Finally I created an “Access Group” linked with a test user and in the “Authorizations information” tab I selected the 3 ACL I just created.When I log on with my user display limitation are OK but I don’t see any hosts or services.I tried a lot of different
Hello, the result of a curl command is the following (data have been modified).curl -X GET -H "Accept: application/json" -H "Authorization: Bearer 1234" "https://toto.com"[{"id":"abcd","name":"theName"}] The plugin is executed./usr/lib/centreon/plugins//centreon_protocol_http.pl --plugin=apps::protocols::http::plugin --mode=json-content --hostname=toto.com --urlpath='/' --header='Authorization: Bearer 1234' --data='' --lookup='' --threshold-value='' --format-ok='' --format-warning='' --format-critical='' --warning-numeric='' --critical-numeric='' --warning-string='' --critical-string='' --port='443' --proto='https' --filter-perfdata=''OK:My concern is how to use --lookup and --format-ok options to display ‘theName’.Does some experience this kind of challenge ?
Hi!I have a Central with some Remote Servers and I need send notifications via email from all Remote Servers. I’ve configure my SNMP Server and is working correctly. I’m testing with host and services indexed on Centreon Central but is not possible send this notification from Remotes.I can’t configure SNMP on remote pollers because is not possible connect to internet. Has anyone had this problem? Has it been able to be solved? BR!
Hello,Since updating to 24.10 (via packages on Debian 12), some of my graphs are in negative.The values received are in positive.It includes CPU, Memory, Storage and some other counters.RAM DiskCounter When you display them in the performance page, they are in positive : I tried deleting and rebuilding graphs to no success.The graphs templates and curves are still the default ones I think. Here is the default curve :CPU curves, Memory, etc are similar (invert is never ticked). I tried ticking invert : Does anyone have any idea ?Thanks !
I need to know if it is possible to specify the certificate which will be monitored for expiration.I have a scenario where I have a software which installs its own certificate in the certificate store where my CA certificate is installed.Now I have the problem that only the certfiicate of the software is monitored and not the one from my CA.Can I specify the Issuer somehow or is there another way to monitor both certificates? And another question I have is, if the X509 certificate Plugin can also monitor the CA Certificate of a Domain Controller. I am asking this because all of my DCs give me an IP Configuration SSL Socket Error when I try to add the X509 Template to the host. UNKNOWN: Error creating SSL socket: Connection timed out, SSL error: IO::Socket::IP configuration failedOther servers with just “normal” CA certificates are monitored just fine. There are no relevant differences in the firewall configuration between DCs and “normal” servers.
Hello,With Cenreon web 23.10.20, all the eventl ogs are available to any user in :“Monitoring > Event Logs"So everyone can see the host/service/ouput of everything, bypassing the ACLs.
Hello,I’ve been asked to know if it is possible to monitor the result of a command like “show ip route” on a CISCO router.Do you know if Centreon is able to do it ? Or perhaps with ntopng ?Thank you for your help,
Hi,I am using alma 9- 24.04.5 for poller.my poller is not generating broker log and also centengine.log only showing [core] [info] poller with ‘’ id 0 connected.On central poller. I checked central-broker-master.log and it showing error as follows:-[tcp] [error] TCP: connection refused to poller_IP:5669 [processing][error] failover connection-to-poller-name: global error: failover: connection-to-poller-name cannot Connect endpoint.What might be the issue?
Hello, I’m running Centreon 24.04.5 and when I try to install Generic SNMP monitoring connector, nothing happens. The other connectors are installed without a problem. I don’t know how to troubleshoot this problem. I sometimes have the following error message in the UI when trying to install connector : “Gateway timeout : The gateway did not receive a timely response from the upstream server or application”. When I try to browse to https://api.imp.centreon.com/api/pluginpack/pluginpack/applications-protocol-snmp , I get the following error : Endpoint not found. Could anybody help me please?
Bonjour, avant de mettre a jour ma plateforme centreon 23.04.23 > 24.10je veux upgrader le PHP en 8.2cependant j'ai plusieurs conflits qui apparaissent et je voudrai savoir comment les resoudre.ci-dessous toutes les infos. Merci d'avance [root@CES-APP-01 php.d]# php -vPHP 8.1.31 (cli) (built: Nov 19 2024 15:24:51) (NTS gcc x86_64)Copyright (c) The PHP GroupZend Engine v4.1.31, Copyright (c) Zend Technologies with the ionCube PHP Loader v14.0.0, Copyright (c) 2002-2024, by ionCube Ltd. with Zend OPcache v8.1.31, Copyright (c), by Zend Technologies with SourceGuardian v13.0.3, Copyright (c) 2000-2022, by SourceGuardian Ltd.[root@CES-APP-01 php.d]# dnf module list phpMise à jour des référentiels de gestion des abonnements.Dernière vérification de l’expiration des métadonnées effectuée il y a 1:46:57 le lun. 23 déc. 2024 01:29:42 EST.Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)Name Stream Profiles
Hi, I configured the SSH Plugin to make some checks on my remote servers using Shell scripts.All is working fine on all server. But yesterday one of my remote servers occured an issue with My centreon: Centreon-engine don’t connect to the remote server using the private key since yesterday ! I haven't changed anything on my config... SSH connections to my remote server from another server is working fine. When I reboot Centreon Server, SSH works again for Centreon-engine for a few time and then it’ stops working...
Big problem, Centreon say your system is up to date ?be careful it can be wrong ...So your system is unsafe…. here is the example:/usr/lib64/nagios/plugins/check_centreon_nrpe3 -H RDSH02 -p 5666 -t 420 -u -2 -P 8192 -c check_centreon_plugins -a 'os::windows::local::plugin' 'updates' ' --filter-title="" --exclude-title="Microsoft Defender Antivirus" --filter-mandatory="yes" --warning-pending-updates="0" --critical-pending-updates="2" --exclude-title="KB5023049" --verbose --display-updates --source-encoding=ISO-8859-1 'OK: windows pending updates: 0 | 'windows.pending.updates.count'=0;0:0;0:2;0;
Hello,After creating a Host-monitoring type widget, it seems that the “Order By” function doesn’t work.Be it with the IP address, duration...etc..Whatever the parameter I chose, weither it’s by ascending or descending order, the order of the Hosts that are displayed never changes.The function works fine with services though.Does anyone encountered this issue ? Can anyone help, please ?Thank you in advance for your kind help and advices.
I’m trying to use the IBM MQ MQI plugin. When I run the command to check the queue-manager on the poller by hand, it returns the expected output. When I do the same thing with the ‘centreon-engine’ user, I’m greeted by sudo’s prompt for a password.Is this known behaviour? What sudo privs are needed for the command to work?
Bonjour tout le monde,est-ce que je peux mettre un cron qui lance une action de purge de ce dossier de manière hebdomadaire ? sinon est-ce qu’il ya une modification spécifique au niveau du fichier /etc/centreon/centreontrapd.pm pour configurer la purge automatique de ces files ?
Hello,On my Centreon, I would like to keep the "ping" check command, but I also want to add alerts for disk storage at 80% and 90%. I’ve tried using custom macros, but I don't fully understand how to set them up.Thank you in advance for your help.
Hihow to free space from /dev/mapper/vg_root-root ? [root@central ~]# df -hSys. de fichiers Taille Utilisé Dispo Uti% Monté surdevtmpfs 3,8G 0 3,8G 0% /devtmpfs 3,8G 0 3,8G 0% /dev/shmtmpfs 3,8G 368M 3,4G 10% /runtmpfs 3,8G 0 3,8G 0% /sys/fs/cgroup/dev/mapper/vg_root-root 20G 20G 283M 99% //dev/mapper/vg_data-var_cache_centreon_backup 10G 104M 9,9G 2% /var/cache/centreon/backup/dev/mapper/vg_data-var_lib_centreon--engine 5,0G 68M 5,0G 2% /var/lib/centreon-engine/dev/mapper/vg_data-var_lib_centreon--broker 25G 337M 25G 2% /var/lib/centreon-broker/dev/mapper/vg_data-var_lib_centreon 169G 12G 158G 7% /var/lib/centreon/dev/mapper/vg_data-var_lib_mysql 538G 38G 501G 7%
Bonjour,Le module MAP qui fonctionnait en version 22.10 n’est plus fonctionnel en 24.10.Le service est bien démarré mais il n’écoute pas sur le port 9443. J’ai ouvert un ticket chez Centreon mais toujours pas de solution. cordialement, Laurent.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.