Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,How can we use the “scenario” mode with SFTP plugin?I don’t have found any manual for using this mode. I saw that we can input a json file, but same question as before, where can i found a man page for creating this file. We have a FTP/SFTP server and would like to do a GET command in the same way as we do with the FTP plugin.Thanks a lotCiao ciaostefano
Hello,I am developing a plugin to retrieve the information provided by openitCockpit.I started with a plugin allowing me to retrieve the load percentage of each processor.From the command line, it works correctly but from the web interface, I get an error (Execute command failed).When I copy the command from the interface to the terminal, it works, so the command is good.I added the plugin path (/usr/lib/nagios/plugins/centreon-plugins/src) to the white list in the file /etc/centreon-gorgone/config.d/whitelist.conf.d/custom.yaml as follows: - ^/usr/lib/nagios/plugins/centreon-plugins/src/.*$I can't find anything in the logs and I don't know what else to do to make it work.Centreon is running on a Debian Bullseye and is on version 24.04.4
OK sorry. I'm having a problem monitoring a Fortinet firewall with centreon. I get following error:(Execute command failed). Could you help me?
Hello, I’m trying to input My ASUSTOR NAS in my centreon supervision.I found OID’s and extract it with an utility software.Now, i would like to create my different commands (storage etc...) in centreon, like for my ups’s but it’s not exactly the same I guess. I don’t know very well what argument i have to put etc... I precise that i’ve not the associated connector, so i would like to create it from start to end. My host is created, my service too, but i would like to bind it with my commands.I hope i’ve been as clear as possible, i’m an “advanced” beginner in centreon, snmp etc….So some things are trouble for me actually. It would be helpful to have an answer.I’m french so you can answer in french.Thanx a lot for help. here is the capture of my command.
Hello AllI want to monitor separately different processes running as services in windows with centreon, those processes runs all with the same executable.How can i acheive this? Thank you
Hello,i have already a free licence, now i’m currently trying to build a test environment with 3 serveurs, i have tried many times to sync all servers, i mean get all checks on one screen, i have read some topics but i can get the pollers check on the central server, please have got any topics to help ?Regards
Bonjour, j’ai un soucis sur les tableaux de bord.En effet, j’ai réinstallé une debian 12 avec centreon 24.10.1. J’ai juste créé 15 Hosts avec 2 services chacun.Quand j’affiche dans le tableau de bord, cela reste bloqué à 10 hosts et j’ai le double de services (60). par contre quand je clique dessus, j’ai bien le bon nombre dans le statut des ressources. Comment résoudre ce bug ? merci
Hello,After upgrade to 24.10, when i click on time line got error message.“The HTTP status code “42” is not valid.” affected on whole system.
HiSince upgrade from 24.04.5 to 24.04.7 the export shortcut does not work and tell me:There was an consistency error in the exported files - please use the legacy export menu to troubleshoot When I use legacy menu no error. If I us default admin account export shortcut work like a charm. I'll try upgrade to 24.10 as my setup is quiet new, same bug. Only error in log file :[2024-11-06T16:18:06+0100] [ERROR] [Centreon\Application\Controller\Configuration\MonitoringServerController:233]: Generation error on monitoring server #3: Authentication token expired Thank you for helping
Hello,I have a trap definition where Status is defined in Advanced matching rules (OK/CRITICAL) according a regx of trap varbind content.I would like to reuse this status in the output message I have to rework, but not able to find a way, @status@ works only for external command and status is not defined anywhere in trap varbinds.Thx for your help
bonjour je suis en train de faire la migration de centreon 19.10 vers la version la plus récente 24.10 mais j’ai cette erreur en cours de migration
Hello everyone,I am using Centreon and ArubaOS-CX to retrieve information from my Aruba Instant On 1960 switch (CPU, Memory, Network Interfaces, etc.).However, when I try to use it, the service status shows as "(Execute command failed)".Has anyone encountered this issue before and found a solution?
Hello! I had installed Centreon 24.04.7 on Debian 12.However, it will prompt for internal server error and something went wrong in UI Login. I did further inspect the page; I am quite new with Centreon, any help will be really appreaciated. Thanks!
Hello, Maybe someone can help me.I try to create reports using MBI.My reports are ok with pdf or xlsx extension BUT… When I try to export in csv, report file is empty, no data inside. Can someone say me why and how to create csv exports? regards, Laurent
Good morning,I don't understand why when I query an OID with the plugin, it doesn't go critical as requested.Am I doing it wrong? the format is not correct?If anyone can guide me please :)it's always OKThank you in advance for your help,Sincerely
Hello guys !When I launch my centreon-map-engine, the service is started, but the port isn't even listening on either 8081 or 9443, even though I've followed the procedure for switching to HTTPS.My MAP is installed on a remote server, and my central server is in HTTPS:Here's the result of the diagnostic.sh: ########## Centreon Map server version ########## [INFO] centreon-map-engine-23.10.14-1.el9.noarch########## System ########## [OK] SELinux is disabled [OK] Firewall is disabled [INFO] Physical memory on the server: 9889424 kb. [INFO] Number of CPU on the server: 2 core(s)########## Java ########## [OK] Java 17 is available [OK] Optimization found for JVM: JAVA_OPTS="-Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/log/centreon-map -Dcentreon-map.signing-key=JsiHiMhJkx9ihkQjKh7TA6KK8UpxNqpAvzY5oXlMxGNZqQqpcUF3NLmfxX4ydHYHu -Dcentreon-map.access-token-validity-seconds=15552000 -Xms512m -Xmx4G"########## Database connection #########
Hello everyone,I’ve been testing Centreon with the IT-100 license and am trying to manage my Aruba Instant On 1960 switch. However, I’m encountering some issues. Specifically, I’m unable to retrieve any information from the switch.The switch is connected, and the ping works fine. However, when I try to retrieve the CPU usage, my new service called "Aruba1_cpu" uses the “Net-aruba-Instant-Ap-Usage-SNMP” model, but the status shows:"OK: total access points: 0."Could anyone help me understand why this is happening and how I can resolve it?
Hello,I need help with centreon_storage database partitioning.After Centreon update from 21.10.15 to 22.10.25 table logs has been corrupted, and i cant select any data from that table. I also cant delete that table (same message occurs). Here is table files list: Did You have any solution for that problem?
I am trying to monitor the service running under systemd on my RHEL 9 and Ubuntu 22.04 servers but I cannot make it work.I did install nrpe4 on the client machine and I am able to launch some commands from the centreon poller.However, I cannot find the check commands for systemd :-( Thank you.Regards.
Hello,I am having some trouble finding a solution to following issue.When using the Net-Aruba-Instant-SNMPv3 template to check AP-usage, I get this result: There are 55 AP’s in this controller but it seems he is not able to retrieve this.I can use this with other Aruba controllers but not this one: Any help would really be appreciated!
"What is the name to select in the Centreon menu to find the different plugins?
Himy actual plaform is the centreon 2.8.19i’m working on the new version centreon 22.10. in the new version, there is no option to disable check or notification in the ressources view. my supervisors (n2 or n1) use this options frequently. Is it a new regular usual of the new centreon version? is there an option to reactivate there ?Davud
Hello !During update from 23.10 to 24.04.7 we faced to some issues (that we do not have on preprod env...)here is some of them and how we solved them (if it may help others users !) : FYI : We are running the Central on Debian 11 with a deported dedicated MariaDB.Just after upgrade => We had to edit /usr/share/centreon/www/class/centreonDB.class.php and then comment the line with the call to function “logSqlError” Then we faced to a second error :“UPGRADE - 24.04.0: Unable to add column is_internal to table widget_models”=> On DB Centreon it has been fixed with : “alter table widget_models ROW_FORMAT=DYNAMIC;” And Last : we got an error on installCoreWidgets (probably due to multiple refresh due to the errors) on “install Core Widgets” solved by commenting //$installCoreWidgets(); in file /usr/share/centreon/www/install/php/Update-24.04.0.php If it may help some other user !Regards
Hello,I migrated centreon from centos 7 to debian 11, following https://docs.centreon.com/docs/migrate/migrate-from-el-to-debian/I'm trying to migrate a poller:I installed centreon-poller, I synchronized the plugins,I had the error on the fingerprint which I also corrected by following https://thewatch.centreon.com/troubleshooting-41/poller-does-not-work-after-migration-or-reinstallation-fingerprint- changed-for-target-1177now I have these errors:2024-02-06 12:08:30 - ERROR - [core] Decoding issue. Protocol not good: hsu1QulEXbVaprhwL1vLME4EbuTA+NHdQ82geAnHF1is+Xlulh7NQwkpT7aYaM4H2024-02-06 12:08:30 - ERROR - [core] Decoding issue. Protocol not good: 856pscVJ+DuNUhlESNtaSg==2024-02-06 12:15:06 - ERROR - [core] Decoding issue. Protocol not good: qxPJSjg+rQRi2xoKLI8gkIZueMBYWT1OCiw5ZXd4/gSDBS6H+5LvQTsrgdnYOZdilbTuQJKUm8dETOVJ what are these errors, I can't find an article on how to correct these errors.thanks for the help
we plan to use the centreon . but we need centreon china salers or partener contactor informatoin ,please prove the contactor information
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.