Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
hello,The Cloud-Azure-Database-PostgreSQL-Api-Storage command contains errors. There are missing spaces between the values and the "--" flags.--critical-serverlog-usage='$_SERVICECRITICALSERVERLOGUSAGE$'--warning-storage-used='$_SERVICEWARNINGSTORAGEUSED$' --critical-storage-used='$_SERVICECRITICALSTORAGEUSED$'--warning-storage-percent='$_SERVICEWARNINGSTORAGEPERCENT$' --critical-storage-percent='$_SERVICECRITICALSTORAGEPERCENT$'--warning-storage-backup='$_SERVICEWARNINGSTORAGEBACKUP$' --critical-storage-backup='$_SERVICECRITICALSTORAGEBACKUP$' $_SERVICEEXTRAOPTIONS$ regards
HiI am trying to filter out host links that are not used so that they are not displayed, but the usual filtering options (--filter= or --exclude=) are not working for me.Does anyone have any tips on how I could filter out unwanted host links?My command: /usr/lib/centreon/plugins//centreon_cisco_standard_snmp.pl --plugin=network::cisco::standard::snmp::plugin --mode=vpc --hostname=xxxxx --snmp-version='2c' --snmp-community='xxxx' --verboseOutput: WARNING: vPC domain '12' host link 'port-channel31' operational status: downStar - host link 'port-channel100' operational status: downStarFor example I would like to filter out port-channel31 and port-channel100.
Hi all, I recently did an install of the free edition of Centreon. All I’ve done was install the VM and update everything to the latest versions and now I’m receiving a few errors in the services section and a bunch if unknowns. The first is for proc-postfix and is CRITICAL: Number of current processes running: 0. I suspect this might just because postfix isn't running and probably isn't a big issue.The other is for Connection-Time and is CRITICAL: Cannot connect: Access denied for user 'centreon-engine'@'localhost' (using password: YES). I also see this in a large number of the unknown issues. Would anyone be kind enough to point me in the right direction on how to fix this? Thanks
Hello,we have several host groups per host. We would like to export them via OpenTicket into EasyVista. We have tried parameters such as: {$host.host_group}, {$host.group}, {$service.host_group}, {$host_selected[0].host_group}, {$service_selected[0].host_group} to make them appear in the description on the EasyVista side, but none of them work. Is there a solution to retrieve the host groups of the machines? We also have the option to use lists in OpenTicket. Knowing that only one of the host groups is relevant for ticket entry, we would like to know if filters can allow displaying only the host groups related to the host of the selected service. Best regards.
I am seeing a ration of the following in the gorgoned.log i don’t see why and it doesn’t tell much.. 2024-05-18 23:56:14 - ERROR - curl perform error : SSL peer certificate or SSH remote key was not OK 2024-05-18 23:56:14 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - http request error 2024-05-18 23:57:14 - ERROR - curl perform error : SSL peer certificate or SSH remote key was not OK 2024-05-18 23:57:14 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - http request error
Everything seems to work but the HostGroups. I’ve only got 3 hosts on this new poller so far but non of the hosts show up in hostgroups pulldown on the Monitoring > status details > hosts > Hostgroup pulldown the hostgroup doesn’t even show up.. Now i can add a host from another group in it and then that host shows up but not the three that are just for that host group. if i add one of those to another group it doesn’t show in that group either. are 23.10 central server and 24.04 poller compatible ? <al>
bonjour,je n’arrive pas à comprendre pourquoi j’ai cette erreur :UNKNOWN: Can't construct cachesur cette requette/usr/lib/centreon/plugins//centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=storage --hostname=xxxxxxxxxxx --snmp-version='3' --snmp-community='xxxxxxxxxxxxxxxxxxxxxx' --snmp-username='xxxxxxxxxxx' --authprotocol='SHA' --authpassphrase='xxxxxxxxxxx' --privprotocol='AES' --privpassphrase='xxxxxxxxxxx' --storage='^/var/app_data$' --name --regexp --display-transform-src='' --display-transform-dst='' --warning-usage='80' --critical-usage='90' --verbose --extend-perfdata='used,used_%,percent()' --filter-perfdata='storage.space|used|free|used_%'.pourriez-vous m’aider merci
Hi I’m having trouble connecting to my MSSQL instance. My server is version 2014, ie SQL Server 12. I enter all the details correctly in Configuration/hosts/hostsconfiguration When Centreon tries to poll the server, it fails with this error: I’ve tried setting up the freetds.conf in /etc with the following:/etc/freetds.confI get the following error from the polls:UNKNOWN: Cannot connect: OpenClient message: LAYER = (0) ORIGIN = (0) SEVERITY = (78) NUMBER = (44)Server , databaseMessage String: Server name not found in configuration files.OpenClient message: LAYER = (0) ORIGIN = (0) SEVERITY = (78) NUMBER = (34)Server , databaseMessage String: Adaptive Server connection failed The command is shown as:/usr/lib/centreon/plugins//centreon_mssql.pl --plugin database::mssql::plugin --hostname='192.168.100.101' --port='1433' --username='username' --password='password' --mode='databases-size' --filter-database='^(?!(tempdb))' --filter-database-state='' --datafiles-maxsize='' --logfiles-ma
hello, In the centengine.log i have to many message like these :[2024-08-07T11:09:59.664+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.664+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.668+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.668+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.669+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.671+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.673+02:00] [neb] [info] [1105] callbacks: generating host check event[2024-08-07T11:09:59.674+02:00] [neb] [info] [1105] callbacks: generating host check eventHow could i decrease its verbosity.I try to play with engine configuration without sucess : Have you any idea?Thanks,Mathias
Bonjour,Suite à la mise à jour des plugins nombreuses sondes en unknown car l’option --force-64bits-counters a été ajoutée dans le modèle du pack. --force-64bits-counters Use this option to monitor a server/device that has more than 2 TB of RAM, the maximum size of a signed 32 bits integer. If you omit it you'll get the remainder of the Euclidean division of the actual value by 2 TB. NB: it cannot work with version 1 of SNMP protocol. 64 bits counters are supported starting version 2c. Je ne sais pas si c’est censé fonctionner partout (j’imagine puisque cela a été activé par défaut ?) mais ce n’est pas le cas chez nous, en retirant l’option c’est OK. Pourtant nous sommes bien en version 2c.Avec l’option j’ai « UNKNOWN: SNMP GET Request: Cant get a single value. » sur un check : /usr/lib/centreon/plugins//centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=memory
Bonjour à tous, Je cherche à configurer GLPI sur centreon via API pour créer des tickets directement via l’interface centreon.J’utilise pour cela le module Openticket.La version de mon centreon est en 24.04.6 et celui de mon GLPI est en 10.0.10.J’ai activé l’API sur GLPI et générer les deux tokens ( user et API )J’ai ensuite configuré une règle sur centreon la connexion est OK : Cependant lorsque je souhaite créer un ticket en utilisant le widget Open ticket il m’est impossible d’en créer un comme si la liaison avec GLPI ne se faisait pas : Si vous pouvez m’aider svp , je bloque dessus depuis 2 jours et je n’arrive pas à solutionner le problème. Je vous remercie d’avance
It seems that I'm limited to discovering /24 subnetworks. When I try using /20 or /23 and increase the timeout (while keeping all other parameters the same), I don't get any results.Is it possible to discover larger subnetworks than /24 ? Thanks.
hello,in the start of the year , an expert was mandated for our client to make his centreon clean . Right from the start , he make the high avaibility cluster on the qualification side ..He made it with mysql 1.3 instead of 1.5 ( for some reason the repository for mariadb 1.5 , install the 1.3 version). He should have stop here , the prerequisite of mysql 1.5 was not meet. but he did it anyway. He was let go before ending his work and didnt revert what he did. Today i cant upgrade , it ask me to upgrade mysql but i cant ( always the same not resolved issue with the repo ) . We try to use a save from all of the servers but the change where already in place , and we cant go on last year because we switch from centos to redhat on january. I cant revert the dnf install of the update. I tried to reverse the HA , but it dont work. How can i reverse the HA , to not be in cluster anymore like it was before , and reuse the DB that was in place before ( and with the good mysql version ) ? Thanks
Hello,In the Dashboard, when I search for a host in the Dataset selection / Host field, I don’t find what I’m looking for. I can type “PAB-s,” but the search bar still displays hosts starting with "A." Even when I scroll down to "P," I can’t see the exact host I’m looking for.For your information, the host is up, and I have some widgets working perfectly on it in Custom Views. The search bar works fine for me in other menus/pages. (even with hundreds of items).
Bonjour à tous,Je cherche à mettre en place une surveillance SNMP pour une Gateway Mail en utilisant le plugin Centreon. Mon objectif est de configurer les seuils suivants pour trois files d'attente de courrier différentes :- OK : 0 à 199 courriers- WARNING : 200 à 500 courriers- CRITICAL : Plus de 500 courriersVoici la commande que j'ai élaborée :/usr/lib/centreon/plugins//centreon_generic_snmp.pl \--plugin=apps::protocols::snmp::plugin \--mode=numeric-value \--hostname=xxxxxxxxxxx \--snmp-version='3' \--snmp-username='xxxxxxxxxxxx' \--authprotocol='SHA' \--authpassphrase='xxxxxxxxxxxxxxxxxx' \--privprotocol='AES' \--privpassphrase='xxxxxxxxxxxxxxxxxxxxxxxx' \--config-json='[ { "oid": ".1.3.6.1.4.1.6101.3004.3.1.0", "perfdata_name": "en_attente", "format": "Courrier en attente: %s", "warning": "200:500", "critical": "501:" }, { "oid": ".1.3.6.1.4.1.6101.3004.3.2.0", "perfdata_name": "en_analyse", "format": "Courrier en a
Hello,Today in the basic shapes there is only a square, a circle, a triangle and a text box. Is it possible to add other basic shapes in MAP without adding an image? THANKS
In 24.04.7, We can not see meta service in Dashboards widget. Is it normal ? Thanks,Regards
Hi,I noticed that in 23.10.17 there is no more “Import/Export” entry in the configuration menu. I see the entry is also missing from the “Menu Access” ACL configuration page. This entry is present in 23.10.16. Has it been moved elsewhere?
Hi,I still get this on some commands: What’s causing this exactly? Can it be fixed somehow?
Hello,I successfully connect to UI, but impossible to connect to CLAPI when user password contains a '&' character.When I change the password for a simple one, both UI and CLAPI authentications are OK.Latest Centreon.
Bonjour, Lorsque j’effectue un scan discovery(plugin Fortinet Fortigate) des interfaces d’un FW Fortinet je souhaiterais obtenir un résultat type : Traffic-portX-”description_interfaceX” A part la variable par défault $name$ (1.3.6.1.2.1.2.2.1.1 (ifName)) je n’obtiens aucun résultat lors du scan Pour l’instant j’ai tenté un scan avec les OID suivants sans résultats1.3.6.1.2.1.2.2.1.2 : Description Interface (ifDescr)1.3.6.1.2.1.31.1.1.1.18 : Alias de l’interface (ifAlias)1.3.6.1.4.1.12356.101.6.3.1.2 : Description de l'interface (fortinetIfDescr).1.3.6.1.4.1.12356.101.6.3.1.3 : Alias de l'interface (fortinetIfAlias) auriez vous une solution ? Merci
Hello,We are encountering an issue with the centreon_aws_rds_api.pl plugin when checking the status of an Amazon RDS MySQL database. The state is not being displayed correctly. /usr/lib/centreon/plugins//centreon_aws_rds_api.pl --plugin=cloud::aws::rds::plugin --mode=instance-status --custommode='paws' --aws-secret-key='' --aws-access-key='' --aws-role-arn='' --proxyurl='' --region='eu-central-1' --filter-instanceid='^awsp-rdsmysql-xxx-core-db$' --zeroed --verbose --warning-status='%{state} =~ /maintenance|modifying|renaming|upgrading|stopping/' --critical-status='%{state} =~ /stopped|failed|storage-full|rebooting|deleting|restore-error/'Use of uninitialized value in sprintf at /usr/lib/centreon/plugins//centreon_aws_rds_api.pl line 12131.Redundant argument in sprintf at /usr/lib/centreon/plugins//centreon_aws_rds_api.pl line 12131.OK: Total instances available : 1, failed : 0, backing-up : 0, maintenance : 0, stopped : 0, storage-full : 0 - Instance 'awsp-rdsmysql-xxx-core-db' state
Hello,I migrate my pollers from rhel8 to rhel9 and the centreon_vmware daemon no longer starts (fresh install with centreon-plugin-Virtualization-VMWare-daemon-3.3.0-1.el9.noarch) Oct 11 14:35:27 xx perl[1187288]: Can't locate centreon/script/centreonvault.pm in @INC (you may need to install the centreon::script::centreonvault module) (@INC contains: /usr/lib64/perl5/libwww-perl-5.837/lib /usr/lib64/perl5 /usr/bin /usr/local/lib64/perl5/5.32 /usr/local/share/perl5/5.32 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/share/perl5) at /usr/share/perl5/vendor_perl/centreon/script/centreon_vmware.pm line 35.Oct 11 14:35:27 xx perl[1187288]: BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/centreon/script/centreon_vmware.pm line 35.Oct 11 14:35:27 xx perl[1187288]: Compilation failed in require at /usr/bin/centreon_vmware.pl line 23.Oct 11 14:35:27 xx perl[1187288]: BEGIN failed--compilation aborted at /usr/bin/centreon_vmware.pl line 23.Oct 11 14:35:27 xx sys
hello,in the event logs page, there is no more information regarding acknowledgement or notification on this page. Only the status (warning, critical, unknown,OK)is this a known issue? i tried to change the debug levels on centreon engine then switched to V1 or V2 without acces thanks for your feedbacks, Regards AM
Hello everyone,I have a connection issue between my central server and my poller that I can't seem to resolve.My central server is in my network, and my poller is in a different remote network. The connection from my central to my poller works on port 5556, but the connection from my poller to my central on port 5669 is not working.I have this message in my poller file /var/log/centreon-engine/centengine.log : [processing] [error] [1937] failover: global error: failover: 'central-module-master-output' cannot connect endpoint[tcp] [error] [1937] TCP: could not connect to PUBLIC_IP:5669 I also have these errors in the /var/log/centreon-gorgone/gorgoned.log file: Here are the open ports on my central: Here are the open ports on my poller: Would anyone be able to help me?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.