Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,In some services, the following message appears instead of the command:“Unable to hide passwords in command (Reason: Macro passwords cannot be detected)”Even though there are no password-type macros.The cause is in this file/usr/share/centreon/src/Centreon/Domain/Monitoring/CommandLineTrait.phpLine 153, you must comment this block as follow : // if two macros are glued or separated by spaces, regex cannot detect properly password string/** if (preg_match('/\(\.\*\)\s*\(\.\*\)/', $macroPattern)) { throw MonitoringServiceException::macroPasswordNotDetected(); }**/With this you will have your command line shown as expected , and from my test, the password hiding is still working.
Upgrading BI from 23.10 to 24.10 breaks PDF report generation, update removes few required JAVA libraries xmlbeans-2.3.0.jar and dom4j-2.1.4.jar.You can download missing JARs fromhttps://repo1.maven.org/maven2/org/apache/xmlbeans/xmlbeans/2.3.0/xmlbeans-2.3.0.jarhttps://repo1.maven.org/maven2/org/dom4j/dom4j/2.1.4/dom4j-2.1.4.jarCopy them to /usr/share/centreon-bi/bin/cbis_lib/ and report generation should work again.
Hello,I want to fully automate the installation and registration of a poller on the central with Ansible.For RPMs or even transcribing the 'registerServerTopology.sh' script, this is no problem.I even managed to generate via a playbook the 'gorgon' configuration of the poller.On the other hand I cannot manage to transcribe the 'poller wizard' module of the interface. I noticed this was using an internal REST API, but I can't find any info on the subject.The objective of this playbook is to install, configure, and declare the poller without administrator intervention (among other things, restarting the gorgon service on the central and the poller)Thank you for your helpPhilippe
Hi,I project to migrate to 25.10 and I install a new server on almalinux 9.6.I’m following the installation from the official documentation, and when I reached the MariaDB installation step, there was a conflict with mysql-common : Total 13 MB/s | 192 MB 00:14Test de la transactionLa vérification de la transaction a réussi.Lancement de la transaction de testLes paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».Erreur : Erreur de la transaction de test : le fichier /usr/share/mysql/charsets/Index.xml entre en conflit avec les tentatives d'installation de mysql-common-8.0.43-1.el9_6.x86_64 et MariaDB-common-10.11.15-1.el9.x86_64 le fichier /usr/share/mysql/charsets/armscii8.x
Last week (May 18, 2026) I was successfully able to upgrade from 24.04 to 24.10 on our backup/test system. All is well there. This weekend I attempted to upgrade our production system from 24.04 to 24.10. I used the exact same guide but it seems like many packages are missing from the 24.10 repos.Both systems are running Oracle Linux 8.10, fully up to date. As you can see there are some packages available but no “centreon” files like centreon-web. I noticed that centreon-24.10-stable-noarch has no available packages at all, I’m guessing this is where the issue lies. This in on the server that I installed 24.10 on last week using the same guide. Can’t find the package in any of the dnf repos but as you can see I installed it last Monday, using the same repos from the guide.
Hello everyone, I’m new here but using Centreon for a few years.I recently installed the Infor ION Grid Monitoring Connector.Https protocol, port and credentials are OKCLI returns all the information I need with both application and node modes but the result can’t be displayed in the GUI, instead the UNKNOWN : 401 Unauthorized is displayedThe --debug option only adds a few strange lines such as :=> Recv header: HTTP/1.1 401 Unauthorized<td>HTTP ERROR: 401 Unauthorized<p>Problem accessing /grid/rest/nodes<pre id="message">Authentication failed - Invalid credentials</pre> Centreon version is 25.10.9 (IT-100) and all plugins are up to date.Does anyone have any ideas on how to resolve this issue ?Best Regards Olivier
Bonjour,Mon infra est la suivante : un serveur Central en 24.10 avec un Poller en 24.10. J’ai aussi deux Remote Server (sur deux autres sites) en 23.04 sur lesquels des Pollers sont raccordés.Je souhaite monter la version des Remote en 24.10 pour les aligner sur mon Central. Préalablement, je ferai la montée en Debian 12.Quelle procédure dois-je suivre ? Celle d’un Central ou celle d’un Poller ? Montée de version depuis Centreon 23.04 | Centreon DocumentationEn espérant avoir été clair, merci avance pour vos retours et conseils !
[root@shvit-centreo01 rpm]# dnf -y updateUpdating Subscription Management repositories.This system has release set to 9 and it receives updates only for this release.Red Hat Enterprise Linux 9 for x86_64 - AppStream (RPMs) 28 kB/s | 4.5 kB 00:00Red Hat Enterprise Linux 9 for x86_64 - BaseOS (RPMs) 49 kB/s | 4.1 kB 00:00epel_9 46 kB/s | 2.3 kB 00:00Foreman_Client_el9 58 kB/s | 1.5 kB 00:00puppet_el9 38 kB/s | 1.5 kB 00:00Error: Problem 1: package mysql-libs-8.0.45-1.el9_7.x86_64 from @System requires mysql-common(x86-64) = 8.0.45-1.el9_7, but none of the providers can be installed - package MariaDB-common-
Hello,I have a script to verify that the reboot tasks are running properly on certain virtual machines. For most of the VM fleet, this script works, but for three VMs, I’m seeing this message in Centreon. So I logged into those machines and saw that there was indeed a reboot task, and that it had even been executed the night before.Here is the script in question filter=enabled eq 1 and has_run eq 1 and title in ('Shutdown','shutdown','reboot','Reboot')warning=task_status = 'running' and most_recent_run_time < -60mcritical=task_status not in ('running') and exit_code > 0perf-config=*(ignored:true)show-all Does anyone know why the script does not recognize the reboot task? Best regards,
Contexte : Il ne s’agit pas d’une App Registration. Le besoin concerne une Enterprise Application configurée avec un Single Sign-On en mode SAML. Ce SAML SSO dispose d’un certificat de signature avec une date d’expiration. Nous souhaiterions remonter cette expiration dans Centreon afin d’anticiper le renouvellement et éviter toute interruption de service. Questions : Existe-t-il un plugin pack, un connecteur, ou un mode de supervision Centreon permettant de récupérer la date d’expiration de ce certificat ? Si ce n’est pas supporté nativement, existe-t-il une méthode recommandée par Centreon pour le superviser, par exemple via Microsoft Graph, une API, ou un script custom ? Si un développement spécifique est nécessaire, pouvez-vous confirmer l’approche la plus adaptée pour l’intégrer proprement dans Centreon ? Nous serions également intéressés par toute documentation, exemple de configuration, ou bonne pratique sur ce sujet.Merci d’avance pour votre retour.
Hello The Watch,We are updating from version 24.10.23 to 25.10.10.We are encountering an error during installation. CMA is blocking the update... Thanks a lot,Best Regards,Vincent
Reminder: Centreon Version 24.04 End of Life (EOL)As per the Centreon product lifecycle, we remind all users that Centreon Infra Monitoring version 24.04 is no longer supported. It is essential to ensure the security and up-to-dateness of your infrastructure by upgrading to a compatible version.If your platform is currently on version 24.04, it is highly recommended to upgrade to a newer version to continue receiving security updates and support. The upgrade process is thoroughly documented and can be accessed here.Thank you for your prompt attention to this important matter and for your continued support in keeping your systems secure. Stay ahead of potential threats by subscribing to the Security Bulletin section. You’ll receive instant notifications whenever a new bulletin is published, ensuring your infrastructure remains secure and up to date.
Hello,Since my last upgrade to 24.10.12, some of my graph’s legends are broken.the metrics are correctly named, but the graphs legend shows “default” instead of metric name.for example : performance data and the graph is : graph legendin parameters > data, metrics name are OK for this service. Any idea how to fix this ?
Hello everyone, I'm having an issue—apparently a communication problem—between my two collectors and my central server. After investigating and conducting extensive research, particularly in the logs, I'm seeing errors when reading the socket data coming from the poller's IP. Here's an excerpt:Central:central-broker-master.logPoller 1:centengine.log For your information, the operating systems are AlmaLinux 8 for the central server and AlmaLinux 9 for the pollers. I installed the latest updates on 25.10.25 Could you help me resolve this issue and let me know if there are any similar cases currently? Thank you.
Hi,Yesterday, i finished my Centreon configuration, as the last ‘job’ i customized the login page.Tobay i opened my Centreon, and it was the original centreon page, not my customization.When i go to the customization i got this now : Nothing was change, no update, no rebot, nothing, i simply closed the interface yesterday @20h45 and open it today @14h145 … Somesone got an idea ? Thanks
Bonjour, Nous disposons d’une Licence On Prem Business et je souhaiterais rattacher ce compte à cette souscription. comment faire?
Bonjour,Depuis que j’ai migré vers la version 25.10.5, je suis obligé de redémarrer mon collecteur tous les jours.Le matin je me connecte et le collecteur semble tourner mais nb de machines : 0 et sur la ligne je retrouve la date de la dernière mise à jour de mon collecteur sur fond Orange.Je redémarre mon collecteur et tout se remet à jour naturellement...Comment puis-je outrepasser cette opération qui n’était pas nécessaire sur la version précédente. Il doit y avoir un paramètre qui bloque l’uptime du collecteur.Merci pour vos retoursBonne journée
Hello,I am looking for a way to install the latest version of Centreon on our platform.I was hoping to find a Docker Image that would make it straightforward, unfortunately I found no image, whether official or not. My only findings was an article describing the installation for a test environment with Vagrant, and hinting on the possibility of doing it with Docker : https://www.centreon.com/blog/comment-demarrer-rapidement-un-centreon-21-04-avec-vagrant/It make me wonder: is there any known limitations with installing Centreon on a docker image or is it just something that no one ever felt the need to document?Thank you for your time!Regards,jla
Hello,Most of the Centreon web menu pages appear blank since the update. I've cleared my browser cache, tested in incognito mode, and cleared the Symfony cache. Nothing works.I checked the logs in /var/log/apache2/error.log and found this, but it might be unrelated:[Thu May 14 12:46:32.281519 2026] [proxy_fcgi:error] [pid 774:tid 774] [client 82.66.247.24:65357] AH01071: Got error 'PHP message: PHP Warning: Undefined variable $sessionKeyFreeze in /usr/share/centreon/www/include/Administration/parameters/general/form.php on line 279; PHP message: PHP Warning: touch(): Utime failed: Syst\xc3\xa8me de fichiers accessible en lecture seulement in /usr/share/centreon/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php on line 178; PHP message: PHP Warning: touch(): Utime failed: Syst\xc3\xa8me de fichiers accessible en lecture seulement in /usr/share/centreon/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php on line 188', referer: http://xxxxxxxxxxxxxxxxxxxx/
Bonjour a tous, lors de l’update nous avons le message suivant dans apache et la page web reste grise: [Fri Mar 29 14:03:50.300703 2024] [proxy_fcgi:error] [pid 78541] [client 10.80.112.1:62988] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught --> Smarty: unable to write file /usr/share/centreon/GPL_LIB/SmartyCache/compile/wrt6606bc364946a0_76211331 <-- \n thrown in /usr/share/centreon/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_writefile.php on line 60', referer: https://***************/centreon/install/upgrade.php Impossible de mettre a jour, le répertoire en question et ces parent sont tous en:/usr/share/centreon/GPL_LIB/SmartyCache# ls -lrttotal 40drwxrwxr-x 2 centreon centreon 4096 Oct 10 19:14 configdrwxrwxr-x 2 centreon centreon 4096 Oct 10 19:14 cachedrwxrwxr-x 2 centreon centreon 28672 Mar 29 18:45 compile /usr/share# ls -lrt centreontotal 52-rw-r--r-- 1 centreon centreon 3203 Oct 2 16:22 container.php-rw-r--r-- 1 centreon centreon 5600
Hello,After upgrading Centreon on AlmaLinux 9 from version 24.10.23 to 24.10.24, I am no longer able to modify any host, for example rename it.When I try to save the modification, I get the following error message: Unexpected return statusI am able to clone the host, but modifying an existing host is not possible.In /var/log/centreon/centreon-web.log, I can see the following error:[2026-05-05T14:23:47+02:00] ERROR : Error during host/hostTemplate update | {"custom":{"hostId":332,"isTemplate":false,"exception":{"message":"Unexpected return status","trace":"#0 /usr/share/centreon/www/include/configuration/configObject/host/DB-Func.php(2912): callHostApi()\n#1 /usr/share/centreon/www/include/configuration/configObject/host/DB-Func.php(2820): updateByApi()\n#2 /usr/share/centreon/www/include/configuration/configObject/host/formHost.php(1156): updateHostInAPI()\n#3 /usr/share/centreon/www/include/configuration/configObject/host/host.php(102): require_once('...')\n#4 /usr/share/centreon/www/
Hello,I recently upgraded a Centreon platform from 24.04 to 24.10 on AlmaLinux 9.The upgrade initially failed because of PHP dependency conflicts (PHP 8.1 vs PHP 8.2 modular filtering), but the platform is now running correctly with:PHP 8.2.30centreon-web 24.10.24API responding correctlyGorgone runningPollers and monitoring workingHowever, I still have an issue with host templates.When editing templates in the UI, I get:"Host template not found"In the logs, I see API calls like:PATCH /centreon/api/latest/configuration/hosts/templates/<id> 2026-05-06T14:39:52+0200] [ERROR] Host template not found {"custom":{"host_template_id":737},"exception":null,"default":{"request_infos":{"uri":"/centreon/api/latest/configuration/hosts/templates/737","http_method":"PATCH","server":"127.0.0.1"}}} [2026-05-06T14:39:52+0200] [DEBUG] Data not found. Generating a not found response {"custom":null,"exception":null,"default":{"request_infos": The templates DO exist in database with:host_register = 0h
Hello,Unable to modify host model after upgrading version 24.10.23 to version 24.10.24, errors are : [2026-05-07T15:23:21+02:00] ERROR : Error during host/hostTemplate update | {"custom":{"hostId":264,"isTemplate":false,"exception":{"message":"You are not authorized to access this resource","trace":"#0 /usr/share/centreon/www/include/configuration/configObject/host/DB-Func.php(2912): callHostApi()\n#1 /usr/share/centreon/www/include/configuration/configObject/host/DB-Func.php(2820): updateByApi()\n#2 /usr/share/centreon/www/include/configuration/configObject/host/formHost.php(1156): updateHostInAPI()\n#3 /usr/share/centreon/www/include/configuration/configObject/host/host.php(102): require_once('...')\n#4 /usr/share/centreon/www/main.get.php(292): include_once('...')\n#5 {main}"}},"exception":null,"default":{"request_infos":{"uri":"/centreon/main.get.php?p=60101","http_method":"POST","server":"toto.local"}}}
Bonjour,Nous avons plusieurs tâches de découvertes d’hôtes .Existe-t-il un plugin permettant de remonter une alerte dans le cas d’erreur ou de dysfonctionnement d’une tache de découverte?Aujourd’hui le seul moyen , que je connaisse, pour vérifier l’état des taches est d’aller manuellement regarder dans le menu Configuration > Hôtes > Découverte.Cdt
Hi there,We’ve just purchased several Cisco Catalyst 1300 switches.The OS has changed with these switches, meaning the standard templates are no longer working, namely Environment, Memory and CPU.Has anyone bought those same switches and looked into it?Thanks,Elise
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.