Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Bonjour à tous.Nouveau problème sur mon centreon en production.Suite à une mise a jours banale dont je ne me souvient plus ce que c’était j’ai un soucis de connexion.Avec mon compte admin, je rentre mes ID, et voici qui s’affiche : Quand je vais dans /var/log/centreon/login.log : 2024-03-16 18:00:10|1|0|0|[local] [10.134.118.230] Authentication succeeded for 'admin'2024-03-16 18:02:01|1|0|0|[local] [10.134.118.230] Authentication succeeded for 'admin'2024-03-16 18:03:33|1|0|0|[local] [10.134.118.230] Authentication succeeded for 'admin'2024-03-16 18:06:33|1|0|0|[local] [10.134.118.230] Authentication succeeded for 'admin'2024-03-16 18:10:52|1|0|0|[local] [10.134.118.230] Authentication succeeded for 'admin'Donc je ne comprend pas….Merci d’avance pour votre aide.
Bonjour à tous.Centreon 23.10 IT-100 fraichement installé sur Debian 12.Quand je crée une tache d’auto découverte snmp avec détection immédiate, celle ci ne se déclenche pas, elle reste en statut “Programmé” mais ne se lance pas.De plus, quand je vais voir le fichier gorgoned.log il y a un tas d’erreurs avec lesquelles je n’arrive pas à trouver la solution. 2024-03-08 22:26:35 - ERROR - [core] Cannot load module 'Net::Curl::Easy'. - Can't locate Net/Curl/Easy.pm in @INC (you may need to install the Net::Curl::Easy module) (@INC contains: /usr/bin /etc/perl /usr/>2024-03-08 22:26:35 - ERROR - [autodiscovery] Receiving DIE: Can't locate object method "new" via package "Net::Curl::Easy" (perhaps you forgot to load "Net::Curl::Easy"?) at /usr/share/perl5/gorgone/class/ht>Can't locate object method "new" via package "Net::Curl::Easy" (perhaps you forgot to load "Net::Curl::Easy"?) at /usr/share/perl5/gorgone/class/http/backend/curl.pm line 271.2024-03-08 22:26:55 - ERROR - [core] Cann
Hi Guys,I wish that everything is allright :) I’m contacting all of you because I’ve got some problems with Centreon 23.10 and you’re help is appreciated. I'm having an issue with Centreon 23.10 . It seems there's a problem with cbd.Indeed, neither the central server nor the pollers are running. The following link has been consulted https://thewatch.centreon.com/data-collection-6/error-during-cbd-exit-config-parser-unified-sql-output-is-incompatible-with-storage-sql-outputs-976?postid=3641#post3641 but it is impossible to delete outputs from central-broker-master One service is missing on cbd services : (usr/sbin/cbd /etc/centreon-broker/central-broker.json Could you give me a hand, please ? It will be appreciated Content of /etc/centreon-broker/central-broker.json{ "centreonBroker": { "broker_id": 1, "broker_name": "central-broker-master", "poller_id": 1, "poller_name": "Central", "module_directory": "/usr/share/centreon/lib/centreon-broker"
Hi guys,I`d like to ask for help because my Centreon UI stopped to work. The alarms still being sent, but i`m unable to access the webpage. I didn`t change nothing and after a Vmware host restart the VM presented this behavior. I`m not a linux guy, but i can see that httpd24-httpd service is dead.I`ve tried to force an upgrade thinking httpd will be repaired or something like that, but didn't happen.Can someone help me please? ● httpd24-httpd.service - The Apache HTTP Server Loaded: loaded (/usr/lib/systemd/system/httpd24-httpd.service; enabled; vendor preset: disabled) Active: inactive (dead) since Sun 2022-03-27 23:12:17 -03; 9s ago Process: 67464 ExecStop=/opt/rh/httpd24/root/usr/sbin/httpd-scl-wrapper $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS) Process: 67463 ExecStart=/opt/rh/httpd24/root/usr/sbin/httpd-scl-wrapper $OPTIONS -DFOREGROUND (code=exited, status=0/SUCCESS) Main PID: 67463 (code=exited, status=0/SUCCESS) Status: "Reading configuration..."Mar 27 23:
OS: Rocky Linux 9.2Centreon: 23.10Hi, When I try to reload/restart one or all my Pollers I get this message. I’m trying to find centcore.cmd but I found this file /var/lib/centreon-engine/rw/centcore.md The problem started when in the Central server, my mount in /var started to get filled with data in /var/lib/centreon0. stopped centreon and mysql1. I added a new 100GB disk and mounted it in /data2. moved the files in /var/lib/centreon to /data/centreon3. created a symlink.4. start centreon and mysql
Hello,does Centreon propose some connectors or any other solution, to be able to monitor IOT devices, like MQTT broker ?
Hi, there,I have several Pollers (Centreon 21.10).I have modified a time period and I would like to know which Poller is affected by this modification. This is to avoid having to reload all Pollers.Is there a way to do this?Stéphane
Hi everyone. “The man who asks a question is a fool for a minute, the man who does not ask is a fool for life.”― ConfuciusHow to effectively disable "performance data" for services? I have the Centreon 21.10.3 and can not find it in the settings.
Hello,I am monitoring a Windows server with NSClient++ RestAPI, and the "Services-Auto" service reports: GoogleUpdaterInternalService124.0.6337.0=stopped (auto), GoogleUpdaterService124.0.6337.0=stopped (auto)I want to exclude them, but the issue is that each time they are updated, the version number increases, and the name changes.I tried to make an exclusion with a wildcard based on what I found here and there, but it doesn't work.Is it possible to make an exclusion with a wildcard? If so, what is the correct syntax?Thanks in advance.
Hello TeamI want to exlude some services with startup type Automatic on Windows Server from being monitored. I understand that it should be done in service Services-Auto. Then i should add New entries in ‘Service check options’ named EXCLUDE, EXCLUDE2, EXCLUDE3 and in the value field windows service name?Is it correct configured on above screeshot? Thanks for reply.
I’m trying to use host discovery as per: https://docs.centreon.com/docs/monitoring/discovery/hosts-discovery/(with the Generic SNMP host discovery provider) Unfortunately, neither “execute immediately” nor scheduled jobs seem to ever progress from ‘scheduled’ to ‘running’ - the host discovery UI has them indefinitely stuck at ‘scheduled’, 0s duration, 0 hosts discovered, “execute now” and “show results” greyed out.What could I be missing?
Hi,We can't register a remote server on the central server.info :remote :ip 5.6.7.8 proto http port 80central:ip 1.2.3.4 proto https port 443here are the details of how to run registerServerTopology.sh :[sysadmin@CENTREON-REMOTE ~]$ sudo /usr/share/centreon/bin/registerServerTopology.sh -u admin -t remote -h https://1.2.3.4 -n remote-weldom[sudo] password for sysadmin: [MOT DE PASSE DU COMPTE SYSADMIN DU REMOTE]Please enter the password of https://1.2.3.4: [MOT DE PASSE DU COMPTE ADMIN WEB API DU CENTRAL] Summary of the information that will be sent: Api Connection: username: admin password: ****** target server: 1.2.3.4 Pending Registration Server: name: remote-weldom hostname: CENTREON-REMOTE.weldom-savoye.lan type: remote address: 5.6.7.8Do you want to register this server with the previous information? (y/n): yMore information is required to convert your platform into Remote :5.6.7.8: Please enter your username: adminPlease enter the password of 10.19.141.162:[MOT DE PASS
Hey there!when I try to install a new central server with an extra db server I get the following errors when I try to install the central-server:Installation in a debian 11 fails - with the following errors:WARNING: Failed to generate ConfigBuilder for extension Symfony\Bundle\FrameworkBundle\DependencyInjection\FrameworkExtension. {"exception":"[object] (Symfony\\Component\\DependencyInjection\\Exception\\EnvNotFoundException(code: 0): Environment variable not found: \"hostCentreon\". at /usr/share/centreon/vendor/symfony/dependency-injection/EnvVarProcessor.php:172)","extensionClass":"Symfony\\Bundle\\FrameworkBundle\\DependencyInjection\\FrameworkExtension"}WARNING: Failed to generate ConfigBuilder for extension FOS\RestBundle\DependencyInjection\FOSRestExtension. {"exception":"[object] (Symfony\\Component\\DependencyInjection\\Exception\\EnvNotFoundException(code: 0): Environment variable not found: \"hostCentreon\". at /usr/share/centreon/vendor/symfony/dependency-injection/EnvVar
Hi all, i have a problem with ldap groups: i imported a ldap group in centreon but none of the users belonging that group can access. I disabled the auto import users because i thought it would be sufficient the group import. i followed this post but i cannot make it work. someone has this problem?
Hello, we have 2 discovery jobs running:one VMWare VM one SNMP agent the same windows VM shows as “server.domain.local” through SNMP discovery (because it is joined in AD domain), and as “server” through VM discovery (the name of the VM object in vcenter). The Centreon then cannot see the 2 objects as the same one. Is there a way in the mappers rules to, either remove the domain in SNMP job, or add it in the VM job, so we can automatically consolidate the 2 entries? i hope it is clear :) sincerely,
Hello,I am noticing that now centreon only sends an email alert once, before it sent an email alert every half an hour. We haven't made any changes to our checks, is this a new centreon behaviour?if you check the web the error is there but the alert is sent only once.Thanks,
Bonjour, J’ai cette erreur quand j’essaye de faire la mise à jour.Est-ce que vous avez une solution?NB: je suis sous debian11
Hi,We try to update Centreon 23.10.7 to 23.10.8.The apt part is OK but the update wizard send us an error :23.10.7 to 23.10.8UPGRADE - 23.10.8: Unable to insert centreon-widget-resourcestable in dashboard_widgetsYou seem to be having trouble with your upgrade.Please check the "upgrade.log" and the "sql-error.log" located in "/var/log/centreon" for more detailsYou may refer to the line in the specified file in order to correct the issue.The SQL files are located in "/usr/share/centreon/www/install/sql/"But do not edit the SQL files unless you know what you are doing.Refresh this page when the problem is fixed.The logs :root@vm-centreon:~# cat /var/log/centreon/upgrade.log2024-02-22 12:14|0|0|UPGRADE - 23.10.8: Unable to insert centreon-widget-resourcestable in dashboard_widgets - Code : 0 - Error : SQLSTATE[HY000]: General error: 1364 Field 'version' doesn't have a default value - Trace : #0 /usr/share/centreon/www/class/centreonDB.class.php(311): PDO->query()#1 /usr/share/centreon/w
I’m just getting familiar with Centreon.I started by adding a couple of server-type hosts from our infrastructure, and put together some monitoring for them using the service scan function. That works great and gives me a very convenient resource overview. (All SNMP-based for now.)Now, I’d like to do a similar thing with the client machines on the network - to be able to see disk space getting low, VMs burning CPU/memory while idling, stuff like that.I’ve added one such client host as a starting point, and again used the scan function to add the 10 or so services I’m interested in.Now, my question is, how do I create templates from those 10 scanned services, so I can put them together into a host template and ideally auto-discover my range of 35+ client machines and have the same service monitors applied?I.e., is there a “template from existing service” function that copies over all the service’s configuration values?
Hi everybody,I’m trying hard to make a threshold working in my service template without any success…Everything is ok from CLI:/centreon_aws_cloudwatchlogs_api.pl --plugin=cloud::aws::cloudwatchlogs::plugin --mode=get-logs --custommode='awscli' […….] --critical-status='%{message} =~ /error/i' But from gui, the Threshold is not valid :CRITICALSTATUS = %{message\} =~ /error/iI tried to put \\ before every special character (\\%\\{message\\} \\=\\~ \\/error\\/i), but the problem persists… Does anyone has an idea ?Thank you for your help.Kind regards,Alexandre
Hello(edit, I made a mistake in the title, i’m upgrading from 22.04, not 21.10, but it is the same question)I’d like to upgrade centreon 22.04 on Centos7 to Alma9 and 23.04my setup is a central with local DB, which I plan to change to an independant DBI’m planning these steps :upgrade the current centos7 to the latest supported centreon 22.10 upgrade all the pollers to 22.10 install a new Alma 9 infrastructure, with an separate mariadb server and try to migrate...here is theproblem that I realized when I was planning the process :the alma 9 apparently only support 23.04, and does not support 22.10. so how do I do the jump from 22.10 to 23.04?do I need to plan a intermediate step with alma8, which is compatible with both 22.10 and 23.04 I could install the DB on an separate Alma 9, and split the databse from the master during the switchover to alma8, but I fear this step may be a bit complicated, maybe I should split the role now while I’m on centos 7 the ideal solution for me would be
Bonjour,J'ai un soucis depuis la mise à jour 23.10.8 et toujous en 23.10.9 sur Debian, les commandes check et acknowledge s'éxecute mais ne font rien, savez vous si c'est un problème connu ?Je vous remercie Hello,I have a problem since the 23.10.8 update and still in 23.10.9 on Debian, the check and acknowledge commands run when requested but do nothing, do you know if this is a known problem?Thank you very much
hello I’m migrating from centreon 19.10 to 22.04 but I have a problem is that the version of centreon 19.10 is on centos 7 while centreon 22.04 no longer supports this distribution? PS: the migration is done but I have the error when I do yum update it shows me that ul is unable to find valid base URL centos 7
I ran this command to remove old metricsfind /var/lib/centreon/metrics -type f -name '*.rrd' -mtime +90 -deleteand I would like to know if is safe to perform this query directly DELETE FROM data_bin WHERE id_metric NOT IN (SELECT metric_id FROM metrics)
hellosince updating from v23.04 to 23.10.9, the configuration is exported but not visible in ressouces status example : I add a hostI export the configuration with reload or restartbut the host does not appear in ressouces status If I restart centengine service the host appears immediatelyI found these errors in centreon-error.logsomebody can help mecentreon-error.log:[22-Feb-2024 17:32:22 Europe/Paris] WARNING: Warning: Undefined array key "metrics" {"exception":"[object] (ErrorException(code: 0): Warning: Undefined array key \"metrics\" at /usr/share/centreon/src/Core/Resources/Infrastructure/API/FindResources/FindResourcesPresenter.php:130)"}
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.