Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,when attempting to upgrade from version 21.10.8 to version 22.04 on CentOS 7, I consistently encounter the "brotli" error.I managed to install version 1.0.4, but it seems insufficient. Is there a minimum required version that needs to be installed?Hi and thanks
[root@monitoring dnf]# yum repolistrepo id repo nameappstream AlmaLinux 9 - AppStreambaseos AlmaLinux 9 - BaseOScentreon-23.04-stable Centreon open source software repository.centreon-23.04-stable-noarch Centreon open source software repository.centreon-plugins-23.04-stable Centreon plugins repository.centreon-plugins-23.04-stable-noarch
My Aruba 1930-24G-PoE shows the following error: “UNKNOWN: SNMP Table Request: Cant get a single value.” I think it is because I have the wrong services from the wrong template for my host. I used the Net-Aruba-Standard-Controller-SNMP-custom Template.What template is the right one?
Hi, i follow this post for managing multiple SID :But I have some issues. First, the test Invalid-Object didn’t work and show me this error:Status informationUNKNOWN: Cannot execute query: ORA-00936: expression absente (DBD ERROR: error possibly near <*> indicator at char 258 in 'SELECTO.object_type||' '||O.owner||'.'||O.object_name||' is '|Second the most of the other tests didn’t show me the command. I have this error:Unable to hide passwords in command (Reason: Macro passwords cannot be detected)Any Idées ? j'ai suivi ce post pour gérer les multi SID :Mais j'ai des dysfonctionnement. Premièrement, le test Invalid-Object ne fonctionne plus et me renvoi l'erreur :Status informationUNKNOWN: Cannot execute query: ORA-00936: expression absente (DBD ERROR: error possibly near <*> indicator at char 258 in 'SELECTO.object_type||' '||O.owner||'.'||O.object_name||' is '|Ensuite la plupart des tests ne présente plus les commandes et m'indique :Unable to hide passwords in command
I’ve successfully upgraded my centreon platform on debian from 23.04 to 23.10Some time after i received an alert about Broker-Stats was CRITICAL.I investigated and i saw this error in /var/log/centreon-broker/central-rrd-master.log :[core] [error] failover: global error: RRD: could not create file '/var/lib/centreon/metrics//tmpl_1703678193_15552000_300_0.rrd: Cannot create temporary fileI changed /var/lib/centreon/metrics folder’s permissions and restarted cbd : now i can see how rrd files are generated under /var/lib/centreon/metrics but owned by centreon-broker instead of centreon : BEFORE UPGRADE :-rwxrwxr-x 1 centreon centreon 450088 Dec 27 11:34 728.rrd-rwxrwxr-x 1 centreon centreon 450088 Dec 27 11:34 727.rrd-rwxrwxr-x 1 centreon centreon 450088 Dec 27 11:34 726.rrd-rwxrwxr-x 1 centreon centreon 450088 Dec 27 11:34 725.rrdAFTER UPGRADING AND CHANGING FOLDER’S PERMISSIONS :-rw-r--r-- 1 centreon-broker centreon-broker 450088
I have updated the central server and the remote pollers from 23.10 to te latest update. Gorgone is updated to 23.10.2. THe problem is that after the upgrade the communication with the remote pollers is failing. I have enabled Debugging and get the following message while updaten the remote pollers:"error":"no_proxy","message":"no proxy configured. cannot manage target.”Could you give me a hint where i have to start searching ? Thanks in advance
Hi,I finally get a window to upgrade Centreon from our current 22.10.11 to the last 22.10 (22.10.14 at this time).I should make this upgrade (along with numerous system package upgrade) on December Saturday the 2nd. I would validate the upgrade on the integration platform the week before. What I’d like to avoid is having a 22.10.15 version being released between the integration platform upgrade and when I do the production platform.With that in mind, I wonder if you’re able to give me some vision on when the next 22.10 release will be released.Notice : upgrading to 22.10.14 after a 22.10.15 has been released, while theoretically doable, seems quite hazardous because of how Centreon package dependencies work.
Wikipedia describes active monitoring like this: “In software design, web design, and electronic product design, synthetic monitoring (also known as active monitoring or proactive monitoring) is a monitoring technique that is done by using a simulation or scripted recordings of transactions. Behavioral scripts (or paths) are created to simulate an action or path that a customer or end user would take on a site, application, or other software (or even hardware). Those paths are then continuously monitored at specified intervals for performance, such as functionality, availability, and response time measures.”Is this possible in Centreon?
There is an SNMP-Trap-Service in Windows Server 2019. What do i need to do to use this in Centreon.Which MIB do I have to download?
Hi,I'm currently using Windows NRPE 0.5 to monitor Windows services with the following command:/usr/lib64/nagios/plugins/check_centreon_nrpe3 -H 192.168.X.X -p 5666 -t 30 -u -2 -P 8192 -c check_service -a "filter=start_type = 'auto' and is_trigger = 0 and name not like 'OneSyncSvc' and name not like 'WpnUserService' and name not like 'clr' and name not like 'CDPUserSvc' and name not like 'CDPSvc' and name not like 'GoogleUpdaterInternalService' and name not like 'GoogleUpdaterService'" "service=*" "exclude=clr_optimization" exclude=sppsvc exclude=TrustedInstaller exclude=TBS exclude="Sophos Clean Service" exclude="Sophos Safestore Service" exclude=SkypeUpdate exclude=MicroFocus-LicenseServer exclude=sppsvc exclude=OneSyncSvc_42be956af exclude=gupdate exclude=COMSysApp exclude=RemoteRegistry exclude=MapsBroker exclude=ShellHWDetection exclude=TrustedInstaller exclude=TBS exclude=WbioSrvc exclude=BITS exclude=tiledatamodelsvc exclude=edgeupdate exclude=GISvc exclude=clr_optimization_v4.0
The Nagios Reader Github has been archived this month, so evidently support and updates will no longer be available.I followed the guide athttps://docs.centreon.com/docs/migrate/nagios-to-centreon/The command - perl nagios_reader_to_centreon_clapi.pl --config /usr/local/nagios/etc/ > /tmp/centreon_clapi_import_commands.txt - executes successfully on my configuration directory without error but the generated clapi text file does not contain any details from my configuration. Our configuration has customized storage locations but follows the Nagios guide for nagios.cfg.I am not certain how to debug in order to get our extensive configuration exported so that we can try our Centreon. Overall spinning up the appliance and playing with the stock configuration is interested but if I can get my monitored hosts and services imported, that would be a far more impressive test.Thanks.
Bonjour,J’ai actuellement des modèles d’hôtes en place et lorsque je créer un nouvel hôte, différents services sont créés automatiquement, jusque là pas de problème.Lorsque mon service qui monitore une interface se créer, le champs --interface= est vide ce qui par défaut prend l’ensemble des interfaces.Un des plugins utilisé est par exemple centreon_plugins.pl --plugin=network::aruba::standard::snmp::pluginMa question est, comment puis-je faire en sorte que lorsque le champs est vide, j’ai une remonté UNKNOWN avec un message contextuel du type ‘pas d’interface spécifiée’ ?Merci d’avanceYohan
Hello,I’ve a problem with this plugin, only with interfaces 1/1, 1/2, 1/3 , 1/,4I only need to check 2/1/1 interface but it checked every interfaces with 1 in the endSame with 2/1/2 , 3, 4,…..
Hello I m using Sonatype Nexus as yum proxy in my company.But I have got a problem to link it to centreon’s repositorys. I’ve got 500 error when downloading repomd.xml Errors during downloading metadata for repository 'PROXY_EL8_X86-64_centreon-23.04-stable': - Status code: 500 for https://XXXXXXXXXXXXX/repository/PROXY_EL8_X86-64_centreon-23.04-stable/repodata/repomd.xml Is anyone that use nexus to do the same ?Is there some ting special to add in my config ? Best regards
Hi,I noticed some time ago that the Centreon UI is doing some requests to the WWW just to display the login page! Today I looked closer, hence this post.URL is https://cdn.eu.pendo.io/agent/static/'+apiKey+'/pendo.jsWhat is it for precisely? May it be disabled? What the consequences using Centreon with no web access or with this particular remote site blocked for any reason?Am I the only to find this kind of thing to be both a potential security hazard and a sure source of poor UI response time? And so being properly unacceptable as a mandatory or even default functionality?https://github.com/centreon/centreon/blob/22.10.x/centreon/www/front_src/src/App/initPendo.jsDoes somebody know if any serious fork of Centreon has been started by someone? The Centreon project is turning to real crapware. Can’t find a better word…And please, don’t complain again about me being agressive or disrespectful, because I’m not. I’m the first to be upset and impacted by what Centreon has become those last
Hi,I have the following error when I try to upgrade centreon 20.10 to 22.10.Here the following error: I already inserted the following request on centreon database:ALTER TABLE centreon.cfg_nagios ROW_FORMAT=DYNAMIC; ALTER TABLE centreon.contact ROW_FORMAT=DYNAMIC;I try to drop manually the column but the error is stil here. I try to change to the SQL request /usr/share/centreon/www/install/php/Update-20.10.12.php because the synthax seemed incorrect$pearDB->query("ALTER TABLE `contact` DROP IF EXISTS COLUMN `contact_platform_data_sending`");Below the upgrade.log content:UPGRADE - 20.10.12: Impossible to drop column 'contact_platform_data_sending' from 'contact' table - Code : 42000 - Error : SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'COLUMN contact_platform_data_sending' at line 1 - Trace : #0 /usr/share/centreon/www/class/centreonDB.c
Hello, as stated in the subject it seems getting parameters parameters for service when service name contains bracketsis not working ? When I do : centreon -u admin -p 'MYPASSWORD' -o SERVICE -a getparam -v 'MYHOST;Test_Service4;notes_url'I get : PHP Warning: Undefined variable $paramString in /usr/share/centreon/www/class/centreon-clapi/centreonService.class.php on line 579notes_urlmynotesurltesttext So there is an error but I get the dataNow if I try with any other service with brackets in the name like this : centreon -u admin -p 'MYPASSWORD' -o SERVICE -a getparam -v 'MYHOST;[PRIO] Test Service5;notes_url'I get : Object not found:MYHOST/[PRIO] Test Service5 I tried a lot of things like using quotes, double-quotes, escape characters and so on and I could not get my results. And of course 90% of our services have brackets in their names… :-( using Centreon 23.04.0
Hello,I’m working on scripts to manage Centreon configuration externally using API/CLAPI interfaces.I’m facing a problem that I don’t know how to solve. When trying to add a macro to a service template, I have problems when macro value contaiuns ‘;’ character. Obviously ‘;’ character is used to separate fields in ‘-v’ option, so ‘centeeon’ gets confused and it does not set macro value correctly.Imagine a value that is ‘123;456’ (for example, in passwords).If I execute command: centreon -u user -p password -o STPL -a setmacro -v ‘TemplateName;MacroName;123;456’Macro value is set to ‘123’ (wrong value). Same happens using API v1.How can I ‘escape’ this ‘;’ character needed in my macro value? I imagine it happens in every object type and every action that uses values.How can I solve it?Thanks,Albert
Hello,I'm new to Centreon and I'd like to install it on AHV nutanix.Has anyone ever done this ?Michel
Hello As a final user, I have some issues with the new view of the ressources status page. For context, we have tens of thousands of probes in centreon. We also have some other scopes in our daily job. It means that a tech is not on centreon more than a week during is timetable. For exemple, he will be on centreon week 2 and again week 6, then week 10 etcJust saying that we can’t focus on centreon more than that due to our timetable. One of the biggest use issue as a final user, is that it was VERY useful to open a alarm (acknowledged or not) in a new tab to watch it evolve (ex : a probe that is monitoring a disk size) especially when you have dozens of alarms in the same time.Now we have to clic multiples time and copy paste the probe name in the same tool to find the probe in centreon.Pulling out this feature without offer another solution wasn’t great just because of minification. (but I’ve seen other post mention that so I won’t go further in explanation) --As a average user, I
Hello,I try to display a specific metrics from the traffic service on map with the Output widget.I can only display the first metric with the following Output format : #curentValue@traffic_in#If i try : #curentValue@traffic_out# the display is ?Did someone experience the same behavior ?
Hi everyone,I hope you're all doing well. I'm facing an issue with our database.Here's the situation:Recently, our database encountered a crash due to being full, and as a result, we lost some data. Specifically, the partitioned table "data_bin" was inadvertently deleted during the crash. Now, I'm trying to repartition the table, but I'm encountering an error stating that a partition already exists.-bash-4.2# /bin/php /usr/share/centreon/bin/centreon-partitioning.php -m data_bin[Mon, 11 Dec 23 17:31:23 +0100] PARTITIONING STARTED[Mon, 11 Dec 23 17:31:23 +0100][migrate] Renaming table centreon_storage.data_bin TO centreon_storage.data_bin_old[Mon, 11 Dec 23 17:31:23 +0100][migrate] Creating parts for new table centreon_storage.data_bin[Mon, 11 Dec 23 17:31:23 +0100] Error : Cannot create table centreon_storage.data_bin with partitions, SQLSTATE[HY000]: General error: 1813 Tablespace for table '`centreon_storage`.`data_bin` /* Partition `p20221211` */' exists. Please DISCARD the tablespa
Bonjour, J’ai installé Nagvis (1.9.35) sur mon Centreon (23.04) pour pouvoir afficher les hôtes sur une carte mais quand je veux rajouter un hôte sur une carte avec le backend Centreon j’ai une erreur de socket comme quoi il n’arrive pas à le lire.Alors que dans les paramètres de Centreon Broker je ne vois pas de paramètres en input qui pourrais bloquer la lecture.J’ai fouillé les fichiers de config, j’ai essayé d’activer TLS mais sans succès (j’avais une erreur tls donc je l’ai désactiver) et j’ai comparé par rapport à une installation que j’ai avec shinken mais je ne vois pas de changement particuliers à pars le port qui est différent pour le backend. Merci par avance
Hello everyone,I have a service that takes up a lot of space in the database. Centreon support advised me to filter the perfomance data with the extraoption: --filter-perfdata='noperfdata'. but when I enter it, I get an error:Invalid command line: unrecognised option '--filter-perfdata=noperfdata'.Can you help me with this option?Best regards,
Hi all,I’m using Centreon version 21.10.14, the OS is Centos 7 and the database MariaDB. I see the following message in /var/log/php-fpm/centreon-error.logPHP Fatal error: Uncaught PDOException: SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction in /usr/share/centreon/www/class/centreonDB.class.php:263 I can’t find any references of this error message and I’m wondering what the root cause is.From time to time my system stops showing any data and I’m starting to debug the issue, could please help me to fix it?Thank you in advance!LM
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.