Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello, I want to monitor the power usage of an Idrac.I’m able to do it with snmpwalk but I want to have a graph like on my other services. What can I do ? Currently, the plugin doesn’t exist for my Idrac model. I tried to do it with SNMP Traps but it looks like it needs a licence and I don’t have it. Anyone has an idea ? Thanks and have a nice day !
Hi,For information there is a typo in the french version (maybe others) of the installation documentation for el9.Centron repo URL is given asdnf config-manager --add-repo https://packages.centreon.com/rpm-standard/23.10/el9/centreon.repoIn this version of the doc:https://docs.centreon.com/fr/docs/installation/installation-of-a-central-server/using-packages/ When you should have:dnf config-manager --add-repo https://packages.centreon.com/rpm-standard/23.10/el9/centreon-23.10.repoAs in this version of the doc:https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-packages/As web browser tend to impose where you end up it can be painfull.PS: Could not find anything on this in the forum, apologises if this is a duplicate.
[2023-10-29T20:09:28.462+08:00] [sql] [error] storage: rebuilder: Unable to connect to the database: mysql_connection: error while starting connection[2023-10-29T20:14:28.462+08:00] [sql] [error] mysql_connection: error while starting connection[2023-10-29T20:14:28.462+08:00] [sql] [error] storage: rebuilder: Unable to connect to the database: mysql_connection: error while starting connection[2023-10-29T20:17:01.596+08:00] [tcp] [error] Error while reading on socket: End of file[2023-10-29T20:17:01.696+08:00] [core] [error] feeder 'central-broker-master-input-1' error:Attempt to read data from peer SCRUBBED:45690 on a closing socket[2023-10-29T20:17:01.696+08:00] [core] [info] bbdo stream stopped with 0 events acknowledged[2023-10-29T20:17:01.696+08:00] [core] [info] feeder: queue files of client 'central-broker-master-input-1' removed[2023-10-29T20:17:01.696+08:00] [core] [info] feeder: thread of client 'central-broker-master-input-1' will exit[2023-10-29T20:17:02.209+08:00] [core] [i
Hi all !Centreon 23.04.2 / On premise / Debian 11.I’ve added a script to get notifications in Google Chat but i can’t configure it correctly.The script : /usr/lib/centreon/plugins/gchat_notify.shIf i run the script drom command line (root user or standard user) it work perfectly.I’ve added a new notification command :If i click here i receive a empty notification : Next, i’ve created a new contact user :And i’ve added this user to the notification host template (and to the host notificatio to test) :When the host is down, i don’nt receive any notification but a can see in the logs that the command is executed : Can you explain me where my configuration is wrong ?Thank’s a lot, JC
Hello!I’m trying to use traffic metrics from interfaces with cisco-standard plugin, everything works correctly but I dont understand how cisco plugin obtain the values from the OID.For Exemple :/usr/lib/centreon/plugins/centreon_cisco_standard_snmp.pl --plugin=network::cisco::standard::snmp::plugin --mode=interfaces --hostname=xx.xx.xx.xx --snmp-version='3' --snmp-community='public' --snmp-username='supervision' --authpassphrase='xxxxxxxxxxxxx' --authprotocol='SHA' --privpassphrase="xxxxxxxxxxxxxx" --privprotocol='AES' --interface='^P22$' --name --add-status --add-traffic --oid-extra-display ifAlias --debugOK: Interface 'P22' [ xxxxxxxxxxxx ] Status : up (admin: up), Traffic In : 0.00b/s (0.00%), Traffic Out : 4.05Gb/s (40.52%) | 'traffic_in'=0.00b/s;;;0;10000000000 'traffic_out'=4052433008.00b/s;;;0;10000000000.1.3.6.1.2.1.2.2.1.5.22 = 4294967295.1.3.6.1.2.1.2.2.1.7.22 = 1.1.3.6.1.2.1.2.2.1.8.22 = 1.1.3.6.1.2.1.2.2.1.10.22 = 0.1.3.6.1.2.1.2.2.1.16.22 = 3141495286.1.3.6.1.2.1.31.1.1.1.
Hi,I installed Centreon 23.04 from the Vmware image. No problem. Then I started the migration from my EL7 centreon 22.10. After migrating the folders (step 4 of the migration) I can no longer connect to the web page. Error: "PDO object is not initialized, constructor was not called"No error in login.log but in centreon-web.log :[2023-09-20T09:19:05+0200] [ERROR] [Core\Security\ProviderConfiguration\Application\UseCase\FindProviderConfigurations\FindProviderConfigurations:61]: PDO object is not initialized, constructor was not called {"trace":"#0 /usr/share/centreon/src/Core/Security/ProviderConfiguration/Infrastructure/Repository/DbReadConfigurationRepository.php(281): PDO->query()\n#1 /usr/share/centreon/src/Core/Security/ProviderConfiguration/Application/UseCase/FindProviderConfigurations/FindProviderConfigurations.php(59): Core\\Security\\ProviderConfiguration\\Infrastructure\\Repository\\DbReadConfigurationRepository->findConfigurations()\n#2 /usr/share/centreon/src/Core/Secu
Hey!I'd like to monitor the PDUs, but the plugin doesn't return any results.Centreon v. 23.04.9 EL9Plugin v.23.04RARITAN Dominion PX-5297/usr/lib/centreon/plugins/centreon_pdu_raritan_snmp.pl --plugin=hardware::pdu::raritan::snmp::plugin --hostname='ip' --snmp-version='2c' --snmp-community='pub' --snmp-timeout=10 --verbose --mode=inlet-sensorsOK: All 0 components are ok []./usr/lib/centreon/plugins/centreon_pdu_raritan_snmp.pl --plugin=hardware::pdu::raritan::snmp::plugin --hostname='ip' --snmp-version='2c' --snmp-community='pub' --snmp-timeout=10 --verbose --mode=ocprot-sensorsOK: All 0 components are ok []./usr/lib/centreon/plugins/centreon_pdu_raritan_snmp.pl --plugin=hardware::pdu::raritan::snmp::plugin --hostname='ip' --snmp-version='2c' --snmp-community='pub' --snmp-timeout=10 --verbose --mode=outlet-sensorsOK: All 0 components are ok [].Result of : snmpwalk -ObentU -v 2c -c pub ip .1.3.6.1.4.1 snmpwalk_result.txtThanks for help.
(fr)Bonjour,J’aimerai savoir, si il est possible de mettre comme valeur pour la macro “WARNING”, une valeur en Go, et non un pourcentage pour un service qui est “OS-Windows-Disk-Generic-Id-SNMP” . Par exemple, remplacer la valeur de base qui est de 80(%),par 10Go par exemple.L’idée est donc de remplacer la limite du WARNING par un nombre de Go a la place d’un pourcentage.Malheureusement, je ne sais pas si c’est possible ou non, je m’en remet donc a vous.Cordialement. (en)I would like to know if it is possible to set a value in Go, not a percentage, for the “WARNING” macro for a service which is “OS-Windows-Disk-Generic-Id-SNMP”. For example, replace the base value which is 80(%),by 10GB for example.The idea is to replace the WARNING limit with a GB number instead of a percentage.Unfortunately, I don’t know if that’s possible or not, so I’m in your hands.Sincerely.
Hi everyone,I'm new to the Centreon platform. I saw that version 23.10 is out. My server is currently running 23.04.I looked at the documentation but there is no guide to upgrade from 23.04 to 23.10.How can I proceed? Thank you Regards
Hello, I’m using two plugins to monitor file-date : centreon_protocol_cifs.pl & centreon_protocol_sftp.plBoth have a native option/argument named : “FILE”I need to be able to exclude certain file by their name and or extensions from my monitoring.I can’t find help or documentation anywhere on this, how do i use this field ? i found this topic with the same need but no answer from 1y ago : Thank you for your help and feedback,Thomas,
hi everyone i’m facing an issue with my own speedtest_centreon.pl script is executable and runs successfully from the command line, returning the expected output. However, within the Centreon interface, it's not producing the desired result and is resulting in a "process timeout" error.here is the script:************************************************************************************************************#!/usr/bin/perluse strict;use warnings;use Net::SNMP;my $host = shift || die "Usage: $0 <host> <community> <test_type>\n";my $community = shift || die "Usage: $0 <host> <community> <test_type>\n";my $test_type = shift || die "Usage: $0 <host> <community> <test_type>\n";my $session = Net::SNMP->session( -hostname => $host, -community => $community,);unless (defined $session) { print "UNKNOWN: Failed to initialize SNMP session.\n"; exit 3;}my $oid = '1.3.6.1.2.1.1.1.0';my $result = $session->get_request(
Hello there, i want to update our old Centreon 2.6.1 monitoring platform to a newer version. Seeing that Centreon is currently on 23.10, i think it would be better to create a separate VM and migrate all the data from the old one to the new one.Checking documentation i see that only goes back to Centreon 3.4, would that method work for an older 2.6.1 version?Also in the current VM we have a disk space problem, where the files “data_bin.MYD” and “data_bin.MYI” take about 250GB of space. It would be possible to migrate to a newer version without this data? (Not copying them or delete them and let Centreon rebuild them, don’t know if it’s possible). Thanks.
Hello,Is there any plugin that can monitor the VM CPU Readiness and DRS Score please?Regards
Hello,It seems the documentation is missing for an upgrade from 23.04 to 23.10.Thanks to correct that please (the last mentionned is from 22.10, it may not be long to add the 23.04 entry) : Best regards,
Hello, I have seen Centreon 23.04 is now compatible with EL 8/9 and Debian 11.We now use the opensource version on Centos + Centreon 20.04 (+pollers) and are going to migrate soon to Centreon 23.04 (+pollers) Can you please let me know which OS/version is recommanded by Centreon to install Centreon 23.04 (server, HA, pollers...) and upcoming versions ?Is it the same to use Alma or Debian or is there a “better” or more recommanded OS (OS used at Centreon to develop the solution now and the next years...) ? Thanks a lot for the information you may provide.
Hello,I have added Central host with “Central” template, but my ssh port isn’t sconfigured by default.Result : I have this message : connect to host 127.0.0.1 port 22: Connection refused.How can I change SSH port on the “App-Monitoring-Centreon-Central-Broker-Stats” command ? Thank you for all :) Florian
Bonjour à tous,J’ai besoin de monitorer certaines interfaces de mon firewall sonicwall, j’ai donc effectué l’installation du plugin pack sonicwall. tout est OK pour le CPU, la RAM, par contre il n’y a pas de template pour les interfaces.J’ai listé les modes acceptés par le plugin et ai vu qu’il était capable de checker les interfaces (mode=interfaces). J’ai lancé la commande suivante dans mon poller :/usr/lib/centreon/plugins//centreon_sonicwall_snmp.pl --plugin=network::sonicwall::snmp::plugin --mode=interfaces --interface='2,3,4,5,6,24,25,26,27,28' --hostname=x.x.x.x --snmp-version='2c' --snmp-community='xxxxxxxxxx' --verboseJ’obtiens bien le statut de chacune de ces interfaces, par contre, je suis incapable de traduire cette commande en macros et générer un template de service…Je me suis penché sur la doc mais je n’arrive pas à traduire cette commande, si quelqu’un pouvait m’aiguiller, je suis nouveau sur Centreon et n’ai pas encore les bons réflexes…merci à tous.
Hello,Since version 22 I noticed that when I launch a command via CLAPI like an APPLYTPL on a host, the poller GUI doesn’t show that poller conf has changed. You don’t have any error generated by your command, in services by host you can see that new services have been created but poller conf is marked as unchanged.Of course if you reload the poller services are deployed successfully.If you click on the button “service creation” under host templates def directly in GUI, the poller conf is this time correctly tagued as changed.This is quite painfull when you make some massive changes because you have to reload all pollers if you don’t want to search which pollers were concerned by your modifications.This bug was not present in v 21, and seems still present in v 23...
Hello, After step Retrieve the databases of migration documenthttps://docs.centreon.com/docs/migrate/migrate-from-el-to-debian/#prerequisitesI cant log in web interface with admin and his credential.In login.log i gotAuthentication failed for 'admin' : invalid credentialsWhat config file i must check to change the password ? Many thanks,
Hi,i tested this chekc. on the Shell is WORKING [root@MONITORING]#/usr/lib/centreon/plugins/centreon_protocol_http.pl --plugin=apps::protocols::http::plugin --mode=json-content --hostname=rbitq.service-now.com --proto='https' --urlpath='/api/now/table/cmdb_ci_win_server?sysparm_query=name=TESTVM&sysparm_limit=1' --basic --credentials --username='interface' --password='PassW0rd' --lookup='$..install_status' --critical-numeric='1:' --format-ok='CMDB' --format-warning='Error : %{values}' --format-critical='NO CMDB %{count}' --http-backend='curl'output:CRITICAL: NO CMDB 0 | 'count'=0;;1:;0; 'time'=0.329s;;;0; is working, in Centreon web i create the Command and i tested in shell su - centreon.engine [root@MONITORING]# # su - centreon-engineLast login: Tue Oct 31 13:53:44 CET 2023 on pts/0-bash-4.2$ /usr/lib/centreon/plugins/centreon_protocol_http.pl --plugin=apps::protocols::http::plugin --mode=json-content --hostname=rbitq.service-now.com --proto='https' --urlpath='/api/now/table/cm
Hi,CentOS 7 / Centreon 22.10.14 i want to start / Test a python script. /usr/bin/env python3 /tmp/Query.py Error:ModuleNotFoundError: No module named 'requests' python --versionPython 2.7.5 What can i do ?Thanks
Hello, I have a problem. When creating a host, I don't have all the templates that appear during template selection (see screenshots).
Hello,I am using a plugin to see the existence of a file but the problem is that the name of that file varies depending on the date. The format would be something likefile_yymmdd.confWhen configuring the control, I don't know how to add this variable parameter to the $_SERVICEFILTERFILENAME$ search field. Maybe a BASH command type date +"%d%m%y" can be added, but I don't know how to do it. Any ideas?Regards,
HiWhen you install a plugin pack, you get the locked featured service templates + the custom service templates, with this inheritance chain (as an example) :App-Protocol-HTTP-Response-Time-custom → App-Protocol-HTTP-Response-Time → generic-active-service-custom → generic-active-serviceIf I want to reduce this chain by using copies of the custom service templates, for example :MyTemplate-HTTP-Response-Time-custom → MyTemplate-generic-active-service-customi guess that my templates won’t be updated if the plugin pack is updated, right ? 🤔 In that case, if I want to keep the benefit of the plugin pack update, I should keep the inheritance from the locked templates, for example :MyTemplate-HTTP-Response-Time-custom → App-Protocol-HTTP-Response-Timebut this locked template has a mandatory inheritance from generic-active-service-customso, if I want to have different templates of generic-active-service (for different environments, PROD, UAT, TEST ...), I think that I must have a chain like th
Bonjour,Je n’arrive plus à afficher des graphs monitoring avec les widgets pour les vues personnalisées alors que d’autres widgets fonctionnent. (voir photo)Et même dans Supervision > Informations de performance > Graphiques je n’ai pas d’affichage. Au début de l’installation de Centreon il y a quelques mois j’avais l’affichage des graphiques sur n’importe quelle vue, mais du jour au lendemain ils ont disparus et je ne sais pas pourquoi.J’ai essayé des solutions trouvé sur d’autres postes similaire mais je n’ai pas eu de résultats positifs dans mes essais.Je voudrais savoir si quelqu’un à une solution et si c’est lié ou pas au fait que je n’ai pas de licence (ex : IT-100 car nous avons 100+ hôtes en supervision) et que prendre une licence n’est pas une option pour le moment.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.