Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,I'm looking to monitor Office 365 via Centreon using the cloud::microsoft::office365::management::pluginVia the list-services mode, everything works and it shows me the list of services.However, when using the service-status mode, for the "Exchange Online" service, the critical-status parameter seems to be wrong.I'm following the Centreon procedure or the --help, but the critical-status "--critical-status='%{status} !~ /serviceOperational|serviceRestored/i'" doesn't work.This is the message returned: UNKNOWN: Wrong critical-status threshold '%{status} !~ /serviceOperational|serviceRestored/i'.If I don't mark the critical-status, it returns: OK: Service 'Exchange Online' status is 'restoringService'.Do you know what parameter to put in critical-status?Thanks in advance
Bonjour ,Je veux monitorer l’espace utilisé sur des volumes sur une baie Dell emc unisphere sc3020La commande curl , exécuté depuis un poller me permet d’interroger l’api rest de la baie curl -k -u apirestuser:password https://10.46.35.56:3033/api/rest/StorageCenter//ScVolume/851722.6J’ai testé le plugin Hardware-Storage-Emc-Unisphere-Restapi mais ce dernier ne semble pas compatible avec cette baie /usr/lib/centreon/centreon-plugins/centreon_plugins.pl --plugin=storage::emc::unisphere::restapi::plugin --mode=storage-resources --hostname=10.46.35.56 --port=3033 --api-username=apirestuser --api-password='password' --ssl-opt="SSL_verify_mode => SSL_VERIFY_NONE" --curl-opt="CURLOPT_SSL_VERIFYPEER => 0" --debugThe requested URL /api/types/storageResource/instances was not found on this serverExiste t-il un autre plugin ?Cdlt
Bonjour,Quelle solution utilisez vous pour les cas suivants :Analyse de fichier de log type /var/log/messages sur RHEL8 en filtrant sur certaine entré comme ERROR ou WARNING mais en excluant par exemple WARNING-Memory ou WARNING-Texte. Sachant que nous utilisons NRPE3 pour scanner ces hosts comme indiqué dans la documentation Centreon.Analyse de fichier de log type C:\ORACLE\Program\19\LOG\alerte.log sur Windows server 20XX en filtrant sur certaine entré comme ERROR ou WARNING mais en excluant par exemple WARNING-Memory ou WARNING-Texte. Sachant que nous utilisons NRPE0.5 pour scanner ces hosts comme indiqué dans la documentation Centreon.on m’a proposé d’utiliser Check_logfiles mais je ne comprends pas bien comment je peux l’intégrer à ma plateforme Centreon 22.10.Cordialement Hi,Which solution do you use for the following cases?Analysis of log files such as /var/log/messages on RHEL8, filtering on certain entries such as ERROR or WARNING but excluding, for example, WARNING-Memory or
Hello everyone!My Centreon upgrade failed during the upgrading process, does anyone have any idea about the issue? Would you please help me to solve it? Thank you in advance.
Hello,I checked that my graphics are updating but it is showing delay. All services.This happens only in the central, in the remote servers they are ok.I don't see any errors in the rrd, broker files...Does anyone have any ideas?delayed about 3 daysLast 7 days:
We’re running 22.10 and for the 2nd time in 8 months, our partition is nearly full [root]# df -h /var/lib/mysqlFilesystem Size Used Avail Use% Mounted on/dev/mapper/centos_centreon--central-var_lib_mysql 94G 87G 3.3G 97% /var/lib/mysqlWe restarted the system and run yum updates daily [root]# rpm -qa | grep centreon | egrep -v "(plugin|pack|widget)"centreon-common-22.10.11-1.el7.noarchcentreon-broker-cbmod-22.10.4-1.el7.x86_64centreon-gorgoned-selinux-0.0.4-1.x86_64centreon-auto-discovery-server-22.10.2-1.el7.noarchcentreon-pp-manager-22.10.0-6.el7.centos.noarchcentreon-broker-22.10.4-1.el7.x86_64centreon-release-22.10-1.el7.centos.noarchcentreon-engine-22.10.4-1.el7.x86_64centreon-central-22.10.11-1.el7.noarchcentreon-license-manager-common-22.10.1-1.el7.noarchcentreon-broker-core-22.10.4-1.el7.x86_64centreon-connector-ssh-22.10.4-1.el7.x86_64centreon-22.10.11-1.el7.noarchcentreon-common-selinux-0.0.11-1.x86_64centreon-engine-extcommands-
I migrated my Centos7 Centreon 22.04 platform to Debian 11 Centreon 22.04.For the Central, I used this procedure : https://docs.centreon.com/docs/migrate/migrate-from-20-x/User IDs for centreon, centreon-engine and centreon-broker accounts are not the same on these 2 platforms.On Centos 7 :uid=994(centreon-broker) gid=992(centreon-broker) groups=992(centreon-broker),995(centreon),994(nagios),993(centreon-engine),989(centreon-gorgone)uid=995(centreon-engine) gid=993(centreon-engine) groups=993(centreon-engine),995(centreon),994(nagios),992(centreon-broker),989(centreon-gorgone)uid=997(centreon) gid=995(centreon) groups=995(centreon),993(centreon-engine),992(centreon-broker),48(apache),989(centreon-gorgone)On debian 11 :uid=112(centreon-broker) gid=120(centreon-broker) groups=120(centreon-broker),33(www-data),118(centreon),119(centreon-engine),121(centreon-gorgone)uid=111(centreon-engine) gid=119(centreon-engine) groups=119(centreon-engine),118(centreon),120(centreon-broker),121(centreo
Hello What can explain the HARD type in the third line? Before my service status state is OK with HARD type and retry 1
Hello, I migrate from 22.10 from 23.04 and when i want to show a command control, i have a blank page. I saw some topics but there is no solution for me… I share some screenshots If you have any ideas, it will be very helpfull. Best regards
Hello everybodyAfter Red Hat announced they will no longer be providing the means for downstream clones to continue to be 1:1 binary copies of Red Hat Enterprise Linux (RHEL), will Centreon still accept AlmaLinux for future relase ?I have now 1 Central and 9 pollers running Centreon 21.04.20 on Centos 7.I plan to migrate everything to Centreon 23.04 on AlmaLinux 9Shall I wait a little bit or can I start migration ?Thank you for your answerPierre
Hi there,I recently updated centreon from 23.02 to 23.04.Now, all my graphs are stating that there is no data like so : Can you please help me solving my issue ? =) PS: I do not think it has anything to do with it, but I had to run this command for centreonweb to work : /usr/share/centreon/bin/console cache:clear I do have centreon-broker-master properly configured (I checked other posts solutions)
Bonjour à tous,Je cherche à automatiser l’installation et la configuration de ma plateforme Centreon.Il s’agit d’une plateforme en mode distribuée. C’est à dire avec plusieurs pollers.Je cherche donc à créer via un script la création dans Centreon des différents fichiers de configuration nécessaires pour engine et broker.Dans la configuration broker (master ou module) le champs “log directory” est obligatoire.Cependant avec Clapi, je ne trouve pas la bonne commande pour le configurer via une commande clapi.Précédemment, c’était ce genre de commande: (tirée de la doc )centreon -u admin -p 'centreon' -o CENTBROKERCFG -a addlogger -v "broker cfg for poller test;/var/log/centreon-broker/central-module.log;file" J’utilise pour le moment la version 22.04.6 et cette commande ne passe plus. J’ai ce message en retour:Method not implemented into Centreon API Je ne trouve pas la commande qui permet de le faire (ou le paramètre à passer en SETPARM ?)Est-ce que parmi la communauté, quelqu’un a égal
After upgrade to Centreon 22.10.2 currently getting command line php errorsgenerating config and reloading poller works fine through GUI but command line and API fail to work and Ideas? centreon -u admin -p password -a APPLYCFG -v 2PHP Warning: Failed loading Zend extension 'ioncube_loader_lin_7.3.so' (tried: /usr/lib64/php/modules/ioncube_loader_lin_7.3.so (/usr/lib64/php/modules/ioncube_loader_lin_7.3.so: undefined symbol: zend_class_serialize_deny), /usr/lib64/php/modules/ioncube_loader_lin_7.3.so.so (/usr/lib64/php/modules/ioncube_loader_lin_7.3.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 02023-07-28 09:45:01 - APPLYCFGPHP Warning: Undefined array key 4 in /usr/share/centreon/www/class/config-generate/broker.class.php on line 207Configuration files generated for poller '2'OK: Centreon Poller 2 can restart without problem...
Hi, I have a problem after upgrading from 22.10 to 23.04. for cisco devices, the service reports: execution command failed. Thank you Tomas
Good morningOn centreon I am trying to modify a service vpn CRITICALSTATUS verification command on the zyxel plugin. currently i have worth Name CRITICALSTATUS Value %{connectstatus} eq "disconnected"I would like it to take into account only active vpn, but I don't see how to do it.THANKS Sorry if it's not very clear j Google translate
Good morning,I have a problem on my centreon server, after logging on to the page, it remains blank.The problem is present on some users but not others.Do you have an idea?Thanks for your help.
Bonjour tout le monde,Je rencontre actuellement une anomalie de configuration GLPIRestApi en Centreon, la connexion est OK mais lors de création du ticket cette erreur s’affiche : Error to open the ticket: ENDPOINT: https://xxxxxxxxxxx/apirest.php/Ticket || GLPI ERROR : ERROR_GLPI_ADD || GLPI MESSAGE: Demandeur est obligatoire || HTTP ERROR: 400. Pouvez-vous m’aider à résoudre ce problème ?Je vous en remercie d’avance.
Hello, I want to set up mail supervision via the imap server plugin But when i try to use in login mode, i have this error : CRITICAL: Unable to connect to IMAP: Unable to connect to XXX.XXX.XXX.XXX: SSL connect attempt failed And that whatever the options i used the error remains the same.Here is the command line: centreon_protocol_imap.pl --plugin=apps::protocols::imap::plugin --mode=login --hostname=ip-server-mail --username='user' --password='password' --warning='' --critical='' (Same with this parameters : --ssl, --insecure, --ssl-opt="SSL_verify_mode => SSL_VERIFY_NONE", ou --ssl='tlsv1')Imap port is open : PORT STATE SERVICE143/tcp open imapNmap done: 1 IP address (1 host up) scanned in 0.03 seconds Have you ever encountered this problem? Or test ideas to find out what is blocking?Thanks in advance for your help and answers.
I have acknowledged the alert and disabled the host that these notifications are connected too, but I can not get the status to go away under the resource status page. We don’t want to be looking at them anymore when we check alerts that actually need our attention. I am new to this system and would really appreciate it if someone could point me in the direction of what I am missing.
Dear.Install from zero the new version Centreon 23.04.5, but when adding devices or services, once restart or reload pollers are not appearing in the resource pantallas and I have to restart the server so that the host or service is loaded..
Hello the community I’m new in Centreon , we have installed the latest version 23.04 but we are having issue with it . We want Centreon to monitor disk space on one Windows server . This Server has mutliple disks attached (it’s a Guest VM on Nutanix) We use (but have tested all the SNMP Disk Template for Windows) OS-WINDOWS-DISKS_GLOBAL-SNMP to get all the disk . Problem is that it can find 3 disks of the 4 existing . The one who is skipped is the bigger one 15TB. I’ve tried to Clear the cache , by removing the file in var/lib/centreon/centplugins , but no effect. What is wird is that when you edit the Cache file in /Var/lib/centreon/centplugins it shows the skiiped disk Here is the content of the cache file of the server , the concerned disk is E:\{"hrstoragetype_7":".1.3.6.1.2.1.25.2.1.2","hrstoragedescr_4":"F:\\ Label:HOMES Serial Number 9a6f5e4a","hrstoragetype_6":".1.3.6.1.2.1.25.2.1.3","hrstoragedescr_3":"E:\\ Label: Serial Number 16704a42","hrstoragedescr_6":"Virtual Memor
Hello,Im asking for ideas how to monitor a optical signal state from Adva FSP 3000.Now im using check_snmp, but there is one issue.When i set correct warning and critical tresholds i get lot of warnings about performance data.(part of log from /var/log/centreon-broker/central-broker-master.log)[perfdata] [error] invalid perfdata format in service: equal sign not present or misplaced '@-0;-248: 'My tresholds: -w @-0:-40:-c=-248:As i found in documentation there is no possibility to remove perfdata, or remove those @ from it.Any ideas?
Hi, I'm trying to create a filter in a Widget but I don't know if it's possible.I have several HostrgroupsFor example:Client1Client1-Database-SQLClient1-Database-DB2Client1-Database-MSSQLClient2Client2-Database-SQLClient2-Database-DB2Client2-Database-MSSQLClient3Client3-Database-SQLClient3-Database-DB2Client3-Database-MSSQLI only want the hostgroups Client1 and Client2 to appear in the list The result is all hostgroups starting with Client1 and Client2can you help me?Thanks
I have an issue with lost .par file content for all centreon_storage partitioning tables on remote server.Couldn't get partition infos for table 'centreon_storage.data_bin'Couldn't get partition infos for table 'centreon_storage.logs'Couldn't get partition infos for table 'centreon_storage.log_archive_service'Couldn't get partition infos for table 'centreon_storage.log_archive_host' [root@AAAAAAAAAA centreon_storage]# ls -alh data_bin*-rw-rw---- 1 mysql mysql 27K Jun 19 02:00 data_bin.frm-rw-rw---- 1 mysql mysql 0 Jun 19 02:00 data_bin.par-rw-rw---- 1 mysql mysql 136M Jun 19 2022 data_bin#P#p20220619.ibd-rw-rw---- 1 mysql mysql 132M Jun 20 2022 data_bin#P#p20220620.ibd-rw-rw---- 1 mysql mysql 132M Jun 21 2022 data_bin#P#p20220621.ibd………………………..-rw-rw---- 1 mysql mysql 112K Jun 16 04:06 data_bin#P#p20230626.ibd-rw-rw---- 1 mysql mysql 112K Jun 17 04:00 data_bin#P#p20230627.ibd-rw-rw---- 1 mysql mysql 112K Jun 18 04:00 data_bin#P#p20230628.ibd-rw-rw---- 1 mysql mysql 112K Jun 18 0
Good morning.I encountered several problems with my centreon database.For 200 hosts is 2500 services, is it normal to have a 61G database?My central server has been around for 6 months.I noticed that I have ghost hosts in the duplicate hosts db.It appears in the database but is invisible in centreon.It's ghost host also makes metrics and inflates the bdd?I have 4.5G data_bin files, is that normal?How to solve the problem ? To reduce, the bdd to a reasonable size?Sorry for my English.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.