Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
hello,I had lost configuration for gorgone on the Central server./etc/centreon-gorgone/31-centreon-api.yamlRight now Im missing username and password for both clapi and centreonbv2. How can I generate propper user and passowrd for it? here a gorgon log file
Bonjour,Je me permet de vous envoyer cet requête concernant mon problème, je ne comprend pas pourquoi mon serveur centreon est en “is not running” alors que tout mes service sont en cours d’exécution ( centengine, cbd, gorgoned...) j’ai bien fait un export de configuration j’ai une erreur de droit que je corrige avec les commande suivantes :chown apache:centreon-engine /etc/centreon-engine/*.cfgchown apache:centreon-broker /etc/centreon-broker/*.jsonl’erreur disparait je continue à exécuter les commande suivante sur mon serveur une fois l’exportation systemctl restart cbd centengine systemctl restart gorgoned systemctl start snmptrapd centreontrapd systemctl start snmpd mais toujours rien il reste en “is not running” Si quelqu’un à une solution ce serait top Cordialement
Hello , We have a problem with a remote poller ,It happens several times a day that it is down with this error message : Database updates not activeWe have also this message on central-broker-master.log :[2022-05-13T07:59:59.516+02:00] [core] [error] failover: global error: BBDO: invalid protocol header, aborting connection: waiting for message of type 'version_response' but nothing received[2022-05-13T07:59:59.516+02:00] [tcp] [error] Error while reading on socket: Operation aborted.It’s ok once we restart the services on central. Has anyone ever had this problem ? Thank for your help.
Hi,I try to obtain my counter page of printer,but when i do graphic this phrase appear “Please select a correct metric_name”.What is a correct metric_name ?thank you :)
Hi,i am trying to upgrade my centreon installation.Problem is that i cant login after the upgrade with an admin. (user works)Debian 10 Centreon 21.04.15to Debian 11 Centreon 23.04.5 its a clean debian 11 and followed the official docs.web login works then dumped the dbs importet the old ones, moved the install directory and started the upgrade process.works so far.but then when i login wiht a admin user i only get a white page (recource button on the left shows up)the i tried a normal user and it works as it should next step edited the db centreon.contacts and made the user to an admin. (next login white page)other way round made the admin user to a nomal user and now i get the full pageTried to create a new admin user through the db an again white page with this user. so i guess its all related to the admin flag. but i dont see any error in the logs (maybe i search on the wrong log..) hopefully someone can help me or has the same problem. browser Chrome Version 114.0.5735.199 Thank
Hello,I have this message in the login page:Some properties doesn't match the json schema :[] The property redirect_url in not defined and the definition does not allow additional propertiesI can log to centreon web despite the message, and it also appears after logout.Centreon Engine 22.04.3 on CentOS Linux release 7.9.2009 (Core). Centreon Web is v. 22.04.12.What can be causing it?Regards,
Been trying to migrate centreon 22.10.10 running on centos7 to 20.10.10 running on rhel8Been using the following guide: https://docs.centreon.com/docs/22.10/migrate/migrate-from-el-to-el/Currently i’m getting this errorCentreon\Infrastructure\DatabaseConnection::__construct(): Argument #1 ($logger) must be of type Psr\Log\LoggerInterface, string given, called in /var/cache/centreon/symfony/ContainerKKWc4vW/App_KernelProdContainer.php on line 735 Config in /etc/centreon/centreon.conf.php looks correct Config in /etc/centreon/conf.pm looks correct Config in /etc/centreon/config.d/10-database.yaml look correct I can login to mariadb locally using the centreon userI should add that I’m at step 5any ideas what can be wrong?
Hello, I am creating this request because I have a problem with the speedtest plugin, I always get the same error: "UNKNOWN: Command error: ERROR: Unable to connect to servers to test latency."Is the plugin still maintained ? if the plugin uses speedtest-cli, I think it's because of that because speedtest-cli doesn't work anymore either Kélian
Bonjour,je souhaiterai savoir quelle sont les bonnes pratiques pour planifier un redémarrage de centreon sur RHEL 8.L’environnement :un serveur Centreon serveur central 22.10 avec bdd mariadb local un serveur Centreon MAP un serveur Centreon MBI avec bdd local un serveur Centreon Poller un serveur Centreon RemoteCordialement Hi,I need to know what is the best practice for plane centreon platform reboot on RHEL 8.The environnement :One Centreon server central 22.10 with local bdd mariadb One Centreon MAP server One Centreon MBI server with local bdd One Centreon Poller One Centreon RemoteRegards
Hello, i’m using the API V2 for set Acknowledge choosen service alert,i’m using the methode “AcknowledgementsPOST4Async”, if for only one service alert, it working !!else if for more than one service alert in same time, it Acknowledge just the first one.I don’t know why ?thanks for help.
Hello, I try to setup the centreon agent based on this documentation for MSP setup: https://docs.centreon.com/docs/health/centreon-agent/ but it fail to install centreon helios. OS: AlmaLinux 8.8Platform: 23.04.3Edition: IT-100 to MSPThe package centreon-helios seems not to be in the repository as you can see: Repository listing: Any idea is welcome
Bonjour,Nous utilisons Centreon pour superviser des routeurs 4G. Ils se trouvent que ceux-ci change souvent d’adresse IP, donc ils perdent la com quelques minutes et la retrouvent.Du coup nous recevons un mail à la déconnexion et à la reconnexion (environ 5min max)J’aimerais savoir comment on pourrait faire pour recevoir le mail uniquement en cas de déconnexion prolongée?Merci
Hi everyone,I'm tearing my hair out over a problem…We’ve got a centreon open source instance on the latest build Centreon 22.10.5 running on CentOS 8.7. I’ve configured https on it, following the official documentation. The vhost for apache is the one shipped in the /usr/share/centreon/examples/centreon.apache.https.conf, just modified to fit the right cert & key paths. Everything works well.Until today…I’m trying to access our Centreon from internet behind a Fortigate webvpn. This firewall is able to provide a web portal where users can create bookmarks to access internal ressources with protocols like http, rdp, ssh… We’re using this portal to access some servers like our ITSM over http, or a test server with RDP… no problems. Except with Centreon…The bookmark set on the webvpn portal is exactly https://centreon.domain.local/centreon/login. When i open the bookmark on the Fortigate, there is a redirect loop on /centreon/login… :I’ve tried with my autologin link, same thing. I’ve
Hello,Is there any solution to backup up centreon on S3 Bucket ?Does someone already do that ?Regards
Hi, would you help please ? I have my Centreon's interface that sent me “Oops Something went wrong” and then on the server I have this log : Since then, I have no more received my habitual notifications by email. How can I fix this ? Cordially,
Bonjour Pour un manque de place, j’ai dû migrer un serveur almalinux 9 en centreon 23.04. Le nouveau serveur est également sous almalinux. Le serveur centreon semble fonctionner correctement sauf que je n’ai aucune données dans les graphes avec un message “There’s no data” Il m’importe juste que toutes les mesures fonctionnent, je peux me permettre de ne pas récupérer les checks précédents. Pouvez vous me dire comment faire pour recevoir à nouveau les checks. Dans statut des ressources les derniers check datent du jour de la migration de serveur.Merci d’avance pour votre aide précieuse.PS : La migration a été faite avec cette procédureMigrer depuis un OS de type EL vers un autre OS de type EL (depuis un Centreon 18.10 ou plus récent) | Centreon Documentation ----Translate------For a low of space, I had to migrate an almalinux 9 server to centreon 23.04. The new server is also running almalinux. The centreon server seems to work properly except that I have no data in the graphs with a m
Hello, I’m trying to see if there is any possibility to switch ON, from a distance, a host which has its status on DOWN. Would you guys tell me if you know how to do it ? Thanks.
Hi,trying to find more information about getting centreon metric data into Splunk. Have looked into this documenation but nothing exists:https://docs.centreon.com/docs/integrations/stream-connectors/splunk-metrics
I just saw these warnings when exporting the configuration:Warningmkdir(): No such file or directoryWarningcopy(media/ppm/operatingsystems-linux-snmp-linux-128.png): Failed to open stream: No such file or directoryWarningmkdir(): No such file or directoryWarningcopy(media/ppm/applications-monitoring-centreon-central-centreon-128-2.png): Failed to open stream: No such file or directoryWarningmkdir(): No such file or directoryWarningcopy(media/ppm/applications-databases-mysql-mysql-128.png): Failed to open stream: No such file or directoryWarningmkdir(): No such file or directoryWarningcopy(media/ppm/applications-monitoring-centreon-database-centreon-128-2.png): Failed to open stream: No such file or directoryWarningmkdir(): No such file or directoryWarningcopy(media/ppm/applications-monitoring-centreon-poller-centreon-128-2.png): Failed to open stream: No such file or directory I got several more but the interesting thing is that the icons i can see are all visable.Just a bug or is ther
I’ve deleted some hosts and the pollers that monitored them. Unfourtunatelly they are still visible in the resource status and I cannot do anything to remove them. Any suggestions?
Hello, I'm having trouble with a configuration issue on Centreon. When I make modifications to the configuration files, for example, when I edit the file /etc/centreon-engine/serviceTemplate.cfg to add a service template, the modification is not visible in the Centreon web interface. My second question is regarding the opposite scenario: when I make a modification through the graphical interface and export that configuration, any manually written changes in the configuration files are overwritten
Hi!I would like to inquire about the possibility of monitoring a datacore and an IronPort using an offline license.In our previous version of Centreon, version "2.6," we used the plugins "check_datacore.pl" and "check_ironport_snmp" for this purpose. However, it appears that these plugins are no longer functional, and I have been unable to locate any relevant documentation.I came across the "Cisco IronPort | Centreon Documentation" page, but unfortunately, it does not provide a solution, and it seems to be applicable only to online licenses.If anyone has any insights or suggestions, I would greatly appreciate your knowledge !
I use afresh install and i ‘am unable to lunch centreonBIETLi have this issue/usr/bin/perl: symbol lookup error: /usr/lib64/perl5/vendor_perl/auto/Net/Curl/Curl.so: undefined symbol: Perl_xs_apiversion_bootcheck
Hello The Watch Community !I’ve received this request from a user : to add in Centreon a monitoring from a file (CSV or Excel) or a mail, with this kind if information :DateTime | Status (OK or KO)Data are sent each 15 minutes. The request is to exploit the data to create a chart, and be able, as usual with Centreon monitoring, to handle issues, by sending mail to a dedicated email address.I really don’t know if the content of a file or a mail can be used as a source for monitoring.Thank you !
Hello everyone,I’m having a problem that I understand, but all I’m doing to fix that don’t work. My problem is that I was trying to export configuration on web centreon and I have such an error : engine : log startedReading main configuration file '/var/cache/centreon/config/engine/1/centengine.DEBUG'.Reading resource file '/var/cache/centreon/config/engine/1/resource.cfg'“Error while processing a config file: Configuration parsing failed in file '/var/cache/centreon/config/engine/1/services.cfg' on line 22604: Service 'Ping' has no check command (property 'check_command')One or more problems occurred while processing the config files.Check your configuration file(s) to ensure that they contain valid directives and data definitions.If you are upgrading from a previous version of Centreon Engine, you should be aware that some variables/definitions may have been removed or modified in this version.Make sure to read the documentation regarding the config files, as well as the version chan
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.