Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,There is possibilty to monitor only inqjury messages (or messages that waitings for answer) from AS400 server?I tried to configure command using filters (severity and ID) but its not enought for me.When i set severity, i still got a information messages (e.g. 200+ messages).I need to check only a messages that waitings for answer.
Hello,I have a central collector that I would like to downgrade to satellite.Because I have to implement an HA.So set up another server that will be central to it.If possible, how to proceed.Thank you
Hi,Is it possible to change the color used for the banner and the menu, which is currently blue?We have two Centreon environments, one is our production environment, the other is a integration/test environment. We’d like to have a different color for the top banner and the menu to help distinguish the two to prevent potential human errors.
Hello,I’m trying to use centreon plugin os::windows::snmp::plugin with list-services mode to get a list of all services on a host. Currently the command return a list of all running services only.Is there a way to do this? Or is this the way that the OID return the info?Thanks in advance,Quentin
Hi,I would like to export hosts and services from centreon to a file. There is an option in the menu. I only choose hosts and services but there is a problem. I have several groups of hosts where standard services are connected (c drive, cpu, memory, etc.). It is convenient because I do not have to set up these services every time, but these services are created automatically.But these services are omitted from the export. has anyone had a similar problem? I tried to make a sql query in the database but it doesn't quite work.
Dear, Centreonists.Hi, I am a newbiew Centreon user.Now I am wondering about applying the migration process for Centreon configuration and data from the one with the version 2.8.32, rhel 6.2 (Santiago) to the one with version 22.10, Red Hat Enterprise Linux release 8.7 (Ootpa).So I have also found out the document online that is disclosed about the migration process fro a Centreon 3.4 to the newest version of a Centreon version, with the below link.the linkMigrate from a Centreon 3.4 platform | Centreon DocumentationBut I am also considered of the difference written in the document that is all about the migration process for the Centreon version 3.4x with rhel7x.So i am not really sure that the document avilable from the link mentioned above one is usable for this migration. Therefore it is the sensitive issues might has arouse due to the version imcompatibilities from the one mentioned in the doc and my actual environment.So, please let me know the way, if anyone knows or have experi
Hi,in the performance of the backup I’ve noticed some errors:# cat /var/log/centreon/centreon-backup.log[2023-02-28 14:35:32] Start central backup processUnrecognized option(s) passed to remove_tree(): mode at /usr/share/centreon/cron/centreon-backup.pl line 708.[2023-02-28 14:35:34] Finish central backup process[2023-02-28 14:35:34] Start monitoring engine backup processNo SSH keys for CentreonNo ssh keys for Centreon EngineUnrecognized option(s) passed to remove_tree(): mode at /usr/share/centreon/cron/centreon-backup.pl line 895.[2023-02-28 14:35:34] Finish monitoring engine backup process[2023-02-28 14:35:34] Start database backup processDumping Db with LVM snapshot (full)Unrecognized option(s) passed to remove_tree(): mode at /usr/share/centreon/cron/centreon-backup.pl line 453.[2023-02-28 14:58:30] Finish database backup process [root@esbio1lpcon001 backup]# ls -lha /var/cache/centreon/backuptotal 4.8Gdrwxrwxr-x 3 centreon centreon 4.0K Feb 28 14:58 .drwxrwxr-x. 6 centreon centr
Hi the community,I’m looking for a way to disable notification globally on my Centreon.In “host” or “service” config, there is a value “default” for the notification parameter, but I can’t figure out where is the default value for notification.Do you have any idea ?David
Hello,When you create a new host with a normal user, the filed ACL Resource groups appears and you must provide a data.This field doesn’t appear when you create a new host with an admin account and more annoying, the field is no more present once the host is created. You cannot correct a mistakeDo you have a procedure which allows me to modify the value I provided in the field “ACL Resource Groups” in case of error?
Hi everyone, is there a simple way to know who created a public view ?Thank you
Hi, I found on the Centreon 19.04 documentation that we could use the plugins pack offline by installing with yum the whole catalog yum install centreon-pack* and then we should have plugins list available on our plugins pack section. But even after I installed them I still have “no plugin found” as result on the plugins pack section.On the license-manager.log I can see the error “[RestNotFoundException] https://api.imp.centreon.com/api/license-manager/instance/subscription : Page not found” so maybe is there a way to specify that we want to use offline mode instead ? Or am I missing a step ?Thanks a lot for your help
Hi all,I want to test ETH via OID 1.3.6.1.2.1.2.2.1.8.XXX It’s work but state stay at OK while the ETH is UP (1) or DOWN (2). Performance data shown : 'value'=2;;0:2;; where the first “2” indicate the down status. How to change status to CRITICAL when the performance data show 2 ? I use centreon_generic_snmp.pl and this command to test this : $CENTREONPLUGINS$/centreon_generic_snmp.pl --plugin=apps::protocols::snmp::plugin --mode=numeric-value --hostname=192.168.1.1 --snmp-community=snmp_community --snmp-version=1 --oid=1.3.6.1.2.1.2.2.1.8.1 --warning=$_SERVICEWARNING$ --critical=$_SERVICECRITICAL$ $_SERVICEOPTIONS$ Thx for all.
Hi,Following the update in 22.04, the following error is displayed when generating and moving files for the CentralWarning : chmod(): Operation not permittedhere are the rights that seem to be problematic:ll /etc/centreon-engine/total 512-rw-rw-r-- 1 centreon-engine centreon-engine 3913 Jun 2 15:03 centengine.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 30924 May 18 14:08 centengine.cfg.rpmnew-rw-rw-r-- 1 centreon-engine centreon-engine 43757 Jun 2 15:03 commands.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 7225 May 18 14:08 commands.cfg.rpmnewdrwxrwxr-x 2 centreon-engine centreon-engine 6 Apr 22 2020 conf.d-rw-rw-r-- 1 centreon-engine centreon-engine 1412 Jun 2 15:03 connectors.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 1628 Jun 2 15:03 contactgroups.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 3297 Jun 2 15:03 contacts.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 1088 Jun 2 15:03 dependencies.cfg-rw-rw-r-- 1 centreon-engine centreon-engine 1
Hi,Since update from 22.10.4 to 22.10.7, the deprecated page is very slow to refresh. I have test with private mode with chrome or firefox. Any idea ?Thanks,
hi,I’m trying to configure centreon to carry out SSO using CAS with LemonLDAP. the integration is working fine when the account is present. however I have enabled auto import but if the user is not present then so login end up on an empty page with errors like https://sup.zeop.biz/centreon/api/beta/administration/parameters {"code":500,"message":"[Centreon\\Domain\\Security\\Session::setUserId]: The value cannot be null"}. the documentation hints that with openconnect auto ldap import is working but is there a way to make it work using CAS or SAML ?cheersErik
Hi guys, first of all sorry for my bad english.I'll try to be as clear as possible.in our infrastructure we have a centreon version 22.10.7 (AlmaLinux 8) and we are having this problem:if a non-admin user with an associated ACL goes on "Status Details" -> "service" and then click on one of the services, the page goes into this error: If that same user goes instead to "Resources Status" and then looks for the same specific service, there are no problems.This happens on all services hosts the user is allowed to.No problem with “admin” users.I don't know if we are doing something wrong with acl but it also happened on another server updated to 22.10.x.this did not happen with the 21.x versions.Any help is appreciate.Tnks
HiIs it possible to get in centreon api v2 the services that correspond to these parameters: dowtime=true, enabled=true, notification=true, service type hard?On the Centreon documentation, I only see downtime and acknowledgedI am using Centreon 22.04CordiallyFrancis
Hi, I’m trying to install MAP on my fresh new install of Centreon in 22.10 folowwing this :https://docs.centreon.com/fr/docs/graph-views/map-web-install/ But the cmd yum install centreon-map-engine return that :# yum install centreon-map-engineLast metadata expiration check: 0:06:59 ago on Fri 03 Mar 2023 10:15:39 AM GMT.No match for argument: centreon-map-engineError: Unable to find a match: centreon-map-engine Any idea ?
Centreon installed properly (debian11) without errorAll services running (cbd, apache2, mariadb, gorgoned, centengine...)When I try to create the first host, “Check Command” box is empty (no plugin listedinside).When (i) is clicked, we get a popup : “ sh: 1: /usr/lib/nagios/plugins: Permission denied “(all files under /usr/lib/nagios/plugins directory are root:root)Ever seen this issue ?Thanks
Hello, we are currently on version 21.10 and when a host changes status it is not updated in Map Geoview, it is only updated when I restart centreon-map. In /var/log/centreon-map/centreon-map.log 2 errors are displayed:[2023-03-17 14:09:56.627] [ERROR] [c.c.s.m.s.b.b.bbdo.BrokerEventProducer] [BrokerEventProducer] : Error occured while communicating with Brokerjavax.net.ssl.SSLHandshakeException: Remote host terminated the handshake at java.base/sun.security.ssl.SSLSocketImpl.handleEOF(SSLSocketImpl.java:1697) at java.base/sun.security.ssl.SSLSocketImpl.decode(SSLSocketImpl.java:1515) at java.base/sun.security.ssl.SSLSocketImpl.readHandshakeRecord(SSLSocketImpl.java:1417) at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:456) at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:427) at com.centreon.studio.map.server.business.broker.bbdo.BrokerEventProducer.negotiateProtocol(BrokerEventProduce
CentOS Linux release 7.9.2009 (Core)Centreon v 22.10.7 Hi the community,I’m currently experiencing a strange issue.1 host has been deleted via the GUI and I’m still receiving notifications.***** Centreon notification *****Type: PROBLEMHost: **MY HOST**Address: **IP WAN**State: DOWNSince: 5d 2h 51m 52sInfo: CRITICAL - **IP WAN**: rta nan, lost 100% I can not see this host or this service via the GUI (even if I change the URL to force the host id) .I looked at the database, was able to found those ghost entries in centreon_storage / table hosts, services and resources.Even if I set enabled, notify to 0, clear next_check or delete the records Centreon is still sending notifications to me.I’ve looked for ghost poller and found nothing.None usefull information found in log files.Poller config already deployed many times, all services restarted, VM restarted.Everything else is up and running.I've scoured the internet and this forum without finding the answer.Any idea ?
If the central Centreon loses connection with the Poller due to a network failure, will the information collected by the probes will be lost or not? If so, there is no a specific configuration for the persistence or memory queue in order to avoid the loss of information until the connection is restored ? Thanks for Help
HelloFor a few days now, all the check about CPU on my servers are at the status “Unknown” after snmp plugin does not return a single value. I tried to reset the snmp conf on server side, check the code in the plugins (pretty hard...) and nothing to do, al lthe status for CPU on Ubuntu servers (18, 20 and 22) are Unknown. I am running the last version of Centreon (22.04.12), running SNMP in version 2c on a private community. It happened after updating all my servers and I can tell the issue started after updating my servers, not the centreon plateform. Any help please !? thanks !!!
Hello guys, Im using Centreon version 22.10.7. I want to use bash script as a command for sending notifications. The script basically takes notification info as argument, creates HTML and then sends this document using muttt via postfix. As per my understanding notification commands are issued by the centreon-engine user. So I made sure the script is located in directory which is accesible by this user (/usr/lib/centreon/plugins/) and gave chmod +x and 777 permission to the script itself. When I log in to ssh using centreon-engine user and use the command it works perfectly fine. The setup in the web GUI look like this: Is there something Im missing? Been trying to solve it the whole day.. please help Thanks in advance for any kind of lead :-)
Morning how to monitor specific windows or linux services.Example : the services of sage on windows or Odoo on linuxCould you help me ?!
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.