Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,There is a way to have “history graph bar” that show status state event if state is SOFT ?Actualy, only hard status are displayed on the bar (and percents on reports). During SOFT event, the bar continue to display OK status that is generaly not the reality.Thank you.Best regards.
Hello, When i use plugin pack Windows Nsclient 0.5 and check uptime the threshold does not work because i never have a warning or critical even with very low thresholds.For example :/usr/lib64/nagios/plugins/check_centreon_nrpe -H s419800bch001.INFRA.ASP -p 5666 -t 60 -u -m 8192 -c check_uptime -a "warning=100s" "critical=200s"OK: uptime: 08:28h, boot: 2023-01-16 02:16:11 (UTC)Thanks for your help
Hi,How do you monitor network bandwidth usage on Windows server? Any advices?
Hello,I’ve followed the upgrade guide from 19.10 to 22.10, but since then, the poller is crashing. I have checked database access and it’s all fine. And here what i got in central-broker-master log :[2023-01-17T14:29:50.625+01:00] [core] [info] Starting the TCP thread pool of 3 threads[2023-01-17T14:29:50.626+01:00] [core] [info] protocols: registering protocol ('file' (layers 1-3)[2023-01-17T14:29:50.626+01:00] [core] [info] protocols: registering protocol ('compression' (layers 6-6)[2023-01-17T14:29:50.626+01:00] [core] [info] protocols: registering protocol ('BBDO' (layers 7-7)[2023-01-17T14:29:50.626+01:00] [core] [info] modules: attempt to load module '/usr/share/centreon/lib/centreon-broker/50-tcp.so'[2023-01-17T14:29:50.629+01:00] [core] [info] modules: attempt to load module '/usr/share/centreon/lib/centreon-broker/10-neb.so'[2023-01-17T14:29:50.631+01:00] [core] [info] NEB: module for Centreon Broker 22.10.0[2023-01-17T14:29:50.631+01:00] [core] [info] modules: attempt to load
Hello,I am installing the last version (22.04) open source of centreon but I encounter problems.I'm going with a distributed architecture (1 central machine, 1 database and pollers).All my VMs are freshly installed OS whose characteristics are as follows:[root@sup-cent-01 ~]# cat /etc/centos-releaseAlmaLinux release 8.6 (Sky Tiger)[root@sup-cent-01 ~]# uname -mx86_64[root@sup-cent-01 ~]# uname -r4.18.0-372.16.1.el8_6.x86_64 I want to install via packages, I followed this procedure:https://docs.centreon.com/docs/installation/installation-of-a-central-server/using-packages/ My problem is that on the central, arrived at step (With a remote database / Run the following command on the Central server:) “dnf install -y centreon-central” I encounter these errors:[root@sup-cent-01 ~]# dnf install -y centreon-centralLast metadata expiration check: 0:44:21 ago on Wednesday 03 August 2022 09:27:07 AM CEST.Error: Problem: package centreon-central-22.04.1-8.el8.noarch requires centreon-license-manag
Hi, I’m currently installating Centreon 21.10. I’m looking for the best way to monitor SMB fioles shares.I haven’t found any specific plugin. Could you help me on that subject? Thanks a lot, Laurent
Hi all,I installed the centreon OVA and activated it with the 100 IT license. Installed and issues a ssl certificate so the webpage is secure. Installed the following packages:Windows NS Client 0.5 and Windows NS Client API. Followed the manual at: Windows NRPE 0.5 | Centreon Documentation On a windows server I installed the centreon-nsclient and made the following config file.; SCHEDULER SECTION - Section for the Scheduler module.[/settings/scheduler/schedules]host_check = Check_OK "Everything is working fine"CPU Load = checkCPU warn=80 crit=90 time=5m time=1m time=30sMemory Usage = checkMem MaxWarn=80% MaxCrit=90% ShowAll=long type=physical type=virtual type=paged type=pageDrive C: Disk Usage = CheckDriveSize MinWarn=10% MinCrit=5% Drive=C: ShowAllUptime = CheckUptime MinCrit=12h ShowAllPrint Spooler Service = check_service service=spooler; SCHEDULER SECTION - Section for the Scheduler module.[/settings/scheduler]; THREAD COUNT - Number of threads to use.threads = 5[/settings/schedul
Hello,I want the envent handler to run a script when a service is in critical/unknown state. I have my script that works correctly when I launch it manually (the centreon account can launch the script). In the poller's logs, the services that are in "critical" state will try to execute the centreon command that launches the script. However nothing happens when the Event Handler launches the command.Any ideas ? The command : /usr/lib/centreon/plugins/eventhandler/open-jira-service-inc $SERVICESTATE$ $SERVICESTATETYPE$ $SERVICEATTEMPT$ There is a log file to see the event handler execute the command ?
je n’arrive pas à me connecté sur la page web de centreon on me dit User is blocked je essaye quelque réponses que je trouve sur le forum mais ça fonctionne toujours pasen faisant UPDATE centreon.contact SET login_attemps=NULL, blocking_time=NULL where contact_id=[change]; on me dit command introuvable update.merci
Hi!I tested Centreon passive checks, and I saw the debug file have recevied the test snmp messages, but the service always pending statue. I guess “submit service” not working normalliy. because /var/lib/centreon/centcore/ is empty and service could not recevied the statue update. please help me, thanks a lot!
Hello,We have a pool of servers that respond to charge and some of them can be shutdown or started in consequence.I don’t know how to manage this in Centreon.We have all the hosts configured in it, with disk space usage/CPU/RAM/Ping service monitoring through NRPE (NSClient++) + the notifications in case of WARNING/CRITICAL but when the host goes down the notifications are sent but we want to avoid this.Do somebody have already face this kind of need?Thanks for your reply!
Hello, I’m trying to install centreon 22.10 on RHEL 8.6.I got thi error: Problem: package centreon-22.10.2-12.el8.noarch requires centreon-central = 22.10.2-12.el8, but none of the providers can be installed - package centreon-central-22.10.2-12.el8.noarch requires centreon-poller = 22.10.2-12.el8, but none of the providers can be installed - package centreon-poller-22.10.0-14.el8.noarch requires centreon-plugin-Operatingsystems-Windows-Snmp, but none of the providers can be installed - package centreon-poller-22.10.1-4.el8.noarch requires centreon-plugin-Operatingsystems-Windows-Snmp, but none of the providers can be installed - package centreon-poller-22.10.2-12.el8.noarch requires centreon-plugin-Operatingsystems-Windows-Snmp, but none of the providers can be installed - cannot install the best candidate for the job - nothing provides perl(DateTime) needed by centreon-plugin-Operatingsystems-Windows-Snmp-20211215-090334.el8.noarch - nothing provides perl(DateTime) needed by c
Bonjour, Depuis une mise à jour de ce matin, je n’ai plus aucune remontée de journaux d’évènement ou de logs pour mes hôtes/sondes… Je ne sais pas ce qui bloque. J’ai un message d’erreur que voici : Symfony\Component\HttpFoundation\Response::__construct(): Argument #2 ($status) must be of type int, string given, called in /usr/share/centreon/src/EventSubscriber/CentreonEventSubscriber.php on line 422Je vous joins une capture d’écran également. D’avance merci ! Florian.
hello, i need help for fix this erros: /etc/centreon-studio/diagnostic.sh: línea 49: /etc/centreon-studio/studio-database.properties: No existe el fichero o el directorio########## Centreon Map server version ########## [INFO] centreon-map-server-21.10.7-5.el7.noarch########## System ########## [OK] SELinux disabled [OK] Firewall is disabled [INFO] Physical memory available on the server: 16266624 kb. [INFO] Number of CPU available on the server: 2 core(s)########## Java ########## [OK] Java 11 installed [INFO] No optimization found for the JVM (Xms and Xmx options).########## Database connection ##########/etc/centreon-studio/diagnostic.sh: línea 168: /etc/centreon-studio/studio-config.properties: No existe el fichero o el directorio########## Broker connection ########## [ERROR] Connection to port########## Authentication ########## [ERROR] Could not authenticate using (error 000)########## Protocol verification ########## [INFO] Bypassing HTTPS check for Map serve
helloIn configuration and Host all my hosts are lowercase, is it possible to rename all to uppercase easilymay be with clapi
Hello,After i upgrade Centreon to 22.10 the Plugin Broker-Stats (App-Monitoring-Centreon-Broker-Stats-Poller-custom) stop working and give this error:/usr/lib/centreon/plugins//centreon_centreon_central.pl --plugin=apps::centreon::local::plugin --hostname=10.80.247.210 --mode=broker-stats --broker-stats-file='/var/lib/centreon-engine/*-module-stats.json' --filter-name='' --warning-speed-events='' --critical-speed-events='' --warning-queued-events='' --critical-queued-events='' --warning-unacknowledged-events='' --critical-unacknowledged-events='' --warning-status='' --critical-status='%{type} eq "output" and %{queue_file_enabled} =~ /true|yes/i' --verbose --remote --ssh-option='-l=centreon'Unknown option: remote at /usr/lib/centreon/plugins//centreon_centreon_central.pl line 2230. Can you help please?
Hi,I’m trying to change my centreon database to a external one. I have alredy exported my centreon.sql and imported in the new remote server (a debian, with mariadb).I have created a centreon user o my remote bbdd and changed the /etc/centreon/centreon.conf.php file of my central server.I have changed the hostCentstorage to my remote server IP and the password parameter but it doesnt work.Any ideas? I havent seen much documentation or topics created on the forum about this….
Hello everyone,Version information : Centreon version 22.10.2PHP 8.1.13Last week, half of my vms died from storage failure. I monitor my vms using one central instance, and two pollers, poller1 and poller2.When the poller 2 died, I made a mistake, and tried to delete the poller and all the hosts linked to it in the Web UI, causing a lot of issues with ghost hosts.I’ve followed web tutorials explaining how to remove them from the centreon_storage database, in the HOSTS table.I thought this solved the issue, but it did only in the deprecated view. In the new view, the old hosts still appear, and when clicked on, make this popup appear : I’ve looked into the various logs and found nothing except for this log :CRITICAL: Host 2048 not found {"context":"[object] (Centreon\\Domain\\Exception\\EntityNotFoundException(code: 0): Host 2048 not found at /usr/share/centreon/src/Centreon/Application/Controller/Monitoring/MetricController.php:82)"}I’ve tried to restart php and the web server to no a
When I trie to Push the configuration, I receveid this error: Preparing environment... OKGenerating files... NOK (Exception received : SQLSTATE[42S22]: Column not found: 1054 Unknown column 'event_queues_total_size' in 'field list' [file: /usr/share/centreon/www/class/centreonDBStatement.class.php] [line: 132] )Aborted.
Apres avoir installer un Poller centreon , celui ci refuse de demarrerMon poller “is not running” J’ai remarqué eglament un logo rouge concernant les databases!Est ce lié ?MerciCordialement
hello, I am currently in version of Centreon v. 20.10.18I would like to setup a distribution management on the pollers, is there already existing code? I started to look if we could find the information concerning the activity of the pollers, but I find nothing satisfactory. Has anyone already implemented this type of operation?Thanks
Helloit’s possible to add more than one SNMP community in discovery rulelike public,public2
Hello, I’m configuring services for my Centreon and I wanted to change format of my storage service.I’ve already change something but I would like to make it better.I’ve found in the linux plugin configuration where lines which display the result are.My current conf for that : 15428 sub custom_usage_output {15429 my ($self, %options) = @_;15430 my ($total_used_value, $total_used_unit) = $self->{perfdata}->change_bytes(value => $self->{result_values}->{used});15431 my ($total_size_value, $total_size_unit) = $self->{perfdata}->change_bytes(value => $self->{result_values}->{total});15432 my ($total_free_value, $total_free_unit) = $self->{perfdata}->change_bytes(value => $self->{result_values}->{free});15433 return sprintf(15434 'Usage : %s / %s (%.2f%%)',15435 $total_size_value . " " . $total_size_unit,15436 $total_used_value . " " . $total_used_unit, $self->{result_values}->{p
Hello,I have followed the tutorials to install Centreon 22.10 on RHEL8.7.Using packages | Centreon DocumentationWeb And Post Installation | Centreon DocumentationFirewall enabled, I applied the rules (Secure your platform | Centreon Documentation)SELinux disabled (too many problems with it)I have only registered the Central Server with the common Linux SNMP template.I noticed errors when exporting the configuration (chmod errors). Below are the default permissions on the folder /etc/centreon-engine/I changed them all by apache:centreon-engine then no more errors.After starting all the services as described in the tutorial, I registered the server and exported the configuration with the options “Move Export Files” and “Restart Monitoring Engine”. I’ve tried Reload and Restart. No errors but the host and its services are not monitored. I’ve noticed that the uptime of the service “centengine” is not reset. If I restart the service manually, I will see the host and its services in “Pending
Hello,I’m currently working on getting a Centreon installation set up for the first time, and have followed the documentation for installation on Almalinux. After set up I can’t seem to get the default central poller to start, however the icon in the top left shows as green.Any assistance on this would be greatly appreciated.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.