Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hi,The new Resource Status page use regexp, while this is a good enhancement, it doesn’t permit to search for a string with a space in it. I tried quoting the string (both simple and double), I also tried to use `\s`, none of this works.How can I achieve that?This is something the Monitoring/Services and Monitoring/Hosts pages permit. It’s useful when searching in the plugin output (or even sometimes in the service name).I’m OK to do my best to start using this new Resource Status page (and, to incite my users to do so) but I’d like to have the same functionalities I had with the old ones.
Hi,The following bug has been closed and I cannot manage to reopen it.It’s not fixed, and even for the « workaround » suggested (which is: using the new Resources Status page) the person who closed the bug didn’t even read correctly what I wrote, he’s telling me to try something I already told wasn’t working.Why is it not possible to reopen a bug? The functionality exists in Github so why does it seems to have been deactivated?Best regards,
Bonjour à tous .je voulais essayer l’OVA 22.10 sur https://download.centreon.com/quand j’importe l’OVA sur Virtualbox, la VM ne démarre pas :FATAL : No bootable medium found! System halted .Pourtant le disque dur est bien importé :Je suis sur un 6.1.40 de virtualbox .Est ce que quelqu’un à déjà eu ce problème ?
Hi,The comment added when one put a downtime on an object is displayed in the tooltip when you rollover the downtime logo (the pink triangle with an exclamation mark).The problem is that line returns aren’t displayed there. The only workaround is to directly write the comment as HTML (ie: with <br /> tags), but that’s not convenient for the average user (nor is for the advanced one in fact…). They are saved in database, they probably should be replaced with an HTML tag for display, or in a HTML container that display text raw. What do you think?More globally, I hope the developer team still has time to enhance the “old” UI, is this the case?I personally think the new UI is unfinished for a good part, so the idea to depreciate the old one so rapidly really is a bad idea. Currently this is the new UI that should be warned as beta, and be optional for the user to test, not the (fully functional) current one marked as depreciated ! 😊 I wonder what other people think? Good thing is b
Hi everyone,I saw a topic that exposes a similar problem but unfortunately the answer is not sufficient.I manage to generate a token but every request i do, the result is the same.I put you in the context, I manage a Centreon with 300 hosts but without license. Is there a connection with this problem? C:\Users\dorian>curl -v https://SERVER/centreon/api/index.php?object=centreon_realtime_services^&action=list -H "Content-Type:application/json" -H "X-AUTH-TOKEN:"TOKEN""* Trying 192.168.90.63:443...* Connected to SERVER (192.168.90.63) port 443 (#0)* schannel: disabled automatic use of client certificate* ALPN: offers http/1.1* ALPN: server accepted http/1.1> GET /centreon/api/index.php?object=centreon_realtime_services&action=list HTTP/1.1> Host: SERVER> User-Agent: curl/7.83.1> Accept: */*> Content-Type:application/json> X-AUTH-TOKEN:kkMNbGrJYJw6xm8RuQIfgCl8GyL7OfsbI2TvLT+hKIkez+4ZrDW+sLazqY3LXviJ>* Mark bundle as not supporting multiuse< HTTP/1.1 40
Hello everyone, For my company i need to count a number of specific process running on a system and get an alert on my centreon dashboard if that number is superior than N. I really apreciate if you have any solution or suggestion. Regards.
Hi everybody,Here’s my problem:each time a service from a host is down we receive 2 mails:one for the service (normal!)and one to say that the host is still up!I don’t understand why.Here is our configuration:Can you tell me if I’ve made a mistake? Thanks for your help
Hello,It is possible to create a filter with AND/OR in the Widgets. For example LIKE %BA-VPN% OR %BA-CLN% Thanks. Regards
HelloI launched myself in the full rebuild of an snmp plugin for huawei dorado (san storage) by using Rest API.I did this because I added a “lun” mode to the existing snmp plugin, but as it happens, if you have too many luns the snmp is getting lots timeout, the table is huge and when go over 50 lun/snapshot the plugin never give the information back… after a bit of digging, I found there is a Restful api, and lot more digging I managed to create my own custom api I have an issue with the thing I coded, I cannot get critical or warning alerts when I use for example “--critical-usage-prct=50” on the perfdatahere is the plugin, work in progress : centreon-plugins/luns.pm at master · christophe-activiumid/centreon-plugins (github.com) (btw, anyone feel free to test it in command line if you have a dorado, it needs a read only account, and work for dorado v6 and v5)everything work fine, except threshold...I do need to implement a cache/statefile on this specific lun mode because with the a
Hi,When looking in the centreon/centreon-plugins Github repository I can’t see the same files which I have in the /usr/lib/centreon/plugins/ directory after an installation from the RPM packages.My knowledge of Perl is very limited, but I suppose there is some kind of install process in order to be able to use the plugins. I looked at the README but didn’t find any. I don’t think that just cloning the repository would permit me to use the plugins, but maybe I’m wrong? If so, how to use them?I’d like to be able to do that in order to test the very last version of the plugins without having to wait for release and packaging.I suppose I’d have to do so if I’d like to participate in the development of the plugins. The README, in the Basic Usage section, shows an example with running the “centreon_plugins.pl” script. Would it work just after I cloned the repository? I didn’t try because the README also tells : “I have finished the install section and I want to monitor a Linux in SNMP”, so
Hello TeamI am configuring monitoring for ESXi and VCenter servers. I have a problem with one environment where is vcenter in version 7.0 and esxi in version 6.5 and 7.0. Is VCenter 7.0 compatible with centreon 22.04 and it should work? i get error : UNKNOWN: Cannot get response (timeout received). With the other vcenter in version 6.5 i had no such problem.
Hello,Mon host est associé à un poller différent du poller central.La commande de discovery manuelle est exécutée sur le poller central.Le flux snmp n’étant pas ouvert entre le poller central et le serveur à intérroger, la découverte ne fonctionne pas.Y-a-t’il un moyen que la commande de découverte parte du poller où est déclaré le host à monitorer ?Ma plateforme est en version : 22.04.7.Cordialement
Hello I would like to know if it is possible to show single metric (ex. Packet loss) for multiple host in single performance graph.Is there a way to do this in Centreon?Thank you
Hello, Since I upgraded to 21.10, the service ‘Partitioning’ on my server goes critical each 10 days because the database isn’t up to date.I did the partitionning mannually twice using this : https://www.sugarbug.fr/blog/files/troubleshooting-partition-mariadb.htmlLast time I tried adding0 4 * * * centreon /bin/php /usr/share/centreon/cron/centreon-partitioning.php >> /var/log/centreon/centreon-partitioning.log 2>&1to the root user crontab. But today my service ‘warning’ and dates are from 10/02. I also checked the user ‘centreon’ crontab which is empty, I don’t know if it’s normal----Also the freespace on centreon database is 0, I would like to add space (if it’s possible) before it cause issues.---Thank you for your assistance :)
Hello,I have a question.I created task to get reports in MBI. (Hostgroups-Incidents-1)Only in the settings of my task, in the report parameters tab, I have nothing in the groups, I cannot select anything, so my task does not apply to... anything.Can you help me please?Cordially
Good day, server: Distributor ID: RedHatEnterpriseDescription: Red Hat Enterprise Linux release 8.6 (Ootpa)Release: 8.6 - mysql versions on both Centreon 20.04 and 22.04 are at V10.5.18 - Performed mysqldump of centreon and centreon_storage from Centreon 20.04 . Imported centreon_storage into V22.04 with no issues. When I import centreon.sql into V22.04, the “admin” login gives me the following error. “t::setTheme(): Argument #1 ($theme) must be of type string, null given, called in /usr/share/centreon/src/Centreon/Infrastructure/Contact/ContactRepositoryRDB.php on line 429”Would anyone know why I’m getting this error?Jacques
Hi,I used all the steps for the Centreon upgrade https://docs.centreon.com/fr/docs/upgrade/upgrade-from-19-10/No error appeared when applying the patch during the update via the web interfaceAlthough the poller is restarted manually after the migration, it does not work properly.In the log files, there is an error in /var/log/centreon-broker/central-broker-master.log :[2022-11-14T13:23:14.301+01:00] [sql] [error] error while loading caches: unified_sql: could not fetch index list from data DB: mysql: result at index 7 should be a boolean, the current value is ''[2022-11-14T13:23:14.301+01:00] [core] [error] failover: global error: unified_sql: could not fetch index list from data DB: mysql: result at index 7 should be a boolean, the current value is ''This error is not specific enough to find out what the problem is.Do you have an idea?
Hello Since the centreon 21.04 upgrade to 22.04.7Since the upgrade we have several errorand despite the deletion of the brocker files and restart cbdsystemctl stop cbd && rm -f /var/lib/centreon-broker/{*cache*,*new*,*unprocess*} && systemctl start cbderrors still persist
Hello, I would like your help, I have 2 docker containers that I would like to monitor with Centreon, the truth is that I have no idea how to start or carry out this work, if it is possible for the console to be seen in case the container is down or up
Hi, Yesterday I upgraded from version 21.10.11 to version 22.04.6I noticed that no charts have been generated since yesterday. What could be the reason?Thanks for any help
Hello,I would like to customize the centreon 22.04 homepage logois it possible ? if or how please. Regards
Hello,We have upgraded centreon 21.04 to centreon 22.04 on our Horprod platform,and we have just been alerted by the security team on several possible security breaches. here is the list of flaws that security has just shared with us: [[Administration] Sanitized and bound media import queries[CLAPI] Sanitized and bound Centreon hostgroup class queries[CLAPI] Sanitized and bound Centreon Service class queries[CLAPI] Sanitized and bound LDAP listing queries[Configuration] Fixed SQLi in Centreon Broker configuration menu[Configuration] Fixed SQLi in contact groups form[Configuration] Sanitized and bound Centreon hostgroups class queries[Configuration] Sanitized and bound Centreon Notification class queries[Configuration] Sanitized and bound Knowledge Base host listing queries[Configuration] Sanitized and bound SNMP Traps groups configuration queries[Configuration] Sanitized and bound SNMP Traps listing queries[Configuration] Sanitized and bound service by hostgroups listing queries[Config
Hello,We are alerted by the security teamA critical flaw “https://github.com/advisories/GHSA-599f-7c49-w659” has just been published affecting an Apache Commons Text library. It allows an external attacker to execute his own code remotely on a server using the vulnerable library.After checking on the centreon servers, unless I am mistaken, I do not have an Apache Commons package.Can centreon be impacted by this Text4Shell flaw?? Thanks in advance
I recently updated Centreon to 20.10.18. Everything seemed to run fine, until I generated new config files and restarted the poller. I found that many contacts were no longer being included in the config files. I discovered that many contacts had their Enable Notifications (contact_enable_notifications in the database) field set to NULL. These contacts were not included in the configuration files. Setting the Enable Notifications to any of the three values fixed it. Has anyone else hit this? Is it a known bug? I’m not sure how those contacts had their Enable Notifications field set like that.
Hello everyone, I am no longer able to export performance graphs to CSV and PNG since the Centreon update. When I click on the CSV icon, nothing happens and when I click on export to PNG image, my chart is replaced with white space. Could you help me please ? [Centreon : 21.10] [OS Red Hat Enterprise Linux 7.9] Best regards
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.