Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
helloi m a error to monitoring my ESXi 6.5UNKNOWN: Cannot get response (timeout received)Esx-HealthEsx-MemoryEsx-CpuEsx-Vm-CountEsx-SwapEsx-Status centreon_vmware.pm is OK (login-password) end start I also have this message in the logs but i don’t know if it has a link:'default' SOAP request error - possibly a protocol issue: Server closed connection without sending any data back at /usr/share/perl5/vendor_perl/Net/HTTP/Methods.pm line 373.
Hello,I have a problem with my Centreon 21.04.4.If I install a new plug-in in my case Virt-VMWare2-ESX, the corresponding templates doesn’t appear in “Templates” in Host configuration.How can I troubleshoot this problem or rebuid the template list (in host configuration) ?Thank you and best regards,Evo
Hi,I want to ask about the "Contact additive inheritance" and "Contact group additive inheritance" in host and service configuration. Because after upgrade from 3.4 to 21.10, when i have it checked and want to uncheck it. It's not working, this option remains still checked.I try also new installation of centreon 22.04 from OVA file and after change "Contacts & Contact groups method calculation" to “Vertical Inheritance Only” the behavior is the same.
Hi,We recently delete some services, but the metrics data are still available in Administration → Parameters → Data, even if we try to select them and use Delete Graphs.How can we correctly delete them?To correctly understand, those metrics are linked to *.rrd files on the server, is that correct?So if the metrics are deleted, it should free disk space ?More info :Centreon version : 22.04.02
Hi,Centreon provides plugin for Elasticsearch and Graylog. Does Centreon plan a plugin for Splunk ?Thanks
Bonjour, J’ai un soucis d’upgrade de Centreon ; en effet une erreur apparait (voir PJ).Lorsque je vais dans l’upgrade.log j’ai un soucis au niveau de ma colonne de ma table host : 2022-10-04 09:54|0|0|UPGRADE - 22.04.6: Impossible to update 'hosts' table - Code : 22003 - Error : SQLSTATE[22003]: Numeric value out of range: 1264 Out of range value for column 'notification_number' at row 57 - Trace : #0 /usr/share/centreon/www/class/centreonDB.class.php(309): PDO->query()#1 /usr/share/centreon/www/install/php/Update-22.04.6.php(32): CentreonDB->query()#2 /usr/share/centreon/src/Core/Platform/Infrastructure/Repository/DbWriteUpdateRepository.php(144): include_once('...')#3 /usr/share/centreon/src/Core/Platform/Infrastructure/Repository/DbWriteUpdateRepository.php(61): Core\Platform\Infrastructure\Repository\DbWriteUpdateRepository->runScript()#4 /usr/share/centreon/www/install/step_upgrade/process/process_step4.php(46): Core\Platform\Infrastructure\Repository\DbWriteUpdateReposit
Hello, The centreon plugin mssql command returns a Timeout. My server is ok, telnet 1433 test is ok. When I use check_mssql_health.pl check it returns timeout What is the problem? CordialyFrancis
Hello, All services in my poller show (execute command failed)In the logs this is what I get: Service check command execution failed: pipe creation failed: Too many open filesWhen I look at the number of open files everything is ok, I only have 10% of open files on my whole system. I don't understand where it comes from. The only solution for now is to reboot.Can anyone tell me where this is coming from? Cordialy,Francis
Hi all,I’m trying to install Centreon 22.04 with a remote MariaDB server.All prerequisites are OK on web & DB servers.During step 6, I specify the IP address of the MariaDB serverJust after this step, I haved checked and all data are correctly stored in config file (/etc/centreon/centreon.conf.php) But at step 7 of the web installation, the process hangs during “Creating database user” with an error (sqlstate[42000]):No privileges for centreon or centreon_storage databases for centreon user has been found, please check your MySQL configuration In php-fmp error log: An error with hostCentreon variable[03-Oct-2022 16:46:50 Europe/Paris] PHP Fatal error: Uncaught Error: Undefined constant "hostCentreon" in /usr/share/centreon/www/class/centreonDB.class.php:142Stack trace:#0 /usr/share/centreon/www/api/internal.php(47): CentreonDB->__construct()#1 {main} thrown in /usr/share/centreon/www/class/centreonDB.class.php on line 142[03-Oct-2022 16:46:52 Europe/Paris] CRITICAL: Environm
Greetings fellow Centreon users,i need i bit of guidance, while updating the minor patch i receive an error on step4, it reads: UPGRADE - 21.10.11: Impossible to update ‘services’ table (screenshot attached) past minor updates have succeeded just fine. the upgrade.log reads:2022-10-03 16:58|0|0|UPGRADE - 21.10.11: Impossible to update 'services' table - Code : 22003 - Error : SQLSTATE[22003]: Numeric value out of range: 1264 Out of range value for column 'notification_number' at row 18 - Trace : #0 /usr/share/centreon/www/class/centreonDB.class.php(263): PDO->query()#1 /usr/share/centreon/www/install/php/Update-21.10.11.php(37): CentreonDB->query()#2 /usr/share/centreon/www/install/step_upgrade/process/process_step4.php(72): include_once('...')#3 {main} the sql-error.log reads:2022-10-03 15:22|0|0| QUERY : ALTER TABLE services MODIFY notification_number BIGINT(20) UNSIGNED DEFAULT NULL Please advise.
Hello, since the centreon 21.04 version upgrade to 22.04 the API calls no longer work404 "Unauthorized" Thanks for your help
Bonjour, Dans le cadre de l’observabilité de nos outils, je souhaite centraliser les logs centreon dans notre stak ELK. L’intégration de log au format json est un plus pour l’indexation et le mapping des champs. Ma question, est il possible de transformer le format des logs en json des différents composant de l’architecture ? Si non, avez vous déjà opérer un parsing de vos logs , avec un logstash ou filebeat ou une définition de l’ensemble des champs ? Merci beaucoup -----------------------------------------------------------------------Hello, I want to centralize the centreon logs in our ELK stak. The integration of logs in json format is easier for the indexing and the mapping of fields. My question, is it possible to transform the format of the logs in json of the various components of the architecture? If not, have you already operated a parsing of your logs, with a logstash or filebeat or a definition of all the fields? Thanks a lot
Hello, A user who is not admin can delete downtime add by an admin user? If no, when user not admin can delete downtime? Cordialy,Francis
Bonjour, Existe t il un centreon_exporter pour exposer les métriques internes de centreon au format prometheus ?Merci beaucoup
Hello, is it possible to hide a hostgroup so i can’t see the alerts in the webpage and not in the summary counter ? But if I click on a host i want to be able to see services status. Thanks for your help, i search for hours without success
Hello,I search to personnalize the summary count of services in right top screen. I would like to exclude a host group of this numbers, is it possible ? Thnks for your help ;)
Hello,when upgrading from centreon 21.04 to 22.04 on a central and a poller everything went well except when restarting the services I got the following error:vim /var/log/centreon-broker/central-broker-master.log[******] [tcp] [error] Error while reading on socket: End of file[******] [core] [error] acceptor: endpoint 'central-broker-master-input' could not accept client: BBDO: peer is using protocol version 2.0.0 whereas we're using protocol version 3.0.0[******] [bbdo] [error] BBDO: peer is using protocol version 2.0.0 whereas we're using protocol version 3.0.0[******] [core] [error] acceptor: endpoint 'central-broker-master-input' could not accept client: BBDO: peer is using protocol version 2.0.0 whereas we're using protocol version 3.0.0[******] [tcp] [error] Error while reading on socket: Operation aborted.[******] [core] [info] Available connections cleaning: Operation aborted.[2******] [core] [info] Available connections cleaning: Operation aborted.[**0] [bbdo] [error] BBDO: p
RHEL 8.6/var/log/centreon-gorgonetaIl -f gorgoned.log 2022-06-15 14:44:09 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '401'] [message: 'Unauthorized']2022-06-15 14:45:00 - INFO - [cron] Launching job 'broker_stats'2022-06-15 14:45:00 - INFO - [cron] Launching job 'engine_stats'2022-06-15 14:45:00 - INFO - [statistics] Collecting Engine statistics from target '1'2022-06-15 14:45:09 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '401'] [message: 'Unauthorized'] I’m not using auto-discovery and I’m getting the above error. Why? Jacques
I have a problem with notification, the notification will be send because the notification is triggered : But I have no email notification.The manuel test whith postfix is OK on the server centreon, which implies that the SMTP configuration is correct :And i receive the mail.The services cbd, centengine, gorgoned are UP.In the file “sudo vim /var/log/centreon-engine/centengine.log” i have the notification alert.The contact or group have notification “active”. Do you have an idea ?
According to Red Hat, CentOS Linux 7 will no longer receive security updates after the year 2024. So, I'm looking for advice on how to convert Centreon 21.10 to Ubuntu OS. Is Ubuntu OS capable of supporting all Centreon packages? Please help.
Hi, After restarting poller services, most of the checked-services are missiong from the GUI.Configuration export result show a total of Checked 7429 services but the GUI only shows 2091 Services. Reading main configuration file '/var/cache/centreon/config/engine/5/centengine.DEBUG'.Reading resource file '/var/cache/centreon/config/engine/5/resource.cfg'Checking global event handlers...Checking obsessive compulsive processor commands...Checked 83 commands.Checked 2 connectors.Checked 25 contacts.Checked 0 host dependencies.Checked 0 host escalations.Checked 70 host groups.Checked 897 hosts.Checked 0 service dependencies.Checked 0 service escalations.Checked 32 service groups.Checked 7429 services.Checked 3 time periods.Total Warnings: 0Total Errors: 0
Hi there, i have a Plattform consisiting of several Remote Servers, some with Pollers attached to them. On one of my remote-servers there was an automated update-job running in error upgrading centreon form 22.04.2 (Plattform Version) to 22.04.4 (remote Server Version) and since then the Machine and its poller are no longer updating the central Centreon. I get the remote marked down with Database Issues and the last update according to the Pollers-Page yesterday. Commands get pushed via gorgone, as i can see them in the logs but results don’t appear to come back to the Central Instance. In the Web of the remote it is all up2date. The broker-log on the Remote shows the following error: BBDO: invalid protocol header, aborting connection: waiting for message of type 'version_response' but nothing received The whole plattform is set to BBDO-Version 2 in the Configs Please help. What will happen if i update the whole plattform to 22.04.4? Will that break the whole communications or will it
Please help ! I’m unable to install packages from Centreon open source software repository. It seems that only this repo source doesn’t work.
Hello, I just finalize an installation of Centreon on Google Cloud, but I'm facing an issue an issue with my cisco Plugin, from my first poller I can request a cisco device using snmp but from my another one I not able the error that I encountered is : UNKNOWN: SNMP Table Request : Timeout. Request is the same on both poller : /usr/lib/centreon/plugins//centreon_cisco_standard_snmp.pl --plugin=network::cisco::standard::snmp::plugin --mode=interfaces --hostname=X.X.X.X --snmp-version='2c' --snmp-community='XXXXX' --interface='^Gi1/1/1$' --name --add-status --add-traffic --warning-in-traffic='70' --critical-in-traffic='80' --warning-out-traffic='70' --critical-out-traffic='80' Thanks in advance for your help.
Hello, Since updating from 21.10 to 22.04 on CentOS 7, we have many issues of services disappearing on the web interface.Both host and service are enabled on the configuration (centreon database) but after digging, the service gets disabled at centreon_storage databas level with “enabled = 0”. There isn’t any issue collecting metrics, service graph keeps being updated, notification are still sent, everything goes well on Poller. We’ve enabled debug at broker level for sql and bbdo but we’ve found nothing else about some sampled service than usual log (perfdata, processing service messages, etc). The bug has impacted about 20% of active services, which is quite important. Restarting the impacted pollers solves the issue for some time (maybe hours) but it’s not efficient to restart pollers a few times a day. We’ve scripted something to :get the disabled services from centreon_storage database check one by one if they are supposed to be enabled in centreon configuration database update th
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.