Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Hello,When i update Centreon from 24.10 to 25.10.I had some errors at update : Exécution du scriptlet: centreon-web-25.10.2-1.el9.noarch 21/62Managing users and groups for apache ...Updating APP_SECRET in centreon environment files ...Updating centreon perl configuration files to central mode ...Managing apache and php fpm configuration and services ...Rebuilding Centreon application cache ...PHP Fatal error: Declaration of Centreon\Application\Normalizer\IconUrlNormalizer::normalize($icon, $format = null, array $context = []) must be compatible with Symfony\Component\Serializer\Normalizer\NormalizerInterface::normalize(mixed $data, ?string $format = null, array $context = []): ArrayObject|array|string|int|float|bool|null in /usr/share/centreon/src/Centreon/Application/Normalizer/IconUrlNormalizer.php on line 40
Hello,I’m running Centreon 25.10.3 on AlmaLinux, and I cannot create hosts from the web UI.When I try to create a host, I get:Error during creation (json encoding). See logs for more detail The Centreon logs show:[2025-12-31T05:30:11+00:00] ERROR : Error during host/hostTemplate creation | {"custom":{"hostId":null,"isTemplate":false,"exception":{"message":"Syntax error","trace":"#0 ... json_decode() ..."}}} I checked PHP-FPM and Apache logs there are no PHP errors or warnings. Memory and execution time are sufficient (memory_limit=128M, max_execution_time=0).I then tested the internal API:curl -k https://localhost/centreon/api/latest/platform/status Output:{"code":404,"message":"No route found for \"GET https:\/\/localhost\/centreon\/api\/latest\/platform\/status\""} I also tried to run the supposed API install command:sudo -u apache /usr/share/centreon/bin/console centreon:api:install But got:There are no commands defined in the "centreon:api" namespace. It seems the /api/latest r
2025-07-20 03:22:57 - DEBUG - => Send data: {"security":{"credentials":{"login":"centreon-gorgone","password":"Jxx5@yyT8!My"}}}Logs, even at debug level should not leak credential of a system user. This log file is by default world readable (/var/log/centreon-gorgone/gorgoned.log).
Hello, I’m getting this error right after logging in with my Google account. If I refresh the page the error disappears, but it comes back every time I log in again. I’ve already cleared my browser cache, but it didn’t help. Has anyone had this issue before? Thanks in advance!
🇬🇧Hello,I’d like to monitor a few database files to track their growth and guide the developers. I started testing the CIFS plugin, but I can’t get accurate graphs for all the files in a folder. I finally found a syntax that works./usr/lib/centreon/plugins//centreon_protocol_cifs.pl --plugin=apps::protocols::cifs::plugin --mode=files-size --hostname='192.168.0.1' --cifs-username='DOMAIN/USER' --cifs-password='xxxxxxxxxxx' --timeout='' --file='/Depot/truc.1' --directory='/Depot' --max-depth='5' --warning-size='' --critical-size='' --verbose --file='/Depot/bidule.exe' --file='/Depot/machin.exe' --file='/Depot/Test.htm' --file='/Depot/chose.ps1'Listing all the files works, but obviously it doesn’t work if new files are added…So I have two questions:How can I monitor an entire folder without having to list every single file? Is that possible? How many files can I monitor without overloading the system? If I have 2,000 files, will Centreon go crazy trying to display all of them?When I
Hi,Since yesterday, Centreon has database issue + Collector down.I found that centreon-engine service is in activating state.in centreon-engine.log : [processing] [error] [688633] failover: global error: failover: 'central-module-master-output' cannot connect endpoint.[2025-12-04T12:17:22.520+01:00] [tcp] [error] [688633] TCP: Connection refused to localhost:5669[2025-12-04T12:17:22.520+01:00] [processing] [error] [688633] failover: global error: failover: 'central-module-master-output' cannot connect endpoint.[2025-12-04T12:17:37.521+01:00] [tcp] [error] [688633] TCP: Connection refused to localhost:5669[2025-12-04T12:17:37.522+01:00] [processing] [error] [688633] failover: global error: failover: 'central-module-master-output' cannot connect endpoint. Service status[root@SN-SUPERVISION-P centreon-engine]# service centreon-engine statusRedirecting to /bin/systemctl status centreon-engine.service● centreon-engine.service - Centreon Engine Monitoring Daemon Loaded: loaded (/etc/syst
Hello everyone, We updated our ESXi to version 8.So I'm trying to configure the new VSphere8 connector without success.I created a dedicated account on vCenter for monitoring.This account is functional since the "host-status" mode is working correctly:/usr/lib/centreon/plugins/centreon_vmware8_esx_restapi.pl --plugin=apps::vmware::vsphere8::esx::plugin --mode=host-status --hostname='vcenter.mycompany.fr' --port='443' --proto='https' --esx-id='host-1234' --username='supervision-centreon@vsphere.local' --password='XXXXXXXXXXXX' OK: Host 'esx1.mycompany.fr', id: 'host-1234': power state is POWERED_ON, connection state is CONNECTEDI can also connect to vCenter via the web and view the characteristics of my ESXi and VMs.I'm having a problem with all other services associated with this connector:/usr/lib/centreon/plugins/centreon_vmware8_esx_restapi.pl --plugin=apps::vmware::vsphere8::esx::plugin --mode=power --hostname='vcenter.mycompany.fr' --port='443' --proto='https' --esx-name='esx1.myc
Bonjour, J’ai un soucis sur les services attachés à un groupe d’hotes. Les paramètres surchargés des macros ne sont plus pris en charge : par exemple : j’utilise le template Os-Linux-Disk-Generic-Name-SNMPje surcharge le champ DISKNAME avec / Cependant voici la commande générée : sudo -u centreon-engine /usr/lib/centreon/plugins//centreon_linux_snmp.pl --plugin=os::linux::snmp::plugin --mode=storage --hostname=monserveur --snmp-version='2c' --snmp-community='macommu' --storage '' --name --display-transform-src='' --display-transform-dst='' --warning-usage='80' --critical-usage='90' --filter-perfdata='storage.space|used|free'Le problème n’est pas vrai lorsque je créé ce service directement rattaché à un hote J’ai lu apparemment centreon voulait abandonner le service par groupe d’hote ce que je trouve très dommage, est ce la raison pour laquelle ces métriques ne remontent plus ?Je vous remercie par avance pour vos réponses
Hello,I’m still trying to understand what happens, but I just upgrade from 24.10.14 to 24.10.15 and this is a disaster.All gorgone to Remote Server flux are downAll flux for Centreon Broken are down. I’m still investigating , but i urge you to no upgrade your production setup and test it before on a stagging.
Since i upgrade many plateform to 25.10 , i have 2 Host Groups menu
We are using a SSO solution to centralize our user authentication flows and because of that users have many many groups.When trying to login through Centreon, those groups data are added within the authentication token, making it reach huge sizes (around 4k characters for now), but the structure of the database on the table “security_authentication_tokens” for the “token” field is limited to 255 characters. i got explained that it is possible within an openid request to ask for a filter on the groups to maybe reduce that token size.Is there something to do in that sense and how can we do it ? This is blocking the deployment of this auth solution at scale.
Hi folks,Here my feedback/issue after go to 25.10Forced check doesn’t work anymore, success message after push it, but nothing happens When I create a new service, host, or modify anything, I have to restart all centreon stack : systemctl restart centengine to show up the new elements. Export config, restart engine from web is no longer enough Custom macros don’t work on service apply to hostgroup. (ok with linked on multiple hosts or host only)I migrate to a new platform (22.10 to 25.10) by following documentation ‘Migrate from an EL-type OS to another EL-type OS’
Bonjour à toutes et tous,J’ai installé dernièrement un serveur avec Centreon pour superviser des serveur Windows (Windows Serveur 2019 DataCenter build 1809)La supervision avec le CMA en mode sans SSL fonctionne parfaitement,J’ai voulu passer en SSL et la plus de communication entre mes hôtes et le collecteur.J’ai fait le test avec un certificat autosigné et avec un certificat provenant de notre autorité de certification interne.J’ai sans doute loupé une étape. Merci de votre aide.
I have installed the it-100 license, when I try to update a plugin or install a new one I get this error
Hi everyone,I’m looking for the most efficient way to generate a list of active services (excluding templates) that do not have any contactgroup defined—neither directly nor inherited from templates.I’d like to explore different methods to achieve this, such as:SQL queries (directly querying the Centreon database) REST API (if applicable) Parsing configuration files (e.g., .conf files in /var/lib/centreon-engine/central/config/)If you’ve already tackled this issue or have any insights, I’d appreciate your input! Which method do you recommend for accuracy and simplicity?Thanks in advance for your help!
hi, i work with the plugin centreon vmware.in test my result is OK with a vcenter, /usr/lib/centreon/plugins/centreon_vmware_connector_client.pl --plugin=apps::vmware::connector::plugin --mode=swap-vm -custommode=connector --connector-hostname='localhost' --connector-port='5700' --container='***********’ i have installed the connector in the same os, but in a highest release (centos 7.4 vs centos 7.9) , the same command return : UNKNOWN: Cannot encode resultwith debug :{ "code": -1, "short_message": "Cannot encode result" }the pb is not the .pm, this is ok on the test platform , and when i ask it with curl in the prod server , it’s ok ...is anyone has (or had) the same problem and have resolved it ? do you have the same problem with another plugin ?
Hello Centreon Community/Support,I am experiencing an issue with a custom Lua stream connector script that is designed to send monitoring events to an external system (BEM). The script functions correctly on one Centreon Poller/Central server, but on a different host (which I'll refer to as "Problem Host"), events are consistently being dropped at the filter stage, resulting in the debug log message filter' returned false.I have confirmed that the target system is listening on the expected port (2540) and that the "Problem Host" can establish a TCP connection to it.Problem Description:On a specific Centreon host (the "Problem Host"), the Centreon Broker Lua stream connector is not processing events as expected. The debug logs show that the filter function in the Lua script is rejecting all incoming service status and host status events, even though the same script works perfectly on another Centreon host. This prevents any alarm messages from being sent to the BEM system.Observed Debug
Hello everyone,We are monitoring a Vcenter v8 cluster, and all was fine with Centreon 22 (so using the sdk file).Since upgrade to Centreon 25.10, connector is not working anymore. I saw that now there is a JSON file instead of the PM one (file is deprecated).I used the configurator to add my Vcenter, and I can see the JSON file filled with the informations (server ip address and login/pwd stored in crypted mode). As I understand, Centreon 25 is now storing credentials in crypted mode.Issue I’m facing is:I believe that the Vcenter platform is receiving the user credentials in crypted mode so I got a “user failed connection”. I looked in the vcenter log files for this. so the Vcenter is not able to authenticate as user is crypted and unknown for him. Is there a way to fix this ? I know that the restAPI plugin is designed for Vcenter8, but could we monitor all the same functionalities as the vmware_centreon plugin ? Many thanks for your replies, Antoni
Hello, I upgraded to version 25.10 and now the centreon_linux_snmp.pl plugin only works for certain checks, such as load mode and swap mode. However, it no longer works with CPU, storage, RAM and memory modes, even though nothing has changed.Furthermore, when I run the command on my poller in CLI, it works, but when I run it from the web interface, I get an ‘execute command failed’ error, even though I have the correct permissions, etc. I really don't understand.Need help, please.
Hello,I’ve got two VMs to monitor with Centreon. For the first one, I'm using a plugin from Centreon’s GitHub repo centreon-plugins/src/centreon_plugins.pl at develop · centreon/centreon-plugins (github.com) plugin-path: src/centreon_plugins.pl For the second VM, I would like to use an RPM instead of pulling the plugin from GitHub.Do you know how I can find the equivalent RPM? Any keywords I should be searching for? Have you used RPMs instead of the GitHub plugins before? Thanks for the help!
With the new, extremely short lifecycle for STS versions (odd-numbered years), have those with only 18 months of support become beta tester versions ?I find this lifecycle choice very surprising.Why does support for STS versions end before the following LTS version is stable and completes its Phase 1 ?Today, if I want to stay on a stable version, I must stay on 24.10 until October 2027, and only then can I double-jump from 24.10 to 26.10, even though 25.10 will no longer be supported.If I upgrade to version 25.10, I'll be forced to upgrade to 26.10, even though it won't be stable yet.I get the impression that these STS versions, like 25.10, offer neither new content nor stability in the short, medium, or long term.I preferred the old cycle.Or at least, in my opinion, it would be better to extend the STS to 24 months.Am I wrong? Have I misunderstood the improvements in this new cycle ? Thanks
SSL certificate problem: unable to get local issuer certificate for "https://x.x.x.x/centreon/api/latest/configuration/hosts/templates".As soon as I want to add a host or create a template, I now get errors like this.Nothing in my configuration has changed except that I upgraded to version 25.10; I was previously on ‘(24.10.)
Hi, I want to check the alerts already defined in prometheus without to use the query mode. Because it is easier for us to define the treshold. Is there a way to ask the result of the alert defined in prometheus withtout ? I have try with the plugins but it doesn’t work.For exemple, If i use the name AlertmanagerFailedReload for this alert :
Hello,Since upgrade to 25.10, we are facing a weird issue on Host adress form.While in 23.04 this field was most likely “open to any format”, it now requires a “valid IP / FQDN Format”, which is a problem actually for multiple reasons. We can’t modify an existing item that is actually configured with a wrong HOSTADDRESS format, resulting to the following error : We also can’t delete an item that is with this kind of HOSTADDRESS format. It does nothing when we click on delete → Just actualizing the interface, but the host still here, and poller config doesn’t see any change. Even if we restart the poller config, it doesn’t do anything (in case it was a ghost change) We have many commands that uses the HOSTADDRESS value, which is not a valid IP (or FQDN) (for certain api calls for example). > This would require to refactor many of our commands. > We can’t deploy any new hosts that are using these commands. > And we can’t really refactor because we won’t be able to change the
Hello,We have created new poller with version 24.10.14 which is not communicating with poller.please have a look at below log from poller as well as central server. poller centengine.log2025-12-03T00:19:57.160-05:00] [processing] [error] [912] failover: global error: failover: 'central-module-master-output' cannot connect endpoint.[2025-12-03T00:22:20.519-05:00] [tcp] [error] [912] TCP: could not connect to 10.*.*.*:5669 : Connection timed outand central servergorgone.log2025-12-03 12:44:46 - ERROR - [legacycmd] Cannot process message type 'SENDCBCFGthrowing it away.2025-12-03 12:44:51 - ERROR - [legacycmd] Cannot process message type 'SENDCBCFGthrowing it away.2025-12-03 12:45:21 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '401'] [message: 'Unauthorized']2025-12-03 12:46:21 - ERROR - [autodiscovery] -class- host discovery - cannot get platform versions - Login error [code: '401'] [message: 'Unauthorized']central-gorgone version
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.