Stream Connectors Release – July 2026
Learn more about the Centreon Infra Monitoring.
Recently active
Bonjour,Je cherche avec le plugin Modbus à faire de la lecture de registre qui sont en booléen (pour faire des alarmes). Est il prévu de faire une mise à jour du plugin? Merci
Hello,I’m encountering an issue with the Centreon API (v24.10) when retrieving downtimes.Sometimes, without explanation, API returns an empty response even though a downtime is correctly created and active at the moment of the request. { "result": [], "meta": { "page": 1, "limit": 10, "total": 0 }}Could you let me know why the API returns this empty result while a downtime is currently active?Is there any known behavior, specific condition, or configuration that could cause this intermittent response? Note that this is the same response we receive when there is no downtime in progress.Therefore, this does not allow us to detect the error. Thank you for your help.
Bonjour à tous, Je rencontre un problème dans les logs Centreon broker de mon serveur central, alors que toute la supervision fonctionne normalement. Dans /var/log/centreon-broker/centreon-broker-master.log j’ai :[processing] [error] failover: global error: BBDO: invalid protocol header, aborting connection: waiting for message of type 'version_response' but nothing received[tcp] [error] Error while reading on socket from (ip db) : Connection reset by peer[[tcp] [error] Error while reading on socket from (ip poller3) : Connection reset by peer[tcp] [error] Error while reading on socket from (ip poller2): Connection reset by peer[tcp] [error] Error while reading on socket from 1ip poller1): Connection reset by peer Tous les pollers fonctionnent bien sur l’interface web de centreon, je souhaite simplement comprendre l’origine de ces connexions TCP rejetées par le broker afin d’éviter de polluer mes logs. Savez vous d'où cela peut provenir ? Merci d’avance. Hello everyone,I am encounte
Hello,I've set up a Windows host without any problems, but I'd like to view only the second disk on the machine. What setting do I need to change, knowing that I want to see disk 1, which is drive letter "e"? Thanks
Hi, i migrate my Centreon-Server and my poller.. All Green, Poller Green, BUT Communication .. key error gorgoned.log ERROR - [core] Client pubkey is not authorized. Thumbprint is 'zPYX3Yv5b7cRU8twP9Z85EtgNJ2a2_C9f1gPqYO48Zc' how can i fix this ?
How can i delete old Hosts / Metrics / Perfdata from the database ? I delete a lot of host , i can see the Hosts.. but This host no longer exists in Centreon configuration. Please reload the configuration. how can i detect all ghost Hosts / Dand the all “old” data from the database TThanks
Hi, i wont to change HTTP to HTTPS Certificate and key all fine … apachectl configtestAH00526: Syntax error on line 85 of /etc/httpd/conf.d/ssl.conf:SSLCertificateFile: file '/etc/pki/tls/certs/localhost.crt' does not exist or is empty localhost.crt not exist ?
Has anyone experienced VMware ESX / vCenter plugins crashing since upgrading to version 25.10?
I have a script that must launch a command when a critical or unknown state in type "HARD" to perform 3 attempts. The problem is that when I add to the script the part (case"$3" in 3) " on types HARD to add an interval of 3 relaunch. I have a syntax error see belowERROR : Erreur de syntaxe : fin de fichier prématurée#!/bin/sh#Titre : Ce script permets de créer un ticket INCIDENT# Note:#Le script s'execute uniquement si le service est vérifié 3 fois (dans l'etat type "soft" et status CRITIQUE )#Dans le cas contraire si le cas est de type "HARD" et de status CRITIQUE le script s'execute de suite sans vérification.case "$1" inOK) ;;WARNING) ;;UNKNOWN) case "$2" in SOFT) #Troisieme variable derriere la commande d'execution du script ($SERVICEATTEMPT$) case "$3" in #"3)" identifie le nombre de tentative avant d'executer le script 3) #commande à executer /usr/lib/centreon/plugins/centreon_notification_centreon_openticke
Bonjour,Connaissez-vous un moyen de superviser un FortiAP avec Centreon ?. Merci d’avance pour votre aide.
Hi, I have an issue with centreon_fortinet_fortigate_restapi.pl. If I try to get license info I get error: UNKNOWN: Cannot decode response (add --debug option to display returned content) Issue comes from the fact that there is letter Ü in output as company name. That messes the output up.I tried different options in the commandline, but at least to me only fix seems to be, is to add UTF-8 encoding to plugin. Or am I missing something or is there some magical hack I can use?NB! It not possible to change the company name not to have that letter Ü in it.
After installing the latest 23.10.29 I do no longer get the password validation errors for a new user. A blank page is shown instead.Here is the relevant log:[17-Nov-2025 11:16:29 Europe/Rome] PHP Fatal error: Uncaught TypeError: Adaptation\Log\LoggerPassword::warning(): Argument #2 ($initiatorId) must be of type int, string given, called in /usr/share/centreon/www/include/configuration/configObject/contact/DB-Func.php on line 1543 and defined in /usr/share/centreon/src/Adaptation/Log/LoggerPassword.php:58Stack trace:#0 /usr/share/centreon/www/include/configuration/configObject/contact/DB-Func.php(1543): Adaptation\Log\LoggerPassword->warning()#1 /usr/share/centreon/vendor/openpsa/quickform/lib/HTML/QuickForm.php(1330): validatePasswordCreation()#2 /usr/share/centreon/www/include/configuration/configObject/contact/formContact.php(1217): HTML_QuickForm->validate()#3 /usr/share/centreon/www/include/configuration/configObject/contact/contact.php(178): require_once('...')#4 /usr/sha
Bonjour à tous,La partie MAP étant décorrélé de Centreon WEB et dans un contexte d’observabilité et de partage d’informations, est-il possible d’utiliser les MAPs de Centreon sans passer par le WEBUI Centreon?Par exemple, affiché une MAP (avec des droits pour tout le monde) dans un outil tierce via une URL. Merci.
HelloWe need to install 4 remote pollers on a network where sources and dependencies originating from Ukraine and Russia are blocked.Is it possible to retrieve an OVA from Centreon with all the sources and dependencies at Centreon?Is it possible to force the download of source code and dependencies in a specific country (France)?Thank you for your help
Hello,I have an issue when exporting a .csv. Every month, I use host groups to export data and generate a report. The link looks like this :https://x.x.x.x/centreon/include/reporting/dashboard/csvExport/csv_HostGroupLogs.php?hostgroup=3&start=1759269600&end=1761951600 It was working last month, today If I select one week, it works, but if I choose one month I get this error in my browser :Il semble y avoir un problème sur ce siteIl est possible que https://x.x.x.x/centreon/include/reporting/dashboard/csvExport/csv_HostGroupLogs.php?hostgroup=3&start=1759269600&end=1761951600 connaisse un problème temporaire ou ait été déplacé.Code d’erreur : 500 Internal Server Error Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus tard ;Centreon navigation menus remain accessible but if I try to go back to the home page or access another panel, I get this “full-screen” message” :Unexpected Application Error!Permission denied to access property "document
Hi! The big issue is that at “Reporting->Availability->Hosts” i see al hosts with “ UNDETERMINED” status for any period selected. In mariadb.log i get this error from 10 to 10 min - “[Warning] Aborted connection xxx to db: 'centreon' user: 'centreon' host: 'localhost' (Got timeout reading communication packets)”I can log in to mysql/mariadb server with my centreon user and password stored in /etc/centreon/centron.conf.php. This is my /etc/my.cnf.d/centreon.cnf=========================================================# cat centreon.cnf ## Custom MySQL/MariaDB server configuration for Centreon#[server]innodb_file_per_table=1open_files_limit = 32000key_buffer_size = 256Msort_buffer_size = 32Mjoin_buffer_size = 4Mthread_cache_size = 64read_buffer_size = 512Kread_rnd_buffer_size = 256K#max_allowed_packet = 8Mmax_allowed_packet = 64Mwait_timeout = 300interactive_timeout = 300net_read_timeout = 60net_write_timeout = 60[mysqld]log_error = /var/log/mariadb/mariadb.loggeneral_log_file = /va
Hi All, I tried to update from 24.10.10. to 24.10.13 this morning.since this, I have multiple services linked to “low-level layers” that doesn’t work. For example, for BigIP F5 template, the service Hardware-Global says : “No components are checked” /usr/lib/centreon/plugins/centreon_f5_bigip_snmp.pl --plugin=network::f5::bigip::snmp::plugin --mode=hardware --hostname=x.x.x.x --snmp-version='3' --snmp-community='public' --snmp-username='toto' --authpassphrase='toto' --authprotocol=sha --privpassphrase='toto' --privprotocol=aes --component='.*' --verbose→CRITICAL: No components are checked.Checking fansChecking power suppliesChecking temperatures Same issue for all Cisco hardware:/usr/lib/centreon/plugins/centreon_cisco_standard_snmp.pl --plugin=network::cisco::standard::snmp::plugin --mode=environment --hostname=x.x.x.x --snmp-version='3' --snmp-community='toto' --component='.*' --snmp-username toto --authpassphrase toto --authprotocol SHA --privpassphrase toto --privprotocol AES --wa
Hello,I’ve written a discovery plugin for oVirt in Perl. Everything works as expected in CLI, now I would like to use it through the Configuration->host>-discovery page as a provider. I didn’t find any related documentation about it. The only thing I was able to do is adding a discovery command into configuration->command->discovery but I didn’t find how to use it . Please help
happens on two different systems, but only since the update from 23.10 to 24.10.https://github.com/centreon/centreon/issues/8822
Hi,Oct 31 16:37:37 servername centengine[257511]: [2025-10-31T16:37:37.146+01:00] [config] [warning] The option 'auto_rescheduling_interval' is no longer available. This option is deprecated.Oct 31 16:37:37 servername centengine[257511]: [2025-10-31T16:37:37.146+01:00] [config] [warning] The option 'auto_rescheduling_window' is no longer available. This option is deprecated.Oct 31 16:37:37 servername centengine[257511]: [2025-10-31T16:37:37.146+01:00] [config] [info] Processing object config file '/etc/centreon-engine/commands.cfg'Oct 31 16:37:37 servername centengine[257511]: [2025-10-31T16:37:37.146+01:00] [config] [info] Processing object config file '/etc/centreon-engine/timeperiods.cfg'Oct 31 16:37:37 servername centengine[257511]: [2025-10-31T16:37:37.146+01:00] [config] [info] Reading resource file '/etc/centreon-engine/resource.cfg'Oct 31 16:37:37 servername centengine[257511]: WARNING: All log messages before absl::InitializeLog() is called are written to STDERROct 31 16:37:37
Hi evryone How can I solve the problem below? It happens to me every 2 or 3 days and it disappears after restarting the broket service. [2024-12-26T14:21:12.461+01:00] [sql] [error] mysql_connection 0x7f7b680225a0 attempts 2: could not store logs correctly: errno=0[2024-12-26T14:21:14.419+01:00] [bbdo] [info] BBDO: received pb acknowledgement for 1000 events[2024-12-26T14:21:19.351+01:00] [bbdo] [info] BBDO: received pb acknowledgement for 1000 events[2024-12-26T14:21:22.474+01:00] [sql] [error] connection fail to execute statement 0x7f7b680225a0: error: errno=0[2024-12-26T14:21:22.474+01:00] [sql] [error] mysql_connection 0x7f7b680225a0 attempts 2: error: errno=0[2024-12-26T14:21:23.589+01:00] [bbdo] [info] BBDO: received pb acknowledgement for 1000 events[2024-12-26T14:21:27.476+01:00] [sql] [error] connection fail to execute statement 0x7f7b680225a0: could not store logs correctly: errno=0[2024-12-26T14:21:27.477+01:00] [sql] [error] mysql_connection 0x7f7b680225a0 attempts 2: c
Hello,We recently upgrade our Centreon central from 22.10 to 24.10.4.Since this upgrade we encouter an issue with the “Event Logs” page.When we have several pages of results and we try to access to the next page, it just shift to the 1 or 2 next records instead of shifting to the 30 next ones.Does someone experienced such an issue ?Regards
Hi,I have a problem when I try to use plugin: network::fortinet::fortigate::restapi::pluginModes system and HA work nicely.But with licences mode I get error:UNKNOWN: Cannot decode response (add --debug option to display returned content)and with health mode I get UNKNOWN: Not an ARRAY reference at /usr/lib/centreon/plugins//centreon_fortinet_fortigate_restapi.pl line 9452. Could it be that Fortigate newer software causes this?
Hello,We actually have an old Centreon version (23.04), and are trying to add a Poller to it’s configuration.We know that we have to upgrade to 24.10 but right now, we need to move on this Poller project (on Alma Linux 9)When we try to install it, it always install latest version 24.10 (via packages, and unattended via script even with the v23.04 script).Doc : Unattended installation of a poller | Centreon DocumentationI even changed the unattended.sh script, to force version 23.04 instead of 24.10 ! Still it installs 24.10 packages.Do you have any idea about this kind of trouble ? How can we manage to install centreon 23.04 packages to add the poller to the configuration ? Best Regards,
Hi,We currently use our custom widget with Smarty Engine and we can use it in “Custom Views”, but in Dashboard or Maps, it is not listed in the fields selection.Do you know if an additionnal configuration is necessary to implement our custom widget in dashboard or map ?Thanks.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.